<!DOCTYPE html>
<html lang="de-DE" prefix="og: http://ogp.me/ns#"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>Zentralisiertes Logmanagement: Security und Compliance out of the Box</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
	<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-563H99');</script>
	
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Das Logmanagement ermöglicht eine ganzheitliche Betrachtung auf die IT-Sicherheit und bildet ein Frühwarnsystem bei Auffälligkeiten und Anomalien."/>
<meta name="robots" content="noodp"/>
<meta name="keywords" content="Log,Security"/>
<link rel="canonical" href="https://jaxenter.de/security-log-management-best-practices-83904" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Zentralisiertes Logmanagement: Security und Compliance out of the Box" />
<meta property="og:description" content="Das Logmanagement ermöglicht eine ganzheitliche Betrachtung auf die IT-Sicherheit und bildet ein Frühwarnsystem bei Auffälligkeiten und Anomalien." />
<meta property="og:url" content="https://jaxenter.de/security-log-management-best-practices-83904" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="Log" />
<meta property="article:tag" content="Security" />
<meta property="article:section" content="Artikel" />
<meta property="article:published_time" content="2019-05-28T09:49:25+00:00" />
<meta property="article:modified_time" content="2019-05-28T10:45:03+00:00" />
<meta property="og:updated_time" content="2019-05-28T10:45:03+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="200" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; Security: Der Weg zum zentralisierten Logmanagement über zehn Hürden Kommentar-Feed" href="https://jaxenter.de/security-log-management-best-practices-83904/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sands-breaking-news-css'  href='https://jaxenter.de/wp-content/plugins/sands-breaking-news/includes/style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpdiscuz-font-awesome-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-4.6.3/css/font-awesome.min.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz.css?ver=5.0.1' type='text/css' media='all' />

<!-- This site uses the Google Analytics by MonsterInsights plugin v 6.0.13 - https://www.monsterinsights.com/ -->
<!-- Normally you will find the Google Analytics tracking code here, but the webmaster disabled your user group. -->
<!-- / Google Analytics by MonsterInsights -->

<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/wpdcookiejs/customcookie.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Antworten verbergen","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Bitte f\u00fclle alle ben\u00f6tigten Felder aus","wc_invalid_field":"Nicht alle von dir ausgef\u00fcllten Felder sind richtig.","wc_error_empty_text":"Bitte f\u00fclle dieses Feld aus.","wc_error_url_text":"Bitte \u00fcberpr\u00fcfe deine angegebene URL.","wc_error_email_text":"Bitte \u00fcberpr\u00fcfe deine angegebene Email-Adresse.","wc_invalid_captcha":"Leider wurde der CAPTCHA -Code falsch eingetragen","wc_login_to_vote":"Um deine Stimme abgeben zu k\u00f6nnen musst du angemeldet sein.","wc_deny_voting_from_same_ip":"Es ist nur eine Stimm-Vergabe m\u00f6glich.","wc_self_vote":"Eigene Kommentare k\u00f6nnen nicht bewertet werden.","wc_vote_only_one_time":"Es ist immer nur eine Bewertung erlaubt.","wc_voting_error":"Bewertungs-Fehler bei deiner Wahl: Bitte versuche es erneut","wc_held_for_moderate":"Dein Kommentar wurde zur Freischaltung vorgelegt.","wc_comment_edit_not_possible":"Tut uns leid aber dieser Kommentar kann leider nicht mehr aktualisiert werden.","wc_comment_not_updated":"Tut uns leid aber dieser Kommentar konnte leider nicht aktualisiert werden.","wc_comment_not_edited":"Es wurden keine \u00c4nderungen von dir vorgenommen.","wc_new_comment_button_text":"neuer Kommentar","wc_new_comments_button_text":"neue Kommentare","wc_new_reply_button_text":"Neue Antwort auf deinen Kommentar","wc_new_replies_button_text":"Bei einen von dir abonnierten Video wurde eine neue Antwort ver\u00f6ffentlicht.","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","is_user_logged_in":false,"commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wordpress_comment_order":"asc","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":4000,"storeCommenterData":100000,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"facebookAppID":"","cookiehash":"b68f42a0021b63881a010e7410207d2c","isLoadOnlyParentComments":0,"version":"5.0.1","wc_post_id":83904,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","lastVisitExpires":1561632315,"lastVisitCookie":{"1":{"83904":1559040315}},"wc_captcha_show_for_guest":"1","wc_captcha_show_for_members":"0","is_email_field_required":"1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js?ver=5.0.1'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.3" />
<link rel='shortlink' href='https://jaxenter.de/?p=83904' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fsecurity-log-management-best-practices-83904" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fsecurity-log-management-best-practices-83904&#038;format=xml" />
            <style type="text/css">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</style>
            	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>
		<style type="text/css" id="wp-custom-css">
			/*
Füge deinen eigenen CSS-Code nach diesem Kommentar hinter dem abschließenden Schrägstrich ein. 



Klicke auf das Hilfe-Symbol oben, um mehr zu erfahren.
*/		</style>
	
		

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>

		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->


	</head>
	<body class="post-template-default single single-post postid-83904 single-format-standard">
		<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-563H99"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
		        <header>
        <div class="topbanner hidden-xs hidden-sm">
        	<div class="container">
					<!-- jaxenter.de_leaderboard_Wordpress -->
                    <div id='div-gpt-ad-1423038811881-3'>
                    </div>
            </div>
         </div>
        	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://jaxenter.de/magazine">Java Magazin</a></li>
<li id="menu-item-77506" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77506"><a href="https://e-academy.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">e.academy</a></li>
<li id="menu-item-77814" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77814"><a href="https://jax.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">JAX 2019</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-79302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79302"><a href="https://jaxenter.de/tag/serverless">Serverless</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/kubernetes">Kubernetes</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/machine-learning">Machine Learning</a></li>
</ul>		</div>
	</div>
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">Java's Most Wanted JDKs:</span>
                                    
                                    <a href="https://jaxenter.de/tag/jdk-most-wanted"><u>Die Steckbriefe der Java-Distributionen</u></a>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>

			                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/08/DevOpsCon-Logo-schwarz2-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p><a href="https://devopsconference.de/" target="_blank" rel="noopener">DevOpsCon 2019: 11. bis 14. Juni | Berlin</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/04/was-sind-microservices-1-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/was-sind-microservices-40571"> Was sind eigentlich Microservices?</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/DYF_Logo_74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://develop-your-future.com/de/?utm_medium=referral&amp;utm_source=jaxenter.de&amp;utm_campaign=marketingbox" target="_blank" rel="noopener">Develop Your Future:</a></p>
<p><a href="https://develop-your-future.com/de/?utm_medium=referral&amp;utm_source=jaxenter.de&amp;utm_campaign=marketingbox" target="_blank" rel="noopener">18.06. in Frankfurt</a></p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			
          </div>
          <div class="custom_header_wa">
                    </div>
		</header>
	<script type="text/javascript">
	$( document ).ready(function() {
		$('.single .next-article-popup-post .popup-close').click(function(){
			$('.single .next-article-popup-post').hide();
		});
		$(window).scroll(function() {
		   var hT = $('#content > .text').offset().top,
		       hH = $('#content > .text').outerHeight(),
		       wH = $(window).height(),
		       wS = $(this).scrollTop();
		   if (wS > (hT+hH-wH)){
			   //console.log(wS);
			   if(!$('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').addClass('active');
			   }
		   }else{
			   if($('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').removeClass('active');
			   }
		   }
		});
	}); 
	</script>
	<div class="hidden-xs next-article-popup-post ">
	    <strong class="popup-heading">Nächster Beitrag:</strong>
	    <div class="popup-content">
	    	        <figure class="thumb">
	            <a href="https://jaxenter.de/devops-vorteile-informationsvisualisierung-boards-83916"><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-150x100.jpg" class="alignleft wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a>
	           <!--  <img src="https://entwickler.de/wp-content/uploads/2017/07/ff-brotli-dotnet-mozilla-stt-engine-90x45.jpg" alt="" data-pin-no-hover="true"> -->
	        </figure>
	   	        <h3 class="popup-post-title"><a href="https://jaxenter.de/devops-vorteile-informationsvisualisierung-boards-83916">"DevOps Stories: Ein Plädoyer für physische Informationsvisualisierung"</a></h3>
	    </div>
	    <span class="popup-close">X</span>
	</div>
	


	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Security und Compliance out of the Box</div>
														<h1 class="title">Security: Der Weg zum zentralisierten Logmanagement über zehn Hürden</h1>
							
									<div class="button-tags-block">
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/log" target="_blank" >
	                  #Log 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/security" target="_blank" >
	                  #Security 	         </a>   
	      		</div>
								
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2019-05-28T09:49">28. Mai 2019</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Pierre Gronau										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="200" src="https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2019/05/shutterstock_1248490627-180x120.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"><p style="text-align: right;"><span style="color: #999999;">©Shutterstock / PioneerMountainHomestead</span></p>
</div>
								</div>
														
															<div class="excerpt">
									<p>Logmanagement sticht in der Gesamtheit aller IT-Sicherheitsmaßnahmen als eine der dringlichsten Herausforderungen zur Absicherung von IT-Strukturen heraus. Seine Funktionen ermöglichen eine ganzheitliche Betrachtung auf die IT-Sicherheit und bilden ein Frühwarnsystem bei Auffälligkeiten und Anomalien.</p>
								</div>
													</div>
					
					
					
					<div class="text">
						<p>Relevante Daten, die zuverlässig Auskunft über die aktuellen Sicherheitslevel von IT-Strukturen geben, fallen im Unternehmen vielerorts und in verschiedenen Formaten an. Voneinander separiert sind sie jedoch häufig nicht aussagekräftig genug, um auf Ereignisse oder konkrete Angriffe zu schließen. Wieviel leichter und schneller ließen sich Abweichungen von Mustern erkennen, wenn Mitarbeiter alle wesentlichen Protokolldaten zentralisiert vorfänden? In der Zusammenführung dieser Daten, der Auflösung sicherheitsgefährdender Datensilos, in Echtzeitanalysen von Protokollen und Zwischenfällen sowie klaren Benachrichtigungskonzepten liegen die Kompetenzen von Lösungen für Logmanagement. Damit Unternehmen hier ihre Hausaufgaben zeitnah erledigen können, sind sie auf Out-of-the-Box-Lösungen angewiesen. Damit sind Systeme gemeint, die auch die Komplexität reduzieren und Prozesse vereinfachen. Dieser Beitrag beschreibt einen möglichen Best Case in Form eines Logmanagementkonzepts über mehrere Etappen.</p>
<div class="boxed">
<h3><span style="color: #23294f;">Artikelserie</span></h3>
<ul style="list-style-type: none;">
<li>Teil 1: Warum brauchen wir jetzt Security as a Service, Compliance as a Service?</li>
<li>Teil 2: Die DSGVO wird als Stammgast in die Unternehmen einziehen</li>
<li>Teil 3: Die DSGVO und die Blockchain – ein leichtes Unterfangen?</li>
<li><strong>Teil 4: Security und Compliance out of the Box</strong></li>
</ul>
</div>
<h2>Aller Anfang ist Identität</h2>
<p>Sichere Identitäten gelten als wesentlicher Ausgangspunkt für Sicherheitsketten, um Datenerhebung, -transport und -verarbeitung auf Hardware-, Software- und Prozessebene abzusichern. Damit bilden sie die Voraussetzung für viele weitere Schutzmaßnahmen, die Unternehmen in puncto Informationssicherheit ergreifen sollten, um sich compliant und wettbewerbsfähig aufzustellen. Denn klar ist: Sobald es einem Angreifer gelingt, sich unberechtigt einer Identität zu bemächtigen, laufen alle darauf aufbauenden Maßnahmen, beispielsweise der Zugriffsschutz, ins Leere. So bietet die Gewährleistung sicherer Identitäten über automatisierte Kommunikation ein solides Startglied in der Vertrauenskette.</p>
<p>Mit der Einführung eines definierten Prozesses leiten IT-Verantwortliche die notwendigen organisatorischen Veränderungen ein, legen eine Strategie fest und nutzen Hilfsmittel zur Erreichung der Sicherheitsziele. Aufgrund der übergeordneten Bedeutung des Sicherheitsprozesses betrachte ich diesen im nachfolgenden Abschnitt detaillierter.</p>
<h2>Die W-Fragen beantworten</h2>
<p>Logmanagement ist ein wesentlicher Bestandteil des Managementsystems für Informationssicherheit (englisch kurz <a href="ftp://ftp.software.ibm.com/software/security/products/qradar/documents/iTeam_addendum/b_Leef_format_guide.pdf">ISM</a>) und eine der dringlichsten Aufgaben bei der sicheren Ausgestaltung von ITK-Systemen. Hier genießt die Sicherstellung der Authentizität des jeweiligen Nutzers oberste Priorität. Pharmazie, Lebensmittelbranche und chemische Industrie achten seit jeher darauf. Organisationen wie die Food and Drug Administration (FDA) in den USA und die europäische Verordnung REACH (Registration, Evaluation, Authorisation and Restriction of Chemicals) aus dem Jahr  2007 haben in diesen Branchen zu einer erheblichen Regulierung geführt, die wiederum eine Nachvollziehbarkeit der Frage „Wer hat wann wie mit welcher Charge der Substanz an welchem Produktionsschritt mitgearbeitet?“ impliziert. Folglich ist die persönliche Anmeldung eines Mitarbeiters an einer Anlage der chemischen Industrie durchaus üblich, während andere Branchen diese Ansätze bisher nur teilweise verfolgten. Mögliche Gründe sind Vorbehalte gegenüber vermuteter Arbeitnehmerüberwachung oder technische Probleme. Jenseits dieser Bedenken liegt auf der Hand, dass die Nachvollziehbarkeit von Handlungen und eine persönliche Zuordenbarkeit nur durch die Nutzung persönlicher Nutzerkonten an den Endgeräten erreicht werden kann. Die geteilte Nutzung von Arbeitsrechnern, Kassensystemen oder Maschinen durch diverse Anwender macht die Verwaltung einer weitaus größeren Zahl an Konten erforderlich. Diese Personalisierung der Benutzerkonten führt wiederum zum Bedarf, diese auch auf einer Vielzahl von Geräten parallel und effizient zu verwalten. Zumindest sollte eine persönliche Zuordenbarkeit auf Ebene der Anwendung möglich sein, wenn der Zugang zu den Betriebssystemen aus technischen Gründen nicht personalisiert werden kann oder soll.</p>
<h2>Logzentralisierung</h2>
<p>Letztlich ist nicht auszuschließen, dass es zu Unregelmäßigkeiten oder offensichtlich missbräuchlicher Nutzung von Anwendungen und Applikationen kommt. Hier müssen Administratoren detailliert nachverfolgen können, wer, wann, wo zugegriffen und welche Änderungen vorgenommen hat. Dies setzt jedoch voraus, dass die Anwendung entsprechend detaillierte Protokollierungsdateien erzeugt, diese speichert und sie auch über längere Zeitfenster möglichst unveränderbar zentral vorhält. Im Sinne einer in der IT üblichen Logzentralisierung erweisen sich Funktionen zur direkten, zugriffgeschützten Speicherung der Protokolle auf einem zumindest logisch abgesetzten Logmanagementserver als sinnvoll. Idealerweise beachten Entscheider hier Standardformate, wie sie etwa durch Syslog, <a href="ftp://ftp.software.ibm.com/software/security/products/qradar/documents/iTeam_addendum/b_Leef_format_guide.pdf">Log Event Extended Format (LEEF)</a>, <a href="https://community.softwaregrp.com/t5/ArcSight-Connectors/ArcSight-Common-Event-Format-CEF-Implementation-Standard/ta-p/1645557?attachment-id=68077">Common Event Format (CEF)</a>, <a href="https://www.dmtf.org/standards/cim">DMTFs Common Information Model (CIM)</a> oder <a href="https://www.dmtf.org/standards/cadf">Cloud Auditing Data Federation (CADF)</a> vorgegeben werden. Dies erleichtert die zentrale Auswertung und Korrelation von Meldungen und ermöglicht die Definition zentraler Schwellenwerte (Thresholds). Dazu gehört auch die Alarmierung der IT-Sicherheit, falls mit einem Benutzerkonto mehrfach innerhalb kurzer Zeit an diversen Geräten erfolglose Zugriffsversuche unternommen werden. Diese Benachrichtigung erfolgt am besten vornehmlich über die Nutzung von sogenannten Security-Information-und-Event-Management-Lösungen (SIEM). In diesem Zusammenhang sollten Entscheider eine skalierbare Lösung wählen, da zum einen wirklich umfangreiche Datensammlungen entstehen können und Angreifer zum anderen mit Distributed-Denial-of-Service-(DDoS-)Attacken bewusst die Grenzen solcher Systeme auszuloten versuchen, um nicht protokollierten Schabernack zu treiben.</p>
<p>Die Notwendigkeit von Logmanagement ergibt sich aus dem Dreiklang von gesetzlichen Auflagen, notwendiger Analyse von Sicherheitsvorfällen und kontinuierlichen Analyseprozessen wie bei der Hardware-/Softwareentwicklung. Dabei folgt effizientes Logmanagement stets diesem Prozess: Annahme -&gt; Verarbeitung -&gt; Auswertung -&gt; Visualisierung.</p>
<div id="attachment_83905" style="width: 530px" class="wp-caption aligncenter"><a href="https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1.png"><img class="wp-image-83905" src="https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1.png" alt="Abb. 1: Logmanagement ist ein Prozess, kein Produkt" width="520" height="347" srcset="https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1.png 4210w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-150x100.png 150w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-300x200.png 300w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-768x513.png 768w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-1024x684.png 1024w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-200x134.png 200w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-170x114.png 170w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-120x80.png 120w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-74x50.png 74w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-190x127.png 190w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_1-180x120.png 180w" sizes="(max-width: 520px) 100vw, 520px" /></a><p class="wp-caption-text">Abb. 1: Logmanagement ist ein Prozess, kein Produkt</p></div>
<p>Jeder, der am Logmanagement beteiligt ist, sollte umfänglich begreifen, dass sich hinter dem Begriff mitnichten ein fertiges Produkt verbirgt, sondern Logmanagement ein Prozess (<strong>Abb. 1</strong>) ist, der sich jedoch zum größten Teil automatisieren lässt. Dementsprechend liegt der wahre Nutzen im Wissensmanagement, im internen Aufbau von Logging-Know-how. Dazu gehören zwangsläufig der Aufbau von Strukturen, die Definition aller personenbezogenen Daten im Betrieb, eine sinnhafte Archivierung der Protokolle sowie eine flankierende Konzernbetriebsvereinbarung (KBV).</p>
<h2>Vom Log- zum Protokollmanagement</h2>
<p>In den letzten zehn Jahren hat die Weiterentwicklung verteilter Systeme neue Komplexitäten in der Verwaltung von Protokolldaten geschaffen. Heutige Systeme können Tausende von Serverinstanzen oder Microservices-Container enthalten, die jeweils ihre eigenen Protokolldaten erzeugen. Mit der raschen Entstehung und Dominanz von Cloud-basierten Systemen erleben wir ein explosionsartiges Wachstum maschinell generierter Protokolldaten. Infolgedessen ist das Protokollmanagement zu einem wesentlichen Grundpfeiler eines modernen IT-Betriebs geworden und unterstützt eine Reihe von Anwendungsfällen wie Debugging, Produktions- und Leistungsüberwachung, Support und Fehlerbehebung. Da kann es in der Praxis durchaus vorkommen, dass Unternehmen bis zu einem halben Petabyte Daten prozessieren müssen.</p>
<h2>Big Protocol Data</h2>
<p>Während verteilte Systeme eine hohe Effizienz in Bezug auf die Skalierbarkeit bieten, stellen sie Teams, die sich auf Protokolldaten beziehen, vor Herausforderungen: Wo sollen sie anfangen und welchen Aufwand benötigen sie, um die benötigten Protokolldateien zu finden? IT-Administratoren, DevOps-Profis und Mitarbeiter, die den protokollerstellenden Systemen am nächsten stehen, haben die Aufgabe, dezentrale Protokolldateien unter Einhaltung von Sicherheits- und Complianceanforderungen zu verwalten. Entwickler und Ingenieure, die Probleme auf Anwendungsebene beheben müssen, könnten sich durch den Zugriff auf Protokolldateien auf Produktionsniveau eingeschränkt fühlen. Betriebs-, Entwicklungs-, Datenwissenschaftler- und Supportteams, die Einblicke in das Benutzerverhalten für Trendanalysen und Fehlerbehebungen benötigen, fehlt oft das technische Fachwissen, das erforderlich ist, um Protokolldaten effizient zu nutzen. Angesichts dieser Herausforderungen ist es wichtig, bei der Implementierung einer Protokollierungslösung für Unternehmen Best Practices unbedingt zu berücksichtigen.</p>
<h2>Der Weg zum Log- und Protokollmanagement über zehn Hürden</h2>
<h3>1. Die passende Strategie</h3>
<p>Die Grundannahme muss stets sein, dass sich kein Mitarbeiter blind einloggen darf. Vor jedem Logvorgang muss vielmehr die sorgfältige Überlegung stehen, was das Unternehmen protokollieren möchte und warum. Die Protokollierung muss, wie jede wichtige IT-Komponente, eine klare Strategie verfolgen. Schon bei der Strukturierung des DevOps-Set-ups und selbst bei der Veröffentlichung jeder neuen Funktion achten IT-Leiter oder IT-Administratoren im Idealfall darauf, dass sie einen organisierten Protokollierungsplan beifügen. Ohne eine genau definierte Strategie kann die Menge permanent anwachsender Protokolldaten ausschließlich manuell verwaltet werden, was letztendlich den Prozess der Identifizierung wichtiger Informationen erschwert. Dieser Protokollierungsplan sollte Anweisungen enthalten, ob personenbezogene Daten, Archivierungsanforderungen oder Ähnliches involviert sind.</p>
<p>Ein Tipp am Rande: Wenn eine IP angegeben ist, geht die Rechtsprechung eigentlich fast immer davon aus, dass die EU-DSGVO im Spiel ist.</p>
<p>Bei der Entwicklung einer Logging-Strategie sollten Verantwortliche definieren, was aus Unternehmenssicht Priorität besitzt und welche Werte sie von den Logs erwarten. Ein guter Plan enthält Protokollierungsmethoden und -werkzeuge, Datenaufbewahrungsstandorte und vor allem eine Vorstellung von den spezifischen Informationen, nach denen Mitarbeiter suchen.</p>
<h3>2. Strukturierung der Logdaten</h3>
<p>Parallel zur Entwicklung einer Protokollierungsstrategie ist es wichtig, das Format der Protokolle zu berücksichtigen. Wer effektive Protokollierungsformate nicht versteht, kann aus den hinterlegten Informationen keine Erkenntnisse gewinnen. Logstrukturen sollten klar und verständlich sein, sowohl aus der Sicht des Menschen als auch aus IT-Sicht. Lesbare Protokolle machen potenzielle Fehlerbehebungen einfacher. Die Simplifizierung ermöglicht es zudem, dass Protokollverwaltungsdienste die Informationen weiterverarbeiten; bessere Analysemöglichkeiten und Optionen zu Datenvisualisierungen sind die positiven Folgen. Zwei gängige Protokollstrukturierungsformate sind JSON und KVP (Key Value Pair). Beide liefern kohärente Protokolldaten für das menschliche Verständnis und ermöglichen es, Softwarelösungen für die Protokollierung und Informationen aus einem semistrukturierten Format zu extrahieren.</p>
<h3>3. Protokolldaten separieren und zentralisieren</h3>
<p>Protokolle sollten immer automatisch gesammelt und zeitnah an einen zentralen Ort geschickt werden – getrennt von ihrer Ursprungsumgebung. Die Konsolidierung von Protokolldaten erleichtert die organisierte Verwaltung und erweitert die Analysefunktionen, sodass Verantwortliche Cross-Analysen effizient durchführen und Korrelationen zwischen verschiedenen Datenquellen identifizieren können. Die Zentralisierung von Protokolldaten reduziert auch das Risiko des Datenverlusts in einer Umgebung mit automatischer Skalierung. Eine Weiterleitung von Protokolldaten an einen zentralen Ort ermöglicht es Systemadministratoren, Entwicklern, QS- und Supportteams, Zugriff auf die Daten zu gewähren, ohne Zugang zum Ursprungssystem bereitzustellen. Dadurch können diese Teams Protokolldaten verwenden, um Probleme zu beheben, ohne ins Herz der IT-Strukturen vordringen zu müssen. Die Replikation und Isolierung von Protokolldaten minimiert auch das Risiko, dass Angreifer Protokolldaten löschen oder manipulieren, um Sicherheitsverletzungen zu verbergen. Selbst wenn das System gefährdet ist, bleiben die Protokolle somit intakt.</p>
<h3>4. End-to-end-Protokollierung</h3>
<p>Um häufig auftretende Komplexitäten bei der Fehlerbehebung zu überwinden und eine ganzheitliche Sicht auf Anwendungen und Systeme zu erhalten, sollten Systemadministratoren <strong>alle</strong> Systemkomponenten überwachen und protokollieren. IT-Mitarbeiter sollten daran denken, aus Serverprotokollen wie zum Beispiel Windows-Sicherheitsprotokollen zu protokollieren. Ebenso wichtig ist jedoch die Protokollierung aller relevanten Metriken und Ereignisse aus der zugrunde liegenden Infrastruktur, den Anwendungsschichten und den Endbenutzerclients. Die End-to-end-Protokollierung ermöglicht es, die Leistung der Systeme aus Sicht des Endnutzers zu verstehen. Dies gelingt, wenn Systemadministratoren Faktoren wie Netzlatenz, Seitenladezeiten und Verzögerungen bei Datenbanktransaktionen aufzeichnen und berücksichtigen. Die hierdurch erzeugte Transparenz gewährleistet eine nahezu nahtlose Benutzerführung.</p>
<h3>5. Datenquellen verknüpfen</h3>
<p>Die End-to-end-Protokollierung an einem zentralen Ort ermöglicht es Verantwortlichen, Datenströme aus diversen Quellen wie Anwendungen, Servern, Middleware, Benutzern und Content Delivery Networks (CDNs) dynamisch zu aggregieren, um die wichtigsten Trends und Kennzahlen in Beziehung zueinander zu setzen. Die Korrelation von Daten unterstützt dabei, Ereignisse, die Systemstörungen verursachen, schnell und sicher zu identifizieren und zu verstehen. So kann beispielsweise das Aufdecken von nahezu Echtzeitkorrelationen zwischen der Nutzung von Infrastrukturressourcen und Anwendungsfehlerraten helfen, Anomalien zu identifizieren und zu reagieren, bevor Endnutzer betroffen sind. Dies beschränkt sich nicht nur auf Cyberattacken, sondern eröffnet auch neue Blickwinkel für die Entwicklung und den Betrieb.</p>
<h3>6. Eindeutige Identifikatoren verwenden</h3>
<p>Eindeutige Identifikatoren sind nützlich im Debugging, Support und bei Analysen. Sie erlauben es, komplette Benutzersitzungen und Aktionen einzelner Benutzer genau zu verfolgen. Wenn IT-Mitarbeiter die eindeutige ID eines Benutzers kennen, können sie die Suche nach allen Aktionen filtern, die dieser Benutzer in einem bestimmten Zeitraum durchgeführt hat. Bei einer Aufschlüsselung seiner Aktivität lässt sich eine gesamte Transaktion vom ersten Klick bis zur ausgeführten Datenbankabfrage verfolgen.</p>
<h3>7. Kontext hinzufügen</h3>
<p>Sobald Protokolle als Daten verwendet werden, ist es wichtig, den Kontext jedes Datenpunkts zu berücksichtigen. Hier ein Beispiel aus der Industrie: Zu wissen, dass ein Arbeiter auf eine Schaltfläche geklickt hat, ist möglicherweise nicht so nützlich, wie zu wissen, dass er beispielsweise gezielt auf die Schaltfläche <span style="font-variant: small-caps;">Verbrauchsmaterial bestellen</span> geklickt hat. Das Hinzufügen eines weiteren Kontexts kann die Art der Aktion aufzeigen. So kann bei einer Maschine nach Überschreiten eines Schwellenwerts automatisch ein Techniker angefordert werden, wenn die Protokolldaten Verschleiß der Maschine anzeigen. Wenn der Klick des Mitarbeiters zu einem Fehler geführt hat, erleichtert der verfügbare Kontext eine schnellere Lösung.</p>
<h3>8. Echtzeitüberwachung durchführen</h3>
<p>Service-Unterbrechungen haben im Endkundengeschäft eine Vielzahl unglücklicher Folgen – darunter missgelaunte Kunden, verlorene Bestellungen und fehlende Daten. Wenn im produzierenden Gewerbe beispielsweise Probleme auf Produktionsniveau auftreten, kann eine nahezu Echtzeitüberwachungslösung entscheidend sein, da oftmals jede Sekunde zählt. Neben einfachen Benachrichtigungen entscheidet die Fähigkeit, Probleme zu untersuchen und wichtige Informationen mit geringem Zeitversatz zu identifizieren. Eine „Live Tail“-Sicht auf ihre Protokolldaten kann Entwickler und Administratoren befähigen, Protokollereignisse nahezu in Echtzeit zu analysieren, wenn Benutzer mit ihren Anwendungen oder Systemen interagieren. Die Live-Tail-Suche und -Berichterstattung ermöglicht es den Supportteams zudem, Kundenprobleme zu untersuchen und zu lösen, sobald sie auftreten.</p>
<h3>9. Verwenden Sie Protokolle, um wichtige Trends zu identifizieren</h3>
<p>Fehlerbehebung und Debugging kratzen nur an der Oberfläche der Protokolldaten. Während Protokolle früher als schmerzhafte letzte Möglichkeit galten, Informationen zu finden, können die heutigen Protokollierungsdienste jeden – vom Entwickler bis zum Datenwissenschaftler – befähigen, nützliche Trends und wichtige Erkenntnisse aus ihren Anwendungen und Systemen zu identifizieren.</p>
<p>Die Behandlung von Protokollereignissen als Daten schafft die Möglichkeit, statistische Analysen zukünftig auch mit künstlicher Intelligenz (KI) auf Benutzerereignisse und Systemaktivitäten anzuwenden. Die Berechnung von Durchschnittswerten hilft, anomale Werte besser zu identifizieren. Die Gruppierung von Ereignistypen und Summenwerten ermöglicht es zudem, Ereignisse über die Zeit zu vergleichen. Diese Einblicke öffnen die Tür zu besser fundierten Geschäftsentscheidungen auf der Grundlage von Daten, die außerhalb der Protokolle oft nicht verfügbar sind.</p>
<h3>10. Das gesamte Team stärken</h3>
<p>Ein Protokollverwaltungs- und Analysedienst, der nur einem hochtechnisierten Team zugänglich ist, schränkt die Möglichkeiten des Unternehmens, von Protokolldaten zu profitieren, erheblich ein. Protokollmanagement- und Analysetools sollte Entwicklern Live-Tail-Debugging, Administratoren Echtzeitalarmierung, Datenwissenschaftlern aggregierte Datenvisualisierungen und Supportteams Livesuch- und Filterfunktionen bieten, idealerweise ohne dass jemand jemals auf die Produktionsumgebung zugreifen muss.</p>
<div id="attachment_83906" style="width: 530px" class="wp-caption aligncenter"><a href="https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2.png"><img class="wp-image-83906" src="https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2.png" alt="Abb. 2: Die zehn Hürden auf dem Weg zum Log- und Protokollmanagement" width="520" height="274" srcset="https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2.png 720w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2-150x79.png 150w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2-300x158.png 300w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2-200x106.png 200w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2-170x90.png 170w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2-120x63.png 120w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2-190x100.png 190w, https://jaxenter.de/wp-content/uploads/2019/05/gronau_logmanagement_2-180x95.png 180w" sizes="(max-width: 520px) 100vw, 520px" /></a><p class="wp-caption-text">Abb. 2: Die zehn Hürden auf dem Weg zum Log- und Protokollmanagement</p></div>
<h2>Security out of the box: Unterstützung für aufwändige Strukturen</h2>
<p>Der in <strong>Abbildung 2</strong> skizzierte Hürdenlauf ist aufwendig und kann IT-Mitarbeiter-Ressourcen, gerade in IT-Arbeitsplatz-intensiven Großunternehmen, belasten. Ich empfehle Open-Source-Lösungen, die Protokolle wie Logfiles aus allen Systemen, Komponenten und von Endgeräten sammeln und strukturieren. Auf Basis erkannter Anomalien identifizieren sie automatisiert ungewünschte Zugriffe, Hackerangriffe und Übertragungsabbrüche. Hilfreich sind Werkzeuge, die Anomalien visualisieren und Verantwortlichen so als Basis für die Ergreifung geeigneter Sicherheitsmaßnahmen dienen.</p>
					</div>
					
										
					
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/security-log-management-best-practices-83904" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/security-log-management-best-practices-83904" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=Security: Der Weg zum zentralisierten Logmanagement über zehn Hürden - https://jaxenter.de/security-log-management-best-practices-83904" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/security-log-management-best-practices-83904" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/security-log-management-best-practices-83904" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/security-log-management-best-practices-83904" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/security-log-management-best-practices-83904" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/security-log-management-best-practices-83904" data-url-old=""></span></div>
						</a>
					</div>
					
					<div class="row"><div class="more-topics"><div class="col-xs-12 col-md-3"><h3 class="box-headline">Verwandte Themen:</h3></div><div class="col-xs-12 col-md-9">		<div class="button-tags-block">
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/log" target="_blank" >
	                   Log 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/security" target="_blank" >
	                   Security 	         </a>   
	      		</div>
	</div></div></div>
					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2018/11/gronau-1-150x100.jpg" width="96" height="64" alt="Pierre Gronau" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Pierre Gronau</div>

																							<div class="author-description">
													Pierre Gronau ist Gründer der Gronau IT Cloud Computing GmbH. Seit zwanzig Jahren arbeitet er als Senior-IT-Berater mit umfangreicher Projekterfahrung. Zu seinen Kompetenzfeldern gehören Servervirtualisierungen, Cloud Computing und Automationslösungen sowie Datensicherheit und IT-Datenschutz. Seine Analyse- und Lösungskompetenz dient Branchen von Gesundheitswesen bis Automotive, von Telekommunikation bis Finanzwesen als Orientierung für Unternehmensentwicklung in puncto Digitalisierungsstrategien und IT-Sicherheitskonzepte.												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/pierregronau">Alle Beiträge von Pierre Gronau</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/4-strategien-container-security-sicherheit-79930" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2019/01/container-security-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/01/container-security-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2019/01/container-security-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/01/container-security-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/01/container-security-200x134.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/01/container-security-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/01/container-security-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2019/01/container-security-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2019/01/container-security-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2019/01/container-security.jpg 500w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							4 Strategien zur Containersicherheit: So lassen sich Security-Sorgen vermeiden						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/agile/security-aware-development-70496" rel="bookmark">
						<div class="image">
															<img width="186" height="130" src="https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes-186x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2018/04/carsten-cordes.jpg 500w" sizes="(max-width: 186px) 100vw, 186px" />													</div>
						<div class="title">
							Security Aware Development: Wie das Thema Sicherheit im ganzen Entwicklungsprozess berücksichtigt werden kann						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/was-die-qualitaet-von-websystemen-ausmacht-pruefbarkeit-31749" rel="bookmark">
						<div class="image">
															<img width="153" height="130" src="https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking-153x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking-153x130.jpg 153w, https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking-150x127.jpg 150w, https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking-300x254.jpg 300w, https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking-200x169.jpg 200w, https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking-170x144.jpg 170w, https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking-94x80.jpg 94w, https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking-180x152.jpg 180w, https://jaxenter.de/wp-content/uploads/2015/12/popart-thinking.jpg 1000w" sizes="(max-width: 153px) 100vw, 153px" />													</div>
						<div class="title">
							Was die Qualität von Websystemen ausmacht: Prüfbarkeit						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

																				<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
							    <div class="wpdiscuz_top_clearing"></div>
                    <div id="comments" class="comments-area">
                    <div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>
                            <h3 id="wc-comment-header">Hinterlasse einen Kommentar</h3>
                <div id="wpcomm" class="wpdiscuz_unauth wpd-default">
                            <div class="wc-comment-bar">
                    <p class="wc-comment-title">
                        Hinterlasse den ersten Kommentar!                    </p>
                    <div class="wpdiscuz_clear"></div>
                </div>
                                    <div class="wc_social_plugin_wrapper">
                            </div>
                    <div class="wc-form-wrapper wc-main-form-wrapper"  id='wc-main-form-wrapper-0_0' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                                        <form class="wc_comm_form wc_main_comm_form" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                                                                                <div class="wc-field-avatararea">
                                <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="64" height="64" alt="avatar" class="avatar avatar-64 wp-user-avatar wp-user-avatar-64 photo avatar-default" />                            </div>
                                                <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">
                                <textarea id="wc-textarea-0_0" pattern=".{1,4000}" maxlength=4000 placeholder="Beginne eine Diskussion" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">4000</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fa fa-user"></i></div>
                                                <input required="required" class="wc_name wpd-field" type="text" name="wc_name" value="" placeholder="Name" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fa fa-at"></i></div>
                                                <input required="required" class="wc_email wpd-field" type="email" name="wc_email" value="" placeholder="Email">
                            </div>
                            <div class="wpdiscuz-item wpd-has-icon">
                                        <div class="wpd-field-icon"><i class="fa fa-link"></i></div>
                                        <input class="wc_website wpd-field" type="text" name="wc_website" value="" placeholder="Website">
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Insert the CAPTCHA code">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5cecf51bc2bd5"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5cecf51bc2bd5" class="wpdiscuz-cnonce" name="cnonce" value="c5cecf51bc2bd5" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                
                                            <label class="wpd_label">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <div class="wpd-field-desc"><i class="fa fa-bell wpdicon wpdicon-on"></i><span>Notify of new replies to this comment - (on)</span></div>
                                    <div class="wpd-field-desc"><i class="fa fa-bell-slash wpdicon wpdicon-off"></i><span>Notify of new replies to this comment - (off)</span></div>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                    </div>
                <div id = "wpdiscuz_hidden_secondary_form" style = "display: none;">
                    <div class="wc-form-wrapper wc-secondary-form-wrapper"  id='wc-secondary-form-wrapper-wpdiscuzuniqueid'  style='display: none;' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                            <div class="wc-secondary-forms-social-content"></div>
                                        <form class="wc_comm_form wc-secondary-form-wrapper" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                                                                                <div class="wc-field-avatararea">
                                <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="48" height="48" alt="avatar" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 photo avatar-default" />                            </div>
                                                <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">
                                <textarea id="wc-textarea-wpdiscuzuniqueid" pattern=".{1,4000}" maxlength=4000 placeholder="Beteilige dich an der Dikussion" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">4000</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fa fa-user"></i></div>
                                                <input required="required" class="wc_name wpd-field" type="text" name="wc_name" value="" placeholder="Name" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fa fa-at"></i></div>
                                                <input required="required" class="wc_email wpd-field" type="email" name="wc_email" value="" placeholder="Email">
                            </div>
                            <div class="wpdiscuz-item wpd-has-icon">
                                        <div class="wpd-field-icon"><i class="fa fa-link"></i></div>
                                        <input class="wc_website wpd-field" type="text" name="wc_website" value="" placeholder="Website">
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Insert the CAPTCHA code">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5cecf51bc2ce2"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5cecf51bc2ce2" class="wpdiscuz-cnonce" name="cnonce" value="c5cecf51bc2ce2" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                
                                            <label class="wpd_label">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <div class="wpd-field-desc"><i class="fa fa-bell wpdicon wpdicon-on"></i><span>Notify of new replies to this comment - (on)</span></div>
                                    <div class="wpd-field-desc"><i class="fa fa-bell-slash wpdicon wpdicon-off"></i><span>Notify of new replies to this comment - (off)</span></div>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                    </div>
                </div>
                                           

                <div class="wpdiscuz-front-actions">
                                            <div class="wpdiscuz-sbs-wrap">
                            <span><i class="fa fa-envelope-o" aria-hidden="true"></i>&nbsp; Subscribe &nbsp;<i class="fa fa-caret-down" aria-hidden="true"></i></span>
                        </div>
                                                            <div class="clearfix"></div>
                </div>

                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://jaxenter.de/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Benachrichtige mich zu: </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">Alle neuen Kommentare</option>
                                                                                                                            <option value="all_comment" >Nur Antworten zu meinen Kommentar/en</option>
                                                                            </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" type="submit" value="›" name="wpdiscuz_subscription_button" />
                                </div> 
                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="52e27d6484" /><input type="hidden" name="_wp_http_referer" value="/security-log-management-best-practices-83904" />                                <input type="hidden" value="83904" name="wpdiscuzSubscriptionPostId" />
                            </form>
                                                <div class="wpdiscuz_clear"></div>
                                            </div>
                    
                                <div id="wcThreadWrapper" class="wc-thread-wrapper">
                                    
                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
                <div class="wpdiscuz_clear"></div>
                                            </div>
        </div>
        <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div>
        					</div>
														</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
				<div class="widget sidebarSpecificTagContent"><p><iframe style="margin: 0px; padding: 0px; overflow: hidden; border: none;" src="https://devopsconference.de/session-qualification/doc-se-2019-1/?layout=sidebarfeed&amp;utmtracker=deactivate" width="350" height="800" scrolling="no"></iframe></p>
</div><div id="polls-widget-5" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-42" class="wp-polls">
	<form id="polls_form_42" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_42_nonce" name="wp-polls-nonce" value="246000732b" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="42" /></p>
		<p><strong>Update auf Java 12 – machen Sie mit?</strong></p><div id="polls-42-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-327" name="poll_42" value="327" /> <label for="poll-answer-327">Sowohl beruflich als auch privat mache ich das Update auf Java 12 mit</label></li>
		<li><input type="radio" id="poll-answer-328" name="poll_42" value="328" /> <label for="poll-answer-328">Ich mache das Update auf Java 12 privat, im Geschäft spielt das Release keine Rolle</label></li>
		<li><input type="radio" id="poll-answer-329" name="poll_42" value="329" /> <label for="poll-answer-329">Ich mache das Update auf Java 12 gar nicht mit</label></li>
		<li><input type="radio" id="poll-answer-330" name="poll_42" value="330" /> <label for="poll-answer-330">Geschäftlich ja, privat nein</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(42);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-42-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="aktuelle_magazine-6" class="widget widget_aktuelle_magazine"><div class="ausgabe-wrapper"><p class="widget-title">Artikel erschienen in</p><div class="image"><a href="https://jaxenter.de/ausgaben/java-magazin-6-19"><img width="212" height="300" src="https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2019/04/JM6_19_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 212px) 100vw, 212px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/ausgaben/java-magazin-6-19">Java Magazin 6.19</a></div><div class="button"><a href="https://jaxenter.de/ausgaben/java-magazin-6-19" class="button">Infos zum Heft</a></div></div></div></div><div id="tag-widget-5" class="widget TagWidget"><a href="https://jaxenter.de/tag/devops"><p class="widget-title">DevOpsCon 2018</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item DevOps DevOps Stories Kolumne" id="posts-by-tag-item-83916"><a class="thumb" href="https://jaxenter.de/devops-vorteile-informationsvisualisierung-boards-83916" title="DevOps Stories: Ein Plädoyer für physische Informationsvisualisierung"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/09/DevOps_Stories-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-vorteile-informationsvisualisierung-boards-83916">DevOps Stories: Ein Plädoyer für physische Informationsvisualisierung</a></li><li class="posts-by-tag-item Agile DevOps Soft Skills Software-Architektur W-JAX 2018" id="posts-by-tag-item-84117"><a class="thumb" href="https://jaxenter.de/softskills-softwarearchitekt-prinzipien-team-84117" title="Softwarearchitekt: Wie ich ein erfolgreicher werde und was er macht"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-300x169.png 300w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-768x432.png 768w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-1024x576.png 1024w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-200x113.png 200w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-170x96.png 170w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-120x68.png 120w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2019/05/Softwarearchitekt-Eberhard-Wolff.png 1280w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/softskills-softwarearchitekt-prinzipien-team-84117">Softwarearchitekt: Wie ich ein erfolgreicher werde und was er macht</a></li><li class="posts-by-tag-item Agile DevOps W-JAX 2018" id="posts-by-tag-item-83986"><a class="thumb" href="https://jaxenter.de/agile-recruiting-transformation-fachkraefte-video-83986" title="Agiles Recruiting: Wie stelle ich sinnvoll (agile) Softwareentwickler ein?"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-300x169.png 300w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-768x432.png 768w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-1024x576.png 1024w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-200x113.png 200w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-170x96.png 170w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-120x68.png 120w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2019/05/Konstantin-Diener.png 1280w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/agile-recruiting-transformation-fachkraefte-video-83986">Agiles Recruiting: Wie stelle ich sinnvoll (agile) Softwareentwickler ein?</a></li><li class="posts-by-tag-item Agile DevOps W-JAX 2018" id="posts-by-tag-item-83830"><a class="thumb" href="https://jaxenter.de/agile-teams-transformation-erfolgsfaktoren-83830" title="Agile Teamentwicklung: So wird ihr Team agil!"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-300x169.png 300w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-768x432.png 768w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-1024x576.png 1024w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-200x113.png 200w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-170x96.png 170w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-120x68.png 120w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2019/05/Reginald-Rink-teamentwicklung.png 1280w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/agile-teams-transformation-erfolgsfaktoren-83830">Agile Teamentwicklung: So wird ihr Team agil!</a></li><li class="posts-by-tag-item Continuous Delivery DevOps" id="posts-by-tag-item-83666"><a class="thumb" href="https://jaxenter.de/devooops-devops-2-kpi-definieren-83666" title="DevOoops – Kontinuierliches Feedback und sinnvolle KPIs als Schlüssel zum Erfolg"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2019/03/devooops-devops.jpg 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devooops-devops-2-kpi-definieren-83666">DevOoops – Kontinuierliches Feedback und sinnvolle KPIs als Schlüssel zum Erfolg</a></li><li class="posts-by-tag-item Agile DevOps DevOpsCon 2018" id="posts-by-tag-item-83581"><a class="thumb" href="https://jaxenter.de/devops-chatops-transformation-video-83581" title="DevOps in ChatOps: Die sieben Wege der Transformation"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--150x84.png 150w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--300x169.png 300w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--768x432.png 768w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--1024x576.png 1024w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--200x113.png 200w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--170x96.png 170w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--120x68.png 120w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--190x107.png 190w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018--180x101.png 180w, https://jaxenter.de/wp-content/uploads/2019/05/Taylor-C-Johannsen-DevOpsCon-2018-.png 1280w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-chatops-transformation-video-83581">DevOps in ChatOps: Die sieben Wege der Transformation</a></li></ul></div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        </div>
    </div>
</div>
									</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-79978" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-79978"><a href="https://jaxenter.de/">JAXenter.de</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="https://entwickler.de/javascript-kompendium">JavaScript Kompendium</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="https://entwickler.de/cloud-compendium">Cloud Compendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://serverless-architecture.io/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Serverless Architecture Conference</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="https://mlconference.ai/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Machine Learning Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://blockchainconf.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Blockchain Technology Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="https://e-academy.net/">e.academy</a></li>
<li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-79980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79980"><a href="https://tutorials.entwickler.de/">entwickler.tutorials</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-79979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79979"><a href="https://entwickler.de/jobs">entwickler.jobs</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>
		
		<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
	</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 

Served from: jaxenter.de @ 2019-05-28 10:45:15 by W3 Total Cache
-->