<!DOCTYPE html>
<html lang="de-DE" prefix="og: http://ogp.me/ns#"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>Mutation Testing: Attack of the Java Mutants</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
	<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-563H99');</script>
	
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Mutation Testing ist ein interessantes Tool, das wir zur Entwicklungszeit einsetzen können, um unsere Tests zu verbessern, während wir sie schreiben."/>
<meta name="robots" content="noodp"/>
<meta name="keywords" content="Java,Testen"/>
<link rel="canonical" href="https://jaxenter.de/mutant-testing-pit-java-84437" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Mutation Testing: Attack of the Java Mutants" />
<meta property="og:description" content="Mutation Testing ist ein interessantes Tool, das wir zur Entwicklungszeit einsetzen können, um unsere Tests zu verbessern, während wir sie schreiben." />
<meta property="og:url" content="https://jaxenter.de/mutant-testing-pit-java-84437" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="Java" />
<meta property="article:tag" content="Testen" />
<meta property="article:section" content="Artikel" />
<meta property="article:published_time" content="2019-07-24T07:40:58+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="202" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; Mutation Testing: Attack of the Java Mutants Kommentar-Feed" href="https://jaxenter.de/mutant-testing-pit-java-84437/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sands-breaking-news-css'  href='https://jaxenter.de/wp-content/plugins/sands-breaking-news/includes/style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpdiscuz-font-awesome-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-4.6.3/css/font-awesome.min.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz.css?ver=5.0.1' type='text/css' media='all' />

<!-- This site uses the Google Analytics by MonsterInsights plugin v 6.0.13 - https://www.monsterinsights.com/ -->
<!-- Normally you will find the Google Analytics tracking code here, but the webmaster disabled your user group. -->
<!-- / Google Analytics by MonsterInsights -->

<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/wpdcookiejs/customcookie.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Antworten verbergen","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Bitte f\u00fclle alle ben\u00f6tigten Felder aus","wc_invalid_field":"Nicht alle von dir ausgef\u00fcllten Felder sind richtig.","wc_error_empty_text":"Bitte f\u00fclle dieses Feld aus.","wc_error_url_text":"Bitte \u00fcberpr\u00fcfe deine angegebene URL.","wc_error_email_text":"Bitte \u00fcberpr\u00fcfe deine angegebene Email-Adresse.","wc_invalid_captcha":"Leider wurde der CAPTCHA -Code falsch eingetragen","wc_login_to_vote":"Um deine Stimme abgeben zu k\u00f6nnen musst du angemeldet sein.","wc_deny_voting_from_same_ip":"Es ist nur eine Stimm-Vergabe m\u00f6glich.","wc_self_vote":"Eigene Kommentare k\u00f6nnen nicht bewertet werden.","wc_vote_only_one_time":"Es ist immer nur eine Bewertung erlaubt.","wc_voting_error":"Bewertungs-Fehler bei deiner Wahl: Bitte versuche es erneut","wc_held_for_moderate":"Dein Kommentar wurde zur Freischaltung vorgelegt.","wc_comment_edit_not_possible":"Tut uns leid aber dieser Kommentar kann leider nicht mehr aktualisiert werden.","wc_comment_not_updated":"Tut uns leid aber dieser Kommentar konnte leider nicht aktualisiert werden.","wc_comment_not_edited":"Es wurden keine \u00c4nderungen von dir vorgenommen.","wc_new_comment_button_text":"neuer Kommentar","wc_new_comments_button_text":"neue Kommentare","wc_new_reply_button_text":"Neue Antwort auf deinen Kommentar","wc_new_replies_button_text":"Bei einen von dir abonnierten Video wurde eine neue Antwort ver\u00f6ffentlicht.","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","is_user_logged_in":false,"commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wordpress_comment_order":"asc","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":4000,"storeCommenterData":100000,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"facebookAppID":"","cookiehash":"b68f42a0021b63881a010e7410207d2c","isLoadOnlyParentComments":0,"version":"5.0.1","wc_post_id":84437,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","lastVisitExpires":1566546063,"lastVisitCookie":{"1":{"84437":1563954063}},"wc_captcha_show_for_guest":"1","wc_captcha_show_for_members":"0","is_email_field_required":"1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js?ver=5.0.1'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.3" />
<link rel='shortlink' href='https://jaxenter.de/?p=84437' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fmutant-testing-pit-java-84437" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fmutant-testing-pit-java-84437&#038;format=xml" />
            <style type="text/css">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</style>
            	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>
		<style type="text/css" id="wp-custom-css">
			/*
Füge deinen eigenen CSS-Code nach diesem Kommentar hinter dem abschließenden Schrägstrich ein. 



Klicke auf das Hilfe-Symbol oben, um mehr zu erfahren.
*/
@media print{
article.post.single .social-icons, .footer-menu, #sidebar, .related-posts, .comments-wrapper{
display:none;
}
}		</style>
	
		

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>

		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->


	</head>
	<body class="post-template-default single single-post postid-84437 single-format-standard">
		<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-563H99"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
		        <header>
        <div class="topbanner hidden-xs hidden-sm">
        	<div class="container">
					<!-- jaxenter.de_leaderboard_Wordpress -->
                    <div id='div-gpt-ad-1423038811881-3'>
                    </div>
            </div>
         </div>
        	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://jaxenter.de/magazine">Java Magazin</a></li>
<li id="menu-item-77506" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77506"><a href="https://e-academy.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">e.academy</a></li>
<li id="menu-item-77814" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77814"><a href="https://jax.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">JAX 2019</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-79302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79302"><a href="https://jaxenter.de/tag/serverless">Serverless</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/kubernetes">Kubernetes</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/machine-learning">Machine Learning</a></li>
</ul>		</div>
	</div>
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">Die beliebtesten JDKs:</span>
                                    
                                    <a href="https://jaxenter.de/quickvote-jdk-distribution-85023"><u>Welche Java-Distribution nutzen Sie?</u></a>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>

			                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/W-JAX-Logo-blau-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p><a href="https://jax.de" target="_blank" rel="noopener">W-JAX 2019: 4. bis 8. November | München</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/04/was-sind-microservices-1-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/was-sind-microservices-40571"> Was sind eigentlich Microservices?</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/DYF_Logo_74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://develop-your-future.com/de/?utm_medium=referral&amp;utm_source=jaxenter.de&amp;utm_campaign=marketingbox" target="_blank" rel="noopener">Die Jobmesse für Entwickler<br />
16.10. in Berlin | 23.10. in München</a></p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			
          </div>
          <div class="custom_header_wa">
                    </div>
		</header>
	<script type="text/javascript">
	$( document ).ready(function() {
		$('.single .next-article-popup-post .popup-close').click(function(){
			$('.single .next-article-popup-post').hide();
		});
		$(window).scroll(function() {
		   var hT = $('#content > .text').offset().top,
		       hH = $('#content > .text').outerHeight(),
		       wH = $(window).height(),
		       wS = $(this).scrollTop();
		   if (wS > (hT+hH-wH)){
			   //console.log(wS);
			   if(!$('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').addClass('active');
			   }
		   }else{
			   if($('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').removeClass('active');
			   }
		   }
		});
	}); 
	</script>
	<div class="hidden-xs next-article-popup-post ">
	    <strong class="popup-heading">Nächster Beitrag:</strong>
	    <div class="popup-content">
	    	        <figure class="thumb">
	            <a href="https://jaxenter.de/enterprisetales-jdbc-datenbank-reaktiv-84457"><img width="150" height="110" src="https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2-150x110.jpg" class="alignleft wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2-150x110.jpg 150w, https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2-300x220.jpg 300w, https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2-200x147.jpg 200w, https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2-170x125.jpg 170w, https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2-109x80.jpg 109w, https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2-177x130.jpg 177w, https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2-180x132.jpg 180w, https://jaxenter.de/wp-content/uploads/2013/10/enterprisetales_2.jpg 430w" sizes="(max-width: 150px) 100vw, 150px" /></a>
	           <!--  <img src="https://entwickler.de/wp-content/uploads/2017/07/ff-brotli-dotnet-mozilla-stt-engine-90x45.jpg" alt="" data-pin-no-hover="true"> -->
	        </figure>
	   	        <h3 class="popup-post-title"><a href="https://jaxenter.de/enterprisetales-jdbc-datenbank-reaktiv-84457">"EnterpriseTales: Reaktiv bis zur Datenbank"</a></h3>
	    </div>
	    <span class="popup-close">X</span>
	</div>
	


	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Mutation Testing mit PIT</div>
														<h1 class="title">Mutation Testing: Attack of the Java Mutants</h1>
							
									<div class="button-tags-block">
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/java" target="_blank" >
	                  #Java 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/testen" target="_blank" >
	                  #Testen 	         </a>   
	      		</div>
								
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2019-07-24T07:40">24. Juli 2019</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Kevin Wittek										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="202" src="https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855-150x101.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855-200x135.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855-190x128.jpg 190w, https://jaxenter.de/wp-content/uploads/2019/06/shutterstock_688942855-180x121.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"><p style="text-align: right;"><span style="color: #999999;">©Shutterstock / delcarmat</span></p>
</div>
								</div>
														
															<div class="excerpt">
									<p>Im gleichen Maß, in dem das Schreiben von Tests immer mehr in den Aufgabenbereich von Entwicklern fällt, müssen wir uns vermehrt die Frage stellen, wie wir die Qualität unserer Testsuite messen und bewerten können. Mutation Testing ist in diesem Kontext ein interessantes Tool, das wir zur Entwicklungszeit einsetzen können, um unsere Tests zu verbessern, während wir sie schreiben.</p>
								</div>
													</div>
					
					
					
					<div class="text">
						<p>Für viele von uns sind Tests ein ständiger Begleiter im Entwickleralltag und für manche womöglich ein zuverlässiger Partner, der es uns erlaubt, die Kontrolle über unseren Produktionscode zu behalten. So ermöglicht es uns eine gute Testsuite, unseren Code kontinuierlich zu erweitern und einem Refactoring zu unterziehen, ohne dass wir uns Sorgen machen müssen, bestehende Funktionalitäten dabei zunichte zu machen.</p>
<p>Aber wie kann ich beim Refactoring meines Testcodes Sicherheit erhalten? Woher weiß ich, dass ich einer Testsuite trauen kann, wenn ich in ein bestehendes Projekt komme? Wie kann ich sicherstellen, dass ich effektive Tests schreibe? Und woher weiß ich, dass mein Team effektive Tests schreibt?</p>
<p>Zusammenfassend stellt sich uns also die Frage: Wie kann ich die Qualität meiner Testsuite beurteilen? Hier wird als Antwort gerne auf Code Coverage verwiesen (vielleicht auch, weil es sich als Metrik so managerfreundlich in Tools wie SonarQube visualisieren lässt). Es gibt verschiedene Code-Coverage-Kriterien, üblich sind zum Beispiel Line-, Branch- oder Statement-Coverage. Doch diese Coverage sagt letztlich nur aus, welche Teile unseres Codes ausgeführt wurden, aber nicht, welche Teile getestet werden. Code ausführen ist nicht das gleiche wie Code testen. Entsprechend kann Code Coverage uns nur sagen, welcher Code nicht getestet wurde.</p>
<div class='widgets_on_page'> <div id="wysiwyg_widgets_widget-5" class="widget widget_wysiwyg_widgets_widget"><!-- Widget by WYSIWYG Widgets v2.3.6 - https://wordpress.org/plugins/wysiwyg-widgets/ --><div class="widgets_on_page">
<div id="wp_editor_widget-3" class="widget WP_Editor_Widget">
<div style="width: 100%; padding: 0px 0px 0px 0px; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box" style="margin: 0 !important; padding: 5px 25px 0px 30px;">
<div class="row">
<div class="sands-sb-content col-xs-3 col-sm-3 col-lg-3">
<div style="padding: 10px;"><img style="max-width: 100%; height: auto; border: 0px solid #fff;" src="/wp-content/uploads/2019/06/Screenshot_33.png" alt="W-JAX 2019 Java-Dossier für Software-Architekten" width="500" height="350" /></div>
</div>
<div class="sands-sb-content col-xs-9 col-sm-9 col-lg-9">
<h3 style="padding-top: 20px !important; color: #455761 !important; text-align: center !important; font-size: 19px !important;"><strong>Kostenlos: 30+ Seiten Java-Wissen von Experten</strong></h3>
<div style="padding: 10px 0px 0px 0px;">
<div class="sb-content-item-sands" style="border-bottom: 0px solid #9d9d9c; padding: 0;">
<p style="margin: 5px; color: #000;">Sie finden Artikel zu<strong> EnterpriseTales</strong>, <strong>Microservices</strong>, <strong>Req4Arcs</strong>, <strong>Java Core</strong> und <strong>Angular-Abenteuer</strong> von Experten wie Uwe Friedrichsen (codecentric AG), Arne Limburg (Open Knowledge), Manfred Steyer (SOFTWAREarchitekt.at) und vielen weiteren.</p>
<div class="button" style="margin: 0 auto; padding: 20px 0px 0px 0px; text-align: center;"><a style="padding: 5px; color: black; background-color: #c6cb00; text-decoration: none; border-radius: 10px !important;" href="https://jax.de/java-dossier-fuer-software-architekten-2019/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_campaign=contentboxdossier2019"><strong>Dossier herunterladen</strong></a></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<p>&nbsp;</p>
<div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://extreme-java-camp.de/"><img style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2019/07/EJC_19_Banner_2126x162_52465_v2.png" alt="Extreme Java Camp 2019" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2019/07/EJC_19_Banner_550x214_52465_v2.png" alt="Extreme Java Camp 2019" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;"></div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jaxenter.de/wp-content/uploads/2019/01/kabutz_heinz_wp.jpg" alt="Heinz Kabutz" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://extreme-java-camp.de/"><span style="color: #6322e6;"><span style="color: #e30613;">Intensiv-Workshops zu fortgeschrittenen Java-Themen und zu Java Concurrency Performance</span></span></a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Dr. Heinz Kabutz (&#8222;The Java Specialist&#8220;)</p>
</div>
</div>
</div>
</div>
</div>
</div>
<!-- / WYSIWYG Widgets --></div>
  </div><!-- widgets_on_page -->
<h2>Rise of the Mutants</h2>
<p>Bereits 1971 veröffentlichte der Student Richard Lipton, bekannt durch seine Pionierarbeit im Bereich des DNA-Computing, das Paper „Fault Diagnosis of Computer Programs“, in dem er erstmalig die Idee äußert, bewusst Bugs in eine zu testende Codebasis einzuführen, um die existierende Testsuite daraufhin zu bewerten, ob sie diesen Bug findet. Da Lipton dieses Paper während seines Studiums lediglich im Rahmen einer Seminararbeit veröffentlicht hat, ist es sehr schwer, diese Quelle ausfindig zu machen, wenngleich das Paper in vielen anderen akademischen Papers referenziert wird.</p>
<p>Glücklicherweise veröffentlichte Lipton zusammen mit DeMillo und Sayward im IEEE Computer Journal 1978 das Paper „Hints on Test Data Selection: Help for the Practicing Programmer“. Unter Berücksichtigung der Coupling-Effect-Hypothese präsentieren Lipton et al. in diesem eine Methode, um festzustellen, ob die verwendeten Testdaten ein Programm hinreichend getestet haben (wir können in diesem Fall Testdaten mit Unit-Tests gleichsetzen). Diese Methode wird in diesem Paper als Program Mutation bezeichnet. Der Coupling Effect besagt, dass Testdaten (Tests), die alle Programme abweichend von einem korrekten Programm nur durch einfache Fehler unterscheiden können, so empfindlich sind, dass sie auch komplexere Fehler implizit unterscheiden. Das Vorgehen ist bei der im Paper vorgestellten Methode wie folgt:</p>
<ol>
<li>Ein Programm P wird mit einer Menge Testdaten T, deren Eignung festgestellt werden soll, von einem Mutation System ausgeführt.
<ol style="list-style-type: lower-alpha;">
<li>Wenn hierbei Fehler auftreten, ist P fehlerhaft -&gt; Abbruch</li>
<li>Wenn hierbei keine Fehler auftreten, könnte P ebenfalls fehlerhaft sein, falls der Umfang von T ungenügend ist.</li>
</ol>
</li>
<li>Das Mutation System erstellt eine Reihe von Mutationen von P, die sich von P durch einzelne, einfache Fehler unterscheiden. Diese bezeichnen wir als P<sub>1</sub>, P<sub>2</sub>, …, P<sub>k</sub>. So wird z. B. der Ausdruck a == b zu a &gt;= b mutiert. Wenn wir nun die mutierten Programme mit den Testdaten ausführen, können zwei verschiedene Fälle eintreten:
<ol style="list-style-type: lower-alpha;">
<li>P<sub>i</sub> verhält sich anders als P, erzeugt also einen Fehler basierend auf den Testdaten.</li>
<li>P<sub>i</sub> verhält sich wie P auf Basis der Testdaten.</li>
</ol>
</li>
<li>Für jeden Mutanten, für den der Fall (a) eingetreten ist, sagen wir, der Mutant wurde „getötet“, wir hatten also Testdaten, die diesen Fehler feststellen konnten. Im Fall (b) sagen wir, der Mutant „lebt“. Das kann zwei verschiedene Gründe haben:
<ol style="list-style-type: lower-alpha;">
<li>Unsere Testdaten sind ungenügend um den durch P<sub>i</sub> eingeführten Defekt zu identifizieren (das ist eine erstrebenswerte Erkenntnis).</li>
<li>P und P<sub>i</sub> sind äquivalente Programme. Wir bezeichnen Pi in diesem Fall als einen Equivalent Mutant, und der kann unmöglich durch Testdaten getötet werden, weil sich das Programm trotz der Mutation verhält wie gewünscht. Diese Mutanten sind händisch zu identifizieren und können ignoriert werden.</li>
</ol>
</li>
</ol>
<p>Bereits in Liptons Paper wird erwähnt, dass dieser Prozess vor allem während des Entwicklungsprozesses dabei helfen soll, gute Testdaten zu erzeugen und einfach Fehler zu finden. Es geht also beim Mutation Testing nicht in erster Linie darum, Metriken in einem nachgelagerten QS-Prozess zu erzeugen.</p>
<h2>Mutation Testing goes Open Source</h2>
<p>Obgleich die theoretischen Grundlagen für Mutation Testing nicht neu sind, dauerte es viele Jahre, bis Mutation Testing schließlich in Teilen Einzug in den Programmieralltag hielt. Einer der prominenteren Open-Source-Vertreter im Java-Umfeld ist vermutlich das im Jahr 2000 veröffentlichte <a href="http://jester.sourceforge.net/">Projekt Jester</a>. Zu Jester finden wir ein interessantes Zitat von Kent Beck: „Why just think your tests are good when you can know for sure? Sometimes Jester tells me my tests are airtight, but sometimes the changes it finds come as a bolt out of the blue. Highly recommended.“</p>
<p>Man könnte nun also meinen, dass ein Open-Source-Tool, das sogar von Kent Beck empfohlen wird, auf eine breite Akzeptanz in Entwicklerkreisen trifft. Das war allerdings augenscheinlich nicht der Fall, und auch wenn es schwer ist, konkrete Gründe zu benennen, so kann man zumindest einen großen Nachteil von Jester (und anderen Mutation-Testing-Tools der entsprechenden Epoche) identifizieren: Mutation Testing war extrem langsam und ressourcenhungrig. Klassische Mutation-Testing-Systeme kompilieren den Code für jeden Mutant und führen die gesamte Testsuite für jeden Mutant aus. Das sorgt dafür, dass Mutation Testing, vor allem in Hinsicht auf schnelles Feedback innerhalb des Entwicklungsprozesses, unpraktisch wird. Mit dieser Erkenntnis könnten wir den Artikel an dieser Stelle enden lassen und Mutation Testing wieder in die Academia-Schublade verbannen, gäbe es nicht mittlerweile Mutation-Testing-Systeme, die eine Lösung für diese Problematik gefunden haben. Ein prominenter Vertreter in der Java-Welt ist <a href="http://pitest.org/">PIT</a>.</p>
<h2>PIT</h2>
<p>PIT wurde 2010 von <a href="https://twitter.com/0hjc">Henri Coles</a> unter der Apache License veröffentlicht und stand ursprünglich für „Parallel Isolated Test“. Der initiale Anwendungsfall war die parallelisierte Ausführung von JUnit-Tests in separaten Class Loadern. Das diente letztlich aber als Grundlage, um aus PIT ein Mutation-Testing-System zu machen. PIT kann als Industriestandard für Mutation Testing im Java-Kontext angesehen werden und findet Verwendung in solch prominenten Projekten wie dem Large Hadron Collider am Europäischen Kernforschungszentrum CERN. Aber was macht PIT anders als Jester, um praktikabler zu werden? Dazu implementiert PIT eine Reihe sinnvoller Optimierungen gegenüber naiven Mutation-Testing-Ansätzen:</p>
<ul>
<li>Tests werden parallelisiert ausgeführt. Da Unit-Tests in der Regel CPU-bound sind, erlaubt uns aktuelle Multi-Core-Prozessorarchitektur ein hohes Maß an Parallelität.</li>
<li>Mutants werden nicht kompiliert, sondern durch Bytecodemanipulation erzeugt.</li>
<li>Tests werden Anhand der Laufzeit priorisiert, sodass billige Tests zuerst laufen. Sobald ein Test fehlschlägt, kann der aktuelle Lauf abgebrochen werden, da der Mutant in dem Fall getötet wurde.</li>
<li>Mithilfe von Code Coverage wird eine Zuordnung zwischen Tests und Codezeilen erzeugt. Somit müssen nur die Tests gegen einen Mutant ausgeführten werden, die eine mutierte Codezeile ausführen.</li>
</ul>
<p>All diese Faktoren zusammengenommen erlauben es, PIT als schnelles Feedback während der Entwicklung einzusetzen, z. B. im Kontext eines TDD-Zyklus. Die Integration in ein bestehendes Projekt ist denkbar einfach, und es gibt Plug-ins für alle gängigen Java-Build-Systeme wie Maven, Ant oder Gradle (darüber hinaus existieren außerdem Plug-ins für gängige IDEs wie z. B. Eclipse oder IntelliJ). In Listing 1 ist die beispielhafte Konfiguration als Maven-Build-Plug-in zu sehen.</p>
<pre class="brush: html" title="Listing 1: PIT – Konfiguration als Maven-Build-Plug-in">&lt;plugin&gt;
  &lt;groupId&gt;org.pitest&lt;/groupId&gt;
  &lt;artifactId&gt;pitest-maven&lt;/artifactId&gt;
  &lt;version&gt;1.4.3&lt;/version&gt;
&lt;/plugin&gt;</pre>
<p>Durch dieses Plug-in wird das Maven Goal <em>mutationCoverage</em> hinzugefügt, das sich folgendermaßen ausführen lässt:</p>
<pre class="brush: java">mvn org.pitest:pitest-maven:mutationCoverage</pre>
<p>Dieses Goal führt die Mutation-Tests aus, gibt eine Zusammenfassung über erzeugte, getötete und überlebende Mutants aus und erzeugt anschließend einen HTML-Report. Das Maven Goal ist umfangreich parametrisierbar, und es kann für einen schnelleren Feedbackzyklus sinnvoll sein, Mutation-Tests nur für einzelne Klassen auszuführen:</p>
<pre class="brush: java">mvn org.pitest:pitest-maven:mutationCoverage -dtargetTests=my.package.Foo*Test -dtargetClasses=my.package.Foo*</pre>
<p>PIT funktioniert out of the box mit JUnit4-Tests. Verwendet man JUnit5, muss ein zusätzliches Plug-in konfiguriert werden (Listing 2).</p>
<pre class="brush: html" title="Listing 2: Maven-Plug-in mit JUnit5-Support">&lt;plugin&gt;
  &lt;groupId&gt;org.pitest&lt;/groupId&gt;
  &lt;artifactId&gt;pitest-maven&lt;/artifactId&gt;
  &lt;version&gt;1.4.3&lt;/version&gt;
  &lt;dependencies&gt;
    &lt;dependency&gt;
      &lt;groupId&gt;org.pitest&lt;/groupId&gt;
      &lt;artifactId&gt;pitest-junit5-plugin&lt;/artifactId&gt;
      &lt;version&gt;0.7&lt;/version&gt;
    &lt;/dependency&gt;
  &lt;/dependencies&gt;
&lt;/plugin&gt;</pre>
<p>Es ist relativ schwer, mit künstlichen Beispielen ein sinnvolles Verständnis für Mutation Testing zu vermitteln, und reale Open-Source-Projekte würden als Beispiel den Rahmen und die Verständlichkeit dieses Artikels sprengen. Wir werden uns daher trotz allem ein relativ abstraktes Beispiel anschauen (das mit freundlicher Genehmigung aus Henry Coles <a href="https://2018.javazone.no/program/4a55ab6a-49c6-4671-822d-5dff26356bcc">Javazone Talk</a> übernommen wurde. Es ist aber zu empfehlen, PIT einfach einmal in einem eigenen Projekt einzusetzen, um ein echtes Gefühl für Mutation Testing zu bekommen.</p>
<p>Angenommen, wir haben den in Listing 3 dargestellten, korrekten Produktionscode. Würden wir nun Code Coverage als unsere einzige Metrik nehmen, anhand derer wir die Qualität unserer Testsuite bewerten, könnten wir die Testsuite aus Listing 4 nehmen und 100 % Code Coverage erreichen.</p>
<pre class="brush: javascript" title="Listing 3: Produktionscode">public class Counter {

  private int count;

  public void count(int i) {
    if (i &gt;= 10) {
      count++;
    }

  }

  public int getCount() {
    return count;
  }
}</pre>
<pre class="brush: java" title="Listing 4: Code-Coverage-Test">class CounterCodeCoverageTest {

  @Test
  void bossSaysMustHaveCodeCoverage() {
    Counter c = new Counter();

    c.count(0);
    c.count(9);
    c.count(11);

    c.getCount();
  }

}</pre>
<p>Hier wird sehr schön deutlich, dass Code Coverage keinerlei Rückschlüsse auf getestete Codezeilen zulässt. Nun wollen wir allerdings annehmen, dass Entwickler in der Regel versuchen, sinnvolle Tests zu schreiben. Diese Tests könnten für unser Beispiel aussehen wie in Listing 5 dargestellt.</p>
<pre class="brush: java" title="Listing 5: Fachlogiktest">class CounterGoodFaithTest {

  private Counter c;

  @BeforeEach
  void setUp() {
    c = new Counter();
  }

  @Test
  void startsWithEmptyCount() {
    assertEquals(0, c.getCount());
  }

  @Test
  void countsIntegersAboveTen() {
    c.count(11);
    assertEquals(1, c.getCount());
  }

  @Test
  void doesNotCountIntegersBelowTen() {
    c.count(9);
    assertEquals(0, c.getCount());
  }
}</pre>
<p>Die Testsuite ist nun auch ein guter Kandidat für Mutation Testing. Wenn wir PIT ausführen, stellen wir fest, dass (in der Defaultkonfiguration) vier Mutants erzeugt wurden und davon drei mit unserer Testsuite getötet werden konnten (<strong>Abb. 1</strong>).</p>
<div id="attachment_84442" style="width: 730px" class="wp-caption aligncenter"><a href="https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1.png"><img class="wp-image-84442" src="https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1.png" alt="Abb. 1: Counter.java" width="720" height="753" srcset="https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1.png 904w, https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1-143x150.png 143w, https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1-287x300.png 287w, https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1-768x803.png 768w, https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1-200x209.png 200w, https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1-170x178.png 170w, https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1-77x80.png 77w, https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1-124x130.png 124w, https://jaxenter.de/wp-content/uploads/2019/06/wittek_mutationtesting_1-180x188.png 180w" sizes="(max-width: 720px) 100vw, 720px" /></a><p class="wp-caption-text">Abb. 1: Counter.java</p></div>
<p>Der überlebende Mutant ist <em>changed conditional boundary</em>, also die Mutation von &lt;= zu &lt;. Und tatsächlich fehlt uns ein Test für unsere Wertgrenze (Listing 6). Wenn wir ihn nachliefern, können alle Mutanten getötet werden.</p>
<pre class="brush: java" title="Listing 6: Fehlender Test">@Test
void countsTen() {
  c.count(10);
  assertEquals(1, c.getCount());
}</pre>
<p>Was wir in diesem Beispiel nicht gesehen haben, ist ein Equivalent Mutant. Bewusst Code zu schreiben, der anfällig für Equivalent Mutants ist, ist gar nicht so einfach, doch wir wollen uns einmal das Beispiel in Listing 7 anschauen.</p>
<pre class="brush: java" title="Listing 7: Equivalent Mutants">public boolean isFoobar() {

  boolean foobar;
  if (1 &gt; 0) {
    foobar = true;
  }

  return foobar;
}

@Test
void isFoobar() {
  assertTrue(c.isFoobar());
}</pre>
<p>Hier erzeugt PIT den Mutant <em>replaced boolean return with true</em>, der <em>return foobar</em> durch <em>return true</em> ersetzt. Diesen können wir natürlich mit keinem vorstellbaren Test töten, da der aktuelle Code ja bereits in jedem Fall <em>true</em> als Wert zurückliefern wird. An dieser Stelle (und in vielen anderen Fällen) kann der Equivalent Mutant allerdings ein Hinweis auf potenziell zu vereinfachenden Code sein.</p>
<h2>Fazit</h2>
<p>Wir haben gesehen, dass Mutation Testing eine mächtige Technik ist, die uns verschiedene Vorteile bietet. Wir können fehlende Test-Cases oder fehlerhafte Tests identifizieren, und wir haben ein Sicherheitsnetz, um unsere Tests einem Refactoring zu unterziehen. Außerdem können durch Equivalent Mutants Hinweise auf Code Smells und redundanten Code gegeben werden. Zusammenfassend noch einmal der Hinweis, dass Mutation Testing in erster Linie ein Tool ist, das beim Entwickeln unterstützen soll und sich nur schlecht als Metrik für managementgetriebene Quality Gates eignet. Außerdem möchte ich hier die Empfehlung an jeden aussprechen, der sich nach diesem Artikel von Mutation Testing angesprochen fühlt: Probiert PIT am besten einfach einmal in einem bestehenden Projekt aus.</p>
					</div>
					
										
					
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/mutant-testing-pit-java-84437" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/mutant-testing-pit-java-84437" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=Mutation Testing: Attack of the Java Mutants - https://jaxenter.de/mutant-testing-pit-java-84437" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/mutant-testing-pit-java-84437" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/mutant-testing-pit-java-84437" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/mutant-testing-pit-java-84437" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/mutant-testing-pit-java-84437" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/mutant-testing-pit-java-84437" data-url-old=""></span></div>
						</a>
					</div>
					
					<div class="row"><div class="more-topics"><div class="col-xs-12 col-md-3"><h3 class="box-headline">Verwandte Themen:</h3></div><div class="col-xs-12 col-md-9">		<div class="button-tags-block">
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/java" target="_blank" >
	                   Java 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/testen" target="_blank" >
	                   Testen 	         </a>   
	      		</div>
	</div></div></div>
					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2019/06/wittek_kevin_sw-130x130.jpg" width="96" height="96" alt="Kevin Wittek" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Kevin Wittek</div>

																							<div class="author-description">
													Kevin Wittek ist Java-Entwickler und JVM-Fan, seit er vor dreizehn Jahren der Sprache begegnete. Inzwischen fungiert Kevin als Software Engineer für die codecentric AG und beschäftigt sich dort mit den Themen Software Craftsmanship, Infrastructure as Code und Continous Integration Pipelines. In seiner Freizeit ist er Musiker, aktives Mitglied der Open-Source-Community und arbeitet als Co-Maintainer am Testcontainers-Projekt.												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/kevinwittek">Alle Beiträge von Kevin Wittek</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/jdk-steckbriefe-oracle-jdk-12-83754" rel="bookmark">
						<div class="image">
															<img width="164" height="130" src="https://jaxenter.de/wp-content/uploads/2019/05/JDK-164x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/05/JDK-164x130.jpg 164w, https://jaxenter.de/wp-content/uploads/2019/05/JDK-150x119.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/05/JDK-300x238.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/05/JDK-200x158.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/05/JDK-170x135.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/05/JDK-101x80.jpg 101w, https://jaxenter.de/wp-content/uploads/2019/05/JDK-180x143.jpg 180w, https://jaxenter.de/wp-content/uploads/2019/05/JDK.jpg 500w" sizes="(max-width: 164px) 100vw, 164px" />													</div>
						<div class="title">
							JDK-Steckbriefe: Oracle JDK 12						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/20-jahre-java-magazin-autoren-teil-3-67559" rel="bookmark">
						<div class="image">
															<img width="173" height="130" src="https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-173x130.jpg" class="attachment-related size-related wp-post-image" alt="Java" srcset="https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-173x130.jpg 173w, https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-150x113.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-300x225.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-768x576.jpg 768w, https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-1024x768.jpg 1024w, https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-200x150.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-170x128.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-107x80.jpg 107w, https://jaxenter.de/wp-content/uploads/2018/02/shutterstock_564005194-180x135.jpg 180w" sizes="(max-width: 173px) 100vw, 173px" />													</div>
						<div class="title">
							Nochmal 20 Jahre Java? &#8211; Die Prognosen unserer Experten						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/extreme-java-string-komprimierung-66584" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2018/01/extreme-java-9.jpg 600w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							<em>Extreme</em> Java: String-Komprimierung in Java 9						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

																				<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
							    <div class="wpdiscuz_top_clearing"></div>
                    <div id="comments" class="comments-area">
                    <div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>
                            <h3 id="wc-comment-header">Hinterlasse einen Kommentar</h3>
                <div id="wpcomm" class="wpdiscuz_unauth wpd-default">
                            <div class="wc-comment-bar">
                    <p class="wc-comment-title">
                        Hinterlasse den ersten Kommentar!                    </p>
                    <div class="wpdiscuz_clear"></div>
                </div>
                                    <div class="wc_social_plugin_wrapper">
                            </div>
                    <div class="wc-form-wrapper wc-main-form-wrapper"  id='wc-main-form-wrapper-0_0' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                                        <form class="wc_comm_form wc_main_comm_form" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                                                                                <div class="wc-field-avatararea">
                                <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="64" height="64" alt="avatar" class="avatar avatar-64 wp-user-avatar wp-user-avatar-64 photo avatar-default" />                            </div>
                                                <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">
                                <textarea id="wc-textarea-0_0" pattern=".{1,4000}" maxlength=4000 placeholder="Beginne eine Diskussion" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">4000</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fa fa-user"></i></div>
                                                <input required="required" class="wc_name wpd-field" type="text" name="wc_name" value="" placeholder="Name" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fa fa-at"></i></div>
                                                <input required="required" class="wc_email wpd-field" type="email" name="wc_email" value="" placeholder="Email">
                            </div>
                            <div class="wpdiscuz-item wpd-has-icon">
                                        <div class="wpd-field-icon"><i class="fa fa-link"></i></div>
                                        <input class="wc_website wpd-field" type="text" name="wc_website" value="" placeholder="Website">
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Insert the CAPTCHA code">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5d37ef6faa27b"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5d37ef6faa27b" class="wpdiscuz-cnonce" name="cnonce" value="c5d37ef6faa27b" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                
                                            <label class="wpd_label">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <div class="wpd-field-desc"><i class="fa fa-bell wpdicon wpdicon-on"></i><span>Notify of new replies to this comment - (on)</span></div>
                                    <div class="wpd-field-desc"><i class="fa fa-bell-slash wpdicon wpdicon-off"></i><span>Notify of new replies to this comment - (off)</span></div>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                    </div>
                <div id = "wpdiscuz_hidden_secondary_form" style = "display: none;">
                    <div class="wc-form-wrapper wc-secondary-form-wrapper"  id='wc-secondary-form-wrapper-wpdiscuzuniqueid'  style='display: none;' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                            <div class="wc-secondary-forms-social-content"></div>
                                        <form class="wc_comm_form wc-secondary-form-wrapper" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                                                                                <div class="wc-field-avatararea">
                                <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="48" height="48" alt="avatar" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 photo avatar-default" />                            </div>
                                                <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">
                                <textarea id="wc-textarea-wpdiscuzuniqueid" pattern=".{1,4000}" maxlength=4000 placeholder="Beteilige dich an der Dikussion" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">4000</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fa fa-user"></i></div>
                                                <input required="required" class="wc_name wpd-field" type="text" name="wc_name" value="" placeholder="Name" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fa fa-at"></i></div>
                                                <input required="required" class="wc_email wpd-field" type="email" name="wc_email" value="" placeholder="Email">
                            </div>
                            <div class="wpdiscuz-item wpd-has-icon">
                                        <div class="wpd-field-icon"><i class="fa fa-link"></i></div>
                                        <input class="wc_website wpd-field" type="text" name="wc_website" value="" placeholder="Website">
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Insert the CAPTCHA code">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5d37ef6faa377"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5d37ef6faa377" class="wpdiscuz-cnonce" name="cnonce" value="c5d37ef6faa377" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                
                                            <label class="wpd_label">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <div class="wpd-field-desc"><i class="fa fa-bell wpdicon wpdicon-on"></i><span>Notify of new replies to this comment - (on)</span></div>
                                    <div class="wpd-field-desc"><i class="fa fa-bell-slash wpdicon wpdicon-off"></i><span>Notify of new replies to this comment - (off)</span></div>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                    </div>
                </div>
                                           

                <div class="wpdiscuz-front-actions">
                                            <div class="wpdiscuz-sbs-wrap">
                            <span><i class="fa fa-envelope-o" aria-hidden="true"></i>&nbsp; Subscribe &nbsp;<i class="fa fa-caret-down" aria-hidden="true"></i></span>
                        </div>
                                                            <div class="clearfix"></div>
                </div>

                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://jaxenter.de/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Benachrichtige mich zu: </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">Alle neuen Kommentare</option>
                                                                                                                            <option value="all_comment" >Nur Antworten zu meinen Kommentar/en</option>
                                                                            </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" type="submit" value="›" name="wpdiscuz_subscription_button" />
                                </div> 
                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="90b5b0461f" /><input type="hidden" name="_wp_http_referer" value="/mutant-testing-pit-java-84437" />                                <input type="hidden" value="84437" name="wpdiscuzSubscriptionPostId" />
                            </form>
                                                <div class="wpdiscuz_clear"></div>
                                            </div>
                    
                                <div id="wcThreadWrapper" class="wc-thread-wrapper">
                                    
                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
                <div class="wpdiscuz_clear"></div>
                                            </div>
        </div>
        <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div>
        					</div>
														</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
				<div id="text-8" class="widget widget_text">			<div class="textwidget"><iframe style="margin: 0px; padding: 0px; overflow: hidden; border: none;" src="https://jax.de/session-qualification/talkqualification_w-jax_2019/?layout=sidebarfeed&amp;utmtracker=deactivate" width="350" height="710" scrolling="no"></iframe></div>
		</div><div id="bwp_recent_comments-5" class="widget bwp-rc-widget"><p class="widget-title">Recent Comments</p>
		<ul class="bwp-rc-ulist">
<li class="recent-comment">

    <span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span>

    

    <span class="recent-comment-single">
      <span class="recent-comment-author">bughunter</span>
      <span class="recent-comment-text">war das vielleicht ursprünglich ein englischer Artikel? "Feld x nicht als endgültig deklariert"? final ist ja ein keyword und wird eher nicht übersetzt.</span>
      <span>
        <a href="https://jaxenter.de/java-valuetype-werttypen-84429#comment-201693" title="Comment on Der neue ValueType in Java">
      		<strong>Der neue ValueType in Java</strong>
        </a>
      </span>

    </span>

</li>
<li class="recent-comment">

    <span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span>

    

    <span class="recent-comment-single">
      <span class="recent-comment-author">kthxbye</span>
      <span class="recent-comment-text">laut Duden steht effektiv auch für "lohnend, nutzbringend"</span>
      <span>
        <a href="https://jaxenter.de/java-valuetype-werttypen-84429#comment-201692" title="Comment on Der neue ValueType in Java">
      		<strong>Der neue ValueType in Java</strong>
        </a>
      </span>

    </span>

</li>
<li class="recent-comment">

    <span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span>

    

    <span class="recent-comment-single">
      <span class="recent-comment-author">S. Waldmann</span>
      <span class="recent-comment-text">Kann es sein, dass der Autor "effektiv" mit "effizient" verwechselt hat? Effektiv bedeutet "hat einen Effekt, eine Auswirkung". Wären Value Types nicht effektiv, hätten sie...</span>
      <span>
        <a href="https://jaxenter.de/java-valuetype-werttypen-84429#comment-201691" title="Comment on Der neue ValueType in Java">
      		<strong>Der neue ValueType in Java</strong>
        </a>
      </span>

    </span>

</li>

		</ul>
</div><div id="polls-widget-5" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-44" class="wp-polls">
	<form id="polls_form_44" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_44_nonce" name="wp-polls-nonce" value="c1d48d245f" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="44" /></p>
		<p><strong>Welche Java-Distribution nutzen Sie?</strong></p><div id="polls-44-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-341" name="poll_44" value="341" /> <label for="poll-answer-341">MicroDoc Custom JRE</label></li>
		<li><input type="radio" id="poll-answer-342" name="poll_44" value="342" /> <label for="poll-answer-342">Red Hat Build of OpenJDK</label></li>
		<li><input type="radio" id="poll-answer-343" name="poll_44" value="343" /> <label for="poll-answer-343">Oracle OpenJDK 12</label></li>
		<li><input type="radio" id="poll-answer-344" name="poll_44" value="344" /> <label for="poll-answer-344">Zulu Community JDK &amp; Zulu Enterprise JDK</label></li>
		<li><input type="radio" id="poll-answer-345" name="poll_44" value="345" /> <label for="poll-answer-345">Amazon Corretto</label></li>
		<li><input type="radio" id="poll-answer-346" name="poll_44" value="346" /> <label for="poll-answer-346">AdoptOpenJDK mit OpenJ9</label></li>
		<li><input type="radio" id="poll-answer-347" name="poll_44" value="347" /> <label for="poll-answer-347">Oracle JDK 12</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(44);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-44-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="aktuelle_magazine-6" class="widget widget_aktuelle_magazine"><div class="ausgabe-wrapper"><p class="widget-title">Artikel erschienen in</p><div class="image"><a href="https://jaxenter.de/ausgaben/java-magazin-7-19"><img width="212" height="300" src="https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2019/05/JM7_19_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 212px) 100vw, 212px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/ausgaben/java-magazin-7-19">Java Magazin 7.19</a></div><div class="button"><a href="https://jaxenter.de/ausgaben/java-magazin-7-19" class="button">Infos zum Heft</a></div></div></div></div><div id="tag-widget-5" class="widget TagWidget"><a href="https://jaxenter.de/tag/devops"><p class="widget-title">DevOpsCon 2018</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Android DevOps Eclipse Jakarta EE" id="posts-by-tag-item-85484"><a class="thumb" href="https://jaxenter.de/jakarta-ee-8-release-date-gitlab-85484" title="Jakarta EE 8, GitLab-Report und Java 13 – Unsere Top-Themen der Woche"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2019/06/JAXenter-Wochenrückblick-1-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/jakarta-ee-8-release-date-gitlab-85484">Jakarta EE 8, GitLab-Report und Java 13 – Unsere Top-Themen der Woche</a></li><li class="posts-by-tag-item Continuous Delivery Continuous Integration DevOps Infrastructure as Code Serverless" id="posts-by-tag-item-85383"><a class="thumb" href="https://jaxenter.de/devsecops-continuous-delivery-interview-heiber-thoughtworks-85383" title="DevSecOps: &#8222;Blinde Automatisierung ohne Bedrohungsmodell und Verständnis hat allenfalls die Relevanz eines Feigenblattes&#8220;"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2019/07/moritz_heiber-150x150.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/07/moritz_heiber-150x150.jpeg 150w, https://jaxenter.de/wp-content/uploads/2019/07/moritz_heiber-200x200.jpeg 200w, https://jaxenter.de/wp-content/uploads/2019/07/moritz_heiber-170x170.jpeg 170w, https://jaxenter.de/wp-content/uploads/2019/07/moritz_heiber-80x80.jpeg 80w, https://jaxenter.de/wp-content/uploads/2019/07/moritz_heiber-130x130.jpeg 130w, https://jaxenter.de/wp-content/uploads/2019/07/moritz_heiber-180x180.jpeg 180w, https://jaxenter.de/wp-content/uploads/2019/07/moritz_heiber.jpeg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devsecops-continuous-delivery-interview-heiber-thoughtworks-85383">DevSecOps: "Blinde Automatisierung ohne Bedrohungsmodell und Verständnis hat allenfalls die Relevanz eines Feigenblattes"</a></li><li class="posts-by-tag-item DevOps GitLab Security" id="posts-by-tag-item-85349"><a class="thumb" href="https://jaxenter.de/gitlab-umfrage-devsecops-sicherheit-85349" title="GitLab-Umfrage zu DevSecOps: Waterfall und Sicherheit bleiben ein Problem"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2019/07/GitLab-Umfrage-zu-DevSecOps.jpg 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/gitlab-umfrage-devsecops-sicherheit-85349">GitLab-Umfrage zu DevSecOps: Waterfall und Sicherheit bleiben ein Problem</a></li><li class="posts-by-tag-item Agile DevOps Programmierung" id="posts-by-tag-item-85271"><a class="thumb" href="https://jaxenter.de/kiss-prinzip-programmierung-komplexitaet-85271" title="YAGNI-, DRY- und KISS-Prinzip: Die Zauberformeln der Programmierung!"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2019/07/YAGNI-DRY-und-KISS-Prinzip-Die-Zauberformeln-der-Programmierung.jpg 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/kiss-prinzip-programmierung-komplexitaet-85271">YAGNI-, DRY- und KISS-Prinzip: Die Zauberformeln der Programmierung!</a></li><li class="posts-by-tag-item DevOps Digitale Transformation W-JAX 2018" id="posts-by-tag-item-85113"><a class="thumb" href="https://jaxenter.de/devops-transformation-best-practices-video-85113" title="DevOps-Transformation: Echt oder nur gefühlt schneller?"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-300x169.png 300w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-768x432.png 768w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-1024x576.png 1024w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-200x112.png 200w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-170x96.png 170w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-120x67.png 120w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2019/07/DevOps-Realitätscheck-Gefühlt-schneller-oder-echt-schneller.png 1042w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-transformation-best-practices-video-85113">DevOps-Transformation: Echt oder nur gefühlt schneller?</a></li><li class="posts-by-tag-item DevOps Künstliche Intelligenz" id="posts-by-tag-item-84971"><a class="thumb" href="https://jaxenter.de/devops-ki-best-practices-interview-luckow-84971" title="DevOps und KI: &#8222;Spezialisierte KIs werden in den wichtigen Aufgabenbereichen von Dev und Ops stark zunehmen&#8220;"  ><img width="150" height="105" src="https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow-150x105.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2019/07/Dr.-Martin-Luckow.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-ki-best-practices-interview-luckow-84971">DevOps und KI: "Spezialisierte KIs werden in den wichtigen Aufgabenbereichen von Dev und Ops stark zunehmen"</a></li></ul></div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        </div>
    </div>
</div>
									</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-79978" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-79978"><a href="https://jaxenter.de/">JAXenter.de</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="https://entwickler.de/javascript-kompendium">JavaScript Kompendium</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="https://entwickler.de/cloud-compendium">Cloud Compendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://serverless-architecture.io/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Serverless Architecture Conference</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="https://mlconference.ai/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Machine Learning Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://blockchainconf.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Blockchain Technology Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="https://e-academy.net/">e.academy</a></li>
<li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-79980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79980"><a href="https://tutorials.entwickler.de/">entwickler.tutorials</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-79979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79979"><a href="https://entwickler.de/jobs">entwickler.jobs</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>
		
		<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
	</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 

Served from: jaxenter.de @ 2019-07-24 07:41:03 by W3 Total Cache
-->