<!DOCTYPE html>
<html lang="de-DE" prefix="og: http://ogp.me/ns#"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>Angular Pro-Tipps: #5 – Dynamic Imports - JAXenter</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>	
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
		
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Im aktuellen fünften Teil von Aaron Czichons Serie zu Angular geht es um dynamische Importe im beliebten JavaScript/TypeScript-Framework."/>
<meta name="robots" content="noodp"/>
<meta name="keywords" content="Angular,Angular Pro-Tipps,JavaScript"/>
<link rel="canonical" href="https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Angular Pro-Tipps: #5 – Dynamic Imports - JAXenter" />
<meta property="og:description" content="Im aktuellen fünften Teil von Aaron Czichons Serie zu Angular geht es um dynamische Importe im beliebten JavaScript/TypeScript-Framework." />
<meta property="og:url" content="https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="Angular" />
<meta property="article:tag" content="Angular Pro-Tipps" />
<meta property="article:tag" content="JavaScript" />
<meta property="article:section" content="Artikel" />
<meta property="article:published_time" content="2017-12-07T16:59:26+00:00" />
<meta property="article:modified_time" content="2017-12-07T17:10:24+00:00" />
<meta property="og:updated_time" content="2017-12-07T17:10:24+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1.png" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="400" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; Angular Pro-Tipps: #5 – Dynamic Imports Kommentar-Feed" href="https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.13 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-18197167-38', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.3" />
<link rel='shortlink' href='https://jaxenter.de/?p=65238' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fangular-pro-tipps-dynamic-imports-65238" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fangular-pro-tipps-dynamic-imports-65238&#038;format=xml" />
	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>

		        
        <script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + 
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		
		<script type='text/javascript'>
		googletag.cmd.push(function() {
		googletag.defineSlot('/21339274/jaxenter.de_contentAD1_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD2_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-1').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD3_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-2').addService(googletag.pubads());		
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper1_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-4').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper2_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-5').addService(googletag.pubads());
		googletag.pubads().collapseEmptyDivs(true);
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();				
		});
		</script>
        
        <script>
  		googletag.cmd.push(function() {
  		googletag.defineSlot('/21339274/jaxenter.de_leaderboard_Wordpress', [728, 90], 'div-gpt-ad-1423038811881-3')
		.addService(googletag.pubads())    
		.setCollapseEmptyDiv();
		  });
		</script>

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>	
		
		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->
		
	</head>
	<body class="post-template-default single single-post postid-65238 single-format-standard">
		
        <header>    
        <div class="topbanner hidden-xs hidden-sm">
        	<div class="container">
					<!-- jaxenter.de_leaderboard_Wordpress -->
                    <div id='div-gpt-ad-1423038811881-3' style='width:100%; min-height:90px; margin:10px 0;'>
                    <script type='text/javascript'>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-3'); });
                    </script>
                    </div>
            </div>
         </div> 
        	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://jaxenter.de/events">Events</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://jaxenter.de/magazine">Java Magazin</a></li>
<li id="menu-item-39337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39337"><a href="https://jax.de/">JAX 2018</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/docker">Docker</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16647" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16647"><a href="https://jaxenter.de/tag/internet-of-things">Internet of Things</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/maschinelles-lernen">Machine Learning</a></li>
</ul>		</div>
	</div>
 
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">DEVOPS:</span>
                                        
                                    <a href="https://jaxenter.de/was-ist-devops-45376">Missverständnisse rund um DevOps – und wie man es richtig macht</a>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>
		
		                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/10/JAX_2017_website_Logo_blau_800x347-e1484239725391_v5-74x50.png" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jax.de">JAX: Die Konferenz für Java, Architektur- und Software-Innovation</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/Angular-5-Features-300x300-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/angular-5-features-63441">Angular 5 ist da – das sind die neuen Features</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/Spring-Boot-Tutorial-1-300x300-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/spring-boot-tutorial-54020">Spring Boot Tutorial: So entwickelt man REST-Services mit Spring Boot</a></p>
<p>&nbsp;</p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			

          </div>
          <div class="custom_header_wa">
                    </div>
		</header>



	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Immer hereinspaziert: Dynamische Importe in Angular</div>
														<h1 class="title">Angular Pro-Tipps: #5 – Dynamic Imports</h1>
							
									<div class="button-tags-block">
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/angular" target="_blank" >
	                  #Angular 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/angular-pro-tipps" target="_blank" >
	                  #Angular Pro-Tipps 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/javascript" target="_blank" >
	                  #JavaScript 	         </a>   
	      		</div>
								
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2017-12-07T16:59">7. Dezember 2017</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Aaron Czichon										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="240" src="https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1.png" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1.png 500w, https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1-150x120.png 150w, https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1-300x240.png 300w, https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1-200x160.png 200w, https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1-170x136.png 170w, https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1-100x80.png 100w, https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1-163x130.png 163w, https://jaxenter.de/wp-content/uploads/2016/08/Kolumne_Angular2_500x400_38556_v1-180x144.png 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"></div>
								</div>
														
															<div class="excerpt">
									<p>Im ersten Teil der Angular Pro-Tipps von Aaron Czichon wurden die mit Angular 2 eingeführten Pipes näher beleuchtet. Für den zweiten Teil widmete sich unser Autor ausführlich dem HTTP-Client. Der dritte Teil der Angular Pro-Tipps stand dann ganz im Zeichen der Dependency Injection in Angular, Teil 4 widmete unser Experte den Neuerungen in Angular 5. Im aktuellen fünften Teil der Serie geht es um dynamische Importe im beliebten Framework.</p>
								</div>
													</div>
					
					
					
					<div class="text">
						<h2>Bisher gelernt</h2>
<div class="boxed" style="float: right; width: 380px; margin: 0 0 0 10px;">
<p><strong>Angular Pro-Tipps von Aaron Czichon<br />
</strong></p>
<ul>
<li>Pro-Tipp #1: <a href="https://jaxenter.de/angular-2-release-highlights-pipes-44693">Angular Pipes</a></li>
<li>Pro-Tipp #2: <a href="https://jaxenter.de/angular-2-pro-tipps-2-http-client-49674">HTTP-Client</a></li>
<li>Pro-Tipp #3: <a href="https://jaxenter.de/angular-2-pro-tipps-3-dependency-injection-51437">Dependency Injection</a></li>
<li>Pro-Tipp #4: <a href="https://jaxenter.de/angular-5-pro-tipp-63802">Was bringt Angular 5?</a></li>
<li><strong>Pro-Tipp #5: Dynamic Imports</strong></li>
<li>Alle Pro-Tipps auf <a href="https://jaxenter.de/tag/angular-pro-tipps">einen Bick</a></li>
</ul>
</div>
<p>Bisher haben Sie gelernt, wie Sie mit den in Angular 2 eingeführten <em>Pipes</em> umgehen. Diese können genutzt werden, um Daten und Objekte vor der Anzeige in der View und/oder vor dem Rendering zu transformieren und entsprechend zu formatieren. Wenn Sie etwa ein Datum in einem bestimmten Format anzeigen wollen, können Sie hierfür eine Pipe verwenden und müssen nicht das eigentliche Datenobjekt bearbeiten.</p>
<p>Im zweiten Teil wurde der HTTP-Client etwas genauer dargestellt. Sie haben gelernt, wie Sie den neuen Client nutzen können, um Daten von einer Schnittstelle abzurufen und wie das Grundprinzip von <em>Observables</em> funktioniert.</p>
<p>Nachdem es im dritten Teil der Kolumne um die Dependency Injection in Angular ging, war der vierte Teil eine Zusammenfassung der Neuerungen in Angular 5. In Teil fünf wird es nun wieder technischer: Es geht um dynamische Importe in Angular.</p>
<h2>Dynamic Imports in Angular</h2>
<p>Sie kennen vermutlich das Problem. Sie haben eine größere Angular-Anwendung mit vielen unterschiedlichen Modulen. Ihre Anwendung ist ideal mit ngModules und Webpack auf Lazy Loading ausgelegt und Sie nutzen Tree-Shaking, so weit es Ihnen möglich ist. Dennoch haben Sie einige Module in Ihrer Anwendung, welche unabhängig funktionieren und nur äußerst selten benötigt werden.</p>
<p>Nehmen wir hierzu ein Beispiel. Sie haben eine Administrationsoberfläche mit Angular entwickelt. Diese Administrationsoberfläche dient zur Gestaltung von Inhalten. Nun soll diese Oberfläche um ein Vorschaumodul für die Inhalte ergänzt werden. Da das Vorschaumodul aber aus verschiedenen Möglichkeiten der Vorschau besteht (z.B. Web, Mobile und Print), möchten Sie nicht immer alle Module mit in Ihrer Anwendung referenzieren.</p>
<p>Hier kommen die sogenannten <code class="code-inline">Dynamic Imports</code> zum Tragen. In normalen Fällen importieren Sie Klassen, Komponenten und Module mit <code class="code-inline">import { SampleModule } from 'sample.module'</code>. So weit so gut. Wollen Sie nun jedoch zur Laufzeit evtl. eine JavaScript- bzw. TypeScript-Datei importieren, welche beispielsweise Funktionen enthält, die Sie nicht immer brauchen, sieht das Ganze anders aus.</p>
<p>Hierzu gibt es, je nach aktuell genutzter TypeScript-Version, zwei Möglichkeiten.</p>
<p>Nutzen Sie noch eine Version, die älter als TypeScript 2.4 ist, müssen Sie die sogenannte <code class="code-inline">System.import</code>-Syntax benutzen. Ab Version 2.4 können Sie die Standard-Import-Möglichkeit von ECMAScript nutzen, den eigentlichen dynamischen Imports. Hierbei ähnelt die Syntax auch dem „normalen“ Import stark. Aber zunächst ein Schritt nach dem anderen.</p>
<p>Starten wir mit der aktuellen, der <code class="code-inline">Import().then()</code>-Syntax. Stellen Sie sich vor, Sie haben eine Collection an Funktionen, die Sie erst benötigen, wenn Sie in Ihrer Anwendung einen entsprechenden Button klicken. In unserem Beispiel enthält diese Datei folgende Implementierungen:</p>
<pre class="brush: java; title: ; notranslate" title="">
// generator.ts
export function generatePdf(data: any) {
	// Implementation
	console.log(„Generate PDF here“);
}
export function generateHtml(data: any) {
	// Implementation
	console.log(„Generate HTML here“);
}
export function generateMarkdown(data: any) {
	// Implementation
	console.log(„Generate HTML here“);
}
</pre>
<p>Das sind nun Ihre Implementierungen in der Datei <code class="code-inline">generator.ts</code>.</p>
<p>Nun benötigen Sie diese Funktionen nicht immer oder möchten diese, während die Anwendung ausgeliefert wird, verändern. Diese Funktionen enthalten keinen Angular-Spezifischen Code und wird möglicherweise von anderen Frameworks ebenso in Ihren Projekten genutzt. Die Funktionen sollen nun nur dann aufgerufen werden, wenn Sie in Ihrer Anwendung (einer Komponente) auf einen Button klicken, der eine dieser Generator-Funktionen ausführt.</p>
<p>Legen Sie sich dazu eine neue Komponente in Ihrem Angular-Projekt an (bspw. mit <code class="code-inline">ng generate component generator</code>).</p>
<p>Ihre neue Komponente sollte in etwa so aussehen.</p>
<pre class="brush: java; title: ; notranslate" title="">
// generator.component.ts

Import { Component } from ‚@angular/core‘;

@Component({
	selector: ‚generator‘,
	templateUrl: ‚./generator.component.html‘,
	styleUrl: ‚./generator.component.css‘
})
export class GeneratorComponent {
	constructor() { }
}
</pre>
<p>Implementieren Sie in diese neue Komponente nun zunächst die drei leeren Methoden für die drei Buttons.</p>
<pre class="brush: java; title: ; notranslate" title="">
// generator.component.ts

...
export class GeneratorComponent {
	constructor() { }

	generatePdfDocument() {
		// Implementation here
	}

	generateHtmlDocument() {
		// Implementation here
	}

	generateMarkdownDocument() {
		// Implementation here
	}
}
</pre>
<p>Ihr Template müssen Sie entsprechend anpassen, sodass dieses auch die entsprechenden Click-Events auslöst.</p>
<pre class="brush: java; title: ; notranslate" title="">
// generator.component.html
&lt;div&gt;
	&lt;button (click)=„generatePdfDocument()“&gt;Generate PDF&lt;/button&gt;
	&lt;button (click)=„generateHtmlDocument()“&gt;Generate HTML&lt;/button&gt;
	&lt;button (click)=„generateMarkdownDocument()“&gt;Generate Markdown&lt;/button&gt;
&lt;/div&gt;
</pre>
<p>Bis hierhin sollte Ihnen alles bekannt sein. Es handelt sich um eine normale Angular-Komponente mit drei Methoden, die von einem Button-Klick getriggert werden.</p>
<p>Jetzt folgt der neue Teil. Nutzen Sie nun die <code class="code-inline">Import().then()</code>-Syntax, um die <code class="code-inline">generator.ts</code>-Datei zu Importen und die darin enthaltenen Methoden aufzurufen.</p>
<pre class="brush: java; title: ; notranslate" title="">
// generator.component.ts

...
export class GeneratorComponent() {
	...

	generatePdfDocument() {
		const data = { /*  Object of sample data */};
		import(‚./generator‘)
			.then(module =&gt; {
				module.generatePdf(data);
			});
	}

	generateHtmlDocument() {
		const data = { /*  Object of sample data */};
		import(‚./generator‘)
			.then(module =&gt; {
				module.generateHtml(data);
			});
	}

	generateMarkdownDocument() {
		const data = { /*  Object of sample data */};
		import(‚./generator‘)
			.then(module =&gt; {
				module.generateMarkdown(data);
			});
	}
}
</pre>
<p>Nun wird die <code class="code-inline">generator.ts</code>-Datei nur dann von Ihrem Server geladen, sofern eine der drei Methoden durch den Klick auf einen Button aufgerufen wird. Das spart Bandbreite und vor allem unnötigen Code auf dem Client, der vielleicht gar nicht benötigt wird.</p>
<p>Um die Anwendung nun zu testen, müssen Sie jedoch noch eine kleine Konfiguration vornehmen. Dem TypeScript-Compiler ist zu diesem Zeitpunkt noch nicht bekannt, dass Sie sogenannte <em>ESNext</em>-Module nutzen möchten. Dessen Standardkonfiguration läuft aktuell noch mit ES2016. Passen Sie hierzu entsprechend in Ihrem Angular-Projekt unter <code class="code-inline">src/tsconfig.app.json</code> die Konfiguration so an, dass TypeScript die ESNext-Module nutzt:</p>
<pre class="brush: java; title: ; notranslate" title="">
// tsconfig.app.json
{
...
	„compilerOptions“: {
		...
		„module“: „esnext“
		...
	}
...
}
</pre>
<p>Starten Sie nun den lokalen Webserver und testen Sie die neue Funktionalität im Browser.</p>
<p><strong>Hinweis:</strong> Wenn Sie die Konfiguration für den TypeScript-Compiler korrekt angegeben haben, brauchen Sie auch keine weiteren Konfigurationsanpassungen für Webpack vornehmen. Webpack erkennt dynamische Imports automatisch und stellt diese als eigene <em>Chunks</em> bereit.</p>
<p>Benutzen Sie nun noch eine TypeScript-Version, die älter als 2.4 ist, müssen Sie auf die alte <code class="code-inline">System.import</code>-Syntax setzen.</p>
<p>Um ein Modul stattdessen mit der <code class="code-inline">import.then</code>-Syntax zu importieren, müssen Sie Ihre Funktionen nun etwas anpassen.</p>
<pre class="brush: java; title: ; notranslate" title="">
// generator.component.ts

...
export class GeneratorComponent() {
	...

	generatePdfDocument() {
		const data = { /*  Object of sample data */};
		System.import(‚./generator‘)
			.then(module =&gt; {
				module.generatePdf(data);
			});
	}

	generateHtmlDocument() {
		const data = { /*  Object of sample data */};
		System.import(‚./generator‘)
			.then(module =&gt; {
				module.generateHtml(data);
			});
	}

	generateMarkdownDocument() {
		const data = { /*  Object of sample data */};
		System.import(‚./generator‘)
			.then(module =&gt; {
				module.generateMarkdown(data);
			});
	}
}
</pre>
<p>TypeScript sollte die Syntax entsprechend auflösen. Sollte dies nicht der Fall sein, deklarieren Sie einfach einen entsprechenden Typ für den Compiler:</p>
<pre class="brush: java; title: ; notranslate" title="">
declare var System: {
	import: Promise&lt;any&gt;
};
</pre>
<p>Für Webpack müssen Sie auch hier keine weitere Konfiguration vornehmen. Einzig müssen Sie darauf achten, dass Webpack im richtigen Kontext läuft und die Dateipfade, welche sie der <code class="code-inline">System.import</code>-Funktion mitgeben, korrekt auflösen kann.</p>
<div class='widgets_on_page'> <div id="wysiwyg_widgets_widget-11" class="widget widget_wysiwyg_widgets_widget"><!-- Widget by WYSIWYG Widgets v2.3.6 - https://wordpress.org/plugins/wysiwyg-widgets/ --><div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"> <img style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2017/12/JAX_2018_Contentbox_2162x162_44034_v1.jpg" alt="JAX" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2017/12/JAX_2018_Speakerbox_550x214_44034_v1.jpg" alt="JAX" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<h3 style="margin: 12px 0; font-size: 19px !important; font-weight: 700 !important; padding: 5px 0 12px 0 !important;"><span style="color: #000000;"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox">JAX &#8211; Die Konferenz für Java, Architektur- und Software-Innovation</a></span></h3>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jaxenter.de/wp-content/uploads/2017/12/Sebastian-Springer-1.jpg" alt="Frank Düsterbeck" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://jax.de/web-development-javascript/creating-enterprise-web-applications-with-node-js/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://jax.de/web-development-javascript/creating-enterprise-web-applications-with-node-js/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Creating Enterprise Web Applications with Node.js');" style="color: #264186; font-size: 19px; font-weight: 600;">Creating Enterprise Web Applications with Node.js</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Sebastian Springer</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="border: 1px solid #fff; max-width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2017/12/MSteyer.jpg" alt="Manfred Steyer" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://jax.de/web-development-javascript/performance-tuning-fuer-angular-der-stand-der-dinge-in-2018/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://jax.de/web-development-javascript/performance-tuning-fuer-angular-der-stand-der-dinge-in-2018/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Performance-Tuning für Angular: Der Stand der Dinge 2018');" style="color: #264186; font-size: 19px; font-weight: 600;">Performance-Tuning für Angular: Der Stand der Dinge 2018</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Manfred Steyer</p>
</div>
</div>
</div>
</div>
</div>
<div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"> <img style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2017/12/iJS_London_2018_Contentbox_2162x162_43689_v2.jpg" alt="International JavaScript Conference" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2017/12/iJS_London_2018_Speakerbox_550x214_43689_v2.jpg" alt="International JavaScript Conference" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<h3 style="margin: 12px 0; font-size: 19px !important; font-weight: 700 !important; padding: 5px 0 12px 0 !important;"><span style="color: #000000;"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox">International JavaScript Conference </a></span></h3>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jaxenter.de/wp-content/uploads/2017/12/Dmytro-Zharkov.jpg" alt="Dmytro Zharkov" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://javascript-conference.com/node-js/make-node-js-apis-great-with-typescript/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://javascript-conference.com/node-js/make-node-js-apis-great-with-typescript/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Make Node.js API’s great with TypeScript');" style="color: #264186; font-size: 19px; font-weight: 600;">Make Node.js API’s great with TypeScript</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Dmytro Zharkov</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="border: 1px solid #fff; max-width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2017/12/Maxim-Salnikov.jpg" alt="Maxim Salnikov" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://javascript-conference.com/angular/workshop-progressive-web-apps-using-the-angular-service-worker/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://javascript-conference.com/angular/workshop-progressive-web-apps-using-the-angular-service-worker/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Progressive Web Apps using the Angular Service Worker');" style="color: #264186; font-size: 19px; font-weight: 600;">Progressive Web Apps using the Angular Service Worker</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Maxim Salnikov</p>
</div>
</div>
</div>
</div>
</div>
<div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://javascript-days.de/"><img style="width: 100%; height: auto;" src="/wp-content/uploads/2017/12/JSD_SE_2018_Webbanner_2126x162_44145_v1.jpg" alt="JavaScript Days" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="/wp-content/uploads/2017/12/JSD_SE_2018_Webbanner_550x214_44145_v1.jpg" alt="JavaScript Days" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;"></div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="/wp-content/uploads/2017/11/Sebastian-Springer.jpg" alt="Sebastian Springer" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://javascript-days.de/javascript/webapplikationen-mit-node-js/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://javascript-days.de/javascript/webapplikationen-mit-node-js/', 'Webapplikationen mit Node.js');" style="color: #d6007f; font-size: 19px; font-weight: 600;">Webapplikationen mit Node.js</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Sebastian Springer (MaibornWolff)</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="sb-content-item-sands col-xs-12" style="padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="border: 1px solid #fff; max-width: 100%; height: auto;" src="/wp-content/uploads/2017/12/Westhoff.jpg" alt="Jakob Westhoff" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://javascript-days.de/javascript/desktop-applikationen-mit-electron/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://javascript-days.de/javascript/desktop-applikationen-mit-electron/', 'Desktop Applikationen mit Electron');" style="color: #d6007f; font-size: 19px; font-weight: 600;">Desktop Applikationen mit Electron</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Jakob Westhoff (Freiberufler)</p>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<!-- / WYSIWYG Widgets --></div>
  </div><!-- widgets_on_page -->
					</div>
					
										
					
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=Angular Pro-Tipps: #5 – Dynamic Imports - https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/angular-pro-tipps-dynamic-imports-65238" data-url-old=""></span></div>
						</a>
					</div>
					
					<div class="row"><div class="more-topics"><div class="col-xs-12 col-md-3"><h3 class="box-headline">Verwandte Themen:</h3></div><div class="col-xs-12 col-md-9">		<div class="button-tags-block">
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/angular" target="_blank" >
	                   Angular 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/angular-pro-tipps" target="_blank" >
	                   Angular Pro-Tipps 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/javascript" target="_blank" >
	                   JavaScript 	         </a>   
	      		</div>
	</div></div></div>
					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2016/08/czichon_aaron-150x105.jpg" width="96" height="67" alt="Aaron Czichon" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Aaron Czichon</div>

																							<div class="author-description">
													Aaron Czichon hat im Alter von 14 Jahren mit Software-Entwicklung angefangen und sich PHP und HTML beigebracht. Seit seiner Ausbildung zum Fachinformatiker Anwendungsentwicklung arbeitet er hauptberuflich bei der cellent AG mit Hauptsitz in Stuttgart. Dort ist er als Software-Entwickler im Projektumfeld mit Javascript und .NET tätig.
Nebenberuflich ist er als freier Entwickler mit seiner WebAtlas GbR unterwegs und macht seinen IT-Fachwirt um seine Kompetenzen in Unternehmensführung und BWL zu erweitern. Mit Ionic beschäftigt er sich seit dem Erscheinen der 3. Alpha-Version Ende November 2013. Ende 2014 gründete er die deutsche Ionic Community „Ionic Germany“. Er ist Mitglied der Ionic Alpha-Gruppe, welche die aktuellsten Neuerungen und Tools von Ionic zum Testen erhält. Nebenbei ist er auf Konferenzen als Speaker. Dort referiert er überwiegend über das Ionic Framework.												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/aaronczichon">Alle Beiträge von Aaron Czichon</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/angular-5-features-63441" rel="bookmark">
						<div class="image">
															<img width="130" height="130" src="https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-130x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-300x300.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-768x768.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/11/Angular-5-Features.jpg 800w" sizes="(max-width: 130px) 100vw, 130px" />													</div>
						<div class="title">
							Angular 5 ist da &#8211; das sind die neuen Features!						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/cross-plattform-web-hat-gewonnen-61561" rel="bookmark">
						<div class="image">
															<img width="186" height="130" src="https://jaxenter.de/wp-content/uploads/2017/02/weyer_christian_300x210-186x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/02/weyer_christian_300x210-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/02/weyer_christian_300x210-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/02/weyer_christian_300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/02/weyer_christian_300x210-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/02/weyer_christian_300x210-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/02/weyer_christian_300x210-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/02/weyer_christian_300x210-180x126.jpg 180w" sizes="(max-width: 186px) 100vw, 186px" />													</div>
						<div class="title">
							Cross-Plattform – das Web hat „gewonnen“						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/angular-4-update-55042" rel="bookmark">
						<div class="image">
															<img width="130" height="130" src="https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-130x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-300x300.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-768x768.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features.jpg 1000w" sizes="(max-width: 130px) 100vw, 130px" />													</div>
						<div class="title">
							Angular 4 &#8211; das Update: Diese Features müssen Sie kennen						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

															<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
													
<div class="comment-form-wrapper">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Schreibe einen Kommentar <small><a rel="nofollow" id="cancel-comment-reply-link" href="/angular-pro-tipps-dynamic-imports-65238#respond" style="display:none;">Antworten abbrechen</a></small></h3>			<form action="https://jaxenter.de/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Deine E-Mail-Adresse wird nicht veröffentlicht.</span></p><p class="comment-form-comment"><label for="comment">Kommentar</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">E-Mail</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Kommentar abschicken" /> <input type='hidden' name='comment_post_ID' value='65238' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e7d0a1dd9c" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="207"/></p>			</form>
			</div><!-- #respond -->
	</div>

											</div>
									</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
					<div id="text-12" class="widget widget_text">			<div class="textwidget"><iframe src="https://jax.de/session-qualification/speakerbox_jaxenter/?layout=sidebarfeed" width="350" height="640" style="margin:0px; padding:0px; overflow:hidden; border:none;" scrolling="no"></iframe></div>
		</div><div id="aktuelle_magazine-4" class="widget widget_aktuelle_magazine"><p class="widget-title">Aktuelle Magazine</p><div class="aktuelle-ausgaben-wrapper"><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/java-magazin"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/11/Java-Magazin-1-18_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/java-magazin">Java Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/java-magazin" class="button">Alle Infos</a></a></div></div></div><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/business-technology"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/11/BT_Magazin_4_17_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/business-technology">Business Technology Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/business-technology" class="button">Alle Infos</a></a></div></div></div></div></div><div id="tag-widget-7" class="widget TagWidget"><a href="https://jaxenter.de/tag/devopscon-2017"><p class="widget-title">DevOpsCon 2017</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Container DevOps DevOpsCon 2017 Docker Kubernetes" id="posts-by-tag-item-64927"><a class="thumb" href="https://jaxenter.de/devops-docker-container-kubernetes-bruns-64927" title="Docker, Kubernetes &#038; Co: &#8222;Container sind definitiv kein Allheilmittel&#8220;"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-300x169.png 300w, https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-768x432.png 768w, https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-200x112.png 200w, https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-170x96.png 170w, https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-120x67.png 120w, https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2017/12/Screenshot-2017-12-1-DevOpsCon-2017-Interview-mit-Michael-Bruns-YouTube1.png 854w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-docker-container-kubernetes-bruns-64927">Docker, Kubernetes & Co: "Container sind definitiv kein Allheilmittel"</a></li><li class="posts-by-tag-item DevOps DevOpsCon 2017 Interview" id="posts-by-tag-item-64793"><a class="thumb" href="https://jaxenter.de/devops-tipps-unternehmen-64793" title="DevOps Tipps: &#8222;DevOps muss von der Unternehmensführung selbst angenommen werden&#8220;"  ><img width="150" height="105" src="https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-150x105.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-tipps-unternehmen-64793">DevOps Tipps: "DevOps muss von der Unternehmensführung selbst angenommen werden"</a></li><li class="posts-by-tag-item AWS Lambda DevOps DevOpsCon 2017 Go Kubernetes" id="posts-by-tag-item-64748"><a class="thumb" href="https://jaxenter.de/devops-go-aws-interview-mohrhard-64748" title="Nicht nur gut für DevOps Tools: &#8222;Go glänzt im Umfeld von AWS Lambda&#8220;"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-300x168.png 300w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-768x431.png 768w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-200x112.png 200w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-170x95.png 170w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-120x67.png 120w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-29-DevOpsCon-2017-Interview-mit-Andreas-Mohrhard-YouTube.png 854w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-go-aws-interview-mohrhard-64748">Nicht nur gut für DevOps Tools: "Go glänzt im Umfeld von AWS Lambda"</a></li><li class="posts-by-tag-item DevOps DevOpsCon 2017" id="posts-by-tag-item-64679"><a class="thumb" href="https://jaxenter.de/devops-tipps-koren-64679" title="DevOps Tipps: &#8222;Lasst eure Leute Fehler machen und daraus lernen&#8220;"  ><img width="150" height="105" src="https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5-150x105.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/11/Nir-Koren-5.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-tipps-koren-64679">DevOps Tipps: "Lasst eure Leute Fehler machen und daraus lernen"</a></li><li class="posts-by-tag-item Cloud DevOps DevOpsCon 2017 Docker Kubernetes" id="posts-by-tag-item-64668"><a class="thumb" href="https://jaxenter.de/devops-docker-container-kubernetes-interview-64668" title="&#8222;Kubernetes wird der kleinste gemeinsame Nenner werden, auf dem alle aufbauen&#8220;"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-300x169.png 300w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-768x432.png 768w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-200x112.png 200w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-170x96.png 170w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-120x67.png 120w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2017/11/Screenshot-2017-11-27-DevOpsCon-2017-Interview-mit-Dr-Roland-Huß-YouTube.png 854w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-docker-container-kubernetes-interview-64668">"Kubernetes wird der kleinste gemeinsame Nenner werden, auf dem alle aufbauen"</a></li><li class="posts-by-tag-item DevOps DevOpsCon 2017" id="posts-by-tag-item-64538"><a class="thumb" href="https://jaxenter.de/devops-tipps-gebt-den-teams-ein-gemeinsames-ziel-64538" title="DevOps Tipps: &#8222;Gebt den Teams ein gemeinsames Ziel&#8220;"  ><img width="150" height="105" src="https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton-150x105.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/11/matthew-skelton.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-tipps-gebt-den-teams-ein-gemeinsames-ziel-64538">DevOps Tipps: "Gebt den Teams ein gemeinsames Ziel"</a></li><li class="posts-by-tag-item Container DevOpsCon 2017 Docker Interview Kubernetes OpenShift W-JAX 2017" id="posts-by-tag-item-63989"><a class="thumb" href="https://jaxenter.de/docker-kubernetes-openshift-63989" title="Docker, Kubernetes, OpenShift: Hype oder Revolution der IT?"  ><img width="150" height="105" src="https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25-150x105.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/11/Michael-Johann-25.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/docker-kubernetes-openshift-63989">Docker, Kubernetes, OpenShift: Hype oder Revolution der IT?</a></li></ul></div><div id="polls-widget-3" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-30" class="wp-polls">
	<form id="polls_form_30" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_30_nonce" name="wp-polls-nonce" value="4ccfadd38e" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="30" /></p>
		<p style="display: none;"><input type="hidden" id="poll_multiple_ans_30" name="poll_multiple_ans_30" value="10" /></p>
		<p><strong>Welches ist die beste Java IDE?</strong></p><div id="polls-30-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="checkbox" id="poll-answer-227" name="poll_30" value="227" /> <label for="poll-answer-227">Android Studio</label></li>
		<li><input type="checkbox" id="poll-answer-228" name="poll_30" value="228" /> <label for="poll-answer-228">NetBeans</label></li>
		<li><input type="checkbox" id="poll-answer-229" name="poll_30" value="229" /> <label for="poll-answer-229">Eclipse</label></li>
		<li><input type="checkbox" id="poll-answer-230" name="poll_30" value="230" /> <label for="poll-answer-230">IntelliJ IDEA</label></li>
		<li><input type="checkbox" id="poll-answer-231" name="poll_30" value="231" /> <label for="poll-answer-231">Visual Studio</label></li>
		<li><input type="checkbox" id="poll-answer-232" name="poll_30" value="232" /> <label for="poll-answer-232">VS Code</label></li>
		<li><input type="checkbox" id="poll-answer-233" name="poll_30" value="233" /> <label for="poll-answer-233">Eclipse Che</label></li>
		<li><input type="checkbox" id="poll-answer-234" name="poll_30" value="234" /> <label for="poll-answer-234">Orion</label></li>
		<li><input type="checkbox" id="poll-answer-235" name="poll_30" value="235" /> <label for="poll-answer-235">Theia</label></li>
		<li><input type="checkbox" id="poll-answer-236" name="poll_30" value="236" /> <label for="poll-answer-236">Atom IDE</label></li>
		<li><input type="checkbox" id="poll-answer-237" name="poll_30" value="237" /> <label for="poll-answer-237">Andere</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(30);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-30-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="tag-widget-2" class="widget TagWidget"><a href="https://jaxenter.de/tag/kolumne"><p class="widget-title">Kolumnen</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Internet of Things Kolumne Planet Android Security" id="posts-by-tag-item-65181"><a class="thumb" href="https://jaxenter.de/planet-android-display-android-things-65181" title="Planet Android: Display ohne Grenzen und eine neue Developer Preview für Android Things"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/11/jaxenter_Kolumne_Android_33421_v2-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/planet-android-display-android-things-65181">Planet Android: Display ohne Grenzen und eine neue Developer Preview für Android Things</a></li><li class="posts-by-tag-item Diversität Karriere Kolumne Women in Tech" id="posts-by-tag-item-65192"><a class="thumb" href="https://jaxenter.de/women-in-tech-leitha-matz-65192" title="Women in Tech: &#8222;Als Frau muss man widerstandsfähig sein und braucht ein dickes Fell&#8220;"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/12/Women_in_Tech_Aufmacher_900x450_39593_Leitha_Matz.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/women-in-tech-leitha-matz-65192">Women in Tech: "Als Frau muss man widerstandsfähig sein und braucht ein dickes Fell"</a></li><li class="posts-by-tag-item Kolumne NetBeans NetBeans Blog" id="posts-by-tag-item-65149"><a class="thumb" href="https://jaxenter.de/netbeans-apache-mailinglisten-65149" title="Am 1. Januar 2018 werden die netbeans.org-Mailinglisten eingestellt"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/12/Netbeans-Blog_600x400_red-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/netbeans-apache-mailinglisten-65149">Am 1. Januar 2018 werden die netbeans.org-Mailinglisten eingestellt</a></li><li class="posts-by-tag-item Backend meets Frontend Container Kolumne Testen &amp; Qualität Vaadin" id="posts-by-tag-item-65147"><a class="thumb" href="https://jaxenter.de/vaadin-persistenz-65147" title="Persistenz einfach in den Entwicklungsprozess integrieren"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/vaadin-persistenz-65147">Persistenz einfach in den Entwicklungsprozess integrieren</a></li><li class="posts-by-tag-item DevOps DevOps Stories Kollaboration Kolumne" id="posts-by-tag-item-64928"><a class="thumb" href="https://jaxenter.de/devops-stories-support-im-team-64928" title="DevOps Stories: So habe ich das noch nie gesehen!"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-stories-support-im-team-64928">DevOps Stories: So habe ich das noch nie gesehen!</a></li></ul></div><div id="bwp_recent_comments-2" class="widget bwp-rc-widget"><p class="widget-title">Letzte Kommentare</p>
		<ul class="bwp-rc-ulist">
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Marius L.</span><span class="recent-comment-text"> Ich finde es am schlimmsten wenn die Prozesse mehrfach, ohne richtige Nachvollziehbarkeit, abgeändert (oder wie es Neudeutsch "aligned" heißt) wird. Das überfordert jeden Entwickler mit... </span> <a href="https://jaxenter.de/mein-scrum-ist-kaputt-65187#comment-189120" title="Comment on Mein Scrum ist kaputt!"><strong>Mein Scrum ist kaputt!</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/uploads/2017/01/schlosser_hartmut_sw-102x150.jpg" width="27" height="40" alt="Hartmut Schlosser" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 alignnone photo" /></span><span class="recent-comment-single"><span class="recent-comment-author">Hartmut Schlosser</span><span class="recent-comment-text"> Hallo Peter - vielen Dank für diese Ergänzung. In JEP 322 heißt es dazu: "The overall format of version strings is the same as that... </span> <a href="https://jaxenter.de/java-10-versionsschema-65118#comment-188956" title="Comment on Next stop Java 10: Roadmap für neue Java-Versionen steht fest"><strong>Next stop Java 10: Roadmap für neue Java-Versionen steht fest</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Peter</span><span class="recent-comment-text"> Also ich bin bei Java releases (noch) sehr konservativ eingestellt. Deshalb würde ich begrüssen, dass im Version string ein LTS für eben diese Version stehen... </span> <a href="https://jaxenter.de/java-10-versionsschema-65118#comment-188951" title="Comment on Next stop Java 10: Roadmap für neue Java-Versionen steht fest"><strong>Next stop Java 10: Roadmap für neue Java-Versionen steht fest</strong></a></span></li>
		</ul>
</div><div id="featured_posts-2" class="widget widget_featured_posts"><p class="widget-title">Featured Posts</p><ul class="featured-posts-list"><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/jax-2018-vorschau-65085"><img width="96" height="80" src="https://jaxenter.de/wp-content/uploads/2015/05/WJAX_Eventgrafik_300x250_30073_v1-96x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2015/05/WJAX_Eventgrafik_300x250_30073_v1-96x80.jpg 96w, https://jaxenter.de/wp-content/uploads/2015/05/WJAX_Eventgrafik_300x250_30073_v1-150x125.jpg 150w, https://jaxenter.de/wp-content/uploads/2015/05/WJAX_Eventgrafik_300x250_30073_v1.jpg 300w, https://jaxenter.de/wp-content/uploads/2015/05/WJAX_Eventgrafik_300x250_30073_v1-200x167.jpg 200w, https://jaxenter.de/wp-content/uploads/2015/05/WJAX_Eventgrafik_300x250_30073_v1-170x142.jpg 170w, https://jaxenter.de/wp-content/uploads/2015/05/WJAX_Eventgrafik_300x250_30073_v1-156x130.jpg 156w, https://jaxenter.de/wp-content/uploads/2015/05/WJAX_Eventgrafik_300x250_30073_v1-180x150.jpg 180w" sizes="(max-width: 96px) 100vw, 96px" /></a></div><div class="title"><a href="https://jaxenter.de/jax-2018-vorschau-65085">JAX 2018 Vorschau: Diese Sessions haben es ins Programm geschafft</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/alexa-skills-entwickeln-64751"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/11/shutterstock_651441421-180x120.jpg 180w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/alexa-skills-entwickeln-64751">Alexa Skills entwickeln: Sprachbefehle für LEGO-Mindstorms-Roboter</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/java-9-taskbar-support-64988"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-200x134.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_242673061.jpg 500w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/java-9-taskbar-support-64988">Java 9 &#8211; eine Einführung: So funktioniert der Taskbar-Support</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/devops-tipps-unternehmen-64793"><img width="114" height="80" src="https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-114x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/11/Rob-Vanstone.jpg 500w" sizes="(max-width: 114px) 100vw, 114px" /></a></div><div class="title"><a href="https://jaxenter.de/devops-tipps-unternehmen-64793">DevOps Tipps: &#8222;DevOps muss von der Unternehmensführung selbst angenommen werden&#8220;</a></div></li></ul></div><div id="newsletter-2" class="widget widget_newsletter"><p class="widget-title">Newsletter</p><div class="newsletter"><p class="newsletter-icon pull-left"><a href="https://jaxenter.de/newsletter"><img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter.jpg" alt="Newsletter" /></a></p><p class="newsletter-info"><a href="https://jaxenter.de/newsletter">Alle Neuigkeiten die wichtig sind, mit dem JAXenter Newsletter!</a></p><p><a href="https://jaxenter.de/newsletter">Jetzt bestellen!</a></p></div></div><div id="text-4" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD1_Wordpress -->
<div id='div-gpt-ad-1423038811881-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-0'); });
</script>
</div></div>
		</div><div id="text-5" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD2_Wordpress -->
<div id='div-gpt-ad-1423038811881-1' style='width:300px; height:250px; clear:both;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-1'); });
</script>
</div></div>
		</div><div id="text-6" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD3_Wordpress -->
<div id='div-gpt-ad-1423038811881-2' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-2'); });
</script>
</div></div>
		</div><div id="text-15" class="widget widget_text">			<div class="textwidget"></div>
		</div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-4'); });
        </script>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-5'); });
        </script>
        </div>
    </div>
</div>				</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="/magazine/business-technology">Business Technology Magazin</a></li>
<li id="menu-item-38592" class="menu-item menu-item-type-post_type menu-item-object-magazin menu-item-38592"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="http://sharepoint-kompendium.de">SharePoint Kompendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13255"><a href="https://finance.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX Finance (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://btdays.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Business Technology Days</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="http://bigdatacon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BigData Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://webtechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">WebTech Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="http://entwickler-akademie.de">Entwickler Akademie</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-563H99" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-563H99');</script>
<!-- End Google Tag Manager -->

		
		<!-- Facebook Ads Pixel Code -->
		<script>
			(function() {
				var _fbq = window._fbq || (window._fbq = []);
				if (!_fbq.loaded) {
					var fbds = document.createElement('script');
					fbds.async = true;
					fbds.src = '//connect.facebook.net/en_US/fbds.js';
					var s = document.getElementsByTagName('script')[0];
					s.parentNode.insertBefore(fbds, s);
					_fbq.loaded = true;
				}
				_fbq.push(['addPixelId', '407071789447604']);
			})();
			window._fbq = window._fbq || [];
			window._fbq.push(['track', 'PixelInitialized', {}]);
		</script>
		<noscript>
			<img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=407071789447604&ev=PixelInitialized" />
		</noscript>

		<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		//document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		
		document.getElementById("syntaxhighlighteranchor").parentNode.insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		//document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
		
		document.getElementById("syntaxhighlighteranchor").parentNode.insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
	</body>
</html>
