<!DOCTYPE html>
<html lang="de-DE" prefix="og: http://ogp.me/ns#"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>UI-Elemente leichtgewichtig entwickeln - JAXenter</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>	
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
		
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Die Rollen und Rechte unserer Webanwendung stehen. Jetzt können wir uns daran machen, die ersten UI-Komponenten zu bauen und zu integrieren."/>
<meta name="robots" content="noodp"/>
<meta name="keywords" content="Backend meets Frontend,Kolumne,Vaadin"/>
<link rel="canonical" href="https://jaxenter.de/vaadin-ui-elemente-62931" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="UI-Elemente leichtgewichtig entwickeln - JAXenter" />
<meta property="og:description" content="Die Rollen und Rechte unserer Webanwendung stehen. Jetzt können wir uns daran machen, die ersten UI-Komponenten zu bauen und zu integrieren." />
<meta property="og:url" content="https://jaxenter.de/vaadin-ui-elemente-62931" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="Backend meets Frontend" />
<meta property="article:tag" content="Kolumne" />
<meta property="article:tag" content="Vaadin" />
<meta property="article:section" content="Artikel" />
<meta property="article:published_time" content="2017-10-10T11:20:22+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="300" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; UI-Elemente leichtgewichtig entwickeln Kommentar-Feed" href="https://jaxenter.de/vaadin-ui-elemente-62931/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.13 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-18197167-38', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.5" />
<link rel='shortlink' href='https://jaxenter.de/?p=62931' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fvaadin-ui-elemente-62931" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fvaadin-ui-elemente-62931&#038;format=xml" />
	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>

		        
        <script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + 
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		
		<script type='text/javascript'>
		googletag.cmd.push(function() {
		googletag.defineSlot('/21339274/jaxenter.de_contentAD1_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD2_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-1').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD3_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-2').addService(googletag.pubads());		
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper1_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-4').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper2_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-5').addService(googletag.pubads());
		googletag.pubads().collapseEmptyDivs(true);
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();				
		});
		</script>
        
        <script>
  		googletag.cmd.push(function() {
  		googletag.defineSlot('/21339274/jaxenter.de_leaderboard_Wordpress', [728, 90], 'div-gpt-ad-1423038811881-3')
		.addService(googletag.pubads())    
		.setCollapseEmptyDiv();
		  });
		</script>

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>	
		
		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->
		
	</head>
	<body class="post-template-default single single-post postid-62931 single-format-standard">
		
        <header>    
        <div class="topbanner hidden-xs hidden-sm">
        	<div class="container">
					<!-- jaxenter.de_leaderboard_Wordpress -->
                    <div id='div-gpt-ad-1423038811881-3' style='width:100%; min-height:90px; margin:10px 0;'>
                    <script type='text/javascript'>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-3'); });
                    </script>
                    </div>
            </div>
         </div> 
        	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://jaxenter.de/events">Events</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://jaxenter.de/magazine">Java Magazin</a></li>
<li id="menu-item-39337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39337"><a href="https://jax.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=menu">W-JAX 2017</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/docker">Docker</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16647" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16647"><a href="https://jaxenter.de/tag/internet-of-things">Internet of Things</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/maschinelles-lernen">Machine Learning</a></li>
</ul>		</div>
	</div>
 
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">Frühling für Enterprise Java:</span>
                                        
                                    <u><a href="https://jaxenter.de/spring-5-released-62586">Spring 5 ist da!</a></u>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>
		
		                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/W-JAX-Logo-blau-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=StartseiteFeature&amp;utm_campaign=Headerleiste">W-JAX 2017: Die Konferenz für Java, Architektur- und Software-Innovation</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/angular-4-update-55042">Angular 4: Diese Features müssen Sie kennen</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/Spring-Boot-Tutorial-1-300x300-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/spring-boot-tutorial-54020">Spring Boot Tutorial: So entwickelt man REST-Services mit Spring Boot</a></p>
<p>&nbsp;</p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			

          </div>
		</header>
	<script type="text/javascript">
	$( document ).ready(function() {
		$('.single .next-article-popup-post .popup-close').click(function(){
			$('.single .next-article-popup-post').hide();
		});
		$(window).scroll(function() {
		   var hT = $('#content > .text').offset().top,
		       hH = $('#content > .text').outerHeight(),
		       wH = $(window).height(),
		       wS = $(this).scrollTop();
		   if (wS > (hT+hH-wH)){
			   //console.log(wS);
			   if(!$('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').addClass('active');
			   }
		   }else{
			   if($('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').removeClass('active');
			   }
		   }
		});
	}); 
	</script>
	<div class="hidden-xs next-article-popup-post ">
	    <strong class="popup-heading">Nächster Beitrag:</strong>
	    <div class="popup-content">
	    	        <figure class="thumb">
	            <a href="https://jaxenter.de/eclipse-weekly-ee4j-mvc-orion-16-62954"><img width="150" height="106" src="https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532-150x106.jpg" class="alignleft wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532-150x106.jpg 150w, https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532-300x212.jpg 300w, https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532-200x141.jpg 200w, https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532-170x120.jpg 170w, https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532-113x80.jpg 113w, https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532-184x130.jpg 184w, https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532-180x127.jpg 180w, https://jaxenter.de/wp-content/uploads/2015/07/shutterstock_149065532.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a>
	           <!--  <img src="https://entwickler.de/wp-content/uploads/2017/07/ff-brotli-dotnet-mozilla-stt-engine-90x45.jpg" alt="" data-pin-no-hover="true"> -->
	        </figure>
	   	        <h3 class="popup-post-title"><a href="https://jaxenter.de/eclipse-weekly-ee4j-mvc-orion-16-62954">"Eclipse Weekly: Status Quo EE4J, Eclipse MVC und der Webdev-Quartalsbericht"</a></h3>
	    </div>
	    <span class="popup-close">X</span>
	</div>
	


	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Teil 15: Backend meets Frontend: Trainer for kids 5</div>
														<h1 class="title">UI-Elemente leichtgewichtig entwickeln</h1>
							
									<div class="button-tags-block">
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/backend-meets-frontend" target="_blank" >
	                  #Backend meets Frontend 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/kolumne" target="_blank" >
	                  #Kolumne 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/vaadin" target="_blank" >
	                  #Vaadin 	         </a>   
	      		</div>
								
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2017-10-10T11:20">10. Oktober 2017</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Sven Ruppert										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="300" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"><p style="text-align: right;"><span style="color: #999999;">© Shutterstock / HelenField</span></p>
</div>
								</div>
														
															<div class="excerpt">
									<p>Die Rollen und Rechte unserer Webanwendung stehen. Jetzt können wir uns daran machen, die ersten UI-Komponenten zu bauen und zu integrieren. Das heißt natürlich auch, dass wir diese Komponenten testen.</p>
								</div>
													</div>
					
					
					
					<div class="text">
						<p>Nachdem wir uns <a href="https://jaxenter.de/rollen-rechte-und-ihre-auswirkungen-auf-das-ui-61964">das letzte Mal</a> damit beschäftigt haben, wie wir die Verbindung zwischen den Rollen und Rechten von Apache Shiro mit den Menüpunkten verbinden, werden wir heute ein wenig mehr im Bereich der grafischen Komponenten tätig sein. Ziel ist es, die ersten Matheaufgaben zu stellen, beginnend mit einfachen Additionen und Subtraktionen.</p>
<div id="attachment_62932" style="width: 310px" class="wp-caption alignright"><img class="wp-image-62932 size-medium" src="https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001-300x234.png" alt="" width="300" height="234" srcset="https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001-300x234.png 300w, https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001-150x117.png 150w, https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001-200x156.png 200w, https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001-170x132.png 170w, https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001-103x80.png 103w, https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001-167x130.png 167w, https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001-180x140.png 180w, https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_Math_001.png 719w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Abb. 1: Die Felder für die Addition</p></div>
<p>Wir hatten in den vergangenen Teilen einige Komponenten für die jeweiligen Arbeitsbereiche vorgesehen. Eine davon war die Komponente <code>MathComponent</code>. Beginnen wir mit einem trivialen Fall und sehen zwei Ausgabefelder für die Komponenten der Addition sowie ein Eingabefeld für das zu berechnende Ergebnis vor (<strong>Abb. 1</strong>). Wenn der Benutzer die Aufgabe gelöst und das Ergebnis in das Eingabefeld geschrieben hat, soll nach dem Drücken eines Buttons überprüft werden, ob die Berechnung korrekt gewesen ist. Das vom Computer berechnete Ergebnis soll dann neben dem Ergebnis des Benutzers erscheinen. Zusätzlich gibt es noch einen grafischen Hinweis, ob das Ergebnis korrekt gewesen ist oder nicht. Hierzu verwenden wir einen lächelnden Smiley, wenn es richtig, oder einen weinenden, wenn es falsch gewesen ist.</p>
<h2>Das GridLayout aufbauen</h2>
<p>Beginnen wir nun mit dem Erstellen der Arbeitsfläche für die Matheaufgaben. Das zugrunde liegende Layout ist diesmal das <code>GridLayout</code>. Hierbei handelt es sich um ein Tabellenkonstrukt, das mit Koordinaten zweidimensional zu adressieren ist. Praktisch bedeutet dies, dass jede Zelle mit einer X- und einer Y-Koordinate versehen ist. Die vollständige Größe wird bei der Erzeugung der Instanz der Klasse <code>GridLayout</code> festgelegt. Sehen wir uns dazu ein Beispiel an. Für das Erzeugen der im <code>GridLayout</code> verwendeten Demo-Buttons definieren wir uns eine Hilfsmethode.</p>
<pre class="brush: java; title: ; notranslate" title="">
  private Button btn(String caption){
    Button button = new Button(caption);
    button.setSizeFull();
    return button;
  }
</pre>
<p>Nun befüllen wir das <code>GridLayout</code> der Größe 4&#215;4 mit gleich großen Buttons (<strong>Abb. 2</strong>).</p>
<pre class="brush: java; title: ; notranslate" title="">
    final GridLayout grid4X4 = new GridLayout(4, 4);

    grid4X4.addComponent(btn(&quot;AA&quot;), 0,0);
    grid4X4.addComponent(btn(&quot;BA&quot;), 1,0);
    grid4X4.addComponent(btn(&quot;CA&quot;), 2,0);
    grid4X4.addComponent(btn(&quot;DA&quot;), 3,0);

    grid4X4.addComponent(btn(&quot;AB&quot;), 0,1);
    grid4X4.addComponent(btn(&quot;BB&quot;), 1,1);
    grid4X4.addComponent(btn(&quot;CB&quot;), 2,1);
    grid4X4.addComponent(btn(&quot;DB&quot;), 3,1);
</pre>
<div id="attachment_62933" style="width: 310px" class="wp-caption alignright"><img class="wp-image-62933 size-medium" src="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001-300x104.png" alt="" width="300" height="104" srcset="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001-300x104.png 300w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001-150x52.png 150w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001-200x69.png 200w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001-170x59.png 170w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001-120x42.png 120w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001-190x66.png 190w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001-180x62.png 180w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_001.png 450w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Abb. 1: Das GridLayout mit 4&#215;4 Buttons</p></div>
<p>Das <code>GridLayout</code> bietet einige Möglichkeiten, um Elemente in übergreifenden Zellen zu positionieren. Als nächstes werden wir einen <code>Button</code> über zwei Zellen in einer Zeile verteilen. Dazu ändern wir den Quelltext wie folgt:</p>
<pre class="brush: java; title: ; notranslate" title="">
    final GridLayout grid4X4 = new GridLayout(4, 4);

    grid4X4.addComponent(btn(&quot;AA&quot;), 0,0);
    grid4X4.addComponent(btn(&quot;BA&quot;), 1,0, 2,0);
    grid4X4.addComponent(btn(&quot;CA&quot;), 3,0);

    grid4X4.addComponent(btn(&quot;AB&quot;), 0,1);
    grid4X4.addComponent(btn(&quot;BB&quot;), 1,1);
    grid4X4.addComponent(btn(&quot;CB&quot;), 2,1);
    grid4X4.addComponent(btn(&quot;DB&quot;), 3,1);
</pre>
<div id="attachment_62934" style="width: 310px" class="wp-caption alignright"><img class="wp-image-62934 size-medium" src="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002-300x105.png" alt="" width="300" height="105" srcset="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002-300x105.png 300w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002-150x53.png 150w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002-200x70.png 200w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002-170x60.png 170w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002-120x42.png 120w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002-190x67.png 190w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002-180x63.png 180w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_002.png 450w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Abb. 3: Der Button BA füllt nicht den gesamten zur Verfügung stehenden Platz aus</p></div>
<p>Allerdings ist das Ergebnis nicht das erwartete. Der Button <em>BA</em> füllt nicht den gesamten zur Verfügung stehenden Platz aus (<strong>Abb. 3</strong>). Wenn man ganz genau hinsieht, ist der Button <em>CA</em> an der rechten Seite auch nicht exakt so weit wie der Rand des Buttons <em>DB</em>. Um dieses Verhalten anzupassen, setzen wir das <code>GridLayout</code> auf <code>setSizeFull()</code>.</p>
<pre class="brush: java; title: ; notranslate" title="">
    final GridLayout grid4X4 = new GridLayout(4, 4);

    grid4X4.setSizeFull();
    grid4X4.addComponent(btn(&quot;AA&quot;), 0,0);
    grid4X4.addComponent(btn(&quot;BA&quot;), 1,0, 2,0);
    grid4X4.addComponent(btn(&quot;CA&quot;), 3,0);

    grid4X4.addComponent(btn(&quot;AB&quot;), 0,1);
    grid4X4.addComponent(btn(&quot;BB&quot;), 1,1);
    grid4X4.addComponent(btn(&quot;CB&quot;), 2,1);
    grid4X4.addComponent(btn(&quot;DB&quot;), 3,1);
</pre>
<div id="attachment_62935" style="width: 310px" class="wp-caption alignright"><img class="wp-image-62935 size-medium" src="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-300x63.png" alt="" width="300" height="63" srcset="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-300x63.png 300w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-150x32.png 150w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-768x162.png 768w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-200x42.png 200w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-170x36.png 170w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-120x25.png 120w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-190x40.png 190w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003-180x38.png 180w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_003.png 966w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Abb. 4: Das GridLayout nutzt nun den gesamten zur Verfügung stehenden Platz aus</p></div>
<p>Das <code>GridLayout</code> verwendet nun den gesamten zur Verfügung stehenden Platz im Browser (<strong>Abb. 4</strong>). Was horizontal funktioniert, ist auch vertikal möglich. Hier anhand des Buttons <em>CA</em> gezeigt (<strong>Abb. 5</strong>).</p>
<pre class="brush: java; title: ; notranslate" title="">
    final GridLayout grid4X4 = new GridLayout(4, 4);

    grid4X4.setSizeFull();
    grid4X4.addComponent(btn(&quot;AA&quot;), 0,0);
    grid4X4.addComponent(btn(&quot;BA&quot;), 1,0, 2,0);
    grid4X4.addComponent(btn(&quot;CA&quot;), 3,0, 3,1);

    grid4X4.addComponent(btn(&quot;AB&quot;), 0,1);
    grid4X4.addComponent(btn(&quot;BB&quot;), 1,1);
    grid4X4.addComponent(btn(&quot;CB&quot;), 2,1);
</pre>
<div id="attachment_62936" style="width: 310px" class="wp-caption alignright"><img class="wp-image-62936 size-medium" src="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-300x63.png" alt="" width="300" height="63" srcset="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-300x63.png 300w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-150x32.png 150w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-768x162.png 768w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-200x42.png 200w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-170x36.png 170w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-120x25.png 120w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-190x40.png 190w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004-180x38.png 180w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_004.png 968w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Abb. 5: Auch vertikal Zeilen zusammenzunehmen, ist möglich</p></div>
<p>Und der Vollständigkeit halber nun noch ein Beispiel, das über Zeilen und Spalten geht (<strong>Abb. 6</strong>).</p>
<pre class="brush: java; title: ; notranslate" title="">
    final GridLayout grid4X4 = new GridLayout(4, 4);

    grid4X4.setSizeFull();
    grid4X4.addComponent(btn(&quot;AA&quot;), 0,0);
    grid4X4.addComponent(btn(&quot;BA&quot;), 1,0, 2,1);
    grid4X4.addComponent(btn(&quot;CA&quot;), 3,0);

    grid4X4.addComponent(btn(&quot;AB&quot;), 0,1);
    grid4X4.addComponent(btn(&quot;CB&quot;), 3,1);
</pre>
<div id="attachment_62937" style="width: 310px" class="wp-caption alignright"><img class="wp-image-62937 size-medium" src="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-300x63.png" alt="" width="300" height="63" srcset="https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-300x63.png 300w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-150x32.png 150w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-768x163.png 768w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-200x42.png 200w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-170x36.png 170w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-120x25.png 120w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-190x40.png 190w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005-180x38.png 180w, https://jaxenter.de/wp-content/uploads/2017/10/Grid4X4_005.png 964w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Abb. 6: Beispiel über Zeilen und Spalten hinweg</p></div>
<h2>Komponententests sind ein Klacks</h2>
<p>Bei allen Beispielen stellt sich die Frage, wie man mit kurzen Entwicklungszyklen iterativ an der UI arbeiten kann? Bei größeren Projekten kommen vor allem die Startzeiten zum Tragen, die sich ergeben, wenn ein größeres UI initialisiert werden muss. Wir wollen aber lediglich eine Komponente entwickeln, losgelöst von der restlichen Anwendung. Recht praktisch wäre es, wenn man ausschließlich die Komponenten in einem Servlet-Container starten könnte, um dann das Ergebnis in einem Browser zu validieren.</p>
<p>Hierfür ist in diesem Projekt schon alles vorhanden. Denn wir haben die Klasse <code>Main</code>, in der wir eine Instanz des Undertow starten und dabei ein Servlet angeben. Als erstes erzeugen wir uns für die Komponententests eine neue Klasse mit einer <em>main</em>-Methode. In unserem Beispiel ist der Name <code>CalcComponentDevelop</code>. Hier verzichten wir vollständig auf die Integration von Shiro. Sicherheit ist bei der Entwicklung von Komponenten ein nachgelagertes Problem. Ziel ist es, möglichst schnell mit der Initialisierung fertig zu sein. Als nächstes benötigen wir ein Servlet und eine der UI-Klassen.</p>
<pre class="brush: java; title: ; notranslate" title="">
@WebServlet(value = &quot;/*&quot;)
@VaadinServletConfiguration(productionMode = false, ui = ComponentTestUI.class)
public class ComponentDevelopmentTestServlet extends VaadinServlet {}

@Theme(&quot;valo&quot;)
//  @PreserveOnRefresh
public class ComponentTestUI extends UI {
  private static final Logger LOGGER = LoggerFactory.getLogger(ComponentTestUI.class);
  @Override
  protected void init(VaadinRequest request) {
    setContent(new CalcComponent());
    setSizeFull();
  }
}
</pre>
<p>In der Main-Methode der Klasse <code>CalcComponentDevelop</code> wird nun genau dieses Servlet gestartet.</p>
<pre class="brush: java; title: ; notranslate" title="">

//SNIPP
DeploymentInfo servletBuilder
        = Servlets.deployment()
                  .setClassLoader(CalcComponentDevelop.class.getClassLoader())
                  .setContextPath(CONTEXT_PATH)
                  .setDeploymentName(&quot;ROOT.war&quot;)
                  .setDefaultEncoding(&quot;UTF-8&quot;)
                  .addServlets(
                      servlet(
                          ComponentDevelopmentTestServlet.class.getSimpleName(),
                          ComponentDevelopmentTestServlet.class).addMapping(&quot;/*&quot;)
                  );
//SNIPP
</pre>
<p>Nun haben wir eine sehr kurze Entwicklungs-Test-Schleife (<strong>Abb. 7</strong>).</p>
<div id="attachment_62938" style="width: 660px" class="wp-caption aligncenter"><img class="wp-image-62938" src="https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015.gif" alt="" width="650" height="406" /><p class="wp-caption-text">Abb. 7: Wir haben nun eine kurze Entwicklungs-Test-Schleife</p></div>
<div class='widgets_on_page'> <div id="wp_editor_widget-38" class="widget WP_Editor_Widget"><p class="widget-title">Backend meets Frontend</p><p><img class="alignleft wp-image-58703" src="https://jaxenter.de/wp-content/uploads/2017/06/shutterstock_601024790_grau-300x300.jpg" alt="" width="150" height="150" />In der Artikelserie Backend meets Frontend stellt <strong>Sven Ruppert</strong> (Vaadin) Konzepte und Technologien rund um das UI-Framework Vaadin vor. Sein Fokus liegt dabei auf modernem Web-Design für Java-Backend-Entwickler.</p>
<p>Zum ersten Teil und damit dem Start der Tutorien rund um die UI-Entwicklung mit Java geht es <a href="https://jaxenter.de/backend-meets-frontend-vaadin-java-58701">hier entlang</a>. Alle Teile der Serie Backend meets Frontend finden sich <a href="https://jaxenter.de/tag/backend-meets-frontend">hier</a>.</p>
</div>
  </div><!-- widgets_on_page -->
<h2>Implementierung des Menüpunkts</h2>
<p>Für die Entwicklung haben wir nun unsere Werkzeuge zusammen. Beginnen wir also damit unser UI für den Menüpunkt zu implementieren. Hier gehen wir recht geradlinig vor, da wir die Anzahl der Elemente und deren Position schon haben. Zu Beginn definieren und erzeugen wir alle gewünschten Elemente.</p>
<pre class="brush: java; title: ; notranslate" title="">
  public static final int COLUMNS = 7;
  public static final int ROWS = 2;

  private GridLayout grid;

  private TextField valueOne;
  private TextField valueTwo;
  private TextField humanResult;
  private TextField machineResult;
  private Label resultLabel;

  private Button buttonNext;
  private Button buttonCalculate;

  private Random random;

  private void initFields() {
    random = new Random(System.nanoTime());

    valueOne = new TextField();
    valueTwo = new TextField();
    humanResult = new TextField();
    machineResult = new TextField();
    resultLabel = new Label();

    buttonNext = btn(&quot;Next&quot;);
    buttonCalculate = btn(&quot;OK&quot;);

    grid = new GridLayout(COLUMNS, ROWS);
  }
</pre>
<p>Da nun alle Elemente vorhanden sind, bauen wir die Grundstruktur auf.</p>
<pre class="brush: java; title: ; notranslate" title="">
  private void createStructure() {
    grid.addComponent(valueOne, 0, 0);
    grid.addComponent(new Label(PLUS.getHtml(), HTML), 1, 0);
    grid.addComponent(valueTwo, 2, 0);
    grid.addComponent(new Label(&quot;=&quot;), 3, 0);
    grid.addComponent(humanResult, 4, 0);
    grid.addComponent(buttonCalculate, 5, 0);
    grid.addComponent(buttonNext, 6, 0);

    grid.addComponent(machineResult, 4, 1);
    grid.addComponent(resultLabel, 5, 1);
  }
</pre>
<p>Nun können wir schon die finale Struktur sehen und testen, ob es dem entspricht, was wir erreichen wollen. Dann beginnen wir mit dem Anpassen der Elemente selbst. Zum Beispiel, dass der Button <code>Next</code> zu Beginn deaktiviert ist, die Texteingabefelder leer sind und das Textfeld für die berechneten Werte auf <em>read-only</em> gesetzt wird. Ebenfalls sorgen wir für eine initiale Aufgabe, indem wir die Textfelder für die Werte <em>A</em> und <em>B</em> mit jeweils einer Zufallszahl befüllen.</p>
<pre class="brush: java; title: ; notranslate" title="">
  private void customizeFields() {
    machineResult.setReadOnly(true);
    machineResult.setReadOnly(true);
    buttonNext.setEnabled(false);

    //clear
    valueOne.setValue(&quot;&quot;);
    valueTwo.setValue(&quot;&quot;);

    humanResult.setValue(&quot;&quot;);
    machineResult.setValue(&quot;&quot;);

    //toggle
    buttonCalculate.setEnabled(true);
    buttonNext.setEnabled(false);

    //init next
    valueOne.setValue(String.valueOf(random.nextInt(10)));
    valueTwo.setValue(String.valueOf(random.nextInt(10)));
  }
</pre>
<p>Jetzt fehlen nur noch die Implementierungen der beiden Buttons, um die Funktion abzubilden. Wir nehmen uns als erstes den einfacheren Fall vor, das Zurücksetzen der Komponente mit dem <em>Next</em> Button.</p>
<pre class="brush: java; title: ; notranslate" title="">
    buttonNext.addClickListener((Button.ClickListener) event -&gt; {
      //clear
      valueOne.setValue(&quot;&quot;);
      valueTwo.setValue(&quot;&quot;);

      humanResult.setValue(&quot;&quot;);
      machineResult.setValue(&quot;&quot;);

      resultLabel.setCaption(&quot;&quot;);

      //toggle
      buttonCalculate.setEnabled(true);
      buttonNext.setEnabled(false);

      //init next
      valueOne.setValue(String.valueOf(random.nextInt(10)));
      valueTwo.setValue(String.valueOf(random.nextInt(10)));
    });
</pre>
<p>Und zu guter Letzt der Button <code>OK</code>, um die Berechnung selbst zu validieren.</p>
<pre class="brush: java; title: ; notranslate" title="">
    buttonCalculate.addClickListener((Button.ClickListener) event -&gt; {
      String valueOneValue = valueOne.getValue();
      String valueTwoValue = valueTwo.getValue();

      Integer a = Integer.valueOf(valueOneValue);
      Integer b = Integer.valueOf(valueTwoValue);

      Integer x = a + b;

      machineResult.setValue(String.valueOf(x));

      //Compare Result
      Integer wasRight = Integer.valueOf(humanResult.getValue()) - x;
      if (wasRight == 0) {
        resultLabel.setCaption(CHECK_CIRCLE.getHtml());
        resultLabel.setCaptionAsHtml(true);

      } else {
        resultLabel.setCaption(CLOSE_CIRCLE.getHtml());
        resultLabel.setCaptionAsHtml(true);
      }
      resultLabel.setCaptionAsHtml(true);
      buttonCalculate.setEnabled(false);
      buttonNext.setEnabled(true);
    });
</pre>
<p>An dieser Stelle sehen wir schon, dass wir einige Dinge miteinander vermischen. Das Extrahieren der Logik, Validieren der Eingabefelder und ähnliches werden wir uns in den nächsten Teilen dann genauer ansehen. Wir haben nun alles zusammen und können die Komponente einzeln testen (<strong>Abb. 8</strong>).</p>
<div id="attachment_62939" style="width: 660px" class="wp-caption aligncenter"><img class="wp-image-62939" src="https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_workflow.gif" alt="" width="650" height="328" /><p class="wp-caption-text">Abb. 8: Der Workflow steht</p></div>
<p>Zu guter letzt muss natürlich die Komponente noch in die Anwendung selbst integriert werden. Hierzu müssen wir an der Stelle lediglich die Klasse <code>Main</code> starten und in der Anwendung bis zum Mathe-Dashboard navigieren (<strong>Abb. 9</strong>). Weitere Anpassungen sollten nicht notwendig sein, da ja dieselbe Komponente initialisiert wird.</p>
<div id="attachment_62940" style="width: 660px" class="wp-caption aligncenter"><img class="wp-image-62940" src="https://jaxenter.de/wp-content/uploads/2017/10/JaxEnter-Vaadin-015_app.gif" alt="" width="650" height="365" /><p class="wp-caption-text">Abb. 9: Alle Komponenten sind in die Anwendung integriert</p></div>
<h2>Fazit</h2>
<p>In diesem Teil haben wir uns damit beschäftigt, wie wir eine einzelne Komponente entwickeln können und gesehen, dass es sinnvoll sein kann, wenn man diese Komponentenentwicklung in eine leichtgewichtige Umgebung auslagert. In unserem Fall bedeutet dies, dass wir die Komponente einzeln in einem Servlet-Container gestartet haben, ohne dass die gesamte Anwendung jedesmal initialisiert werden muss. So sind Zyklen von wenigen Sekunden möglich, obwohl der Servlet-Container jedesmal komplett neu gestartet wird. Damit können wir auch annehmen, das Fehler vom vorherigen Durchlauf so gut wie nie Einfluss auf den aktuellen Durchlauf haben. Diesmal haben wir das noch explizit für diese eine Komponente gemacht. In den nächsten Teilen werden wir uns ansehen, wie man das allgemeiner für die Entwicklung einsetzen kann.</p>
<p>Den Quelltext findet ihr auf <a href="https://github.com/Java-Publications/vaadin-017-helloworld-15" target="_blank" rel="noopener noreferrer">GitHub</a>. Bei Fragen und Anregungen einfach melden unter sven@vaadin.com oder per Twitter @SvenRuppert.</p>
<p>Happy Coding!</p>
<div class='widgets_on_page'> <div id="wysiwyg_widgets_widget-9" class="widget widget_wysiwyg_widgets_widget"><!-- Widget by WYSIWYG Widgets v2.3.6 - https://wordpress.org/plugins/wysiwyg-widgets/ --><div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"><img style="width: 100%; height: auto;" src="/wp-content/uploads/2017/09/WJAX_2017_Contentbox_2126x162_42564_v1.jpg" alt="W-JAX" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="/wp-content/uploads/2017/09/WJAX_2017_Speakerbox_550x214_42564_v1.jpg" alt="W-JAX" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;"></div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jax.de/wp-content/uploads/2016/12/1479293980344_hartmann_nils_wp.jpg" alt="Nils Hartmann" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://jax.de/web-development-javascript/das-javascript-oekosystem-orientierungshilfen/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://jax.de/web-development-javascript/das-javascript-oekosystem-orientierungshilfen/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Das JavaScript-Ökosystem: Orientierungshilfen');" style="color: #264186; font-size: 19px; font-weight: 600;">Das JavaScript-Ökosystem: Orientierungshilfen</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Nils Hartmann (EOS Technology Solutions)</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="border: 1px solid #fff; max-width: 100%; height: auto;" src="https://jax.de/wp-content/uploads/2016/12/1479384952433_toedter_kai_wp.jpg" alt="Nils Hartmann" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://jax.de/web-development-javascript/workshop-coole-web-apps-mit-spring-boot-angular-und-typescript/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://jax.de/web-development-javascript/workshop-coole-web-apps-mit-spring-boot-angular-und-typescript/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Coole Web-Apps mit Spring Boot, Angular und TypeScript');" style="color: #264186; font-size: 19px; font-weight: 600;">Coole Web-Apps mit Spring Boot, Angular und TypeScript</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Kai Tödter (Siemens AG)</p>
</div>
</div>
</div>
</div>
</div>
</div>
<div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://api-summit.de/"><img style="width: 100%; height: auto;" src="/wp-content/uploads/2017/09/API_Summit_2126x162_41329_v1.jpg" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><a href="https://api-summit.de/"><img class="" style="width: 100%; height: auto;" src="/wp-content/uploads/2017/09/API_Summit_550x214_41329_v1.jpg" alt="API Summit 2017" /></a></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<h3 style="margin: 12px 0; font-size: 19px !important; font-weight: 700 !important; padding: 5px 0 12px 0 !important;"><span style="color: #a4187e;"><a href="https://api-summit.de/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://api-summit.de/', 'Das große Trainingsevent für Web APIs mit Java, .NET und Node.js');" style="color: #293133;">Das große Trainingsevent für Web APIs mit Java, .NET und Node.js</a></span></h3>
</div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jaxenter.de/wp-content/uploads/2017/09/Stephan-Müller-1.png" alt="Stephan Müller" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #a4187e;"><a href="https://api-summit.de/api/web-apis-mit-java-rest-ist-nur-der-anfang-teil-1/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://api-summit.de/api/web-apis-mit-java-rest-ist-nur-der-anfang-teil-1/', 'Web-APIs mit Java: REST ist nur der Anfang');" style="color: #293133; font-size: 19px; font-weight: 600;">Web-APIs mit Java: REST ist nur der Anfang</a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Stephan Müller (OPEN KNOWLEDGE)</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="border: 1px solid #fff; max-width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350.jpg" alt="Thilo Frotscher" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #a4187e;"><a href="https://api-summit.de/api/fallstricke-beim-design-von-web-apis/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://api-summit.de/api/fallstricke-beim-design-von-web-apis/', 'Fallstricke beim Design von Web APIs');" style="color: #293133; font-size: 19px; font-weight: 600;">Fallstricke beim Design von Web APIs</a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Thilo Frotscher (Freiberufler)</p>
</div>
</div>
</div>
</div>
</div>
</div>
<!-- / WYSIWYG Widgets --></div>
  </div><!-- widgets_on_page -->
					</div>
					
										
					
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/vaadin-ui-elemente-62931" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/vaadin-ui-elemente-62931" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=UI-Elemente leichtgewichtig entwickeln - https://jaxenter.de/vaadin-ui-elemente-62931" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/vaadin-ui-elemente-62931" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/vaadin-ui-elemente-62931" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/vaadin-ui-elemente-62931" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/vaadin-ui-elemente-62931" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/vaadin-ui-elemente-62931" data-url-old=""></span></div>
						</a>
					</div>
					
					<div class="row"><div class="more-topics"><div class="col-xs-12 col-md-3"><h3 class="box-headline">Verwandte Themen:</h3></div><div class="col-xs-12 col-md-9">		<div class="button-tags-block">
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/backend-meets-frontend" target="_blank" >
	                   Backend meets Frontend 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/kolumne" target="_blank" >
	                   Kolumne 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/vaadin" target="_blank" >
	                   Vaadin 	         </a>   
	      		</div>
	</div></div></div>
					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2015/01/ruppert_sven_sw-150x143.jpg" width="96" height="92" alt="Sven Ruppert" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Sven Ruppert</div>

																							<div class="author-description">
													Sven Ruppert arbeitet seit 1996 mit Java und ist Developer Advocate bei Vaadin. In seiner Freizeit spricht er auf internationalen und nationalen Konferenzen, schreibt für IT-Magazine und für Tech-Portale. Twitter: @SvenRuppert												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/svenruppert">Alle Beiträge von Sven Ruppert</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/vaadin-webanwendungen-apache-shiro-61670" rel="bookmark">
						<div class="image">
															<img width="130" height="130" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 130px) 100vw, 130px" />													</div>
						<div class="title">
							Webanwendungen absichern mit Apache Shiro						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/vaadin-anwendungsentwicklung-61111" rel="bookmark">
						<div class="image">
															<img width="130" height="130" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 130px) 100vw, 130px" />													</div>
						<div class="title">
							Anwendungsentwicklung mit Vaadin						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/vaadin-docker-junit-5-60792" rel="bookmark">
						<div class="image">
															<img width="130" height="130" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 130px) 100vw, 130px" />													</div>
						<div class="title">
							Testen mit Docker und jUnit5						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

															<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
													
<div class="comment-form-wrapper">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Schreibe einen Kommentar <small><a rel="nofollow" id="cancel-comment-reply-link" href="/vaadin-ui-elemente-62931#respond" style="display:none;">Antworten abbrechen</a></small></h3>			<form action="https://jaxenter.de/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Deine E-Mail-Adresse wird nicht veröffentlicht.</span></p><p class="comment-form-comment"><label for="comment">Kommentar</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">E-Mail</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Kommentar abschicken" /> <input type='hidden' name='comment_post_ID' value='62931' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="bcfc0f3aa5" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="71"/></p>			</form>
			</div><!-- #respond -->
	</div>

											</div>
									</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
					<div id="text-16" class="widget widget_text">			<div class="textwidget"><iframe src="https://jax.de/session-qualification/wp-sidebar-feed-featured-box-jax/?layout=sidebarfeed"" width="350" height="800" style="margin:0px; padding:0px; overflow:hidden; border:none;" scrolling="no"> </iframe></div>
		</div><div id="polls-widget-3" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-28" class="wp-polls">
	<form id="polls_form_28" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_28_nonce" name="wp-polls-nonce" value="e49a78a037" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="28" /></p>
		<p><strong>Ist EE4J ein guter Name für Java EE?</strong></p><div id="polls-28-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-223" name="poll_28" value="223" /> <label for="poll-answer-223">Ja</label></li>
		<li><input type="radio" id="poll-answer-224" name="poll_28" value="224" /> <label for="poll-answer-224">Nein</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(28);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-28-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="aktuelle_magazine-4" class="widget widget_aktuelle_magazine"><p class="widget-title">Aktuelle Magazine</p><div class="aktuelle-ausgaben-wrapper"><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/java-magazin"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-11-17_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/java-magazin">Java Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/java-magazin" class="button">Alle Infos</a></a></div></div></div><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/business-technology"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/08/BT_Magazin_3_17_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/business-technology">Business Technology Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/business-technology" class="button">Alle Infos</a></a></div></div></div><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/eclipse-magazin"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2016/03/ECM-Magazin-3-16_Cover_595x842-e1471272115384.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/eclipse-magazin" class="button">Alle Infos</a></a></div></div></div></div></div><div id="tag-widget-2" class="widget TagWidget"><a href="https://jaxenter.de/tag/kolumne"><p class="widget-title">Kolumnen</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Backend meets Frontend Kolumne Vaadin" id="posts-by-tag-item-62931"><a class="thumb" href="https://jaxenter.de/vaadin-ui-elemente-62931" title="UI-Elemente leichtgewichtig entwickeln"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/vaadin-ui-elemente-62931">UI-Elemente leichtgewichtig entwickeln</a></li><li class="posts-by-tag-item Android Kolumne Mobile Planet Android Security" id="posts-by-tag-item-62623"><a class="thumb" href="https://jaxenter.de/planet-android-google-pixel-62623" title="Planet Android: Die Stars der Google Keynote, Security und Bill Gates&#8216; Smartphone"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/jaxenter_Kolumne_Android_33421_v2-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/planet-android-google-pixel-62623">Planet Android: Die Stars der Google Keynote, Security und Bill Gates' Smartphone</a></li><li class="posts-by-tag-item Checkpoint Java Java Java 9 Kolumne" id="posts-by-tag-item-62771"><a class="thumb" href="https://jaxenter.de/checkpoint-java-observer-pattern-62771" title="Checkpoint Java: Die ersten reaktiven Schritte mit dem Observer Pattern"  ><img width="150" height="121" src="https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-150x121.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-150x121.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-300x242.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-200x161.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-170x137.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-99x80.jpg 99w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-161x130.jpg 161w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-180x145.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/checkpoint-java-observer-pattern-62771">Checkpoint Java: Die ersten reaktiven Schritte mit dem Observer Pattern</a></li><li class="posts-by-tag-item Diversität Karriere Kolumne Women in Tech" id="posts-by-tag-item-62704"><a class="thumb" href="https://jaxenter.de/women-in-tech-erica-langhi-62704" title="Women in Tech: In der Technik wird man zur lebenslang Lernenden"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/10/Women_in_Tech_Aufmacher_900x450_39593_Erica_Langhi.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/women-in-tech-erica-langhi-62704">Women in Tech: In der Technik wird man zur lebenslang Lernenden</a></li><li class="posts-by-tag-item Backend meets Frontend Kolumne Security Vaadin" id="posts-by-tag-item-61964"><a class="thumb" href="https://jaxenter.de/rollen-rechte-und-ihre-auswirkungen-auf-das-ui-61964" title="Rollen, Rechte und ihre Auswirkungen auf das UI"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/rollen-rechte-und-ihre-auswirkungen-auf-das-ui-61964">Rollen, Rechte und ihre Auswirkungen auf das UI</a></li></ul></div><div id="bwp_recent_comments-2" class="widget bwp-rc-widget"><p class="widget-title">Letzte Kommentare</p>
		<ul class="bwp-rc-ulist">
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Ulrich</span><span class="recent-comment-text"> Ja, wie im Vorgängerkommentar schon geschrieben, klingt es wie eine Library... EE4J kommt gleich nach Log4J... J2EE, JEE waren etablierte Abkürzungen, die auch in Stellenbeschreibungen... </span> <a href="https://jaxenter.de/quickvote-ee4j-62693#comment-180010" title="Comment on Neues Quickvote: Ist EE4J ein guter Name für Java EE?"><strong>Neues Quickvote: Ist EE4J ein guter Name für Java EE?</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">TestP</span><span class="recent-comment-text"> Hi, also ich finde den Namen nicht gut. EE4J klingt wie irgendeine kleine 08/15-Bibliothek, die man halt so einbindet. Wird dem Riesenframework irgendwo nicht gerecht.... </span> <a href="https://jaxenter.de/quickvote-ee4j-62693#comment-180007" title="Comment on Neues Quickvote: Ist EE4J ein guter Name für Java EE?"><strong>Neues Quickvote: Ist EE4J ein guter Name für Java EE?</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Jens</span><span class="recent-comment-text"> Was ist in der Besprechung mit Selektionen gemeint? Ich habe nicht alles bis ins Details gelesen, aber die Kritik erscheint mir ob der Intensität, mit... </span> <a href="https://jaxenter.de/buchtipp-refactoring-javascript-61601#comment-179828" title="Comment on Buchtipp: Refactoring JavaScript"><strong>Buchtipp: Refactoring JavaScript</strong></a></span></li>
		</ul>
</div><div id="featured_posts-2" class="widget widget_featured_posts"><p class="widget-title">Featured Posts</p><ul class="featured-posts-list"><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/java-ee-8-62568"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-180x120.jpg 180w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/java-ee-8-62568">Java EE 8: Hält es, was die lange Wartezeit versprochen hat?</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/spring-5-released-62586"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-180x120.jpg 180w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/spring-5-released-62586">Spring 5 ist da! Frühling für Enterprise Java</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/java-9-infografik-project-jigsaw-62290"><img width="114" height="80" src="https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-114x80.png" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-114x80.png 114w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-150x105.png 150w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-300x211.png 300w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-200x140.png 200w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-170x119.png 170w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-185x130.png 185w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-180x126.png 180w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic.png 500w" sizes="(max-width: 114px) 100vw, 114px" /></a></div><div class="title"><a href="https://jaxenter.de/java-9-infografik-project-jigsaw-62290">Java 9 Infografik: Project Jigsaw auf einen Blick</a></div></li></ul></div><div id="newsletter-2" class="widget widget_newsletter"><p class="widget-title">Newsletter</p><div class="newsletter"><p class="newsletter-icon pull-left"><a href="https://jaxenter.de/newsletter"><img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter.jpg" alt="Newsletter" /></a></p><p class="newsletter-info"><a href="https://jaxenter.de/newsletter">Alle Neuigkeiten die wichtig sind, mit dem JAXenter Newsletter!</a></p><p><a href="https://jaxenter.de/newsletter">Jetzt bestellen!</a></p></div></div><div id="text-4" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD1_Wordpress -->
<div id='div-gpt-ad-1423038811881-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-0'); });
</script>
</div></div>
		</div><div id="tag-widget-7" class="widget TagWidget"><a href="https://jaxenter.de/tag/Docker"><p class="widget-title">Dossier Docker</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Container Docker Java 9 Programmiersprachen" id="posts-by-tag-item-62786"><a class="thumb" href="https://jaxenter.de/java-9-docker-top-10-september-62786" title="Java 9, Docker &#038; der Todeszeitpunkt von Programmiersprachen – Top 10 der populärsten JAXenter-Stories"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/10/shutterstock_561583474.jpg 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/java-9-docker-top-10-september-62786">Java 9, Docker & der Todeszeitpunkt von Programmiersprachen – Top 10 der populärsten JAXenter-Stories</a></li><li class="posts-by-tag-item Buchtipp Container Docker" id="posts-by-tag-item-62465"><a class="thumb" href="https://jaxenter.de/docker-praxiseinstieg-62465" title="Buchtipp: Docker Praxiseinstieg"  ><img width="106" height="150" src="https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker-106x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker-213x300.jpg 213w, https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker-200x282.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker-170x240.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker-180x254.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/09/mitp_docker.jpg 567w" sizes="(max-width: 106px) 100vw, 106px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/docker-praxiseinstieg-62465">Buchtipp: Docker Praxiseinstieg</a></li><li class="posts-by-tag-item Docker Linux Tutorial" id="posts-by-tag-item-62049"><a class="thumb" href="https://jaxenter.de/docker-einfuehrung-linux-basics-62049" title="Einführung: Was Sie über Docker wissen müssen"  ><img width="150" height="92" src="https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-150x92.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-150x92.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-300x185.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-200x123.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-170x105.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-120x74.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-190x117.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-180x111.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung.jpg 650w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/docker-einfuehrung-linux-basics-62049">Einführung: Was Sie über Docker wissen müssen</a></li><li class="posts-by-tag-item Container Docker" id="posts-by-tag-item-61779"><a class="thumb" href="https://jaxenter.de/docker-virtuelle-maschine-61779" title="Docker vs. Virtuelle Maschine: Wo liegen die Unterschiede?"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="© Shutterstock / Julia Waller" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-300x300.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-768x768.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps.jpg 800w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/docker-virtuelle-maschine-61779">Docker vs. Virtuelle Maschine: Wo liegen die Unterschiede?</a></li></ul></div><div id="text-5" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD2_Wordpress -->
<div id='div-gpt-ad-1423038811881-1' style='width:300px; height:250px; clear:both;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-1'); });
</script>
</div></div>
		</div><div id="text-6" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD3_Wordpress -->
<div id='div-gpt-ad-1423038811881-2' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-2'); });
</script>
</div></div>
		</div><div id="text-15" class="widget widget_text">			<div class="textwidget"></div>
		</div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-4'); });
        </script>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-5'); });
        </script>
        </div>
    </div>
</div>				</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="/magazine/business-technology">Business Technology Magazin</a></li>
<li id="menu-item-38592" class="menu-item menu-item-type-post_type menu-item-object-magazin menu-item-38592"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="http://sharepoint-kompendium.de">SharePoint Kompendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13255"><a href="https://finance.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX Finance (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://btdays.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Business Technology Days</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="http://bigdatacon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BigData Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://webtechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">WebTech Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="http://entwickler-akademie.de">Entwickler Akademie</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-563H99" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-563H99');</script>
<!-- End Google Tag Manager -->

		
		<!-- Facebook Ads Pixel Code -->
		<script>
			(function() {
				var _fbq = window._fbq || (window._fbq = []);
				if (!_fbq.loaded) {
					var fbds = document.createElement('script');
					fbds.async = true;
					fbds.src = '//connect.facebook.net/en_US/fbds.js';
					var s = document.getElementsByTagName('script')[0];
					s.parentNode.insertBefore(fbds, s);
					_fbq.loaded = true;
				}
				_fbq.push(['addPixelId', '407071789447604']);
			})();
			window._fbq = window._fbq || [];
			window._fbq.push(['track', 'PixelInitialized', {}]);
		</script>
		<noscript>
			<img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=407071789447604&ev=PixelInitialized" />
		</noscript>

		<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		//document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		
		document.getElementById("syntaxhighlighteranchor").parentNode.insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		//document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
		
		document.getElementById("syntaxhighlighteranchor").parentNode.insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.7.5' type='text/css' media='all' />
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
	</body>
</html>
