<!DOCTYPE html>
<html lang="de-DE" prefix="og: http://ogp.me/ns#"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>Praxis-Check Software-Architektur: Conway’s Law auf der Spur</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>	
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
		
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Erfahrene Software-Architekten erklären, warum Conway’s Law im Kontext von Domain-driven Design und Microservices relevanter ist denn je."/>
<meta name="robots" content="noodp"/>
<meta name="keywords" content="Architektur,Interview"/>
<link rel="canonical" href="https://jaxenter.de/software-architektur-conways-law-60617" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Praxis-Check Software-Architektur: Conway’s Law auf der Spur" />
<meta property="og:description" content="Erfahrene Software-Architekten erklären, warum Conway’s Law im Kontext von Domain-driven Design und Microservices relevanter ist denn je." />
<meta property="og:url" content="https://jaxenter.de/software-architektur-conways-law-60617" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="Architektur" />
<meta property="article:tag" content="Interview" />
<meta property="article:section" content="Artikel" />
<meta property="article:published_time" content="2017-08-14T13:51:37+00:00" />
<meta property="article:modified_time" content="2017-08-15T08:26:41+00:00" />
<meta property="og:updated_time" content="2017-08-15T08:26:41+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2017/08/conways-law.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="668" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; Praxis-Check Software-Architektur: Conway’s Law auf der Spur Kommentar-Feed" href="https://jaxenter.de/software-architektur-conways-law-60617/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.13 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-18197167-38', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.5" />
<link rel='shortlink' href='https://jaxenter.de/?p=60617' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fsoftware-architektur-conways-law-60617" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fsoftware-architektur-conways-law-60617&#038;format=xml" />
	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>

		        
        <script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + 
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		
		<script type='text/javascript'>
		googletag.cmd.push(function() {
		googletag.defineSlot('/21339274/jaxenter.de_contentAD1_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD2_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-1').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD3_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-2').addService(googletag.pubads());		
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper1_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-4').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper2_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-5').addService(googletag.pubads());
		googletag.pubads().collapseEmptyDivs(true);
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();				
		});
		</script>
        
        <script>
  		googletag.cmd.push(function() {
  		googletag.defineSlot('/21339274/jaxenter.de_leaderboard_Wordpress', [728, 90], 'div-gpt-ad-1423038811881-3')
		.addService(googletag.pubads())    
		.setCollapseEmptyDiv();
		  });
		</script>

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>	
		
		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->
		
	</head>
	<body class="post-template-default single single-post postid-60617 single-format-standard">
		
        <header>    
        <div class="topbanner hidden-xs hidden-sm">
        	<div class="container">
					<!-- jaxenter.de_leaderboard_Wordpress -->
                    <div id='div-gpt-ad-1423038811881-3' style='width:100%; min-height:90px; margin:10px 0;'>
                    <script type='text/javascript'>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-3'); });
                    </script>
                    </div>
            </div>
         </div> 
        	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://jaxenter.de/events">Events</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://jaxenter.de/magazine">Java Magazin</a></li>
<li id="menu-item-39337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39337"><a href="https://jax.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=menu">W-JAX 2017</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/docker">Docker</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16647" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16647"><a href="https://jaxenter.de/tag/internet-of-things">Internet of Things</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/maschinelles-lernen">Machine Learning</a></li>
</ul>		</div>
	</div>
 
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">Die Liebe zum Coden:</span>
                                        
                                    <a href="https://jaxenter.de/wie-die-liebe-zu-code-begann-59693">Wie begann eure Love Story?</a>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>
		
		                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/W-JAX-Logo-blau-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=StartseiteFeature&amp;utm_campaign=Headerleiste">W-JAX 2017: Die Konferenz für Java, Architektur- und Software-Innovation</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/angular-4-update-55042">Angular 4: Diese Features müssen Sie kennen</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/Spring-Boot-Tutorial-1-300x300-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/spring-boot-tutorial-54020">Spring Boot Tutorial: So entwickelt man REST-Services mit Spring Boot</a></p>
<p>&nbsp;</p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			

          </div>
		</header>

	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Wie man Conway’s Law begegnet</div>
														<h1 class="title">Praxis-Check Software-Architektur: Conway’s Law auf der Spur</h1>
						
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2017-08-14T13:51">14. August 2017</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Hartmut Schlosser										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="200" src="https://jaxenter.de/wp-content/uploads/2017/08/conways-law.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/conways-law.jpg 1000w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-768x513.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-200x134.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-180x120.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"><p>©</p>
</div>
								</div>
														
															<div class="excerpt">
									<p>In Diskussionen um zeitgemäße Software-Architektur darf das Gesetz von Conway nicht fehlen: Die Struktur einer Software hängt von der Organisationsstruktur des Unternehmens ab. Doch was bedeutet diese Beobachtung für die Praxis der Software-Entwicklung? Erfahrene Software-Architekten erklären, warum Conway’s Law im Kontext von Domain-driven Design und Microservices relevanter ist denn je.</p>
								</div>
													</div>
					
					
					
					<div class="text">
						<h2>Praxis-Check Software-Architektur</h2>
<p>Melvin E. Conway hat 1968 die Beobachtung angestellt, dass das Design von Systemen Kopien der Kommunikationsstrukturen der Unternehmen darstellen, die diese Systeme entwickeln. Was bedeutet das konkret für  Software-Architekten?</p>
<div id="related-box" class="boxed" style="float: right; width: 280px; margin: 0px 0px 0px 10px; text-align: center;">
<p><strong>HINTERGRUND ZUM THEMA </strong></p>
<p><a href="https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600.jpg"><img class="wp-image-60658 aligncenter" src="https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600.jpg" alt="" width="150" height="100" srcset="https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600.jpg 600w, https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/BT-Magazin-4-15_Aufmacher_Toth_SS_Media_iStock_artishokcs_900x600-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></p>
<p class="title"><a href="https://jaxenter.de/conway-2-0-wie-architekturstile-agile-zusammenarbeit-foerdern-oder-behindern-32175"><strong>Conway 2.0: Wie Architekturstile agile Zusammenarbeit fördern oder behindern</strong></a></p>
</div>
<p>Hängen Software-Architekten in ihrer Arbeit davon ab, wie ein Unternehmen mit den Kunden kommuniziert, wie sich die Abteilungen des Unternehmens untereinander austauschen, wie die IT intern aufgebaut ist, wie die Mitglieder der einzelnen Team miteinander reden und zusammenarbeiten?</p>
<p><em>Wir haben mit sieben Software-Architekten über die Erscheinungsformen und Auswirkungen von Conways Gesetz gesprochen. Im ersten Teil dieser Reihe verraten sie uns, wo ihnen Conway&#8217;s Law bereits begegnet ist und wie man festgefahrene Unternehmensstrukturen, die sich negativ auf Software-Architekturen auswirken, aufbrechen kann.</em></p>
<h2>Conway&#8217;s Law in der Praxis</h2>
<div class="boxed" style="width: 175px; float: left; margin: 0 15px 0 0;">
<p><strong>Die Experten</strong></p>
<div id="attachment_60629" style="width: 160px" class="wp-caption alignleft"><a href="https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal.jpg"><img class="wp-image-60629 size-thumbnail" src="https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal-150x105.jpg" alt="" width="150" height="105" srcset="https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/carola-lilienthal.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><p class="wp-caption-text">Dr. Carola Lilienthal ist CEO bei der WPS – Workplace Solutions GmbH. Seit 2003 analysiert sie die Zukunftsfähigkeit von Softwarearchitekturen und wendet in ihren eigenen Projekten DDD an.</p></div>
<div id="attachment_60630" style="width: 160px" class="wp-caption alignleft"><a href="https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller.jpg"><img class="wp-image-60630 size-thumbnail" src="https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller-150x105.jpg" alt="" width="150" height="105" srcset="https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/ralf-d-mueller.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><p class="wp-caption-text">Ralf D. Müller arbeitet als Architekt und Entwickler und erlebt täglich die Notwendigkeit effektiver Dokumentation. Er ist erklärter AsciiDoc-Fan und Committer bei arc42 sowie Gründer des docToolchain Projektes.</p></div>
<div id="attachment_60631" style="width: 160px" class="wp-caption alignleft"><a href="https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov.jpg"><img class="wp-image-60631 size-thumbnail" src="https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov-150x105.jpg" alt="" width="150" height="105" srcset="https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/stefan-tilkov.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><p class="wp-caption-text">Stefan Tilkov ist Geschäftsführer und Principal Consultant bei der innoQ Deutschland GmbH, wo er sich vorwiegend mit der strategischen Beratung von Kunden im Umfeld von Softwarearchitekturen beschäftigt.</p></div>
<div id="attachment_60632" style="width: 160px" class="wp-caption alignleft"><a href="https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke.jpg"><img class="wp-image-60632 size-thumbnail" src="https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke-150x105.jpg" alt="" width="150" height="105" srcset="https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/gernot-starke.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><p class="wp-caption-text">Dr. Gernot Starke (innoQ Fellow), ist Gründer und Maintainer der Open-Source-Architekturprojekte arc42 und aim42, (Mit-)Gründer und aktives Mitglied des iSAQB sowie Autor mehrerer Fachbücher.</p></div>
<div id="attachment_60633" style="width: 160px" class="wp-caption alignleft"><a href="https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp.jpg"><img class="wp-image-60633 size-thumbnail" src="https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp-150x105.jpg" alt="" width="150" height="105" srcset="https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><p class="wp-caption-text">Lars Röwekamp, Gründer des IT-Beratungs- und Entwicklungsunternehmens OPEN KNOWLEDGE GmbH, beschäftigt sich im Rahmen seiner Tätigkeit als „CIO New Technologies“ mit der eingehenden Analyse und Bewertung neuer Software- und Technologietrends.</p></div>
<div id="attachment_60635" style="width: 160px" class="wp-caption alignleft"><a href="https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff.jpg"><img class="wp-image-60635 size-thumbnail" src="https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff-150x105.jpg" alt="" width="150" height="105" srcset="https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/eberhard-wolff.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><p class="wp-caption-text">Eberhard Wolff ist Fellow bei innoQ und arbeitet seit mehr als fünfzehn Jahren als Architekt und Berater, oft an der Schnittstelle zwischen Business und Technologie.</p></div>
<div id="attachment_52138" style="width: 160px" class="wp-caption alignleft"><a href="https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt.jpg"><img class="wp-image-52138 size-thumbnail" src="https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt-150x105.jpg" alt="" width="150" height="105" srcset="https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/01/Matthias_Bohlen_bunt-180x126.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><p class="wp-caption-text">Matthias Bohlen ist Softwarearchitekt und Mitglied des iSAQB. Mit seinen Coaching-Programmen hilft er Führungskräften und Teams dabei, profitable Produkte zur Tür hinaus zu bekommen, ohne dabei den Verstand zu verlieren.</p></div>
</div>
<p><strong>Ein Beispiel aus deiner Praxis: Wo wurde dir Conway&#8217;s Law ganz deutlich vor Augen geführt?</strong></p>
<blockquote style="float: right; width: 250px; margin: 0 0 0 10px; font-family: Lora; font-size: 24px;"><p>An den Schnittstellen traten häufig Missverständnisse auf.</p></blockquote>
<p><strong>Carola Lilienthal</strong>: Bei einem Kunden von uns waren die Teams nach Programmiersprachen geschnitten, so dass ein Team für die C#-Clients, ein Team für die Java-Server-Komponenten und ein Team für das PLSQL in den Datenbanken zuständig war. Diese Aufteilung führte dazu, dass die fachlichen Begriffe in den einzelnen sprachlichen Teilen und auch Teams nicht einheitlich verwendet wurden und so an den Schnittstellen häufig Missverständnisse auftraten. Kunden, die verschiedene Clients benutzten, hatten ein einheitliches Frontend, aber die Abstimmung zwischen den Programmiersprachenteams kostete viel Zeit und führte immer wieder zu Hacks, damit die Teile zusammen passen.</p>
<p>Schließlich hat der Kunde auf Feature-Teams umgestellt, in denen jeweils Team-Mitglieder mit unterschiedlichen Programmiersprachenkenntnissen an einem Feature zusammen arbeiten. In der darauffolgenden Zeit wurde die fachliche Struktur der Software viel klarer. Es wurde allmählich möglich, fachlich geschnittene Microservices mit ihrem eigenen Datenbankschema und ihrem eigenen Client-Code zu separieren. Je länger die Teams so arbeiteten, desto eher kam es nun vor, dass die Oberfläche an Einheitlichkeit verlor. Jedes Team machte seine eigenen Oberflächen unabhängig von den anderen Teams.</p>
<p>Schließlich wurde ein kleines Team eingeführt, das dafür zuständig ist, auf die Einheitlichkeit der Oberfläche zu achten.</p>
<p><strong>Ralf D. Müller</strong>: Die Auswirkungen von Conway&#8217;s Law sehe ich persönlich bei Web-Projekten vor allem direkt in den Projektteams, weniger in der Organisation, in die das Projektteam eingebettet ist. So macht es z.B. einen großen Unterschied, ob man in einem Web-Projekt reine “Full-Stack”-Developer einplant oder die Umsetzung auf Backend- und Frontend-Entwickler verteilt. Die entstehenden Softwarestrukturen unterscheiden sich nicht nur im Schnitt, sondern auch in der Komplexität. Dies macht sich aus meiner Sicht gerade bei modernen Frontend-Frameworks wie Angular oder React stark bemerkbar.</p>
<p>Aber auch der vertikale Schnitt durch die Aufteilung eines Projekts auf mehrere agile Teams hat einen entsprechend großen Einfluss auf das Ergebnis.</p>
<p style="text-align: center;"><strong>Lesen Sie auch: <a href="https://jaxenter.de/software-architektur-trends-2017-54479">Das sind die Software-Architektur-Trends 2017</a></strong></p>
<p><strong>Stefan Tilkov:</strong> Das vielleicht offensichtlichste Beispiel sind die vielen Web- und E-Commerce-Systeme, die oft durch eine Initiative einer Marketing-Abteilung entstanden sind und oft auch dort betreut wurden, während sich die restlichen Fachabteilungen mit der IT-Abteilung abstimmt, von ihr betreut wird oder sich mit ihr auseinandersetzt. In der Gesamtarchitektur spiegelt sich das dann auf einmal in einer Vielzahl wenig sinnvoller Redundanzen wider, die im Moment in vielen Unternehmen gerade aufgelöst werden.</p>
<p>Doch man findet die Effekte von Conway’s Law auch bei den vielen Querschnittsabteilungen, die sich verselbständigen und Systeme betreuen, die dann in einer Architektur als Fremdkörper auftauchen. Das können zentrale Datenbanken, monolithische Systeme oder Integrationsserver sein, die von einer Organisationseinheit regelrecht bewacht werden, sodass die Prozesse unglaublich aufwändig werden und jede Änderung mit massiven Schmerzen verbunden ist.</p>
<p>Aber auch wenn fast alles richtig gelaufen ist, bekommt man manchmal durch Unachtsamkeit frische Conway-Effekte: Es gab bei der Neuentwicklung eines großen Shopsystems eine schöne <a href="http://scs-architecture.org">SCS-artige Architektur</a> [1], bei der knapp zehn Teams hervorragend parallel arbeiten konnten, da die von ihnen realisierten Teilsysteme über wenige, standardisierte Schnittstellen miteinander kommunizierten, mit Hilfe von Redundanz auf Autonomie geachtet wurde, jedes Team volle Verantwortung für alle Schichten von Persistenz bis UI hatte – eigentlich eine wunderbare Struktur, bei der Architektur und Organisation aufeinander abgestimmt waren. Aber dann gab es die Initiative, für die Auslieferung von Frontend-Komponenten und -Assets ein zentrales Team aufzusetzen.</p>
<p>Das hat – wie jede Form der Zentralisierung – durchaus Vorteile, man muss z.B. alles nur an einer Stelle lösen. Es hat aber auch massive Nachteile – in diesem Fall konkret, dass das neu eingeführte zentrale Frontend-Team zum Bottleneck für alle anderen wurde. Die Architektur veränderte sich, mit allen Nachteilen, weil die Organisation sich im Zweifelsfall durchsetzt.</p>
<p><strong>Gernot Starke: </strong>Darf ich voranstellen, dass ich &#8222;Conway’s Law“ für eine totale Fehlbenennung halte: Es sollte &#8222;Conway’s Observation&#8220; heißen &#8211; weil es weder ein Gesetz noch eine eiserne Regel ist, sondern eine (empirische) Beobachtung.</p>
<p>Als Softwarearchitekten arbeiten wir häufig in einem Unternehmenskontext, bei dem wir auf organisatorische Randbedingungen meistens Rücksicht nehmen müssen, und selten einmal &#8222;organizational change&#8220; anstoßen können, um diese Randbedingungen für unsere Entwicklung zu lockern. Meistens hingegen liegen organisatorische Änderungen außerhalb der uns zugestandenen Kompetenzen &#8211; und wir müssen mit der bestehenden Organisation leben.</p>
<blockquote style="float: right; width: 250px; margin: 0 0 0 10px; font-family: Lora; font-size: 24px;"><p>Ich müsste eher überlegen, bei welchen meiner Projekte die interne Organisation <em>keine</em> Auswirkungen auf die Softwarestruktur hatte.</p></blockquote>
<p>Zu der eigentlichen Frage, wo mir Conway bereits begegnet ist: Ich müsste eher überlegen, bei welchen meiner Kunden bzw. Projekte die interne Organisation <em>keine</em> Auswirkungen auf die Softwarestruktur hatte. Conway hat bei mir beispielsweise im Maschinenbau zugeschlagen:</p>
<p>Diverse Komponenten von Großmaschinen wurden von verschiedenen Ingenieurteams entwickelt, mit jeweils ziemlich speziellen Anforderungen. Die Software für die Rüstung dieser Maschinen war in komplett anderer Technologie entwickelt, genauso wie die Software zur Überwachung/Monitoring zur Laufzeit. Das hat Synergien gründlich verhindert 🙁</p>
<p>Ein zweites Beispiel stammt von Versicherungen: Dort habe ich Datenbankteams angetroffen, die losgelöst von den sogenannten Client/Server-Teams gearbeitet haben. Dann brauchte es noch eine dritte Gruppe, die Integrations-Leute, die C/S und DB zu den berüchtigten Deployment-Monolithen zusammengebracht haben.</p>
<p><strong>Lars Röwekamp: </strong>Es ist für mich immer wieder faszinierend, feststellen zu „dürfen“, wie aktuell dieses vor fast 50 Jahren aufgestellte Gesetz heute noch ist. Wir als open knowledge sind häufig bei großen Kunden mit klassischen Konzernstrukturen im Einsatz. Die dort vorherrschenden, sehr komplexen Organisations- und Kommunikationsstrukturen sorgen nicht selten dafür, dass von speziellen Architektur-Teams extrem umfangreiche und hoch generische, konzernweite Architekturen vorgegeben werden.</p>
<blockquote style="float: right; width: 250px; margin: 0 0 0 10px; font-family: Lora; font-size: 24px;"><p>Es ist faszinierend, wie aktuell dieses vor fast 50 Jahren aufgestellte Gesetz heute noch ist.</p></blockquote>
<p>Die eigentlichen Anwendungen bzw. deren konkrete Fachlichkeiten werden dann via architekturspezifischer DSLs, XML-Konfigurationen oder irgendeinem anderen Voodoo-Ansatz auf mystische Art und Weise generiert. Was ursprünglich einmal gut gemeint war, führt in der Regel dazu, das selbst kleinste Features &#8211; dank Medienbruch &#8211; nur sehr umständlich umzusetzen sind und ein fachliches Debugging kaum noch möglich ist.</p>
<p>Als ich bei einem unserer größeren Kunden einmal Conway’s Law thematisiert habe, hat dieser das aktuelle Organisationsdiagramm und ein Schaubild der „gelebten“ Architektur gegenüber gestellt. Beide Schaubilder sahen sich erschreckend ähnlich und erinnerten eher an den U-Bahn-Fahrplan einer europäischen Großstadt als an ein strukturiertes und gut durchdachtes System.</p>
<p><strong>Eberhard Wolff: </strong>Für mich ist das Gesetz von Conway ein wichtiges Werkzeug, um zu verstehen, was in Projekten vor sich geht. Wenn unterschiedliche Dienstleister für die verschiedenen Teile des Projekts verantwortlich sind, dann beeinflusst das die Kommunikation und die Architektur.</p>
<p>Kommunikation über Firmengrenzen hinweg ist aufwändig, insbesondere wenn die Teams am jeweiligen Firmenstandort des Dienstleisters arbeiten. So entstehen sehr isolierte Module. Ein Zusammenhalt der Architektur ist schwierig.</p>
<p>Dass Teams, die nach Fachlichkeiten aufgestellt sind, die Architektur beeinflussen, haben wir schon vor 15 Jahren in einem Projekt festgestellt. Allerdings haben wir es damals noch nicht zur Steuerung der Architektur genutzt.</p>
<p><strong>Matthias Bohlen: </strong>Bei einem Kunden mit drei Entwicklungsteams wurde ich beauftragt, die Teams zu coachen, damit diese an der Architektur absichtlich und transparent arbeiten<strong> &#8211; </strong>nicht wie vorher auf Zuruf und bei absoluter Notwendigkeit, sondern mit der Absicht, Architekturarbeit als ganz normalen Bestandteil der täglichen Entwicklungsarbeit zu sehen. Es drehte sich um Medizintechnik.</p>
<p>Als ich mit den drei Teams in eine Bestandsaufnahme der Ist-Architektur ging, wurde schnell klar, dass Conway&#8217;s Law wirksam war: Das System war in drei Zuständigkeiten aufgeteilt: Team 1 machte Embedded<strong>&#8211;</strong>Systeme, direkt an die Hardware angeschlossen. Team 2 machte die Management-Systeme zur Verwaltung der User und Geräte, und Team 3 kümmerte sich um High<strong>&#8211;</strong>Speed-Netzwerktechnik, die zur Verbindung all dieser Geräte und der User diente. Die Kommunikationsgrenzen zwischen den Teams waren deutlich spürbar: Jedes Team löste seine Probleme selbst, teilweise redundant zu dem, was die anderen machten. Es gab jeden Frameworktyp (z.B. Loggingframework) jeweils in drei Geschmacksrichtungen.</p>
<p>Wo die Teams in Probleme gerieten, war folgende Stelle: Sie hatten das System in drei Aspekte aufgeteilt, die jedoch eng gekoppelt waren. Die High-Speed-Netzwerke konnte man nicht ohne die Embedded-Systeme betrachten, die Management-Systeme mussten wissen, wie viele Embedded-Geräte es gab und wie die Netzwerktopologie gestaltet war. So kam es, dass die Teams langsam wurden, weil sie trotz Teamgrenzen häufig etwas absprechen mussten.</p>
<p>Es wäre deutlich besser gewesen, sie hätten das System in klare Subsysteme geteilt, die wirklich unabhängig oder nur wenig abhängig sind, dann hätten sie deutlich schneller und entspannter arbeiten können.</p>
<div class='widgets_on_page'> <div id="wysiwyg_widgets_widget-12" class="widget widget_wysiwyg_widgets_widget"><!-- Widget by WYSIWYG Widgets v2.3.6 - https://wordpress.org/plugins/wysiwyg-widgets/ --><div style="width: 100%;padding: 0 0px 0 0px;background-color: #fff;border: 0px solid #DDDDDD">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important;padding: 0">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"><img style="width: 100%;height: auto" src="/wp-content/uploads/2017/06/WJAX_2017_Contentbox_2126x162_41560_v1.jpg" alt="W-JAX" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0"><img class="" style="width: 100%;height: auto" src="/wp-content/uploads/2017/06/WJAX_2017_Speakerbox_550x214_41560_v1.jpg" alt="W-JAX" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c;padding: 0"></div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c;padding: 0">
<div class="col-xs-1" style="padding: 5px 0"><img style="max-width: 100%;height: auto;border: 1px solid #fff" src="https://jax.de/wp-content/uploads/2017/05/Mike-Wiesner.jpg" alt="Mike Wiesner" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important;padding: 0px !important"><a href="https://jax.de/big-data-machine-learning/data-event-driven-microservices-mit-apache-kafka/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://jax.de/big-data-machine-learning/data-event-driven-microservices-mit-apache-kafka/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Data- und Event-driven Microservices mit Apache Kafka');" style="color: #264186;font-size: 19px;font-weight: 600">Data- und Event-driven Microservices mit Apache Kafka</a></h3>
<p style="margin: 0px 0 5px;color: #000">mit Mike Wiesner (MHP &#8211; A Porsche Company)</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="padding: 0">
<div class="col-xs-1" style="padding: 5px 0"><img style="border: 1px solid #fff;max-width: 100%;height: auto" src="https://jax.de/wp-content/uploads/2017/05/Uwe-Friedrichsen.jpg" alt="Niko Köbler" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important;padding: 0px !important"><a href="https://jax.de/software-architecture/digitization-solutions-a-new-breed-of-software/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://jax.de/software-architecture/digitization-solutions-a-new-breed-of-software/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Digitization Solutions – a new Breed of Software');" style="color: #264186;font-size: 19px;font-weight: 600">Digitization Solutions – a new Breed of Software</a></h3>
<p style="margin: 0px 0 5px;color: #000">with Uwe Friedrichsen (codecentric AG)</p>
</div>
</div>
</div>
</div>
</div>
</div>
<div style="width: 100%;padding: 0 0px 0 0px;background-color: #fff;border: 0px solid #DDDDDD">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important;padding: 0">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0"><a href="https://software-architecture-summit.de/"><img style="width: 100%;height: auto" src="https://jaxenter.de/wp-content/uploads/2017/06/SAS_Herbst_2017_WidgetHeader_2126x162_40669_v1.jpg" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0"><a href="https://software-architecture-summit.de/"><img class="" style="width: 100%;height: auto" src="https://jaxenter.de/wp-content/uploads/2017/06/SAS_Herbst_2017_WidgetHeader_550x214_40669_v1.jpg" alt="Software Architecture Summit 2017" /></a></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c;padding: 0">
<h3 style="margin: 12px 0;font-size: 19px !important;font-weight: 700 !important;padding: 5px 0 12px 0 !important"><span style="color: #00528c"><a href="https://software-architecture-summit.de/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://software-architecture-summit.de/', '10 Power Workshops  |  4 spannende Keynotes  |  12 Top-Trainer');" style="color: #00528c">10 Power Workshops  |  4 spannende Keynotes  |  12 Top-Trainer</a></span></h3>
</div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c;padding: 0">
<div class="col-xs-1" style="padding: 5px 0"><img style="max-width: 100%;height: auto;border: 1px solid #fff" src="https://jaxenter.de/wp-content/uploads/2017/06/Dr.-Carola-Lilienthal-1.jpg" alt="Dr. Carola Lilienthal" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important;padding: 0px !important"><span style="color: #ec6707"><a href="https://software-architecture-summit.de/softwarearchitektur/the-core-of-domain-driven-design/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://software-architecture-summit.de/softwarearchitektur/the-core-of-domain-driven-design/', 'The Core of Domain-Driven Design');" style="color: #ec6707;font-size: 19px;font-weight: 600">The Core of Domain-Driven Design</a></span></h3>
<p style="margin: 0px 0 5px;color: #000">mit Dr. Carola Lilienthal (Workplace Solutions)</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="padding: 0">
<div class="col-xs-1" style="padding: 5px 0"><img style="border: 1px solid #fff;max-width: 100%;height: auto" src="https://jaxenter.de/wp-content/uploads/2017/06/Sascha-Möllering.jpg" alt="Sascha Möllering" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important;padding: 0px !important"><span style="color: #ec6707"><a href="https://software-architecture-summit.de/softwarearchitektur/reaktive-architekturen-mit-microservices/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://software-architecture-summit.de/softwarearchitektur/reaktive-architekturen-mit-microservices/', 'Reaktive Architekturen mit Microservices');" style="color: #ec6707;font-size: 19px;font-weight: 600">Reaktive Architekturen mit Microservices</a></span></h3>
<p style="margin: 0px 0 5px;color: #000">mit Sascha Möllering (Amazon Web Services Germany)</p>
</div>
</div>
</div>
</div>
</div>
</div>
<!-- / WYSIWYG Widgets --></div>
  </div><!-- widgets_on_page -->
<h2>Wie man Conway’s Law begegnet</h2>
<p><em>Man kann Conway&#8217;s Law als strukturalistisches Prinzip verstehen – die agierenden Objekte sind abhängig von den sie umgebenden Strukturen, d.h. auch den Beziehungen der Objekte untereinander. Was bedeutet das für den agierenden Software-Architekten?</em></p>
<p><em>Er kommt in ein Unternehmen, in dem bestimmte Strukturen vorherrschen – eine Unternehmenskultur, Abteilungsgrenzen, Teams, etablierte Prozesse und inoffizielle, als selbstverständlich angenommene Gepflogenheiten. Er ist aber auch mit Menschen konfrontiert, die diese Strukturen einerseits tragen und andererseits verändern können. Wo setzt man da als Architekt an, um negative Strukturen ein Stück weit aufzubrechen?</em></p>
<h3>Welches Mittel hat sich in deiner Praxis bewährt, um den Effekten von Conway&#8217;s Law zu begegnen?</h3>
<blockquote style="float: right; width: 250px; margin: 0 0 0 10px; font-family: Lora; font-size: 24px;"><p>Das einzige Mittel, das sich in meiner Praxis bewährt hat, ist, mit Menschen direkt zu sprechen.</p></blockquote>
<p><strong>Carola Lilienthal: </strong>Das einzige Mittel, das sich in meiner Praxis bewährt hat, ist, mit Menschen direkt zu sprechen. Wenn ich in ein Unternehmen komme, um Veränderungsprozesse anzustoßen, dann gelingt mir das nur, indem ich zu den Beteiligten gehe und mit ihnen spreche. Für vorhandene Strukturen und Prozesse gibt es in jeder Organisation viele Gründe und Geschichten, die die Mitarbeiter miteinander erlebt haben und auf die sich ihr Verhalten aufbaut. Diese Geschichten muss man als Externer verstehen und würdigen, um Veränderungen in Gang setzen zu können.</p>
<p><strong>Ralf D. Müller:</strong> Wie bei so vielen Problemen in der Softwareentwicklung gibt es hier wohl nicht die “Silver Bullet”, so dass man Probleme dieser Art je nach Situation angehen muss.</p>
<p><strong>Stefan Tilkov: </strong>Am wichtigsten ist aus meiner Sicht, sich darüber klar zu werden, welchen Kampf man für den wichtigsten hält, um sich nicht an X Fronten gleichzeitig aufzureiben (wenn mir die militaristische Metapher gestattet ist). Also am besten das dringendste Problem identifizieren und sich zunächst auf dessen Lösung konzentrieren, anstatt gleich zu versuchen, alles auf einmal zu ändern. In unserer Architekturarbeit, aber auch in unseren Entwicklungsprojekten versuchen wir in aller Regel als erstes, wenige globale Regeln in Verbindung mit viel lokaler Autonomie zu etablieren. Damit beschränkt man die Entscheidungsfreiheit bestehender Strukturen und Teams zwar, aber nicht in einem zu großen Maße. Gleichzeitig schafft man die Möglichkeit, schrittweise Verbesserungen einzuführen.</p>
<p><strong>Gernot Starke: </strong>Ja, Separation-of-Concern: für organisatorische Änderungen Leute dazuholen, die das professionell und Full-time machen. Als Softwarearchitekten neben der Entwicklungsarbeit noch schnell eine Abteilung oder gar Unternehmen umorganisieren wäre aus meiner Sicht ein etwas vermessener Anspruch&#8230;</p>
<p>Einer meiner Kunden hat das beherzigt und einen Profi für „Change Management“ angeheuert &#8211; eine erfahrene, empathische und trotzdem durchsetzungsstarke Dame. Sie hatte sowohl strategisches wie politisches Verständnis, hat die Software-Teams „mitgenommen“, aber auch das Management. Diese Zusammenarbeit war für mich eine positive Erfahrung, weil sich durch ihre Arbeit in diesem Unternehmen wirklich Dinge positiv verändert haben &#8211; was viele Software-Teams in den Jahren vorher nicht annähernd geschafft hatten.</p>
<p><strong>Lars Röwekamp: </strong>Hier sprichst du ein sehr wichtiges Thema an. In vielen Unternehmen herrschen historisch bedingt Strukturen vor, die von den meisten Mitarbeitern einfach als von Gott gegeben hingenommen und somit nicht mehr hinterfragt werden. Es kommt daher nicht von ungefähr, dass sich gerade in großen Unternehmen immer wieder kleine Lab-ähnlich Teams herausbilden. Dies ist häufig die einzige Möglichkeit, legitim aus den vorgegebenen Strukturen auszubrechen. Projekte werden als Prototypen oder Proof-of-Concepts getarnt, da für diese weniger starre Auflagen gelten als für normale Software-Projekte.</p>
<p style="text-align: center;"><strong>Lesen Sie auch: <a href="https://jaxenter.de/domain-driven-design-expertencheck-45685">Domain-driven Design im Experten-Check: Warum ist DDD heute relevanter denn je?</a></strong></p>
<p>In meiner Rolle als Architekt hinterfrage ich grundsätzlich den Nutzen bestehender Strukturen, Frameworks etc. Kann mir keiner der Beteiligten einen sinnvollen Grund für das Vorhandensein nennen &#8211; „das war schon immer so“ ist übrigens KEIN sinnvoller Grund &#8211; dann stelle ich dass Konstrukt auf den Prüfstand und entsorge es gegebenenfalls.</p>
<p>Psychologisch gesehen sollte man hier natürlich mit einem gewissen Feingefühl vorgehen. Oftmals wird ein architektonisches Refactoring als eine Art Schuldeingeständnis für eine Fehlplanung der Vergangenheit interpretiert. Dies ist insbesondere dann der Fall, wenn sich spezielle Teams für die Architektur verantwortlich zeichnen und andere für die Implementierung der Anwendungen auf Basis dieser Architektur. Hier ist ein Finger-Pointing quasi vorprogrammiert. Es ist also wichtig zu vermitteln, dass Software lebt und Refactoring somit einen ganz natürlich Prozess darstellt, um auf geänderte Anforderungen bzw. einen geänderten Kontext zu reagieren.</p>
<blockquote style="float: right; width: 250px; margin: 0 0 0 10px; font-family: Lora; font-size: 24px;"><p>Software-Architektur ist nur scheinbar ein technisches Thema.</p></blockquote>
<p><strong>Eberhard Wolff: </strong>Bei der Einstellung von Mitarbeiten oder bei Umorganisationen werden Architekten oft mit einbezogen, da sie die technische Expertise der Personen am besten abschätzen können. Dann können sie auch andere organisatorische Maßnahmen vorschlagen, um die Architektur zu beeinflussen.</p>
<p>Generell ist Software-Architektur nur scheinbar ein technisches Thema. Ein Architekt muss Ideen und Kritik aus den Teams aufnehmen und die Architektur kommunizieren. Diese Maßnahmen beeinflussen die Kommunikationsstrukturen und damit die Architektur.</p>
<p><strong>Matthias Bohlen: </strong>Als erstes Transparenz herstellen. Die beteiligten Teams sind meist schon so lange im Geschäft, dass sie wegen leichter Betriebsblindheit nicht mehr in jedem Fall erkennen, wenn Architektur und Organisation nicht mehr zusammenpassen. Gerade wenn sich (wie heute) das Geschäft stark verändert, sind andere Architekturen hilfreicher als früher, um agil zu bleiben und schnell reagieren zu können. Es ist gut, wenn ein Architekt, der das erkennt, mal kurz prüft, wie es mit Conway&#8217;s Law bestellt ist und darauf aufmerksam macht. Dann können die Führungskräfte und Teams entscheiden und notwendige Veränderungen herbeiführen.</p>
<p><em>Im zweiten Teil dieser Reihe verraten die Experten, was gute Software-Architektur ausmacht und welchen Grad der Flexibilität für ein System gesund ist. Bleiben Sie dran!</em></p>
<p><strong>Hintergrund zum Thema:</strong></p>
<blockquote data-secret="8vjfwCZxOE" class="wp-embedded-content"><p><a href="https://jaxenter.de/conway-2-0-wie-architekturstile-agile-zusammenarbeit-foerdern-oder-behindern-32175">Conway 2.0: Wie Architekturstile agile Zusammenarbeit fördern oder behindern</a></p></blockquote>
<p><iframe class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://jaxenter.de/conway-2-0-wie-architekturstile-agile-zusammenarbeit-foerdern-oder-behindern-32175/embed#?secret=8vjfwCZxOE" data-secret="8vjfwCZxOE" width="500" height="282" title="&#8222;Conway 2.0: Wie Architekturstile agile Zusammenarbeit fördern oder behindern&#8220; &#8212; JAXenter" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
					</div>
					
										
					
											<div class="links-literatur">
							<div class="headline">Links & Literatur</div>
							<div class="content"><p>[1] SCS (Self-contained Systems):<a href="http://scs-architecture.org/"> http://scs-architecture.org</a></p>
</div>
						</div>
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/software-architektur-conways-law-60617" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/software-architektur-conways-law-60617" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=Praxis-Check Software-Architektur: Conway’s Law auf der Spur - https://jaxenter.de/software-architektur-conways-law-60617" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/software-architektur-conways-law-60617" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/software-architektur-conways-law-60617" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/software-architektur-conways-law-60617" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/software-architektur-conways-law-60617" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/software-architektur-conways-law-60617" data-url-old=""></span></div>
						</a>
					</div>

					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2017/01/schlosser_hartmut_sw-102x150.jpg" width="65" height="96" alt="Hartmut Schlosser" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Hartmut Schlosser</div>

																							<div class="author-description">
													Hartmut Schlosser ist Redakteur und Online-Koordinator bei Software &amp; Support Media. Seine Spezialgebiete liegen bei Java-Enterprise-Technologien, JavaFX, Eclipse und DevOps. Vor seiner Tätigkeit bei S &amp; S Media studierte er Musik, Informatik, französische Philologie und Ethnologie.												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/hartmutschlosser">Alle Beiträge von Hartmut Schlosser</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/redux-angular-javafx-57371" rel="bookmark">
						<div class="image">
															<img width="186" height="130" src="https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky-186x130.png" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky-186x130.png 186w, https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky-150x105.png 150w, https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky-300x210.png 300w, https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky-200x140.png 200w, https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky-170x119.png 170w, https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky-114x80.png 114w, https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky-180x126.png 180w, https://jaxenter.de/wp-content/uploads/2017/05/manuel-mauky.png 500w" sizes="(max-width: 186px) 100vw, 186px" />													</div>
						<div class="title">
							Redux &#038; Angular: Die Architektur-Alternative zur klassischen MVC-Variante						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/beim-uebergang-zu-microservices-geht-es-nicht-nur-um-einen-technologiewechsel-34188" rel="bookmark">
						<div class="image">
															<img width="186" height="130" src="https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger-186x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2016/02/Christian-Deger.jpg 500w" sizes="(max-width: 186px) 100vw, 186px" />													</div>
						<div class="title">
							&#8222;Beim Übergang zu Microservices geht es nicht nur um einen Technologiewechsel&#8220;						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/architekturen-bewerten-aber-wie-33941" rel="bookmark">
						<div class="image">
															<img width="186" height="130" src="https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke-186x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2016/01/Harm-Gnoyke.jpg 500w" sizes="(max-width: 186px) 100vw, 186px" />													</div>
						<div class="title">
							Architekturen bewerten – aber wie?						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

															<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
														<div class="comments">
		<ol class="comments-list">
			<li id="comment-175260" class="clearfix level-1"><div class="comment-info"><span class="comment-author">Praxis-Check Software-Architektur: Conway’s Law auf der Spur &#8211; Bizzcheck.de</span><span class="comment-date">2017-08-14 14:03:13</span></div><div class="comment-body"><p>[&#8230;] Ein Beispiel aus deiner Praxis: Wo wurde dir Conway’s Law ganz deutlich vor Augen geführt? An den Schnittstellen traten &#8230; (Orginal &#8211; Story lesen&#8230;) [&#8230;]</p>
</div></li></li><!-- #comment-## -->
<li id="comment-175264" class="clearfix level-1"><div class="comment-info"><span class="comment-author">Praxis-Check Software-Architektur: Conway&#8217;s Law auf der Spur &#8211; JAXenter &#8211; BB-10 &#8211; Aktuell</span><span class="comment-date">2017-08-14 15:05:16</span></div><div class="comment-body"><p>[&#8230;] JAXenter [&#8230;]</p>
</div></li></li><!-- #comment-## -->
<li id="comment-175279" class="clearfix level-1"><div class="comment-info"><span class="comment-author">TestP</span><span class="comment-date">2017-08-14 17:04:08</span></div><div class="comment-body"><p>Tolle Interviews, danke. :)</p>
<p>Grüße</p>
</div></li></li><!-- #comment-## -->
		</ol>
	</div>

<div class="comment-form-wrapper">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Schreibe einen Kommentar <small><a rel="nofollow" id="cancel-comment-reply-link" href="/software-architektur-conways-law-60617#respond" style="display:none;">Antworten abbrechen</a></small></h3>			<form action="https://jaxenter.de/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Deine E-Mail-Adresse wird nicht veröffentlicht.</span></p><p class="comment-form-comment"><label for="comment">Kommentar</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">E-Mail</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Kommentar abschicken" /> <input type='hidden' name='comment_post_ID' value='60617' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="154911e3bd" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="66"/></p>			</form>
			</div><!-- #respond -->
	</div>

											</div>
									</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
					<div id="text-16" class="widget widget_text">			<div class="textwidget"><iframe src="https://jax.de/session-qualification/wp-sidebar-feed-featured-box-jax/?layout=sidebarfeed" width="350" height="760" style="margin:0px; padding:0px; overflow:hidden; border:none;" scrolling="no"></iframe></div>
		</div><div id="tag-widget-7" class="widget TagWidget"><a href="https://jaxenter.de/tag/blockchain"><p class="widget-title">Dossier Blockchain</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Bitcoin Blockchain Interview" id="posts-by-tag-item-60515"><a class="thumb" href="https://jaxenter.de/bitcoin-hard-fork-interview-flaskaemper-60515" title="Bitcoin Hard Fork: Ein Sturm im Wasserglas?"  ><img width="150" height="110" src="https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water-150x110.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water-150x110.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water-300x221.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water-200x147.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water-170x125.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water-109x80.jpg 109w, https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water-177x130.jpg 177w, https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water-180x132.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/bitcoin_water.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/bitcoin-hard-fork-interview-flaskaemper-60515">Bitcoin Hard Fork: Ein Sturm im Wasserglas?</a></li><li class="posts-by-tag-item Bitcoin Blockchain Interview" id="posts-by-tag-item-60356"><a class="thumb" href="https://jaxenter.de/bitcoin-hard-fork-interview-60356" title="Bitcoin Hard Fork: was passiert ist und wie es dazu kam"  ><img width="150" height="85" src="https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143-150x85.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143-150x85.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143-300x169.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143-200x113.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143-170x96.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143-120x68.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143-190x107.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143-180x102.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_666842143.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/bitcoin-hard-fork-interview-60356">Bitcoin Hard Fork: was passiert ist und wie es dazu kam</a></li><li class="posts-by-tag-item Bitcoin Blockchain Interview" id="posts-by-tag-item-60139"><a class="thumb" href="https://jaxenter.de/blockchain-internet-of-trust-60139" title="Expertencheck: Beginnt mit der Blockchain das nächste Internet-Zeitalter?"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/07/blockchain-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/blockchain-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain.jpg 1000w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/blockchain-internet-of-trust-60139">Expertencheck: Beginnt mit der Blockchain das nächste Internet-Zeitalter?</a></li><li class="posts-by-tag-item Angular Blockchain Go Java Java EE" id="posts-by-tag-item-60162"><a class="thumb" href="https://jaxenter.de/java-ethereum-angular-spring-60162" title="Java 9 und Java EE 8, Blockchain, Angular – Top 10 der populärsten JAXenter-Stories"  ><img width="150" height="132" src="https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-150x132.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-150x132.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-300x263.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-768x674.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-1024x899.jpg 1024w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-200x176.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-170x149.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-91x80.jpg 91w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-148x130.jpg 148w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_609784637-180x158.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/java-ethereum-angular-spring-60162">Java 9 und Java EE 8, Blockchain, Angular – Top 10 der populärsten JAXenter-Stories</a></li></ul></div><div id="polls-widget-3" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-23" class="wp-polls">
	<form id="polls_form_23" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_23_nonce" name="wp-polls-nonce" value="e1a890922f" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="23" /></p>
		<p style="display: none;"><input type="hidden" id="poll_multiple_ans_23" name="poll_multiple_ans_23" value="9" /></p>
		<p><strong>Welche Java-Version setzen Sie ein?</strong></p><div id="polls-23-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="checkbox" id="poll-answer-166" name="poll_23" value="166" /> <label for="poll-answer-166">Java 8</label></li>
		<li><input type="checkbox" id="poll-answer-167" name="poll_23" value="167" /> <label for="poll-answer-167">Java 7</label></li>
		<li><input type="checkbox" id="poll-answer-168" name="poll_23" value="168" /> <label for="poll-answer-168">Java 6</label></li>
		<li><input type="checkbox" id="poll-answer-169" name="poll_23" value="169" /> <label for="poll-answer-169">Java 5</label></li>
		<li><input type="checkbox" id="poll-answer-170" name="poll_23" value="170" /> <label for="poll-answer-170">Java 1.4</label></li>
		<li><input type="checkbox" id="poll-answer-171" name="poll_23" value="171" /> <label for="poll-answer-171">Java 1.3</label></li>
		<li><input type="checkbox" id="poll-answer-172" name="poll_23" value="172" /> <label for="poll-answer-172">Java 1.2</label></li>
		<li><input type="checkbox" id="poll-answer-173" name="poll_23" value="173" /> <label for="poll-answer-173">Java 1.1</label></li>
		<li><input type="checkbox" id="poll-answer-174" name="poll_23" value="174" /> <label for="poll-answer-174">Java 1.0</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(23);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-23-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="aktuelle_magazine-4" class="widget widget_aktuelle_magazine"><p class="widget-title">Aktuelle Magazine</p><div class="aktuelle-ausgaben-wrapper"><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/java-magazin"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/java-magazin">Java Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/java-magazin" class="button">Alle Infos</a></a></div></div></div><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/business-technology"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/business-technology">Business Technology Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/business-technology" class="button">Alle Infos</a></a></div></div></div><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/eclipse-magazin"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2016/03/ECM-Magazin-3-16_Cover_595x842-e1471272115384.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/eclipse-magazin" class="button">Alle Infos</a></a></div></div></div></div></div><div id="tag-widget-2" class="widget TagWidget"><a href="https://jaxenter.de/tag/kolumne"><p class="widget-title">Kolumnen</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Diversität Kolumne Women in Tech" id="posts-by-tag-item-60682"><a class="thumb" href="https://jaxenter.de/women-in-tech-heather-kirksey-60682" title="Women in Tech: Man kann die Herausforderungen auch zu seinem Vorteil nutzen"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Heather_Kirksey.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/women-in-tech-heather-kirksey-60682">Women in Tech: Man kann die Herausforderungen auch zu seinem Vorteil nutzen</a></li><li class="posts-by-tag-item Backend meets Frontend Kolumne Testen &amp; Qualität Vaadin" id="posts-by-tag-item-59895"><a class="thumb" href="https://jaxenter.de/vaadin-webdriver-binary-59895" title="Die Grundlagen für UI-Tests mit mehreren Browsern"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/vaadin-webdriver-binary-59895">Die Grundlagen für UI-Tests mit mehreren Browsern</a></li><li class="posts-by-tag-item Kolumne Mobile Planet Android Programmieren" id="posts-by-tag-item-60597"><a class="thumb" href="https://jaxenter.de/planet-android-android-things-smartboy-60597" title="Planet Android: Android Things DP 5, Google Camera 4.4 &#038; der SmartBoy"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Planet Android" srcset="https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2016/03/jaxenter_Kolumne_Android_33421_v2-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/planet-android-android-things-smartboy-60597">Planet Android: Android Things DP 5, Google Camera 4.4 & der SmartBoy</a></li><li class="posts-by-tag-item Checkpoint Java Java Java 9 Kolumne" id="posts-by-tag-item-60588"><a class="thumb" href="https://jaxenter.de/checkpoint-java-funktional-reaktiv-60588" title="Checkpoint Java: Funktional und reaktiv mit Java 9"  ><img width="150" height="121" src="https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-150x121.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-150x121.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-300x242.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-200x161.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-170x137.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-99x80.jpg 99w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-161x130.jpg 161w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-180x145.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/checkpoint-java-funktional-reaktiv-60588">Checkpoint Java: Funktional und reaktiv mit Java 9</a></li><li class="posts-by-tag-item Diversität Kolumne Women in Tech" id="posts-by-tag-item-60546"><a class="thumb" href="https://jaxenter.de/women-in-tech-helen-beal-60546" title="Women in Tech: Du wirst nicht genommen, weil du gut bist, sondern weil du eine Frau bist"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/Women_in_Tech_Aufmacher_900x450_39593_Helen_Beal.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/women-in-tech-helen-beal-60546">Women in Tech: Du wirst nicht genommen, weil du gut bist, sondern weil du eine Frau bist</a></li></ul></div><div id="bwp_recent_comments-2" class="widget bwp-rc-widget"><p class="widget-title">Letzte Kommentare</p>
		<ul class="bwp-rc-ulist">
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://secure.gravatar.com/avatar/454436af40c6bc28a493d22cf7bdeb7d?s=40&#038;d=https%3A%2F%2Fjaxenter.de%2Fwp-content%2Fplugins%2Fwp-user-avatar%2Fimages%2Fwpua-96x96.png&#038;r=g" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Markus</span><span class="recent-comment-text"> Hallo, leider sagt der Artikel nicht aus, was der eigentliche Kritikpunkt bzw. das ausgemachte Problem an der durch Facebook modifizierten Lizenz ist. Könnt ihr das... </span> <a href="https://jaxenter.de/apache-foundation-react-nicht-nutzen-59628#comment-175329" title="Comment on Apache Foundation empfiehlt Open Source Software von Facebook nicht zu nutzen"><strong>Apache Foundation empfiehlt Open Source Software von Facebook nicht zu nutzen</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">TestP</span><span class="recent-comment-text"> Tolle Interviews, danke. 🙂 Grüße </span> <a href="https://jaxenter.de/software-architektur-conways-law-60617#comment-175279" title="Comment on Praxis-Check Software-Architektur: Conway’s Law auf der Spur"><strong>Praxis-Check Software-Architektur: Conway’s Law auf der Spur</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Marco G</span><span class="recent-comment-text"> Hypermedia ist nicht zwingend notwendig um eine REST-API anzubieten. Es gibt ein REST Maturity Model und für eine vollständige REST-Maturity muss man HATEOAS umetzen. Mit... </span> <a href="https://jaxenter.de/web-api-frotscher-60543#comment-174841" title="Comment on Web-APIs im Einsatz: Diese Tipps helfen bei der schmerzfreien Umsetzung"><strong>Web-APIs im Einsatz: Diese Tipps helfen bei der schmerzfreien Umsetzung</strong></a></span></li>
		</ul>
</div><div id="featured_posts-2" class="widget widget_featured_posts"><p class="widget-title">Featured Posts</p><ul class="featured-posts-list"><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/software-architektur-conways-law-60617"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/08/conways-law-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/conways-law-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-768x513.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-200x134.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/conways-law.jpg 1000w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/software-architektur-conways-law-60617">Praxis-Check Software-Architektur: Conway’s Law auf der Spur</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/fx-test-junit-test-javafx-osgi-60634"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-150x99.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-300x199.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-200x132.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-190x126.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503-180x119.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/shutterstock_376301503.jpg 500w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/fx-test-junit-test-javafx-osgi-60634">FX-Test: JUnit-Tests für JavaFX- und OSGi-Anwendungen</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/typescript-flow-javascript-java-60683"><img width="120" height="67" src="https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-120x67.png" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-120x67.png 120w, https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-300x169.png 300w, https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-768x432.png 768w, https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-200x112.png 200w, https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-170x96.png 170w, https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2017/08/typescript-javascript-java-flow-zeigermann.png 953w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/typescript-flow-javascript-java-60683">TypeScript &#038; Flow: Ist das wirklich JavaScript für Java-Entwickler?</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/checkpoint-java-funktional-reaktiv-60588"><img width="99" height="80" src="https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-99x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-99x80.jpg 99w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-150x121.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-300x242.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-200x161.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-170x137.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-161x130.jpg 161w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java-180x145.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/Checkpoint_Java.jpg 500w" sizes="(max-width: 99px) 100vw, 99px" /></a></div><div class="title"><a href="https://jaxenter.de/checkpoint-java-funktional-reaktiv-60588">Checkpoint Java: Funktional und reaktiv mit Java 9</a></div></li></ul></div><div id="newsletter-2" class="widget widget_newsletter"><p class="widget-title">Newsletter</p><div class="newsletter"><p class="newsletter-icon pull-left"><a href="https://jaxenter.de/newsletter"><img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter.jpg" alt="Newsletter" /></a></p><p class="newsletter-info"><a href="https://jaxenter.de/newsletter">Alle Neuigkeiten die wichtig sind, mit dem JAXenter Newsletter!</a></p><p><a href="https://jaxenter.de/newsletter">Jetzt bestellen!</a></p></div></div><div id="text-4" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD1_Wordpress -->
<div id='div-gpt-ad-1423038811881-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-0'); });
</script>
</div></div>
		</div><div id="text-5" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD2_Wordpress -->
<div id='div-gpt-ad-1423038811881-1' style='width:300px; height:250px; clear:both;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-1'); });
</script>
</div></div>
		</div><div id="text-6" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD3_Wordpress -->
<div id='div-gpt-ad-1423038811881-2' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-2'); });
</script>
</div></div>
		</div><div id="text-15" class="widget widget_text">			<div class="textwidget"></div>
		</div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-4'); });
        </script>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-5'); });
        </script>
        </div>
    </div>
</div>				</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="/magazine/business-technology">Business Technology Magazin</a></li>
<li id="menu-item-38592" class="menu-item menu-item-type-post_type menu-item-object-magazin menu-item-38592"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="http://sharepoint-kompendium.de">SharePoint Kompendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13255"><a href="https://finance.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX Finance (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://btdays.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Business Technology Days</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="http://bigdatacon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BigData Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://webtechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">WebTech Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="http://entwickler-akademie.de">Entwickler Akademie</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-563H99" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-563H99');</script>
<!-- End Google Tag Manager -->

		
		<!-- Facebook Ads Pixel Code -->
		<script>
			(function() {
				var _fbq = window._fbq || (window._fbq = []);
				if (!_fbq.loaded) {
					var fbds = document.createElement('script');
					fbds.async = true;
					fbds.src = '//connect.facebook.net/en_US/fbds.js';
					var s = document.getElementsByTagName('script')[0];
					s.parentNode.insertBefore(fbds, s);
					_fbq.loaded = true;
				}
				_fbq.push(['addPixelId', '407071789447604']);
			})();
			window._fbq = window._fbq || [];
			window._fbq.push(['track', 'PixelInitialized', {}]);
		</script>
		<noscript>
			<img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=407071789447604&ev=PixelInitialized" />
		</noscript>

		<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.7.5' type='text/css' media='all' />
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.5'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
	</body>
</html>
