<!DOCTYPE html>
<html lang="de-DE"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>Migration nach AWS: Optimierungen für Serverless-Anwendungen</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
	<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-563H99');</script>
	
<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Im letzten Serienteil werfen wir einen Blick auf AWS-Lambda-Funktionen, um Sicherheit, Zuverlässigkeit und Performance zu erhöhen sowie Kosten zu senken."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Migration nach AWS: Optimierungen für Serverless-Anwendungen" />
<meta property="og:description" content="Im letzten Serienteil werfen wir einen Blick auf AWS-Lambda-Funktionen, um Sicherheit, Zuverlässigkeit und Performance zu erhöhen sowie Kosten zu senken." />
<meta property="og:url" content="https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="AWS" />
<meta property="article:tag" content="Cloud" />
<meta property="article:tag" content="Java" />
<meta property="article:tag" content="Serverless" />
<meta property="article:section" content="Artikel" />
<meta property="article:published_time" content="2020-07-22T06:19:28+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778.jpg" />
<meta property="og:image:secure_url" content="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="400" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://jaxenter.de/#website","url":"https://jaxenter.de/","name":"JAXenter","inLanguage":"de-DE","description":"Infos &amp; News f\u00fcr Java, Architektur, Web &amp; DevOps","potentialAction":{"@type":"SearchAction","target":"https://jaxenter.de/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443#primaryimage","inLanguage":"de-DE","url":"https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778.jpg","width":600,"height":400},{"@type":"WebPage","@id":"https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443#webpage","url":"https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443","name":"Migration nach AWS: Optimierungen f\u00fcr Serverless-Anwendungen","isPartOf":{"@id":"https://jaxenter.de/#website"},"inLanguage":"de-DE","primaryImageOfPage":{"@id":"https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443#primaryimage"},"datePublished":"2020-07-22T06:19:28+00:00","dateModified":"2020-07-22T06:19:28+00:00","author":{"@id":"https://jaxenter.de/#/schema/person/48766b4ab60290ad58f45d8e37df4b14"},"description":"Im letzten Serienteil werfen wir einen Blick auf AWS-Lambda-Funktionen, um Sicherheit, Zuverl\u00e4ssigkeit und Performance zu erh\u00f6hen sowie Kosten zu senken."},{"@type":["Person"],"@id":"https://jaxenter.de/#/schema/person/48766b4ab60290ad58f45d8e37df4b14","name":"Christian M\u00fcller","image":{"@type":"ImageObject","@id":"https://jaxenter.de/#authorlogo","inLanguage":"de-DE","url":"https://secure.gravatar.com/avatar/a18db047edcf15eb519a2680576dc506?s=96&d=wp_user_avatar&r=g","caption":"Christian M\u00fcller"},"description":"In seiner Rolle als Senior Solutions Architekt bei Amazon Web Services (AWS) in Frankfurt hilft Christian M\u00fcller seinen Kunden, das volle Potenzial der AWS Cloud zu nutzen, um sie so noch erfolgreicher zu machen. Seine besonderen Interessen liegen dabei in den Bereichen Messaging, Event-getriebene Architekturen und Serverless.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; Migration nach AWS: Optimierungen für Serverless-Anwendungen Kommentar-Feed" href="https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://jaxenter.de/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='sands-breaking-news-css'  href='https://jaxenter.de/wp-content/plugins/sands-breaking-news/includes/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpdiscuz-font-awesome-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.0.6/css/fontawesome-all.min.css?ver=5.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz.css?ver=5.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-user-content-css-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-user-content.css?ver=5.3.5' type='text/css' media='all' />

<!-- This site uses the Google Analytics by MonsterInsights plugin v 6.0.13 - https://www.monsterinsights.com/ -->
<!-- Normally you will find the Google Analytics tracking code here, but the webmaster disabled your user group. -->
<!-- / Google Analytics by MonsterInsights -->

<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/wpdccjs/wpdcc.js?ver=5.3.5'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=5.3.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/jaxenter.de\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Antworten verbergen","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Bitte f\u00fclle alle ben\u00f6tigten Felder aus","wc_invalid_field":"Nicht alle von dir ausgef\u00fcllten Felder sind richtig.","wc_error_empty_text":"Bitte f\u00fclle dieses Feld aus.","wc_error_url_text":"Bitte \u00fcberpr\u00fcfe deine angegebene URL.","wc_error_email_text":"Bitte \u00fcberpr\u00fcfe deine angegebene Email-Adresse.","wc_invalid_captcha":"Leider wurde der CAPTCHA -Code falsch eingetragen","wc_login_to_vote":"Um deine Stimme abgeben zu k\u00f6nnen musst du angemeldet sein.","wc_deny_voting_from_same_ip":"Es ist nur eine Stimm-Vergabe m\u00f6glich.","wc_self_vote":"Eigene Kommentare k\u00f6nnen nicht bewertet werden.","wc_vote_only_one_time":"Es ist immer nur eine Bewertung erlaubt.","wc_voting_error":"Bewertungs-Fehler bei deiner Wahl: Bitte versuche es erneut","wc_held_for_moderate":"Dein Kommentar wurde zur Freischaltung vorgelegt.","wc_comment_edit_not_possible":"Tut uns leid aber dieser Kommentar kann leider nicht mehr aktualisiert werden.","wc_comment_not_updated":"Tut uns leid aber dieser Kommentar konnte leider nicht aktualisiert werden.","wc_comment_not_edited":"Es wurden keine \u00c4nderungen von dir vorgenommen.","wc_new_comment_button_text":"neuer Kommentar","wc_new_comments_button_text":"neue Kommentare","wc_new_reply_button_text":"Neue Antwort auf deinen Kommentar","wc_new_replies_button_text":"Bei einen von dir abonnierten Video wurde eine neue Antwort ver\u00f6ffentlicht.","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":false,"commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wpdiscuzCommentsOrder":"asc","wpdiscuzCommentOrderBy":"comment_date_gmt","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":4000,"storeCommenterData":100000,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"socialLoginAgreementCheckbox":0,"enableFbLogin":0,"enableFbShare":0,"facebookAppID":"","facebookUseOAuth2":0,"enableGoogleLogin":0,"googleAppID":"","cookiehash":"b68f42a0021b63881a010e7410207d2c","isLoadOnlyParentComments":0,"ahk":"","enableDropAnimation":0,"isNativeAjaxEnabled":1,"cookieCommentsSorting":"wpdiscuz_comments_sorting","enableLastVisitCookie":0,"version":"5.3.5","wc_post_id":97443,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","isCookiesEnabled":true,"wc_captcha_show_for_guest":"1","wc_captcha_show_for_members":"0","is_email_field_required":"1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js?ver=5.3.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Sind Sie sicher, dass Sie diesen Kommentar l\u00f6schen wollen?","msgConfirmCancelSubscription":"Sind Sie sicher, dass Sie Ihr Abo k\u00fcndigen wollen?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-user-content.js?ver=5.3.5'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/lity/lity.js?ver=5.3.5'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://jaxenter.de/?p=97443' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fserverless%2Faws-optimierungen-serverless-anwendungen-97443" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fserverless%2Faws-optimierungen-serverless-anwendungen-97443&#038;format=xml" />
            <style>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</style>
            	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>
		<style type="text/css" id="wp-custom-css">
			/*
Füge deinen eigenen CSS-Code nach diesem Kommentar hinter dem abschließenden Schrägstrich ein. 



Klicke auf das Hilfe-Symbol oben, um mehr zu erfahren.
*/
@media print{
article.post.single .social-icons, .footer-menu, #sidebar, .related-posts, .comments-wrapper{
display:none;
}
}		</style>
		
		

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>

		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->


	</head>
	<body class="post-template-default single single-post postid-97443 single-format-standard">
		<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-563H99"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
		        <header>
                	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-86812" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86812"><a href="https://kiosk.entwickler.de/java-magazin/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">Java Magazin</a></li>
<li id="menu-item-77506" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77506"><a href="https://e-academy.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">e.academy</a></li>
<li id="menu-item-77814" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77814"><a href="https://jax.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">JAX 2020</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-79302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79302"><a href="https://jaxenter.de/tag/serverless">Serverless</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/kubernetes">Kubernetes</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/machine-learning">Machine Learning</a></li>
</ul>		</div>
	</div>
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">DevOps im Jahr 2020:</span>
                                    
                                    <u><a href="https://jaxenter.de/devops/devops-2020-survey-94449">Unsere große DevOps-Umfrage</a></u>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>

			                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2020/07/MLcon-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://mlconference.ai/online-edition-2020/" target="_blank" rel="noopener">ML Conference Online Edition | 29. &#8211; 30. Juli</a></p>
<h1 class="header-date"></h1>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2020/04/Gopher-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://kiosk.entwickler.de/kiosk-specials/kiosk-specials-volume-3/" target="_blank" rel="noopener">Kiosk Special Vol. 3: Alles zur Programmiersprache Go</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2020/06/w-jax-2020-Hybrid-300x200-1-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p><a href="https://jax.de/muenchen" target="_blank" rel="noopener">W-JAX 2020 | 2. bis 6. November</a></p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			
          </div>
          <div class="custom_header_wa">
                    </div>
		</header>



	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Wir bringen eine Java-Anwendung in die Cloud - Teil 7</div>
														<h1 class="title">Migration nach AWS: Optimierungen für Serverless-Anwendungen</h1>
							
									<div class="button-tags-block">
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/aws" target="_blank" >
	                  #AWS 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/cloud" target="_blank" >
	                  #Cloud 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/java" target="_blank" >
	                  #Java 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/serverless" target="_blank" >
	                  #Serverless 	         </a>   
	      		</div>
								
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2020-07-22T08:19">22. Juli 2020</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Christian Müller										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="200" src="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778.jpg 600w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_322087778-180x120.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"><p style="text-align: right;"><span style="color: #999999;">©Shutterstock / Romas_Photo</span></p>
</div>
								</div>
														
															<div class="excerpt">
									<p>In den vorangehenden sechs Teilen dieser Serie haben wir uns mit der schrittweisen Optimierung einer Anwendung hin zu einer Serverless-Architektur, der Verschlüsselung von Daten und Optimierungen für Container beschäftigt. In diesem abschließenden Teil der Serie werfen wir einen Blick auf mögliche Optimierungen für AWS-Lambda-Funktionen mit dem Ziel, die Sicherheit, Zuverlässigkeit und Performance zu erhöhen sowie die Kosten zu senken. </p>
								</div>
													</div>
					
					
					
					<div class="text">
						<p>Im Folgenden möchten wir betrachten, wie wir unsere serverlose Architektur aus dem vierten Artikel ganz konkret hinsichtlich Geschwindigkeit, Durchsatz, Zuverlässigkeit und Kosten optimieren können. Auch in serverlosen Architekturen gibt es in der Regel noch Konfigurationseinstellungen, die wir für unseren konkreten Workload überprüfen und optimieren sollten. In den folgenden Absätzen werden wir jeden Service unserer Architektur betrachten und mögliche Optimierungen diskutieren.</p>
<h2>Artikelserie</h2>
<div class="boxed">
<p class="SuS_Kastentext"><a href="https://jaxenter.de/cloud/warum-wechseln-aws-migration-96946">Teil 1: Warum wechseln?</a></p>
<p class="SuS_Kastentext"><a href="https://jaxenter.de/serverless/migration-aws-managed-services-97020">Teil 2: Verwendung von Managed Services</a></p>
<p class="SuS_Kastentext"><a href="https://jaxenter.de/cloud/migration-aws-java-container-97057">Teil 3: Verwendung von Containern</a></p>
<p class="SuS_Kastentext"><a href="https://jaxenter.de/cloud/migration-nach-aws-going-serverless-2-97173">Teil 4: Going Serverless</a></p>
<p class="SuS_Kastentext"><a href="https://jaxenter.de/cloud/migration-aws-verschluesselung-java-97284">Teil 5: Verschlüsselung für Java-Entwickler</a></p>
<p class="SuS_Kastentext"><a href="https://jaxenter.de/serverless/migration-aws-optimierung-container-97359">Teil 6: Optimierung bei Containern</a></p>
<p class="SuS_Kastentext">Teil 7: Optimierung bei Serverless-Anwendungen</p>
</div>
<h2>Optimierung unseres API Gateway</h2>
<p>Wie in Teil 4 bereits dargestellt, besitzt das Amazon API Gateway [1] drei unterschiedliche Ausprägungen:</p>
<ul class="ListeGegliedert">
<li>
<p class="SuS_Aufzaehlung_gegliedert"><em>Edge-optimized (Standard)</em>: Zu bevorzugen, sollten unsere Kunden in Europa oder weltweit verteilt sein. Durch die verwaltete Integration mit Amazon CloudFront [2] werden Daten nah bei unseren Kunden für den schnellen Zugriff zwischengespeichert und der Netzwerkpfad ist mittels des Amazon-Netzwerk-Backbone optimiert.</p>
</li>
<li>
<p class="SuS_Aufzaehlung_gegliedert"><em>Regional</em>: Zu bevorzugen, wenn unsere Kunden nur aus einem begrenzten Einzugsbereich kommen (z. B. Deutschland) und wir unser Amazon API Gateway nah oder innerhalb dieses Einzugsbereichs bereitstellen können (z. B. Frankfurt). Ein weiterer Grund kann sein, dass wir volle Kontrolle über die Amazon-CloudFront-Distribution benötigen, um sie selbst konfigurieren zu können.</p>
</li>
<li>
<p class="SuS_Aufzaehlung_gegliedert"><em>Private</em>: Zu bevorzugen, sollte unser API nur intern aus bestimmten Amazon VPCs [3] aufrufbar sein.</p>
</li>
</ul>
<p>Die Wahl der Ausprägung hat einen Einfluss auf die Kosten unseres API Gateways und die Latenz des Aufrufs.</p>
<p>Mit der Nutzung des Amazon API Gateway profitieren wir ohne zusätzliche Kosten vom automatischen Schutz durch AWS Shield Standard [4]. AWS Shield Standard bietet Schutz vor den am häufigsten vorkommenden Infrastrukturangriffen (Ebenen 3 und 4) wie SYN/UDP-Floods, Reflexionsangriffe und andere. Durch deren Abwehr wird eine hohe Verfügbarkeit Ihrer Anwendungen unter AWS sichergestellt. Um einen noch höheren Schutz vor Angriffen zu erhalten, können wir gegen zusätzliche Kosten AWS Shield Advanced in Verbindung mit einer Amazon-CloudFront-Distribution nutzen.</p>
<p>Amazon API Gateway bietet auch eine Integration mit der AWS WAF [5]. Diese Web Application Firewall erlaubt es, uns sehr effektiv vor gängigen Cross-Site-Scripting- oder SQL-Injection-Angriffen aus dem Web zu schützen. Darüber hinaus erlaubt es uns die AWS WAF, bestimmte IP-Adressbereiche oder CIDR-Blöcke auszuschließen (Blacklisting) oder nur bestimmte zuzulassen (Whitelisting).</p>
<p>Explizit soll hier auch nochmal auf die Möglichkeit hingewiesen werden, dass das Amazon API Gateway eine direkte Integration mit anderen AWS Services anbietet. Sollte unsere AWS-Lambda-Funktion keine Geschäftslogik beinhalten und die Anfragen nur an die Amazon DynamoDB weiterleiten, können wir auf diese AWS-Lambda-Funktion verzichten [6] und das Amazon API Gateway den Service aufrufen lassen. Das reduziert unsere Latenz und spart Kosten.</p>
<p>Standardmäßig drosselt das Amazon API Gateway Zugriffe auf 10 000 Requests pro Sekunde [7]. Sollten wir eine solche Last nicht erwarten bzw. sollte unser Backend diese Last nicht handeln können, sollten wir diese Konfiguration auf einen angemessenen Wert reduzieren. Hier haben wir die Möglichkeit, Limits auf unseren Stages (unterschiedliche Versionen unseres API) oder noch feingranularer auf Methodenebene zu definieren. Das ist sinnvoll, da zum Beispiel unsere <em>signup</em>-Methode viel seltener aufgerufen wird als eine Abfrage auf eine Resource. Das erhöht die Ausfallsicherheit unseres API aufgrund einer Überlastung unseres Backends.</p>
<p>Diese Limitierungen machen keine Unterscheidung, von wem der Aufruf kommt. Sollten wir die Anforderung besitzen, bestimmte Kunden möglichst gar nicht zu drosseln (z. B. weil sie ein Premiumabonnement besitzen), dann kommen API Keys ins Spiel. Dabei definieren wir Nutzungspläne, die wir mit Aufruflimits versehen. Diese Limits können wir wieder auf Ebene unseres API, einer Stage oder einzelner Methoden definieren. Wir legen geringere Limits für unsere Basiskunden und höhere für unsere Premiumkunden fest. Im Anschluss erzeugen wir für unsere Kunden API Keys, die wir mit den entsprechenden Nutzungsplänen verknüpfen.</p>
<p>Auf der AWS re:invent 2019 wurde das neue Amazon API Gateway HTTP API vorgestellt [8], das, verglichen mit dem REST API, noch einen reduzierten Funktionsumfang hat, aber eine geringere Latenz besitzt und circa 70 Prozent geringere Kosten verursacht. Über die nächsten Monate werden bekannte Funktionen aus dem Amazon API Gateway REST API auch für das HTTP API zur Verfügung gestellt. Also sollte man immer mal wieder vorbeischauen.<br />
<div class='widgets_on_page'> <div id="wysiwyg_widgets_widget-7" class="widget widget_wysiwyg_widgets_widget"><!-- Widget by WYSIWYG Widgets v2.3.6 - https://wordpress.org/plugins/wysiwyg-widgets/ --><div style="width: 100%; padding: 0 0px 0 0px; background-color: #f5f5f5; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://serverless-architecture.io/berlin/?utm_medium=referral&amp;utm_source=jaxenter.de&amp;utm_campaign=sands_om&amp;utm_content=article_ad"> <img style="width: 100%; height: auto;" src="/wp-content/uploads/2020/06/SLA_20_Smartblocks_1000x100_58216_v2.jpg" alt="Serverless Architecture Conference" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="/wp-content/uploads/2020/06/SLA_20_Smartblocks_550x214_58216_v2.jpg" alt="&quot;" /></div>
</div>
<div class="col-xs-12" style="background-color: #f5f5f5; padding: 15px; display: grid;">
<div class="col-xs-12" style="border-bottom: 1px solid #9d9d9c;">
<div class="col-xs-1" style="padding: 5px 0;"><img class="alignnone" style="max-width: 100%; height: auto; border: 1px solid #fff;" src="/wp-content/uploads/2020/06/Marcia-Villalba.jpg" alt="Marcia Villalba" width="500" height="350" data-pin-nopin="true" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #8bb315;"><a style="color: #002782; font-size: 19px; font-weight: 600;" href="https://serverless-architecture.io/serverless-engineering-operations/ci-cd-for-serverless-applications-on-aws/?loc=ber/?utm_medium=referral&amp;utm_source=jaxenter.de&amp;utm_campaign=sands_om&amp;utm_term=article_sessionbox" target="_blank" rel="noopener noreferrer">CI/CD for Serverless Applications on AWS</a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Marcia Villalba (AWS)</p>
</div>
</div>
<div class="col-xs-12" style="border-bottom: 1px solid #9d9d9c;">
<div class="col-xs-1" style="padding: 5px 0;"><img class="alignnone" style="max-width: 100%; height: auto; border: 1px solid #fff;" src="/wp-content/uploads/2020/06/Gunnar-Grosch-3.jpg" alt="Gunnar Grosch" width="500" height="350" data-pin-nopin="true" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #8bb315;"><a style="color: #002782; font-size: 19px; font-weight: 600;" href="https://serverless-architecture.io/serverless-engineering-operations/performing-chaos-in-a-serverless-world/?loc=ber/?utm_medium=referral&amp;utm_source=jaxenter.de&amp;utm_campaign=sands_om&amp;utm_term=srticle_sessionbox" target="_blank" rel="noopener noreferrer">Performing Chaos in a Serverless World</a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Gunnar Grosch (Opsio AB)</p>
</div>
</div>
<div class="col-xs-12" style="border-bottom: 0px solid #9d9d9c;">
<div class="col-xs-1" style="padding: 5px 0;"><img class="alignnone" style="max-width: 100%; height: auto; border: 1px solid #fff;" src="/wp-content/uploads/2020/06/Rob-Richardson.jpg" alt="Rob Richardson" width="500" height="350" data-pin-nopin="true" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #8bb315;"><a style="color: #002782; font-size: 19px; font-weight: 600;" href="https://serverless-architecture.io/serverless-architecture-design/service-mess-to-service-mesh/?utm_medium=referral&amp;utm_source=jaxenter.de&amp;utm_campaign=sands_om&amp;utm_term=article_sessionbox" target="_blank" rel="noopener noreferrer">Service Mess to Service Mesh<br />
</a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Rob Richardson (MemSQL)</p>
</div>
</div>
</div>
</div>
<div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://it-security-summit.de/"><img style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2020/06/ISS_2020_2126x162_57918_v2.jpg" alt="IT Security Summit 2020" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2020/06/ISS_2020_700x350_57918_v2.jpg" alt="IT Security Summit 2020" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;"></div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jaxenter.de/wp-content/uploads/2020/03/christian_schneider.jpg" alt="Christian Schneider" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://it-security-summit.de/it-security-summit/web-pentesting-offensive-java-exploitation/"><span style="color: #6322e6;"><span style="color: #482683;">Web Pentesting – Offensive Java Exploitation</span></span></a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Christian Schneider</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="sb-content-item-sands col-xs-12" style="padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="border: 1px solid #fff; max-width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2020/06/1561643567921_almazova_victoria_wp.jpg" alt="Victoria Almazova" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://it-security-summit.de/it-security-summit/zero-trust-why-are-we-having-this-conversation/"><span style="color: #6322e6;"><span style="color: #482683;">Zero Trust – why are we having this conversation?</span></span></a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Victoria Almazova</p>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<!-- / WYSIWYG Widgets --></div>
  </div><!-- widgets_on_page --></p>
<h2>Optimierung unserer Funktionen</h2>
<p>Nicht neu für uns ist, dass sich die Größe unserer Funktion und deren Abhängigkeiten direkt auf die Dauer der ersten Ausführung unserer Lambda-Funktion auswirkt, den so genannten Kaltstart. Darüber hinaus können aber auch die Wahl der Frameworks, die Wiederverwendung von HTTP- oder Datenbankverbindungen und ihre Konfiguration (Keep-alive) und weitere Faktoren eine signifikante Auswirkung auf die Ausführungsgeschwindigkeit unserer Funktion haben. Um hier einen schnellen und guten Überblick zu erhalten, empfehle ich die AWS re:invent Präsentation „Best practices for AWS Lambda and Java“ [9].</p>
<p>Sollte sich die Kaltstartzeit trotz aller Bemühungen nicht auf ein annehmbares Maß (bezogen auf unsere Anforderungen) reduzieren lassen, so können wir von der Möglichkeit Gebrauch machen, unsere AWS-Lambda-Funktionen von AWS vorwärmen zu lassen [10]. Die Kaltstartzeit für so vorgewärmte Funktionen beträgt weniger als 100 ms. Zuvor sollten wir aber abwägen, ob z. B. die Betrachtung unserer Latenz bezogen auf 99,9 Prozent der Aufrufe ausreichend ist, oder ob eine Betrachtung auf 99,99 Prozent gefordert oder notwendig ist und so die gegebenenfalls anfallenden Mehrkosten gerechtfertigt werden können. Die konkreten Prozentzahlen hängen natürlich vom Aufrufpattern unseres API ab.</p>
<p>Wenn wir unsere AWS-Lambda-Funktion nach AWS deployen, müssen wir den Arbeitsspeicher dieser Funktion konfigurieren. Dabei reicht die Bandbreite von 128 MB bis 3 GB. Diese Einstellung bestimmt aber auch, wie viel CPU- und Netzwerkkapazität der Funktion zur Verfügung gestellt wird. Da sich diese Einstellung direkt auf die Ausführungsgeschwindigkeit und die Kosten unserer Funktion auswirkt, sollten wir es richtig machen. Doch wie ermitteln wir die optimalen Einstellungen für unsere AWS-Lambda-Funktion?</p>
<p>Mit der AWS-Lambda-Power-Tuning-Anwendung [11] aus dem AWS Serverless Application Repository (AWS SAR) [12], kann das sehr schnell und einfach ermittelt werden (<strong>Abb.1</strong>). Die Anwendung testet unsere Lambda-Funktion mit den von uns vorgegebenen Arbeitsspeichereinstellungen und kann sie visualisieren. Wir können dann sehr einfach entscheiden, was die optimale Konfiguration bezogen auf die Ausführungsgeschwindigkeit oder unsere Kosten ist.</p>
<div class="commentedFigure">
<div id="attachment_97450" style="width: 710px" class="wp-caption alignnone"><a href="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1.jpg" target="_blank" rel="noopener noreferrer"><img aria-describedby="caption-attachment-97450" class="wp-image-97450" title="Abb. 1: Visualisierung unseres Testergebnisses" src="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1.jpg" alt="Abb. 1: Visualisierung unseres Testergebnisses" width="700" height="308" srcset="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1.jpg 2127w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-300x132.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-1024x450.jpg 1024w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-150x66.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-768x338.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-1536x675.jpg 1536w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-2048x900.jpg 2048w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-200x88.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-170x75.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-120x53.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-190x84.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_1.tif_fmt1-180x79.jpg 180w" sizes="(max-width: 700px) 100vw, 700px" /></a><p id="caption-attachment-97450" class="wp-caption-text">Abb. 1: Visualisierung unseres Testergebnisses</p></div>
</div>
<p>Eine elementare Regel in Bezug auf die Sicherheit unserer Anwendung ist, dass wir unseren AWS-Lambda-Funktionen nur die Zugriffsrechte geben, die sie auch wirklich benötigen, und nicht mehr. Anstatt unserer AWS-Lambda-Funktion alle Rechte auf alle Amazon-DynamoDB-Tabellen in unserem Account zu geben (einschließlich der Berechtigung, Tabellen zu löschen), geben wir ihr nur das Zugriffsrecht auf diese eine Tabelle und nur für genau die Operation, die sie benötigt – z. B. das Lesen eines Eintrags mittels seines Primärschlüssels (Listing 1).</p>
<div class="codelisting">
<pre class="brush: plain; title: Listing 1; notranslate" title="Listing 1">

{
  &quot;Version&quot;: &quot;2012-10-17&quot;,
  &quot;Statement&quot;: [
    {
      &quot;Sid&quot;: &quot;GetItemAPIActionsOnOrders&quot;,
      &quot;Effect&quot;: &quot;Allow&quot;,
      &quot;Action&quot;: [
        &quot;dynamodb:GetItem&quot;
      ],
      &quot;Resource&quot;: &quot;arn:aws:dynamodb:eu-central-1:123456789012:table/Orders&quot;
    }
  ]
}</pre>
</div>
<p>Aus genau diesem Grund nutzen wir auch eine separate AWS-Lambda-Funktion pro Methode, die unser Amazon API Gateway veröffentlicht – sogenannte Single Purpose Functions. Nur so können wir das Least-Privilege-Prinzip umsetzen.</p>
<p>Im Gegensatz zu den sogenannten Fat Functions oder Monolithic Functions hilft uns dieser Ansatz auch, unsere Funktionen klein zu halten (weniger Abhängigkeiten) und die Vergabe des Arbeitsspeichers zu optimieren.</p>
<p>Standardmäßig können wir in einem AWS-Account und in einer AWS-Region bis zu 1 000 AWS-Lambda-Funktionen gleichzeitig ausführen. Dieses Limit gilt für alle Funktionen, die wir deployt haben. Darüber hinaus haben wir die Möglichkeit, die Nebenläufigkeit pro Funktionen zu beschränken (Kasten: „Nebenläufigkeit gegenüber Transaktionen pro Sekunde (TPS)“). Das ist notwendig, wenn unsere AWS-Lambda-Funktion mit einem Backend kommunizieren muss, das nicht in der Lage ist, Hunderte gleichzeitige Anfragen zu verkraften. Diese Beschränkung dient gleichzeitig auch als Kapazitätsreservierung. So können wir sicherstellen, dass wir für bestimmte Funktionen immer eine definierte Kapazität vorhalten, auch wenn andere Funktionen unsere restliche Kapazität aufbrauchen (Noisy-Neighbour-Problem). Das erhöht die Zuverlässigkeit unserer Anwendung.</p>
<div class="boxed">
<p><strong>Nebenläufigkeit gegenüber Transaktionen pro Sekunde (TPS)</strong></p>
<p class="SuS_Kastentext">Nicht selten verwechseln Kunden die Begrifflichkeiten Nebenläufigkeit (Concurrency) und Transaktionen (bzw. Requests) pro Sekunde. AWS Lambda hat standardmäßig eine Nebenläufigkeit von bis zu 1 000 Funktionen pro AWS-Account und AWS-Region. Soll die maximale Anzahl der Transaktionen pro Sekunde ermittelt werden, die damit erreicht werden kann, wird die durchschnittliche Ausführungszeit der Funktion benötigt. Beträgt diese genau eine Sekunde, so können wir bei einer Gleichverteilung der Aufrufe 1 000 Transaktionen pro Sekunde erreichen. Beträgt die Ausführungszeit hingegen nur 100 ms, können wir bis zu 10 000 Transaktionen pro Sekunde bewältigen. Bei einer Ausführungszeit von 10 Sekunden allerdings nur 100 Transaktionen pro Sekunde.</p>
</div>
<p>Im vorigen Artikel haben wir Quarkus für die Optimierung von containerbasierten Workloads genauer betrachtet. Quarkus ist aber nicht auf die Nutzung in Containern oder virtuellen Maschinen limitiert, sondern kann auch sehr einfach genutzt werden, um AWS-Lambda-Funktionen zu implementieren. Hier profitieren wir ganz besonders von der Möglichkeit, ein natives Image zu erstellen. Damit können wir eine Lambda Custom Runtime als Laufzeitumgebung wählen und auf eine JVM (~80 MB) verzichten. Ein vollständiges Beispiel ist unter [13] zu finden.</p>
<p>Eine native AWS-Lambda-Funktion zeichnet sich durch eine reduzierte Kaltstartzeit und durch einen geringeren Speicherverbrauch aus. So lässt sich der Kaltstart einer AWS-Lambda-Funktion, die parallel auf Amazon S3 und Amazon DynamoDB zugreift, auf ca. 400 Millisekunden reduzieren – und das mit einem geringeren Hauptspeicherbedarf (<strong>Abb. 2</strong>). Das führt zu geringeren Kosten und einem gleichmäßigeren Kundenerlebnis, da die Kaltstarts weniger stark ins Gewicht fallen. Unter [14] finden wir etliche Beispiele, die uns helfen, das Kaltstartverhalten einer Spring-PetClinic-Anwendung von ursprünglich 11,5 Sekunden Schritt für Schritt auf 410 Millisekunden zu reduzieren. Weitere Best Practices hat das AWS-Lambda-Team auf seiner Webseite dokumentiert [15].</p>
<div class="commentedFigure">
<div id="attachment_97451" style="width: 710px" class="wp-caption alignnone"><a href="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-scaled.jpg" target="_blank" rel="noopener noreferrer"><img aria-describedby="caption-attachment-97451" class="wp-image-97451" title="Abb. 2: Visualisierung eines Kaltstarts einer nativen AWS-Lambda-Funktion mit AWS X-Ray" src="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-scaled.jpg" alt="Abb. 2: Visualisierung eines Kaltstarts einer nativen AWS-Lambda-Funktion mit AWS X-Ray" width="700" height="156" srcset="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-scaled.jpg 2560w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-300x67.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-1024x228.jpg 1024w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-150x33.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-768x171.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-1536x342.jpg 1536w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-2048x457.jpg 2048w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-200x45.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-170x38.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-120x27.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-190x42.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_2.tif_fmt1-180x40.jpg 180w" sizes="(max-width: 700px) 100vw, 700px" /></a><p id="caption-attachment-97451" class="wp-caption-text">Abb. 2: Visualisierung eines Kaltstarts einer nativen AWS-Lambda-Funktion mit AWS X-Ray</p></div>
</div>
<h2>Optimierung unserer Datenbank</h2>
<p>Amazon DynamoDB [16] stellt uns vor die Wahl, die für unsere Anwendung notwendigen Lese- und Schreiboperationen zu konfigurieren – sogenannte Read Capacity Units (RCUs) und Write Capacity Units (WCUs). Das können wir manuell über einen API-Aufruf durchführen oder automatisch mittels AWS Auto Scaling [17], um einer vorgegebenen Zielauslastung zu entsprechen. AWS Auto Scaling erhöht oder reduziert die aktuell konfigurierten RCUs oder WCUs basierend auf der aktuellen Auslastung und im Rahmen unserer vorgegebenen Grenzen, um unseren Zielvorgaben zu entsprechen. Während das für viele Workloads schon sehr gut geeignet ist, ist es keine optimale Lösung für Workloads mit häufig schnell und stark ansteigender oder fallender Last. Auch für Workloads, die über längere Zeit nicht genutzt werden (z. B. Entwicklungs- und Testumgebungen in der Nacht), ist die On-Demand-Konfiguration besser geeignet. Hier wird pro Datenbankanfrage abgerechnet. Unsere Amazon-DynamoDB-Tabelle wird initial so für uns bereitgestellt, dass sie mindestens 4 000 Schreib- und 12 000 Leseoperationen pro Sekunde unterstützt. Grundsätzlich richtet sich die Bereitstellung der Lese- und Schreibkapazität nach unserer bisherigen Lastspitze, von der ausgehend Amazon DynamoDB die doppelte Lese- und Schreibkapazität bereitstellt. Sollten wir anhaltend eine höhere Last als unsere bisherige Lastspitze erhalten, wird diese zu unserer neuen Lastspitze und Amazon DynamoDB stellt sofort die doppelte Kapazität zur Verfügung. Es kann jedoch zu einer Drosselung kommen, wenn wir innerhalb von 30 Minuten das Doppelte unseres vorherigen Spitzenwertes überschreiten. Für neue Anwendungen mit geringem oder unbekanntem Lastaufkommen ist das in der Regel die kostengünstigere und zuverlässigere Wahl.</p>
<p>Das von AWS bereitgestellt Software Development Kit (SDK) für Amazon DynamoDB führt standardmäßig einen konsistenten Lesezugriff durch. Konsistenz innerhalb einer Amazon-DynamoDB-Tabelle wird normalerweise in unter einer Sekunde hergestellt. Liegt zwischen unserem Schreib- und folgendem Lesezugriff mehr als eine Sekunde, oder kann unsere Applikation mit eventuell konsistenten Daten umgehen, dann sollten wir unsere Lesezugriffe entsprechend konfigurieren. Das kann zu einer gesteigerten Verfügbarkeit und Performance führen, da jetzt ein beliebiger Server die Anfrage beantworten kann. Zusätzlich halbieren wir unsere Kosten verbunden mit Lesezugriffen, da sie nur die Hälfte der konsistenten Leseanfragen kosten.</p>
<p>Es gibt noch etliche weitere Möglichkeiten, die Geschwindigkeit und die Kosten unserer Amazon DynamoDB zu optimieren. Da darauf einzugehen den Umfang eines eigenständigen Artikels hätte, verweisen wir hier auf die dokumentierten Best Practices [18].</p>
<h2>Optimierung unserer Monitoringumgebung</h2>
<p>Auch hier können wir optimieren, vor allem unsere Kosten. Die Logausgaben unserer AWS-Lambda-Funktionen werden automatisch nach Amazon CloudWatch Logs [19] geschrieben. Das ist bequem und erlaubt uns, sehr einfach mit Amazon CloudWatch Logs Insights [20] einen gesamtheitlichen Blick auf alle Logeinträge unserer AWS-Lambda-Funktionen zu erhalten. Allerdings ist die Aufbewahrung dieser Logeinträge im Standard unbeschränkt – sie werden also niemals gelöscht. Das führt über die Zeit zu steigenden Kosten für Amazon CloudWatch Logs und ist oft unnötig, insbesondere in Entwicklungs- und Testumgebungen. Auch dafür existiert im AWS SAR eine nützliche Anwendung [21], die die Einstellungen für alle existierenden und neu hinzukommenden Amazon-CloudWatch-Logs-Gruppen auf einen für uns sinnvollen Wert setzen kann (z. B. 14 Tage). Sollten wir unsere Logdateien von Produktionsumgebungen länger aufheben müssen, empfiehlt sich aufgrund der günstigeren Speicherkosten der in Amazon CloudWatch Logs integrierte Export nach Amazon S3 [22]. Über eine Amazon S3 Lifecycle Policy [23] können wir definieren, wann diese Logfiles in noch günstigere Speicherklassen verschoben (z. B. Amazon Glacier [24]) oder gelöscht werden sollen.</p>
<p>Im vierten Artikel dieser Serie hatten wir auch kurz die Möglichkeit angesprochen, eigene geschäftsrelevante Metriken in Amazon CloudWatch als Custom Metrics zu erzeugen (z. B. das Volumen der bewegten Geldmenge in einer Finanzapplikation). Wenn wir das direkt über den Aufruf des Amazon CloudWatch Metric API durchführen, führt dieser zusätzliche HTTP Request zu einer größeren Latenz in unserer Anwendung und verursacht bei intensiver Nutzung spürbare Kosten. Seit einigen Monaten besteht jedoch eine weitaus bessere Möglichkeit, eigene Metriken zu erstellen. Amazon CloudWatch Embedded Metric Format [25] erlaubt es uns, Logeinträge in einem vordefinierten Format nach Amazon CloudWatch Log zu schreiben, aus denen dann automatisch die Metriken extrahiert und nach Amazon CloudWatch Metric gepostet werden. Das reduziert die Latenz, da das Schreiben des Logeintrags viel schneller ausgeführt wird, und es hilft uns, weitere, unnötige Kosten zu sparen (Listing 2).</p>
<div class="codelisting">
<pre class="brush: plain; title: Listing 2; notranslate" title="Listing 2">

{
  &quot;_aws&quot;: {
    &quot;Timestamp&quot;: 1576064416496,
    &quot;CloudWatchMetrics&quot;: [{
      &quot;Namespace&quot;: &quot;ecommerce-cart&quot;,
      &quot;Dimensions&quot;: [[&quot;Environment&quot;], [&quot;Environment&quot;, &quot;CategoryId&quot;]],
      &quot;Metrics&quot;: [
        {&quot;Name&quot;: &quot;PriceInCart&quot;, &quot;Unit&quot;: &quot;None&quot;},
        {&quot;Name&quot;: &quot;QuantityInCart&quot;, &quot;Unit&quot;: &quot;None&quot;}
      ]
    }]
  },
  &quot;Environment&quot;: &quot;prod&quot;,
  &quot;CategoryId&quot;: &quot;bca4cec1&quot;,
  &quot;PriceInCart&quot;: 100,
  &quot;QuantityInCart&quot;: 2,
  ...
  &quot;Message&quot;: &quot;Added 2 items 'a23390f3' to cart '58dd189f'&quot;,
  &quot;customerId&quot;: &quot;e57a3b12a0&quot;
}</pre>
</div>
<p>Ein weiterer positiver Aspekt der Nutzung des Amazon CloudWatch Embedded Metric Format ist, das wir damit automatisch auch strukturierte Logeinträge in JSON erzeugen, die sich viel besser weiterverarbeiten und visualisieren lassen (z. B. mit Amazon CloudWatch Log Insights). Aber auch komma- oder tabseparierte Logeinträge lassen sich so einfach auswerten. Nehmen wir zum Beispiel an, wir möchten ermitteln, wie groß der Anteil der Kaltstarts unserer Funktion im Verhältnis zu allen Ausführungen ist. Nach der Ausführung einer AWS-Lambda-Funktion wird automatisch ein Logeintrag wie der folgende erzeugt:</p>
<pre><code>REPORT RequestId: 4a88e6f5-b6a9-4307-a1ed-141758487c8f Duration: 1567.73 ms Billed Duration: 1600 ms Memory Size: 512 MB Max Memory Used: 97 MB Init Duration: 355.15 ms</code></pre>
<p>Dabei wird <em>Init Duration</em> nur gemeldet, wenn es sich um die erste Ausführung einer AWS-Lambda-Funktion handelt, also einen Kaltstart. Das erlaubt uns, die in Listing 3 gezeigte Abfrage in Amazon CloudWatch Log Insights zu definieren (<strong>Abb.3</strong>).</p>
<div class="codelisting">
<pre class="brush: plain; title: Listing 3; notranslate" title="Listing 3">

filter @type = &quot;REPORT&quot;
| stats
  sum(strcontains(
    @message,
    &quot;Init Duration&quot;))
  / count(*)
  * 100
  as coldStartPercentage,
  avg(@duration)
  by bin(5m)</pre>
</div>
<div class="commentedFigure">
<div id="attachment_97452" style="width: 710px" class="wp-caption alignnone"><a href="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1.jpg" target="_blank" rel="noopener noreferrer"><img aria-describedby="caption-attachment-97452" class="wp-image-97452" title="Abb. 3: Visualisierung unserer AWS-Lambda-Funktions-Kaltstarts pro 5 Minuten" src="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1.jpg" alt="Abb. 3: Visualisierung unserer AWS-Lambda-Funktions-Kaltstarts pro 5 Minuten" width="700" height="409" srcset="https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1.jpg 1845w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-300x175.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-1024x598.jpg 1024w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-150x88.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-768x449.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-1536x897.jpg 1536w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-200x117.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-170x99.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-120x70.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-190x111.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/mueller_aws_7_3.tif_fmt1-180x105.jpg 180w" sizes="(max-width: 700px) 100vw, 700px" /></a><p id="caption-attachment-97452" class="wp-caption-text">Abb. 3: Visualisierung unserer AWS-Lambda-Funktions-Kaltstarts pro 5 Minuten</p></div>
</div>
<h2>Fazit</h2>
<p>In diesem siebten und letzten Teil unserer Artikelserie haben wir betrachtet, wie wir auch serverlose Applikationen im Bezug auf Geschwindigkeit, Zuverlässigkeit, Sicherheit und Kosten optimieren können. Neben den hier erläuterten Optionen hat AWS 46 weitere Best Practices für alle Arten von Architekturen im AWS Well-Architected Framework [26] dokumentiert. Im Dokument AWS Serverless Applications Lens [27] wird mit neun weiteren Fragen speziell auf serverlose Architekturen eingegangen. Seit Ende 2018 haben wir die Möglichkeit, das AWS Well-Architected Tool [28] in unserer AWS Console zu nutzen, um unsere Applikationen einem Review zu unterziehen – ohne jegliche Kosten. Am Ende des Reviews erhalten wir neben einer Zusammenfassung sehr detaillierte Hinweise auf kritische oder hochkritische Probleme im Bezug auf Sicherheit, Zuverlässigkeit, Kostenoptimierung, Leistung und Effizienz oder betriebliche Exzellenz. Durch zahlreiche Links zu Videos, Blogposts oder zur AWS-Dokumentation werden wir dabei unterstützt, diese Probleme schnell und effektiv zu beheben. Das sollte auch unser nächster Schritt nach dem Lesen und Nachvollziehen dieser Artikelserie sein. Entscheider sollten auf diese Review bestehen, bevor neue Applikationen in den produktiven Betrieb übernommen werden. Denn sie hilft, zu verstehen, wo Schwachstellen und Chancen in der Applikation liegen, sodass wir diese in unser Backlog aufnehmen und entsprechend priorisieren können.</p>
<p>&nbsp;</p>
					</div>
					
										
					
											<div class="links-literatur">
							<div class="headline">Links & Literatur</div>
							<div class="content"><p>[1] <a href="https://aws.amazon.com/api-gateway/" target="_blank" rel="noopener">https://aws.amazon.com/api-gateway/</a></p>
<p>[2] <a href="https://aws.amazon.com/cloudfront/" target="_blank" rel="noopener">https://aws.amazon.com/cloudfront/</a></p>
<p>[3] <a href="https://aws.amazon.com/vpc/" target="_blank" rel="noopener">https://aws.amazon.com/vpc/</a></p>
<p>[4] <a href="https://aws.amazon.com/shield/" target="_blank" rel="noopener">https://aws.amazon.com/shield/</a></p>
<p>[5] <a href="https://aws.amazon.com/waf/" target="_blank" rel="noopener">https://aws.amazon.com/waf/</a></p>
<p>[6] <a href="https://docs.aws.amazon.com/apigateway/latest/developerguide/getting-started-aws-proxy.html" target="_blank" rel="noopener">https://docs.aws.amazon.com/apigateway/latest/developerguide/getting-started-aws-proxy.html</a></p>
<p>[7] <a href="https://docs.aws.amazon.com/apigateway/latest/developerguide/api-gateway-request-throttling.html" target="_blank" rel="noopener">https://docs.aws.amazon.com/apigateway/latest/developerguide/api-gateway-request-throttling.html</a></p>
<p>[8] <a href="https://aws.amazon.com/blogs/compute/announcing-http-apis-for-amazon-api-gateway/" target="_blank" rel="noopener">https://aws.amazon.com/blogs/compute/announcing-http-apis-for-amazon-api-gateway/</a></p>
<p>[9] <a href="https://www.youtube.com/watch?v=ddg1u5HLwg8" target="_blank" rel="noopener">https://www.youtube.com/watch?v=ddg1u5HLwg8</a></p>
<p>[10] <a href="https://aws.amazon.com/blogs/aws/new-provisioned-concurrency-for-lambda-functions/" target="_blank" rel="noopener">https://aws.amazon.com/blogs/aws/new-provisioned-concurrency-for-lambda-functions/</a></p>
<p>[11] <a href="https://serverlessrepo.aws.amazon.com/applications/arn:aws:serverlessrepo:us-east-1:451282441545:applications~aws-lambda-power-tuning" target="_blank" rel="noopener">https://serverlessrepo.aws.amazon.com/applications/arn:aws:serverlessrepo:us-east-1:451282441545:applications~aws-lambda-power-tuning</a></p>
<p>[12] <a href="https://aws.amazon.com/serverless/serverlessrepo/" target="_blank" rel="noopener">https://aws.amazon.com/serverless/serverlessrepo/</a></p>
<p>[13] <a href="https://github.com/aws-samples/aws-quarkus-demo/tree/master/lambda" target="_blank" rel="noopener">https://github.com/aws-samples/aws-quarkus-demo/tree/master/lambda</a></p>
<p>[14] <a href="https://github.com/muellerc/lambda-on-java-workshop/" target="_blank" rel="noopener">https://github.com/muellerc/lambda-on-java-workshop/</a></p>
<p>[15] <a href="https://docs.aws.amazon.com/lambda/latest/dg/best-practices.html" target="_blank" rel="noopener">https://docs.aws.amazon.com/lambda/latest/dg/best-practices.html</a></p>
<p>[16] <a href="https://aws.amazon.com/dynamodb/" target="_blank" rel="noopener">https://aws.amazon.com/dynamodb/</a></p>
<p>[17] <a href="https://aws.amazon.com/autoscaling/" target="_blank" rel="noopener">https://aws.amazon.com/autoscaling/</a></p>
<p>[18] <a href="https://docs.aws.amazon.com/amazondynamodb/latest/developerguide/best-practices.html" target="_blank" rel="noopener">https://docs.aws.amazon.com/amazondynamodb/latest/developerguide/best-practices.html</a></p>
<p>[19] <a href="https://aws.amazon.com/cloudwatch/" target="_blank" rel="noopener">https://aws.amazon.com/cloudwatch/</a></p>
<p>[20] <a href="https://docs.aws.amazon.com/AmazonCloudWatch/latest/logs/AnalyzingLogData.html" target="_blank" rel="noopener">https://docs.aws.amazon.com/AmazonCloudWatch/latest/logs/AnalyzingLogData.html</a></p>
<p>[21] <a href="https://serverlessrepo.aws.amazon.com/applications/arn:aws:serverlessrepo:us-east-1:374852340823:applications~auto-set-log-group-retention" target="_blank" rel="noopener">https://serverlessrepo.aws.amazon.com/applications/arn:aws:serverlessrepo:us-east-1:374852340823:applications~auto-set-log-group-retention</a></p>
<p>[22] <a href="https://aws.amazon.com/s3/" target="_blank" rel="noopener">https://aws.amazon.com/s3/</a></p>
<p>[23] <a href="https://docs.aws.amazon.com/AmazonS3/latest/dev/object-lifecycle-mgmt.html" target="_blank" rel="noopener">https://docs.aws.amazon.com/AmazonS3/latest/dev/object-lifecycle-mgmt.html</a></p>
<p>[24] <a href="https://aws.amazon.com/glacier/" target="_blank" rel="noopener">https://aws.amazon.com/glacier/</a></p>
<p>[25] <a href="https://docs.aws.amazon.com/AmazonCloudWatch/latest/monitoring/CloudWatch_Embedded_Metric_Format.html" target="_blank" rel="noopener">https://docs.aws.amazon.com/AmazonCloudWatch/latest/monitoring/CloudWatch_Embedded_Metric_Format.html</a></p>
<p>[26] <a href="https://aws.amazon.com/architecture/well-architected/" target="_blank" rel="noopener">https://aws.amazon.com/architecture/well-architected/</a></p>
<p>[27] <a href="https://d1.awsstatic.com/whitepapers/architecture/AWS-Serverless-Applications-Lens.pdf" target="_blank" rel="noopener">https://d1.awsstatic.com/whitepapers/architecture/AWS-Serverless-Applications-Lens.pdf</a></p>
<p>[28] <a href="https://console.aws.amazon.com/wellarchitected/home?#/workloads" target="_blank" rel="noopener">https://console.aws.amazon.com/wellarchitected/home?#/workloads</a></p>
<p>&nbsp;</p>
</div>
						</div>
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=Migration nach AWS: Optimierungen für Serverless-Anwendungen - https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/serverless/aws-optimierungen-serverless-anwendungen-97443" data-url-old=""></span></div>
						</a>
					</div>
					
					<div class="row"><div class="more-topics"><div class="col-xs-12 col-md-3"><h3 class="box-headline">Verwandte Themen:</h3></div><div class="col-xs-12 col-md-9">		<div class="button-tags-block">
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/aws" target="_blank" >
	                   AWS 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/cloud" target="_blank" >
	                   Cloud 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/java" target="_blank" >
	                   Java 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/serverless" target="_blank" >
	                   Serverless 	         </a>   
	      		</div>
	</div></div></div>
					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2020/07/mueller_christian_sw.tif_fmt1-111x150.jpg" width="71" height="96" alt="Christian Müller" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Christian Müller</div>

																							<div class="author-description">
													In seiner Rolle als Senior Solutions Architekt bei Amazon Web Services (AWS) in Frankfurt hilft Christian Müller seinen Kunden, das volle Potenzial der AWS Cloud zu nutzen, um sie so noch erfolgreicher zu machen. Seine besonderen Interessen liegen dabei in den Bereichen Messaging, Event-getriebene Architekturen und Serverless.												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/christian-mueller">Alle Beiträge von Christian Müller</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/cloud/migration-aws-verschluesselung-java-97284" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_81823363.jpg 600w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							Migration nach AWS: Verschlüsselung für Java-Entwickler						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/serverless/migration-aws-managed-services-97020" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_211160746.jpg 600w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							Migration nach AWS: Verwendung von Managed Services						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/cloud/warum-wechseln-aws-migration-96946" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_458567878.jpg 600w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							Migration nach AWS: Wir bringen eine Java-Anwendung in die Cloud						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

																				<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
							    <div class="wpdiscuz_top_clearing"></div>
    <div id="comments" class="comments-area"><div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>            <h3 id="wc-comment-header">
                                Hinterlasse einen Kommentar            </h3>
                    <div id="wpcomm" class="wpdiscuz_unauth wpd-default">
            <div class="wpdiscuz-form-top-bar">
                <div class="wpdiscuz-ftb-left">
                                                            <div id="wc_show_hide_loggedin_username">
                                            </div>
                </div>
                                <div class="wpd-clear"></div>
            </div>


                        <div class="wc_social_plugin_wrapper">
                            </div>
                    <div class="wc-form-wrapper wc-main-form-wrapper"  id='wc-main-form-wrapper-0_0' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                                        <form class="wc_comm_form wc_main_comm_form" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">

                                                                                                        <div class="wc-field-avatararea">
                                        <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" />                                    </div>
                                
                                <textarea id="wc-textarea-0_0" pattern=".{1,4000}" maxlength=4000 placeholder="Beginne eine Diskussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">4000</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                                <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                                <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*">
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website">
                                            </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Geben Sie den CAPTCHA-Code ein">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5f17da803427e"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5f17da803427e" class="wpdiscuz-cnonce" name="cnonce" value="c5f17da803427e" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" title="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" />
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                        </div>
                <div id = "wpdiscuz_hidden_secondary_form" style = "display: none;">
                    <div class="wc-form-wrapper wc-secondary-form-wrapper"  id='wc-secondary-form-wrapper-wpdiscuzuniqueid'  style='display: none;' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                            <div class="wc-secondary-forms-social-content"></div><div class="clearfix"></div>
                                        <form class="wc_comm_form wc-secondary-form-wrapper" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">

                                                                                                        <div class="wc-field-avatararea">
                                        <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="48" height="48" alt="avatar" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 photo avatar-default" />                                    </div>
                                
                                <textarea id="wc-textarea-wpdiscuzuniqueid" pattern=".{1,4000}" maxlength=4000 placeholder="Beteilige dich an der Dikussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">4000</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                                <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                                <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*">
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website">
                                            </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Geben Sie den CAPTCHA-Code ein">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5f17da803449d"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5f17da803449d" class="wpdiscuz-cnonce" name="cnonce" value="c5f17da803449d" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" title="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" />
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                        </div>
                </div>
                                           

                                    <div class="wpdiscuz-front-actions">
                                                    <div class="wpdiscuz-sbs-wrap">
                                <span><i class="far fa-envelope" aria-hidden="true"></i>&nbsp; Subscribe &nbsp;<i class="fas fa-caret-down" aria-hidden="true"></i></span>
                            </div>
                                                                        <div class="clearfix"></div>
                    </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://jaxenter.de/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Benachrichtige mich zu: </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">Alle neuen Kommentare</option>
                                                                                                                            <option value="all_comment" >Nur Antworten zu meinen Kommentar/en</option>
                                                                            </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" type="submit" value="›" name="wpdiscuz_subscription_button" />
                                </div> 
                                                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="9ae236d708" /><input type="hidden" name="_wp_http_referer" value="/serverless/aws-optimierungen-serverless-anwendungen-97443" />                                                                <input type="hidden" value="97443" name="wpdiscuzSubscriptionPostId" />
                            </form>
                                                <div class="wpdiscuz_clear"></div>
                                            </div>
                    
                                <div id="wcThreadWrapper" class="wc-thread-wrapper">
                                    
                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
                <div class="wpdiscuz_clear"></div>
                                            </div>
        </div>
        <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div>
        					</div>
														</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
				<div class="widget sidebarSpecificTagContent"><p><iframe style="margin: 0px; padding: 0px; overflow: hidden; border: none; height: 620px; width: 340px;" src="https://jax.de/session-qualification/speakerboxwjax20/?layout=sidebarfeed&amp;utmtrackerversion=0" width="350" height="620" scrolling="no"><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start">﻿</span><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start">﻿</span><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start">﻿</span><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start">﻿</span><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start">﻿</span></iframe></p>
</div><div class="widget sidebarSpecificTagContent"><p><iframe style="margin: 0px; padding: 0px; overflow: hidden; border: none;" src="https://serverless-architecture.io/session-qualification/speaker-box-sla-3/?layout=sidebarfeed&amp;utmtrackerversion=1" width="350" height="665" scrolling="no"></iframe></p>
</div><div id="custom_html-12" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- /21339274/jaxenter.de_contentAD1_Wordpress -->
<div id='div-gpt-ad-1423038811881-0'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-0'); });
</script>
</div>
</div></div><div id="polls-widget-5" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-51" class="wp-polls">
	<form id="polls_form_51" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_51_nonce" name="wp-polls-nonce" value="384161ec69" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="51" /></p>
		<p><strong>Arbeiten in Zeiten der Pandemie – Sind Sie schon im Home Office?</strong></p><div id="polls-51-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-404" name="poll_51" value="404" /> <label for="poll-answer-404">Ja, ich arbeite Vollzeit im Home Office</label></li>
		<li><input type="radio" id="poll-answer-405" name="poll_51" value="405" /> <label for="poll-answer-405">Ja, allerdings nur teilweise – Ich habe auch einige Office-Termine</label></li>
		<li><input type="radio" id="poll-answer-406" name="poll_51" value="406" /> <label for="poll-answer-406">Nein, ich arbeite im Büro</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(51);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-51-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="media_image-3" class="widget widget_media_image"><a href="https://kiosk.entwickler.de/entwickler-magazin/entwickler-magazin-spezial-vol-24/"><img width="300" height="300" src="https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1-300x300.jpg" class="image wp-image-96312  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1-300x300.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/06/ekiosk_Special_Banner_EMS_Responsive_1200x1200_57842_v1-1.jpg 350w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="aktuelle_magazine-6" class="widget widget_aktuelle_magazine"><p class="widget-title">Aktuelle Magazine</p><div class="aktuelle-ausgaben-wrapper"><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/java-magazin"><img width="150" height="210" src="https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848.jpg 1200w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-214x300.jpg 214w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-730x1024.jpg 730w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-107x150.jpg 107w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-768x1077.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-1095x1536.jpg 1095w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-200x281.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-170x238.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-93x130.jpg 93w, https://jaxenter.de/wp-content/uploads/2020/07/cover_xxx_JM8_20_cover@2x_1592820035848-180x252.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/java-magazin">Java Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/java-magazin" class="button">Alle Infos</a></a></div></div></div></div></div><div id="tag-widget-5" class="widget TagWidget"><a href="https://jaxenter.de/tag/devops"><p class="widget-title">DevOpsCon 2020</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Consul DevOps Interview Istiuo Microservices Service Mesh" id="posts-by-tag-item-97303"><a class="thumb" href="https://jaxenter.de/microservices/consul-service-mesh-97303" title="Consul 1.8 goes Service Mesh: &#8222;Es geht um mehr als nur Kubernetes&#8220;"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin-300x300.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/07/RaymondAustin.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/microservices/consul-service-mesh-97303">Consul 1.8 goes Service Mesh: "Es geht um mehr als nur Kubernetes"</a></li><li class="posts-by-tag-item Corona COVID-19 DevOps Home Office SDM" id="posts-by-tag-item-97196"><a class="thumb" href="https://jaxenter.de/karriere/was-haben-arbeiten-im-home-office-und-sdm-gemeinsam-97196" title="Was haben Arbeiten im Home-Office und SDM gemeinsam?"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1375982312.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/karriere/was-haben-arbeiten-im-home-office-und-sdm-gemeinsam-97196">Was haben Arbeiten im Home-Office und SDM gemeinsam?</a></li><li class="posts-by-tag-item AWS Cloud DevOps Serverless" id="posts-by-tag-item-97173"><a class="thumb" href="https://jaxenter.de/cloud/migration-nach-aws-going-serverless-2-97173" title="Migration nach AWS: Going Serverless"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/07/shutterstock_1125990425.jpg 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/cloud/migration-nach-aws-going-serverless-2-97173">Migration nach AWS: Going Serverless</a></li><li class="posts-by-tag-item CI/CD DevOps ML" id="posts-by-tag-item-96844"><a class="thumb" href="https://jaxenter.de/mlops-you-rock-it-you-roll-it-ci-cd-und-operations-fuer-machine-learning-96844" title="MLOps: You rock it, you roll it! CI/CD und Operations für Machine Learning"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/07/30_Kammer_Visengeriyeva.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/mlops-you-rock-it-you-roll-it-ci-cd-und-operations-fuer-machine-learning-96844">MLOps: You rock it, you roll it! CI/CD und Operations für Machine Learning</a></li><li class="posts-by-tag-item CI/CD Continuous Delivery Continuous Integration DevOps" id="posts-by-tag-item-96839"><a class="thumb" href="https://jaxenter.de/viel-mehr-als-time-to-market-continuous-delivery-warum-man-oefter-deployen-sollte-96839" title="Viel mehr als Time to Market &#8211; Continuous Delivery: Warum man öfter deployen sollte"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/03/Java_header_standard_900x450.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/viel-mehr-als-time-to-market-continuous-delivery-warum-man-oefter-deployen-sollte-96839">Viel mehr als Time to Market - Continuous Delivery: Warum man öfter deployen sollte</a></li><li class="posts-by-tag-item Continuous Integration DevOps DevSecOps Interview Security" id="posts-by-tag-item-96726"><a class="thumb" href="https://jaxenter.de/security/security-interview-lech-sandecki-96726" title="Themenkomplex Security: &#8222;Sicherheit ist eine dauerhaufte Aufgabe, die immer Teil des Entwicklungsprozesses sein sollte&#8220;"  ><img width="146" height="150" src="https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-146x150.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-146x150.jpeg 146w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-293x300.jpeg 293w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-999x1024.jpeg 999w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-768x787.jpeg 768w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-200x205.jpeg 200w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-170x174.jpeg 170w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-78x80.jpeg 78w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-127x130.jpeg 127w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final-180x184.jpeg 180w, https://jaxenter.de/wp-content/uploads/2020/06/Lech-headshot-final.jpeg 1249w" sizes="(max-width: 146px) 100vw, 146px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/security/security-interview-lech-sandecki-96726">Themenkomplex Security: "Sicherheit ist eine dauerhaufte Aufgabe, die immer Teil des Entwicklungsprozesses sein sollte"</a></li></ul></div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        </div>
    </div>
</div>
									</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-79978" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-79978"><a href="https://jaxenter.de/">JAXenter.de</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="https://entwickler.de/javascript-kompendium">JavaScript Kompendium</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="https://entwickler.de/cloud-compendium">Cloud Compendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://serverless-architecture.io/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Serverless Architecture Conference</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="https://mlconference.ai/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Machine Learning Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://blockchainconf.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Blockchain Technology Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="https://e-academy.net/">e.academy</a></li>
<li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-79980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79980"><a href="https://tutorials.entwickler.de/">entwickler.tutorials</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-79979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79979"><a href="https://entwickler.de/jobs">entwickler.jobs</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>
		
		<a id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/jaxenter.de\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
	</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 

Served from: jaxenter.de @ 2020-07-22 08:19:44 by W3 Total Cache
-->