<!DOCTYPE html>
<html lang="de-DE" prefix="og: http://ogp.me/ns#"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>Serverless glücklich: Die erste anspruchsvolle Implementierung mit Fn Project - JAXenter</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>	
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
	<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-563H99');</script>
<!-- End Google Tag Manager -->	
	
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="In seiner neuen Artikelserie stellt Sven Ruppert Oracles Fn Project ausführlich vor und zeigt, was man damit &quot;Serverless&quot; alles anstellen kann."/>
<meta name="robots" content="noodp"/>
<meta name="keywords" content="Cloud,Fn Project,Serverless,Serverless glücklich"/>
<link rel="canonical" href="https://jaxenter.de/oracle-fn-project-serverless-2-74408" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Serverless glücklich: Die erste anspruchsvolle Implementierung mit Fn Project - JAXenter" />
<meta property="og:description" content="In seiner neuen Artikelserie stellt Sven Ruppert Oracles Fn Project ausführlich vor und zeigt, was man damit &quot;Serverless&quot; alles anstellen kann." />
<meta property="og:url" content="https://jaxenter.de/oracle-fn-project-serverless-2-74408" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="Cloud" />
<meta property="article:tag" content="Fn Project" />
<meta property="article:tag" content="Serverless" />
<meta property="article:tag" content="Serverless glücklich" />
<meta property="article:section" content="Artikel" />
<meta property="article:published_time" content="2018-08-29T10:47:25+00:00" />
<meta property="article:modified_time" content="2018-08-29T14:03:30+00:00" />
<meta property="og:updated_time" content="2018-08-29T14:03:30+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200.jpg" />
<meta property="og:image:width" content="301" />
<meta property="og:image:height" content="200" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; Serverless glücklich: Die erste anspruchsvolle Implementierung mit Fn Project Kommentar-Feed" href="https://jaxenter.de/oracle-fn-project-serverless-2-74408/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sands-breaking-news-css'  href='https://jaxenter.de/wp-content/plugins/sands-breaking-news/includes/style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpdiscuz-font-awesome-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-4.6.3/css/font-awesome.min.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz.css?ver=5.0.1' type='text/css' media='all' />

<!-- This site uses the Google Analytics by MonsterInsights plugin v 6.0.13 - https://www.monsterinsights.com/ -->
<!-- Normally you will find the Google Analytics tracking code here, but the webmaster disabled your user group. -->
<!-- / Google Analytics by MonsterInsights -->

<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/wpdcookiejs/customcookie.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Antworten verbergen","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Bitte f\u00fclle alle ben\u00f6tigten Felder aus","wc_invalid_field":"Nicht alle von dir ausgef\u00fcllten Felder sind richtig.","wc_error_empty_text":"Bitte f\u00fclle dieses Feld aus.","wc_error_url_text":"Bitte \u00fcberpr\u00fcfe deine angegebene URL.","wc_error_email_text":"Bitte \u00fcberpr\u00fcfe deine angegebene Email-Adresse.","wc_invalid_captcha":"Leider wurde der CAPTCHA -Code falsch eingetragen","wc_login_to_vote":"Um deine Stimme abgeben zu k\u00f6nnen musst du angemeldet sein.","wc_deny_voting_from_same_ip":"Es ist nur eine Stimm-Vergabe m\u00f6glich.","wc_self_vote":"Eigene Kommentare k\u00f6nnen nicht bewertet werden.","wc_vote_only_one_time":"Es ist immer nur eine Bewertung erlaubt.","wc_voting_error":"Bewertungs-Fehler bei deiner Wahl: Bitte versuche es erneut","wc_held_for_moderate":"Dein Kommentar wurde zur Freischaltung vorgelegt.","wc_comment_edit_not_possible":"Tut uns leid aber dieser Kommentar kann leider nicht mehr aktualisiert werden.","wc_comment_not_updated":"Tut uns leid aber dieser Kommentar konnte leider nicht aktualisiert werden.","wc_comment_not_edited":"Es wurden keine \u00c4nderungen von dir vorgenommen.","wc_new_comment_button_text":"neuer Kommentar","wc_new_comments_button_text":"neue Kommentare","wc_new_reply_button_text":"Neue Antwort auf deinen Kommentar","wc_new_replies_button_text":"Bei einen von dir abonnierten Video wurde eine neue Antwort ver\u00f6ffentlicht.","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","is_user_logged_in":false,"commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wordpress_comment_order":"asc","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":400,"storeCommenterData":100000,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"facebookAppID":"","cookiehash":"b68f42a0021b63881a010e7410207d2c","isLoadOnlyParentComments":0,"version":"5.0.1","wc_post_id":74408,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","lastVisitExpires":1538162830,"lastVisitCookie":{"1":{"74408":1535570830}},"wc_captcha_show_for_guest":"1","wc_captcha_show_for_members":"0","is_email_field_required":"1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js?ver=5.0.1'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.3" />
<link rel='shortlink' href='https://jaxenter.de/?p=74408' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Foracle-fn-project-serverless-2-74408" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Foracle-fn-project-serverless-2-74408&#038;format=xml" />
            <style type="text/css">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</style>
            	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>
		<style type="text/css" id="wp-custom-css">
			/*
Füge deinen eigenen CSS-Code nach diesem Kommentar hinter dem abschließenden Schrägstrich ein. 



Klicke auf das Hilfe-Symbol oben, um mehr zu erfahren.
*/		</style>
	
		        
        <script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + 
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		
		<script type='text/javascript'>
		googletag.cmd.push(function() {
		googletag.defineSlot('/21339274/jaxenter.de_contentAD1_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD2_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-1').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD3_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-2').addService(googletag.pubads());		
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper1_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-4').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper2_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-5').addService(googletag.pubads());
		googletag.pubads().collapseEmptyDivs(true);
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();				
		});
		</script>
        
        <script>
  		googletag.cmd.push(function() {
  		googletag.defineSlot('/21339274/jaxenter.de_leaderboard_Wordpress', [728, 90], 'div-gpt-ad-1423038811881-3')
		.addService(googletag.pubads())    
		.setCollapseEmptyDiv();
		  });
		</script>

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>	
		
		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->

		
	</head>
	<body class="post-template-default single single-post postid-74408 single-format-standard">
		<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-563H99"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
		        <header>    
        <div class="topbanner hidden-xs hidden-sm">
        	<div class="container">
					<!-- jaxenter.de_leaderboard_Wordpress -->
                    <div id='div-gpt-ad-1423038811881-3' style='width:100%; min-height:90px; margin:10px 0;'>
                    <script type='text/javascript'>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-3'); });
                    </script>
                    </div>
            </div>
         </div> 
        	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://jaxenter.de/events">Events</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://jaxenter.de/magazine">Java Magazin</a></li>
<li id="menu-item-39337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39337"><a href="https://jax.de/">W-JAX 2018</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/docker">Docker</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16647" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16647"><a href="https://jaxenter.de/tag/internet-of-things">Internet of Things</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/maschinelles-lernen">Machine Learning</a></li>
</ul>		</div>
	</div>
 
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">Jakarta EE im Klartext:</span>
                                        
                                    <a href="https://jaxenter.de/tag/klartext-jakarta-ee">Unsere neue Interview-Serie zu Enterprise Java</a>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>

			                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/W-JAX-Logo-blau-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jax.de/">W-JAX 2018: 5. bis 9. November in München</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/Docker-Tutorial-300x208-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p><a href="https://jaxenter.de/einfuehrung-docker-tutorial-container-61528">Grundkurs Docker: Eine praktische Einführung in die Welt der Container</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/blockchain-conf-logo-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://blockchainconf.net/">Blockchain Technology Conference: 19. bis 21.11, Berlin</a></p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			
          </div>
          <div class="custom_header_wa">
                    </div>
		</header>
	<script type="text/javascript">
	$( document ).ready(function() {
		$('.single .next-article-popup-post .popup-close').click(function(){
			$('.single .next-article-popup-post').hide();
		});
		$(window).scroll(function() {
		   var hT = $('#content > .text').offset().top,
		       hH = $('#content > .text').outerHeight(),
		       wH = $(window).height(),
		       wS = $(this).scrollTop();
		   if (wS > (hT+hH-wH)){
			   //console.log(wS);
			   if(!$('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').addClass('active');
			   }
		   }else{
			   if($('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').removeClass('active');
			   }
		   }
		});
	}); 
	</script>
	<div class="hidden-xs next-article-popup-post ">
	    <strong class="popup-heading">Nächster Beitrag:</strong>
	    <div class="popup-content">
	    	        <figure class="thumb">
	            <a href="https://jaxenter.de/women-in-tech-samantha-quinones-74427"><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-150x75.jpg" class="alignleft wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2018/08/Women_in_Tech_Aufmacher_900x450_39593_Samantha_Quiniones.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a>
	           <!--  <img src="https://entwickler.de/wp-content/uploads/2017/07/ff-brotli-dotnet-mozilla-stt-engine-90x45.jpg" alt="" data-pin-no-hover="true"> -->
	        </figure>
	   	        <h3 class="popup-post-title"><a href="https://jaxenter.de/women-in-tech-samantha-quinones-74427">"Women in Tech: &#8222;Die besten Entwickler befassen sich mit Problemen, für die es noch keine Lösungen gibt&#8220;"</a></h3>
	    </div>
	    <span class="popup-close">X</span>
	</div>
	


	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Teil 2 – Servlerless für alle</div>
														<h1 class="title">Serverless glücklich: Die erste anspruchsvolle Implementierung mit Fn Project</h1>
							
									<div class="button-tags-block">
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/cloud" target="_blank" >
	                  #Cloud 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/fn-project" target="_blank" >
	                  #Fn Project 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/serverless" target="_blank" >
	                  #Serverless 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/serverless-gluecklich" target="_blank" >
	                  #Serverless glücklich 	         </a>   
	      		</div>
								
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2018-08-29T10:47">29. August 2018</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Sven Ruppert										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="199" src="https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200.jpg 301w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-300x199.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-190x126.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-180x120.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"></div>
								</div>
														
															<div class="excerpt">
									<p>Der Begriff <em>Serverless</em> ist in aller Munde und meist verbunden mit einem der großen Cloud-Anbieter wie Amazon, IBM, Microsoft oder Google. Aber was kann man damit eigentlich machen? Wie funktioniert das ganze und wie kann man sich dem Thema nähern? Und noch wichtiger: Kann man Serverless auch ohne öffentliches Rechenzentrum verwenden? In unserer Artikelserie &#8222;Serverless glücklich&#8220; geht Sven Ruppert, Developer Advocate bei Vaadin, auf diese und weitere Fragen ein und bietet einen Überblick über Oracles Fn Project.</p>
								</div>
													</div>
					
					
					
					<div class="text">
						<p>Im <a href="https://jaxenter.de/oracle-fn-project-serverless-1-73554">ersten Teil</a> der Einführung in Oracles Fn Project haben wir uns angesehen, wie ein <code>HelloWorld</code> als Funktion implementiert werden kann. Die grundlegende Struktur wurde lokal mittels Docker und dem Kommandozeilen-Werkzeug <em>fn</em> vorbereitet. Nun kommen wir zu unserer ersten etwas anspruchsvolleren Implementierung.</p>
<h2>Was wir erreichen wollen</h2>
<p>Ziel ist es, eine minimale Anwendung zu schreiben, die eine Funktion konsumiert. Was wird hierfür benötigt und wie sieht die Entwicklung aus? Als Beispiel werden wir einen einfachen Login-Mechanismus implementieren, der von einer Vaadin-Anwendung verwendet wird.</p>
<h2>Benötigte Infrastruktur</h2>
<p>Bisher wurde der FN Server via Kommandozeilenwerkzeug gestartet. Allerdings handelt es sich hier auch lediglich um einen recht einfachen Docker-Aufruf, da der Fn Server selbst als Docker Image vorhanden ist. Da wir sowohl den Fn Server als auch das dazugehörige User Interface starten möchten, werden alle benötigten Elemente in einer Datei <code>docker-compose.yml</code> gespeichert. Der nachfolgende Befehl <code>docker-compose up</code> wird bei Bedarf die benötigten Images aus dem Internet herunterladen und die entsprechenden Conatiner erzeugen sowie starten.</p>
<pre class="brush: plain; title: ; notranslate" title="">
version: '3'
services:

  fnserver:
    image: fnproject/fnserver
    hostname: fnserver
    container_name: fnserver
    restart: always
    ports:
      - &quot;8080:8080&quot;
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock

  fnserver-ui:
    image: fnproject/ui
    hostname: fnserver-ui
    container_name: fnserver-ui
    restart: always
    ports:
      - &quot;4000:4000&quot;
    depends_on:
          - fnserver
    links:
      - &quot;fnserver&quot;
    environment:
      - FN_API_URL=http://fnserver:8080
</pre>
<p>Der Fn Server ist unter dem Port <code>8080</code> und die grafische Oberfläche unter dem Port <code>4000</code> erreichbar. Ein erster Test zeigt einem dann das nachfolgende Bild auf dem Bildschirm.</p>
<p><a href="https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001.png"><img src="https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001.png" alt="" width="700" class="aligncenter size-full wp-image-74410" srcset="https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001.png 2000w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-150x67.png 150w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-300x134.png 300w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-768x343.png 768w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-1024x457.png 1024w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-200x89.png 200w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-170x76.png 170w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-120x54.png 120w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-190x85.png 190w, https://jaxenter.de/wp-content/uploads/2018/08/fnproject-001-img-001-180x80.png 180w" sizes="(max-width: 2000px) 100vw, 2000px" /></a></p>
<h2>Die Modul-Struktur</h2>
<p>Sehen wir uns zu Beginn an, wie das Projekt strukturiert werden soll. Wie wir später sehen werden, ist es notwendig, die einzelnen Elemente in diesem Projekt in einzelne Maven-Projekte auszulagern. </p>
<p>Um das Beispiel möglichst überschaubar zu halten, werden wir das Projekt lediglich in drei Teile aufteilen. Der erste Teil ist das API das auf beiden Seiten, der grafischen Oberfläche und auf der Fn-Project-Seite, eingesetzt wird. Ich gehe in diesem Beispiel diesen Weg, da auf beiden Seiten Java die verwendete Sprache sein wird. Aus diesem Grund beitet es sich an, die Schnittstelle ebenfalls in Java zu definieren. Würden unterschiedliche Sprachen zum Einsatz kommen, wäre das JSON-Modell die einzige Schnittstellendefinition.</p>
<p>Wie gerade schon angedeutet, gibt es dann noch zwei weitere Teile. Zum Einen die grafische Oberfläche, in der auch der Client-Teil zu den Fn-Funktionen abgebildet wird. Der dritte und letzte Teil ist dann die Fn-Funktionen-Seite. Hierbei handelt es sich um die Schnittstellenimplementierung mittels Fn Project.</p>
<p>Alles zusammen haben wir also nun folgende Projekte:</p>
<ul>
<li>API-Projekt zur Definition der Schnittstelle</li>
<li>Fn-Project-Module</li>
<li>UI als grafische Schnittstelle zum Benutzer</li>
</ul>
<p>Für ein <code>Hello World</code> ist das schon einiges.  </p>
<div class='widgets_on_page'> <div id="wysiwyg_widgets_widget-8" class="widget widget_wysiwyg_widgets_widget"><!-- Widget by WYSIWYG Widgets v2.3.6 - https://wordpress.org/plugins/wysiwyg-widgets/ --><div class="widgets_on_page">
<div id="wp_editor_widget-3" class="widget WP_Editor_Widget">
<div style="width: 100%; padding: 0px 0px 0px 0px; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box" style="margin: 0 !important; padding: 0;">
<div class="row">
<div class="sands-sb-content col-xs-3 col-sm-3 col-lg-3">
<div style="padding: 10px;"><img style="max-width: 100%; height: auto; border: 0px solid #fff;" src="https://jaxenter.de/wp-content/uploads/2018/06/DOC_Cover_Whitepaper-1.jpg" alt="DevOpsCon Whitepaper 2018" width="500" height="350" /></div>
</div>
<div class="sands-sb-content col-xs-9 col-sm-9 col-lg-9">
<h3 style="padding-top: 20px !important; color: #ff7800 !important; text-align: center !important; font-size: 19px !important;"><strong>Free: 40+ pages of DevOps expert knowledge</strong></h3>
<div style="padding: 10px;">
<div class="sb-content-item-sands" style="border-bottom: 0px solid #9d9d9c; padding: 0;">
<p style="margin: 5px; color: #000;">Learn about <strong>Containers</strong>,<strong>Continuous Delivery</strong>, <strong>DevOps Culture</strong>, <strong>Cloud Platforms</strong> &amp; <strong>Security</strong> with articles by experts like Kai Tödter (Siemens), Nicki Watt (OpenCredo), Tobias Gesellchen (Europace AG) and many more.</p>
<div class="button" style="margin: 0 auto; padding: 20px 0px 0px 0px; text-align: center;"><a style="padding: 5px; color: white; background-color: #ff7800; text-decoration: none; border-radius: 10px !important;" href="https://devopsconference.de/devops-kultur/experten-dossier-2018/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_campaign=contentboxdossier2018"><strong>Download whitepaper for free</strong></a></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<!-- / WYSIWYG Widgets --></div>
  </div><!-- widgets_on_page -->
<h3>&#8222;fnproject-helloworld-modules-api-login&#8220;</h3>
<p>Das Obermodul-API wird für die einzelnen Aufgaben in Module zerteilt. Eines davon ist derzeit das Modul, welches die Definition für den Login-Service bereitstellt. Die Unterteilung wird hier aus dem Grunde vorgenommen, da die Teilfunktionen in dazu korrespondierenden unabhängige Fn-Project-Funktionen abgebildet werden. Die Anwendung, also das UI selbst, erhält alle Abhängigkeiten, um daraus das Backend der Anwendung zu konsumieren.</p>
<h3>&#8222;fnproject-helloworld-modules-ui&#8220;</h3>
<p>In diesem Modul werden die UI-Elemente der Anwendung untergebracht. Die Vaadin-Anwendung wird den mittels Fn Project den angebotenen Service konsumieren und damit den Log-in-Prozess abbilden.</p>
<h3>&#8222;fnproject-helloworld-modules-services-login&#8220;</h3>
<p>Korrespondierend zu dem Modul <code>fnproject-helloworld-modules-api-login</code> handelt es sich bei diesem Modul um die Implementierung selbst. Die Implementierung enthält den Server-Teil. Dieser stellt die Fn-Project-Funktion dar, die dann von dem Client konsumiert werden wird. </p>
<h2>Das API &#8222;LoginService&#8220;</h2>
<p>Das API, das hier zum Einsatz kommen soll, ist sehr überschaubar, handelt es sich doch um lediglich eine zu implementierende Funktionalität. Was hier auffällt, ist die Verwendung der Jackson-Annotationen: Diese sind notwendig, um das Mapping zwischen Pojo und JSON zu definieren. </p>
<p>Eine Frage, die sich immer wieder stellen wird, ist die Frage nach dem richtigen Ort, an dem API-Definitionen und Modelle mit technischen Annotationen durchsetzt werden. Hier habe ich mich der Einfachheit halber dafür endschieden, dieses direkt in dem Modell und damit auch in dem API zu verwenden. Damit ist das API natürlich technisch nicht mehr neutral.</p>
<pre class="brush: java; title: ; notranslate" title="">
public class Login extends Pair&lt;String, String&gt; {

  @JsonCreator
  public Login(
      @JsonProperty(&quot;login&quot;) String login,
      @JsonProperty(&quot;password&quot;) String password) {
    super(login, password);
  }

  public static CheckedFunction&lt;Login, String&gt; toJson() {
    return (login) -&gt; {
      final ObjectMapper objectMapper = new ObjectMapper();
      return objectMapper.writerFor(Login.class).writeValueAsString(login);
    };
  }

  public static CheckedFunction&lt;String, Login&gt; fromJson() {
    return (json) -&gt; new ObjectMapper()
        .readerFor(Login.class)
        .readValue(json);
  }

  public String getLogin() {
    return getT1();
  }

  public String getPassword() {
    return getT2();
  }
}

public interface LoginService {
  boolean checkLogin(Login login);
</pre>
<p>Die Aufgabe ist schnell erklärt. Basierend auf den Parametern mit den Namen <code>login</code> und <code>passwd</code> wird ein Boolean zurückgeliefert. <code>TRUE</code> bedeutet, dass es sich um eine valide Kombination handelt.</p>
<h2>Services – Log-in – FN</h2>
<p>Kommen wir nun zu der Implementierung der Log-in-Funktion. Die Logik selbst kann in Core Java geschrieben werden. Das bedeutet auch, dass die Logik selbst mittels JUnit getestet werden kann und dabei kein weiterer Technologie-Stack notwendig ist. In diesem Beispiel wird absichtlich auf eine Nutzerdatenbank oder Frameworks wie zum Beispiel Keycloack oder Shiro verzichtet.  </p>
<pre class="brush: java; title: ; notranslate" title="">
public class LoginServiceFN implements LoginService {

  @Override
  public boolean checkLogin(Login login) {
    return match(
        matchCase(() -&gt; success(FALSE)),
        matchCase(() -&gt; login == null,
                  () -&gt; failure(&quot;login should not be null&quot;)
        ),
        matchCase(() -&gt; login.getLogin() == null ||
                        login.getPassword() == null,
                  () -&gt; failure(&quot;login or passwd is null&quot;)
        ),
        matchCase(() -&gt; login.getLogin().isEmpty() ||
                        login.getPassword().isEmpty(),
                  () -&gt; failure(&quot;login or passwd is empty&quot;)
        ),
        matchCase(() -&gt; login.getLogin().equals(&quot;admin&quot;) &amp;&amp;
                        login.getPassword().equals(&quot;admin&quot;),
                  () -&gt; success(TRUE)
        )
    )
        .ifAbsent(System.out::println) //logger to use
        .getOrElse(() -&gt; FALSE);
  }
}
</pre>
<p>Diese Implementierung erlaubt lediglich die Authentifizierung mit dem Usernamen <code>admin</code> und dem Passwort <code>admin</code>. Via JUnit kann sie nun getestet werden:</p>
<pre class="brush: java; title: ; notranslate" title="">
  @Test
  void checkLogin000() {
    final Login login = new Login(&quot;admin&quot;, &quot;admin&quot;);
    boolean checkLogin = new LoginServiceFN().checkLogin(login);
    Assertions.assertTrue(checkLogin);
  }

  @Test
  void checkLogin001() {
    final Login login = new Login(&quot;admin&quot;, &quot;&quot;);
    boolean checkLogin = new LoginServiceFN().checkLogin(login);
    Assertions.assertFalse(checkLogin);
  }

  @Test
  void checkLogin002() {
    final Login login = new Login(&quot;admin&quot;, null);
    boolean checkLogin = new LoginServiceFN().checkLogin(login);
    Assertions.assertFalse(checkLogin);
  }
</pre>
<p>Oracles Fn Project bietet einem noch (derzeit ausschließlich auf Basis von jUnit4) die Möglichkeit, die Funktionen lokal zu testen. Realisiert worden ist diese Funktionalität durch den Einsatz einer <em>Rule</em> mit dem Klassenanemn <code>FnTestingRule</code>.</p>
<pre class="brush: java; title: ; notranslate" title="">
  @Rule //junit4 !!
  public final FnTestingRule testing = FnTestingRule.createDefault();

  public static CheckedFunction&lt;Login, String&gt; toJson() {
    return (login) -&gt; {
      final ObjectMapper objectMapper = new ObjectMapper();
      return objectMapper.writerFor(Login.class).writeValueAsString(login);
    };
  }

  private Consumer&lt;Triple&lt;String, String, String&gt;&gt; test() {
    return (triple) -&gt; toJson()
        .apply(new Login(triple.getT1(), triple.getT2()))
        .ifAbsent(() -&gt; {
          throw new RuntimeException(&quot;JSON Encoding failed for &quot; + triple.getT1() + &quot; - &quot; + triple.getT2());
        })
        .ifPresent(success -&gt; {
                     testing.givenEvent().withBody(success).enqueue();
                     testing.thenRun(LoginServiceFN.class, &quot;checkLogin&quot;);
                     assertEquals(triple.getT3(), testing.getOnlyResult().getBodyAsString());
                   }
        );
  }

  @Test //junit4 !!
  public void checkLogin000() {
    test().accept(next(&quot;admin&quot;, &quot;admin&quot;, &quot;true&quot;));
  }

  @Test //junit4 !!
  public void checkLogin001() {
    test().accept(next(&quot;admin&quot;, null, &quot;false&quot;));
  }

  @Test //junit4 !!
  public void checkLogin002() {
    test().accept(next(&quot;admin&quot;, &quot;asas&quot;, &quot;false&quot;));
  }
</pre>
<p>Nun wurde die Funktion, die abgebildet worden ist, auf zwei verschiedene Arten getestet. In diesem Beispiel müssen die Tests noch unabhängig voneinander gepflegt werden. Das ist sicherlich bei größeren Projekten nicht ratsam. In unserem Beispiel gibt es einem aber erst einmal die Möglichkeit, beide Arten der Tests auszuprobieren und miteinander zu vergleichen.</p>
<p>Kommen wir nun zu der Herausforderung, die Fn-Funktion in einem Docker-Container anzubieten und dort zu testen. Das ist ja schließlich der finale Zustand, der funktionieren muss. Hierzu wird das Image gebaut, um dann nachfolgend im Docker Host verwendet werden zu können. Auf der Kommandozeile kann mit dem Befehl <code>fn deploy --all --local</code> der Bereitstellungsprozess gestartet werden. Als erstes wird die Versionsnummer inkrementiert, danach das Image neu gebaut. Zu guter Letzt wird ein Container gestartet und die Route innerhalb von FN gesetzt. </p>
<p>Wurde der Befehl erfolgreich abgeschlossen, kann man mit dem Aufruf <code>fn routes list vaadin-fnproject-002</code> überprüfen, wie die URL auf die Funktion gesetzt worden ist. In diesem Fall ergibt sich bei mir die folgende Ausgabe.</p>
<pre class="brush: plain; title: ; notranslate" title="">
$ fn routes list vaadin-fnproject-002
path            image                                           endpoint
/service-login  publications/vaadin-fnproject-002-login:0.0.15  localhost:8080/r/vaadin-fnproject-002/service-login
</pre>
<p>Da die Funktion nun innerhalb des Docker Host bereitgestellt worden ist, kann der Zugriff per <code>curl</code> überprüft werden. Hierzu nehmen wir die URL, die uns gerade auf der Komandozeile ausgegeben worden ist, und verwenden diese:</p>
<pre class="brush: plain; title: ; notranslate" title="">
curl -X POST -d '{}' http://localhost:8080/r/vaadin-fnproject-002/service-login
</pre>
<p>Bei diesem Aufruf übergeben wir keine Daten, demnach liefert die Funktion als Ergebnis ein <code>false</code>. Soweit stimmt alles. Wenn der Aufruf mit Daten versehen wird, in unserem Fall mit <code>admin</code> und <code>admin</code>, bekommen wir <code>true</code> zurück. Die Funktion erfüllt also die für sie vorgesehene Aufgabe.</p>
<h2>Fullstack-Test der Funktionen</h2>
<p>Wir haben bisher die Möglichkeiten angesehen, wie man die Logik losgelöst von der umhüllenden Technologie testen kann. Der Test auf dem lokalen System mittels der im FDK gelieferten <code>Rule</code> bringt einen schon näher an die realen Eigenschaften des Systems heran. Hier wird man zum Beispiel damit konfrontiert, wie das JSON Encoding funktioniert. Aber wie kann man nun das Gesamtsystem testen?</p>
<p>Notwendig hierfür ist eine in Docker lauffähige Funktionsinstanz. Der JUnit-Test kann mittels HttpOK einen Request gleich dem Aufruf mittels <code>curl</code> erzeugen und absetzen. Auch hier werden wieder Request-/Response-Paare definiert. Aber wenn man sich das ein wenig genauer überlegt, so hat man all diese Dinge ja schon einmal implememntiert.</p>
<h2>Anbindung an die Vaadin-App</h2>
<p>Kommen wir zu der Anbindung an die Vaadin-Anwendung. Hier werden wir nun basierend auf den Eingabewerten die Funktion aufrufen und dann entscheiden, ob man einen erfolgreichen Log-in hatte oder nicht. Der Aufbau der Vaadin-Anwendung selbst ist sehr einfach gehalten, da es sich um eine Demonstration handelt. Wer mehr darüber lesen möchte, der sollte sich die <a href="https://github.com/Nano-Vaadin-Demos/nano-vaadin">entsprechende Dokumentation</a> ansehen.</p>
<p>Die erste Komponente, die zum Einsatz kommt, ist in diesem Fall die <code>LoginComponent</code>. Es werden lediglich ein Textfeld, ein Passwortfeld und zwei Buttons angezeigt. Der eine Button, um den Log-in-Prozess zu starten, der andere, um den Prozess vollständig abzubrechen. Der dafür notwendige Quelltext kann recht einfach gehalten werden. Wir gehen hier nicht von einer Anwendung aus, die in Produktion gehen soll.</p>
<pre class="brush: java; title: ; notranslate" title="">
public class LoginComponent extends Composite implements HasLogger {

  private final TextField     loginField    = new TextField();
  private final PasswordField passwordField = new PasswordField();
  private final Button        okButton      = new Button();
  private final Button        cancelButton  = new Button();
  private final FormLayout    formLayout    = new FormLayout(loginField,
                                                             passwordField,
                                                             new HorizontalLayout(
                                                                 okButton, 
                                                                 cancelButton));

  public LoginComponent() {

    loginField.setCaption(&quot;Username&quot;);
    passwordField.setCaption(&quot;Password&quot;);

    okButton.setCaption(&quot;OK&quot;);
    cancelButton.setCaption(&quot;Cancel&quot;);

    setCompositionRoot(formLayout);
  }

  public Component postConstruct() {

    okButton.addClickListener((Button.ClickListener) clickEvent -&gt; {
      LoginServiceClient client = new LoginServiceClient();
      Login              login  = new Login(
                                        loginField.getValue(),
                                        passwordField.getValue());
      if (client.checkLogin(login)) {
        LoginComponent
            .this
            .getUI()
            .setContent(new DashboardComponent().postConstruct());
      } else {
        cancelButton.click();
      }
    });

    cancelButton.addClickListener((Button.ClickListener) clickEvent -&gt; {
      loginField.setValue(&quot;&quot;);
      passwordField.setValue(&quot;&quot;);
    });
    return this;
  }
}
</pre>
<p>Das Verhalten ist schnell erklärt: Immer dann, wenn der Button <code>OK</code> betätigt wird, werden die Werte, die in den beiden Eingabefeldern sind, abgeholt und in eine Instanz der Klasse <code>Login</code> verpackt. Diese Instanz wird dann der Instanz der Klasse <code>LoginServiceClient()</code> übergeben. Liefert der Aufruf <code>true</code> zurück, so ist der Log-in-Prozess erfolgreich verlaufen. Als Reaktion darauf wird die angezeigte Komponente gegen eine Instanz der Klasse <code>DashboardComponent</code> ausgetauscht.</p>
<p>Von Bedeutung ist demnach die Implementierung der Klasse <code>LoginServiceClient</code>. Hier handelt es sich um die Implementierung, die eine Anfrage an die Funktion stellen soll, die wir vorher im Docker Host aktiviert und mittels <code>curl</code> getestet haben.</p>
<h2>Die Client-Implementierung</h2>
<p>Die Client-Implementierung ist in unserem Beispiel via HttpOK umgesetzt worden. Der Client implementiert, genau wie die Funktions-Implementierung, das Interface <code>LoginServer</code>. Hierbei handelt es sich um eine Besonderheit, da wir beide Seiten mittels Java implementieren. Zudem ist in dieser Implementierung die URL zum Service direkt angegeben worden, was für eine Implementierung im produktiven Einsatz selbstverständlich nicht zu empfehlen ist.</p>
<pre class="brush: java; title: ; notranslate" title="">
public class LoginServiceClient implements LoginService {

  public static final MediaType JSON
      = MediaType.parse(&quot;application/json; charset=utf-8&quot;);

  // not production ready ,-)
  public static final String URL = &quot;http://127.0.0.1:8080/r/vaadin-fnproject-002/service-login&quot;;

  //performs best if client will be shared
  private static final OkHttpClient client = new OkHttpClient();

  public CheckedBiFunction&lt;String, String, String&gt; request() {
    return (url, json) -&gt; {
      final Request request = new Request.Builder()
          .url(url)
          .post(RequestBody.create(JSON, json))
          .build();
      return client
          .newCall(request)
          .execute()
          .body()
          .string();
    };
  }

  @Override
  public boolean checkLogin(Login login) {
    if (login == null) return false;
    return toJson()
        .apply(new Login(login.getLogin(), login.getPassword() ))
        .flatMap(loginAsJson -&gt;
                     request()
                         .apply(URL, loginAsJson)
                         .or(() -&gt; Result.success(&quot;false&quot;))
        )
        .map(Boolean::parseBoolean)
        .getOrElse(() -&gt; Boolean.FALSE);
  }
}
</pre>
<h2>Fazit – Der Workflow</h2>
<p>Wenn man nun soweit gekommen ist und einige Versuche unternommen hat, Änderungen, die im API vorgenommen worden sind, bis in die Funktion hinein zu bekommen, so fällt einem einiges auf. Der praktische Ablauf bei der Entwicklung ist durch einige Eigenarten geprägt. Wenn man zum Beispiel die Signatur der Methode im Interface verändert, so muss man <code>mvn clean deploy</code> durchführen. Das ist notwendig, damit der <code>SNAPSHOT</code> in dem genutzten Repository verfügbar ist.</p>
<p>Ein <code>install</code> reicht nicht aus. Das liegt darin begründet, das der Build-Prozess, der später innerhalb von Docker gestartet wird, diesen <code>SNAPSHOT</code> benötigt. Das führt dazu, dass ohne weitere Vorkehrungen der Zugriff auf das lokale <code>.m2</code>-Verzeichnis nicht gegeben ist. Was ebenfalls auffällt: der Caching-Vorgang beim Bauen der Images führt dazu, dass manchmal Änderungen nicht aktiviert werden. Das passiert zum Beispiel dann, wenn die vorherige Stufe alle Dependencys abgeholt hat und nur der nachfolgende Übersetzungsprozess fehlgeschlagen ist. In diesem Fall muss man die Images, die temporär zum Einsatz kommen, manuell löschen. Sind diese Images gelöscht, so beginnt der Prozess von Beginn an. Der nächste Punkt, der dann auffällt, ist der Zeitbedarf, um wieder alle Dependencys aus dem Internet zu holen. Was bei einer guten Internetverbindung kaum auffällt, nervt gewaltig, wenn man eben nur recht schmalbandig an das Internet angebunden ist. </p>
<p>All diese Eigenarten zusammengefasst, ergeben sich folgende Punkte, die einer Optimierung bedürfen:</p>
<ul>
<li>Ein lokal verfügbares Maven Repository</li>
<li>Eine Build Pipeline, die alle Module nacheinander automatisch baut und bereitstellt</li>
<li>Ein auf Wunsch deaktiviertes Caching der einzelnen Build-Stufen (Docker Images)</li>
<li>Ein Update der auf JUnit4 basierenden Testunterstützung auf JUnit5</li>
</ul>
<p>Wir werden in den nächsten Teilen auf genau diese Dinge eingehen.</p>
<p align="center"><strong>Happy Coding!</strong></p>
<p align="center"><iframe sandbox="allow-scripts" security="restricted" src="https://jaxenter.de/oracle-fn-project-serverless-1-73554/embed" width="700" height="400" title="&#8222;Serverless glücklich: Eine Einführung in Oracles Fn Project&#8220; &#8212; JAXenter" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" class="wp-embedded-content"></iframe></p>
					</div>
					
										
					
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/oracle-fn-project-serverless-2-74408" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/oracle-fn-project-serverless-2-74408" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=Serverless glücklich: Die erste anspruchsvolle Implementierung mit Fn Project - https://jaxenter.de/oracle-fn-project-serverless-2-74408" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/oracle-fn-project-serverless-2-74408" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/oracle-fn-project-serverless-2-74408" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/oracle-fn-project-serverless-2-74408" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/oracle-fn-project-serverless-2-74408" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/oracle-fn-project-serverless-2-74408" data-url-old=""></span></div>
						</a>
					</div>
					
					<div class="row"><div class="more-topics"><div class="col-xs-12 col-md-3"><h3 class="box-headline">Verwandte Themen:</h3></div><div class="col-xs-12 col-md-9">		<div class="button-tags-block">
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/cloud" target="_blank" >
	                   Cloud 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/fn-project" target="_blank" >
	                   Fn Project 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/serverless" target="_blank" >
	                   Serverless 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/serverless-gluecklich" target="_blank" >
	                   Serverless glücklich 	         </a>   
	      		</div>
	</div></div></div>
					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2015/01/ruppert_sven_sw-150x143.jpg" width="96" height="92" alt="Sven Ruppert" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Sven Ruppert</div>

																							<div class="author-description">
													Sven Ruppert arbeitet seit 1996 mit Java und ist Developer Advocate bei Vaadin. In seiner Freizeit spricht er auf internationalen und nationalen Konferenzen, schreibt für IT-Magazine und für Tech-Portale. Twitter: @SvenRuppert												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/svenruppert">Alle Beiträge von Sven Ruppert</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/oracle-fn-project-serverless-1-73554" rel="bookmark">
						<div class="image">
															<img width="190" height="126" src="https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-190x126.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-190x126.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-300x199.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2018/08/oracle-project-fn-serverless-300x200.jpg 301w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							Serverless glücklich: Eine Einführung in Oracles Fn Project						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/einfuehrung-fn-serverless-64209" rel="bookmark">
						<div class="image">
															<img width="130" height="130" src="https://jaxenter.de/wp-content/uploads/2017/11/quillin_bob-130x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/11/quillin_bob-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/11/quillin_bob-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/11/quillin_bob-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/11/quillin_bob-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/11/quillin_bob-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/11/quillin_bob-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/11/quillin_bob.jpg 254w" sizes="(max-width: 130px) 100vw, 130px" />													</div>
						<div class="title">
							Einführung in Fn: &#8222;Serverless muss offen, Community-gesteuert und Cloud-neutral sein&#8220;						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/microservices-aws-cloud-moellering-63188" rel="bookmark">
						<div class="image">
															<img width="186" height="130" src="https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1-186x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/10/Sascha-Möllering-1.jpg 500w" sizes="(max-width: 186px) 100vw, 186px" />													</div>
						<div class="title">
							&#8222;Das Aufbrechen eines Monolithen in Microservices ist keine triviale Aufgabe&#8220;						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

																				<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
							    <div class="wpdiscuz_top_clearing"></div>
                    <div id="comments" class="comments-area">
                    <div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>
                            <h3 id="wc-comment-header">Hinterlasse einen Kommentar</h3>
                <div id="wpcomm" class="wpdiscuz_unauth wpd-default">
                            <div class="wc-comment-bar">
                    <p class="wc-comment-title">
                        Hinterlasse den ersten Kommentar!                    </p>
                    <div class="wpdiscuz_clear"></div>
                </div>
                                    <div class="wc_social_plugin_wrapper">
                            </div>
                    <div class="wc-form-wrapper wc-main-form-wrapper"  id='wc-main-form-wrapper-0_0' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                                        <form class="wc_comm_form wc_main_comm_form" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                                                                                <div class="wc-field-avatararea">
                                <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="64" height="64" alt="avatar" class="avatar avatar-64 wp-user-avatar wp-user-avatar-64 photo avatar-default" />                            </div>
                                                <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">
                                <textarea id="wc-textarea-0_0" pattern=".{1,400}" maxlength=400 placeholder="Beginne eine Diskussion" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">400</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fa fa-user"></i></div>
                                                <input required="required" class="wc_name wpd-field" type="text" name="wc_name" value="" placeholder="Name" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fa fa-at"></i></div>
                                                <input required="required" class="wc_email wpd-field" type="email" name="wc_email" value="" placeholder="Email">
                            </div>
                            <div class="wpdiscuz-item wpd-has-icon">
                                        <div class="wpd-field-icon"><i class="fa fa-link"></i></div>
                                        <input class="wc_website wpd-field" type="text" name="wc_website" value="" placeholder="Website">
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Insert the CAPTCHA code">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5b86d76e905cd"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5b86d76e905cd" class="wpdiscuz-cnonce" name="cnonce" value="c5b86d76e905cd" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                
                                            <label class="wpd_label">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <div class="wpd-field-desc"><i class="fa fa-bell wpdicon wpdicon-on"></i><span>Notify of new replies to this comment - (on)</span></div>
                                    <div class="wpd-field-desc"><i class="fa fa-bell-slash wpdicon wpdicon-off"></i><span>Notify of new replies to this comment - (off)</span></div>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                    </div>
                <div id = "wpdiscuz_hidden_secondary_form" style = "display: none;">
                    <div class="wc-form-wrapper wc-secondary-form-wrapper"  id='wc-secondary-form-wrapper-wpdiscuzuniqueid'  style='display: none;' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                            <div class="wc-secondary-forms-social-content"></div>
                                        <form class="wc_comm_form wc-secondary-form-wrapper" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                                                                                <div class="wc-field-avatararea">
                                <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="48" height="48" alt="avatar" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 photo avatar-default" />                            </div>
                                                <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">
                                <textarea id="wc-textarea-wpdiscuzuniqueid" pattern=".{1,400}" maxlength=400 placeholder="Beteilige dich an der Dikussion" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">400</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fa fa-user"></i></div>
                                                <input required="required" class="wc_name wpd-field" type="text" name="wc_name" value="" placeholder="Name" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fa fa-at"></i></div>
                                                <input required="required" class="wc_email wpd-field" type="email" name="wc_email" value="" placeholder="Email">
                            </div>
                            <div class="wpdiscuz-item wpd-has-icon">
                                        <div class="wpd-field-icon"><i class="fa fa-link"></i></div>
                                        <input class="wc_website wpd-field" type="text" name="wc_website" value="" placeholder="Website">
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Insert the CAPTCHA code">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5b86d76e90746"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5b86d76e90746" class="wpdiscuz-cnonce" name="cnonce" value="c5b86d76e90746" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                
                                            <label class="wpd_label">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <div class="wpd-field-desc"><i class="fa fa-bell wpdicon wpdicon-on"></i><span>Notify of new replies to this comment - (on)</span></div>
                                    <div class="wpd-field-desc"><i class="fa fa-bell-slash wpdicon wpdicon-off"></i><span>Notify of new replies to this comment - (off)</span></div>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                    </div>
                </div>
                                           

                <div class="wpdiscuz-front-actions">
                                            <div class="wpdiscuz-sbs-wrap">
                            <span><i class="fa fa-envelope-o" aria-hidden="true"></i>&nbsp; Subscribe &nbsp;<i class="fa fa-caret-down" aria-hidden="true"></i></span>
                        </div>
                                                            <div class="clearfix"></div>
                </div>

                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://jaxenter.de/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Benachrichtige mich zu: </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">Alle neuen Kommentare</option>
                                                                                                                            <option value="all_comment" >Nur Antworten zu meinen Kommentar/en</option>
                                                                            </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" type="submit" value="›" name="wpdiscuz_subscription_button" />
                                </div> 
                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="f8fa88cc27" /><input type="hidden" name="_wp_http_referer" value="/oracle-fn-project-serverless-2-74408" />                                <input type="hidden" value="74408" name="wpdiscuzSubscriptionPostId" />
                            </form>
                                                <div class="wpdiscuz_clear"></div>
                                            </div>
                    
                                <div id="wcThreadWrapper" class="wc-thread-wrapper">
                                    
                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
                <div class="wpdiscuz_clear"></div>
                                            </div>
        </div>
        <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div>
        					</div>
														</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
				<div class="widget sidebarSpecificTagContent serverless"><p><iframe style="margin: 0px; padding: 0px; overflow: hidden; border: none;" src="https://devopsconference.de/session-qualification/speaker-box-devopscon/?layout=sidebarfeed" width="350" height="750" scrolling="no"> </iframe></p>
</div><div id="polls-widget-5" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-35" class="wp-polls">
	<form id="polls_form_35" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_35_nonce" name="wp-polls-nonce" value="abc5097090" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="35" /></p>
		<p><strong>Welches Versionskontrollsystem soll ab Java 12 verwendet werden?</strong></p><div id="polls-35-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-256" name="poll_35" value="256" /> <label for="poll-answer-256">Bazaar</label></li>
		<li><input type="radio" id="poll-answer-257" name="poll_35" value="257" /> <label for="poll-answer-257">BitKeeper</label></li>
		<li><input type="radio" id="poll-answer-258" name="poll_35" value="258" /> <label for="poll-answer-258">Darcs</label></li>
		<li><input type="radio" id="poll-answer-259" name="poll_35" value="259" /> <label for="poll-answer-259">Fossil</label></li>
		<li><input type="radio" id="poll-answer-260" name="poll_35" value="260" /> <label for="poll-answer-260">Git</label></li>
		<li><input type="radio" id="poll-answer-261" name="poll_35" value="261" /> <label for="poll-answer-261">GNU arch</label></li>
		<li><input type="radio" id="poll-answer-262" name="poll_35" value="262" /> <label for="poll-answer-262">Mercurial</label></li>
		<li><input type="radio" id="poll-answer-263" name="poll_35" value="263" /> <label for="poll-answer-263">Monotone</label></li>
		<li><input type="radio" id="poll-answer-264" name="poll_35" value="264" /> <label for="poll-answer-264">Subversion (SVN)</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(35);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-35-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="aktuelle_magazine-6" class="widget widget_aktuelle_magazine"><p class="widget-title">Aktuelle Magazine</p><div class="aktuelle-ausgaben-wrapper"><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/java-magazin"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2018/07/Java-Magazin-9-18_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/java-magazin">Java Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/java-magazin" class="button">Alle Infos</a></a></div></div></div><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/business-technology"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2018/08/BT_Magazin_3_18_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/business-technology">Business Technology Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/business-technology" class="button">Alle Infos</a></a></div></div></div></div></div><div id="tag-widget-5" class="widget TagWidget"><a href="https://jaxenter.de/tag/devops"><p class="widget-title">DevOpsCon 2018</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Agile Business DevOps DevOps Stories Karriere" id="posts-by-tag-item-73738"><a class="thumb" href="https://jaxenter.de/devops-stories-entwickler-psychologie-73738" title="DevOps Stories: Wie kann man nur …!? – Wieso Entwickler sich mit Psychologie beschäftigen sollten"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/05/DevOps_Stories.jpg 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-stories-entwickler-psychologie-73738">DevOps Stories: Wie kann man nur …!? – Wieso Entwickler sich mit Psychologie beschäftigen sollten</a></li><li class="posts-by-tag-item Architektur DevOps Microservices" id="posts-by-tag-item-73920"><a class="thumb" href="https://jaxenter.de/praxis-check-software-architektur-73920" title="Praxis-Check Software-Architektur: Die Rolle des Architekten &#8211; vom Kathedralenbauer zum Change Manager?"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/08/software-architektur-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2018/08/software-architektur.jpg 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/praxis-check-software-architektur-73920">Praxis-Check Software-Architektur: Die Rolle des Architekten - vom Kathedralenbauer zum Change Manager?</a></li><li class="posts-by-tag-item Agile Container DevOps Java Microservices" id="posts-by-tag-item-73544"><a class="thumb" href="https://jaxenter.de/top-10-juli-2018-73544" title="Monolithen, Microservices, Meecrowave – Top 10 der beliebtesten Themen im Juli"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-200x134.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2018/08/top-10-juli.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/top-10-juli-2018-73544">Monolithen, Microservices, Meecrowave – Top 10 der beliebtesten Themen im Juli</a></li><li class="posts-by-tag-item Container DevOps Security" id="posts-by-tag-item-73378"><a class="thumb" href="https://jaxenter.de/container-sicherheit-devops-73378" title="Wie sichert man Container? Von der Sicherheit der Daten im DevOps-Zeitalter"  ><img width="150" height="91" src="https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213-150x91.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213-150x91.jpg 150w, https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213-300x183.jpg 300w, https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213-200x122.jpg 200w, https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213-170x103.jpg 170w, https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213-120x73.jpg 120w, https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213-190x116.jpg 190w, https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213-180x110.jpg 180w, https://jaxenter.de/wp-content/uploads/2018/07/shutterstock_553567327-350x213.jpg 350w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/container-sicherheit-devops-73378">Wie sichert man Container? Von der Sicherheit der Daten im DevOps-Zeitalter</a></li><li class="posts-by-tag-item Cloud DevOps DevOpsCon 2017 Microservices Testen &amp; Qualität" id="posts-by-tag-item-73057"><a class="thumb" href="https://jaxenter.de/logging-microservices-cloud-fontaine-73057" title="Logging Zeiten von Microservices und der Cloud"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-300x169.png 300w, https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-768x432.png 768w, https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-200x112.png 200w, https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-170x96.png 170w, https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-120x67.png 120w, https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-190x107.png 190w, https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube-180x101.png 180w, https://jaxenter.de/wp-content/uploads/2018/07/Screenshot_2018-07-19-Logging-in-the-age-of-Microservices-and-the-Cloud-YouTube.png 854w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/logging-microservices-cloud-fontaine-73057">Logging Zeiten von Microservices und der Cloud</a></li><li class="posts-by-tag-item DevOps DevOps Stories Kolumne" id="posts-by-tag-item-72936"><a class="thumb" href="https://jaxenter.de/devops-stories-flow-72936" title="DevOps Stories: Ich komme hier zu nichts! Was Unterbrechungen für Entwickler bedeuten"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/10/DevOps_Stories-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-stories-flow-72936">DevOps Stories: Ich komme hier zu nichts! Was Unterbrechungen für Entwickler bedeuten</a></li></ul></div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-4'); });
        </script>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-5'); });
        </script>
        </div>
    </div>
</div>									</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="/magazine/business-technology">Business Technology Magazin</a></li>
<li id="menu-item-38592" class="menu-item menu-item-type-post_type menu-item-object-magazin menu-item-38592"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="http://sharepoint-kompendium.de">SharePoint Kompendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13255"><a href="https://finance.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX Finance (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://btdays.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Business Technology Days</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="http://bigdatacon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BigData Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://webtechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">WebTech Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="http://entwickler-akademie.de">Entwickler Akademie</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>
		
		<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		//document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		
		document.getElementById("syntaxhighlighteranchor").parentNode.insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		//document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
		
		document.getElementById("syntaxhighlighteranchor").parentNode.insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
	</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 

Served from: jaxenter.de @ 2018-08-29 19:27:10 by W3 Total Cache
-->