<!DOCTYPE html>
<html lang="de-DE" prefix="og: http://ogp.me/ns#"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>OpenAPI-Spezifikation 3.0.0 veröffentlicht - JAXenter</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>	
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
		
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Die Open API Initiative hat den Release der OpenAPI-Spezifikation 3.0.0. verkündet."/>
<meta name="robots" content="noodp"/>
<meta name="keywords" content="API"/>
<link rel="canonical" href="https://jaxenter.de/openapi-3-60076" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="OpenAPI-Spezifikation 3.0.0 veröffentlicht - JAXenter" />
<meta property="og:description" content="Die Open API Initiative hat den Release der OpenAPI-Spezifikation 3.0.0. verkündet." />
<meta property="og:url" content="https://jaxenter.de/openapi-3-60076" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="API" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2017-07-28T10:57:36+00:00" />
<meta property="article:modified_time" content="2017-07-28T10:57:56+00:00" />
<meta property="og:updated_time" content="2017-07-28T10:57:56+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635.jpg" />
<meta property="og:image:width" content="6000" />
<meta property="og:image:height" content="4000" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; OpenAPI-Spezifikation 3.0.0 veröffentlicht Kommentar-Feed" href="https://jaxenter.de/openapi-3-60076/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.13 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-18197167-38', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.5" />
<link rel='shortlink' href='https://jaxenter.de/?p=60076' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fopenapi-3-60076" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fopenapi-3-60076&#038;format=xml" />
	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>

		        
        <script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + 
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		
		<script type='text/javascript'>
		googletag.cmd.push(function() {
		googletag.defineSlot('/21339274/jaxenter.de_contentAD1_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD2_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-1').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD3_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-2').addService(googletag.pubads());		
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper1_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-4').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper2_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-5').addService(googletag.pubads());
		googletag.pubads().collapseEmptyDivs(true);
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();				
		});
		</script>
        
        <script>
  		googletag.cmd.push(function() {
  		googletag.defineSlot('/21339274/jaxenter.de_leaderboard_Wordpress', [728, 90], 'div-gpt-ad-1423038811881-3')
		.addService(googletag.pubads())    
		.setCollapseEmptyDiv();
		  });
		</script>

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>	
		
		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->
		
	</head>
	<body class="post-template-default single single-post postid-60076 single-format-standard">
		
        <header>    
        <div class="topbanner hidden-xs hidden-sm">
        	<div class="container">
					<!-- jaxenter.de_leaderboard_Wordpress -->
                    <div id='div-gpt-ad-1423038811881-3' style='width:100%; min-height:90px; margin:10px 0;'>
                    <script type='text/javascript'>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-3'); });
                    </script>
                    </div>
            </div>
         </div> 
        	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://jaxenter.de/events">Events</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://jaxenter.de/magazine">Java Magazin</a></li>
<li id="menu-item-39337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39337"><a href="https://jax.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=menu">W-JAX 2017</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/docker">Docker</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16647" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16647"><a href="https://jaxenter.de/tag/internet-of-things">Internet of Things</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/maschinelles-lernen">Machine Learning</a></li>
</ul>		</div>
	</div>
 
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">BLOCKCHAIN WEEK:</span>
                                        
                                    <u><a href="https://jaxenter.de/blockchain-influencer-bitcoin-59713">Sind Sie schon Teil der Revolution?</a></u>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>
		
		                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/W-JAX-Logo-blau-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=StartseiteFeature&amp;utm_campaign=Headerleiste">W-JAX 2017: Die Konferenz für Java, Architektur- und Software-Innovation</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/angular-4-update-55042">Angular 4: Diese Features müssen Sie kennen</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/Spring-Boot-Tutorial-1-300x300-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/spring-boot-tutorial-54020">Spring Boot Tutorial: So entwickelt man REST-Services mit Spring Boot</a></p>
<p>&nbsp;</p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			

          </div>
		</header>

	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Standardisierung für REST APIs</div>
														<h1 class="title">OpenAPI-Spezifikation 3.0.0 veröffentlicht</h1>
						
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2017-07-28T10:57">28. Juli 2017</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Melanie Feldmann										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="200" src="https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635.jpg 6000w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-1024x683.jpg 1024w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/shutterstock_571421635-180x120.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"><p style="text-align: right;"><span style="color: #999999;">© Shutterstock / studiostoks</span></p>
</div>
								</div>
														
															<div class="excerpt">
									<p>Die Open API Initiative hat den Release der OpenAPI-Spezifikation 3.0.0. verkündet. Nach zwei Jahren Entwicklungszeit ist damit der nächste große Schritt für eine Standardisierung von REST APIs getan.</p>
								</div>
													</div>
					
					
					
					<div class="text">
						<p>Die OpenAPI Spezifikation definiert die Interfaces für RESTful APIs, beschreibt Ressourcen und Operationen in einem Format, das sowohl für Menschen als auch für Maschinen einfach zu verstehen sein soll. Microsoft nutzt die Spezifikation beispielsweise für seine Azure APIs. Die wichtigsten Weiterentwicklungen der Spezifikation betreffen die Untersützung für die Beschreibung von Callbacks,und Links, um Beziehungen zwischen Operationen auszudrücken. Außerdem wurden die Parameterbeschreibungen verbessert. Entwickler können nun Schemas nutzen. Und auch das Handling von mehrteiligen Dokumenten ist jetzt einfacher. Bei der JSON-Unterstützung sind neue Schema wie <code>oneOf</code>, <code>not</code> oder <code>deprecated</code> hinzugekommen. Bisher hat OpenAPI GitHub-Flavored Mardkown (GFM) für die Textbeschreibungen von Services genutzt. Da GFM aber über keine eigene Spezifikation verfügt, ist OpenAPI auf CommonMark umgestiegen. Da CommonMark aber in großen Teilen mit GFM kompatibel ist, sollten hier keine Schwierigkeiten liegen. Dafür soll die Lesbarkeit steigen. Die komplette <a href="https://github.com/OAI/OpenAPI-Specification/blob/master/versions/3.0.0.md" target="_blank" rel="noopener noreferrer">Dokumentation findet sich auf GitHub</a>.</p>
<p style="text-align: center;"><strong>Lesen Sie auch: <a href="https://jaxenter.de/restful-apis-dokumentieren-52052?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_campaign=seealso">RESTful APIs dokumentieren – so geht’s!</a></strong></p>
<h2>Die Open API Initiative</h2>
<p>Die Open API Initiative (OAI) wurde von einem Konsortium von Industrieexperten 2015 gegründet, um eine anbieterneutrale Standardisierung von REST APIs voranzutreiben und zu promoten. Im Zuge der Gründung spendete das Unternehmen SmartBear die Swagger-Spezifikation 2.0. Das bedeutet, dass die OpenAPI-Spezifikation semantisch identisch zu Swagger 2.0 ist. OpenAPI 3.0.0 ist damit eine Weiterentwicklung von Swagger 2.0. Die Organisation ist unter dem Dach der Linux Foundation angesiedelt. Mitglieder sind unter anderem Adobe, Atlassian, Google und die Software AG.</p>
					</div>
					
										
					
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/openapi-3-60076" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/openapi-3-60076" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=OpenAPI-Spezifikation 3.0.0 veröffentlicht - https://jaxenter.de/openapi-3-60076" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/openapi-3-60076" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/openapi-3-60076" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/openapi-3-60076" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/openapi-3-60076" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/openapi-3-60076" data-url-old=""></span></div>
						</a>
					</div>

					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2017/03/Feldmann_Melanie-130x130.jpg" width="96" height="96" alt="Melanie Feldmann" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Melanie Feldmann</div>

																							<div class="author-description">
													Melanie Feldmann ist seit 2015 Redakteurin beim Java Magazin und JAXenter. Sie hat Technikjournalismus an der Hochschule Bonn-Rhein-Sieg studiert. Ihre Themenschwerpunkte sind IoT und Industrie 4.0.												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/melaniefeldmann">Alle Beiträge von Melanie Feldmann</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/twitter-api-plattform-55774" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-200x134.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/04/shutterstock_354572006.jpg 500w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							Das hat Twitter mit seiner API-Plattform gelernt						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/java-magazin-4-2017-api-53516" rel="bookmark">
						<div class="image">
															<img width="92" height="130" src="https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1-92x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1-180x255.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/02/Java-Magazin-4-17_Cover_595x842_v2-1.jpg 595w" sizes="(max-width: 92px) 100vw, 92px" />													</div>
						<div class="title">
							Java Magazin 4.2017 erschienen: Titelthema &#8222;Auf diese APIs können Sie bauen&#8220;						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/natural-language-api-google-liest-auch-zwischen-den-zeilen-43724" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-e1471270143966.jpg 300w, https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2016/07/shutterstock_442139878-180x120.jpg 180w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							Natural Language API: Google liest auch zwischen den Zeilen						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

															<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
													
<div class="comment-form-wrapper">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Schreibe einen Kommentar <small><a rel="nofollow" id="cancel-comment-reply-link" href="/openapi-3-60076#respond" style="display:none;">Antworten abbrechen</a></small></h3>			<form action="https://jaxenter.de/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Deine E-Mail-Adresse wird nicht veröffentlicht.</span></p><p class="comment-form-comment"><label for="comment">Kommentar</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">E-Mail</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Kommentar abschicken" /> <input type='hidden' name='comment_post_ID' value='60076' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d78cf6e908" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="24"/></p>			</form>
			</div><!-- #respond -->
	</div>

											</div>
									</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
					<div id="tag-widget-7" class="widget TagWidget"><a href="https://jaxenter.de/tag/blockchain"><p class="widget-title">Dossier Blockchain</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Bitcoin Blockchain" id="posts-by-tag-item-60039"><a class="thumb" href="https://jaxenter.de/blockchain-bitcoin-disruptiv-60039" title="Blockchain – die Büchse der Pandora: Wie disruptiv ist die Technologie hinter Bitcoin?"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/07/blockchain-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/blockchain-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain.jpg 1000w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/blockchain-bitcoin-disruptiv-60039">Blockchain – die Büchse der Pandora: Wie disruptiv ist die Technologie hinter Bitcoin?</a></li><li class="posts-by-tag-item Bitcoin Blockchain jax tv" id="posts-by-tag-item-60029"><a class="thumb" href="https://jaxenter.de/blockchain-revolution-hyperledger-60029" title="Die Blockchain-Revolution: Warum mit ihr die nächste Generation des Internets beginnt"  ><img width="150" height="84" src="https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195-150x84.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195-150x84.png 150w, https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195-300x167.png 300w, https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195-200x111.png 200w, https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195-170x95.png 170w, https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195-120x67.png 120w, https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195-190x106.png 190w, https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195-180x100.png 180w, https://jaxenter.de/wp-content/uploads/2017/07/Screen-Shot-2017-06-09-at-12.04.11-PM-350x195.png 350w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/blockchain-revolution-hyperledger-60029">Die Blockchain-Revolution: Warum mit ihr die nächste Generation des Internets beginnt</a></li><li class="posts-by-tag-item Bitcoin Blockchain" id="posts-by-tag-item-59873"><a class="thumb" href="https://jaxenter.de/blockchain-chancen-herausforderungen-59873" title="Jenseits des Hypes: Chancen und Herausforderungen der Blockchain"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/07/blockchain-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/blockchain-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain.jpg 1000w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/blockchain-chancen-herausforderungen-59873">Jenseits des Hypes: Chancen und Herausforderungen der Blockchain</a></li><li class="posts-by-tag-item Bitcoin Blockchain" id="posts-by-tag-item-59930"><a class="thumb" href="https://jaxenter.de/ethereum-blockchain-einfuehrung-59930" title="Die Ethereum Blockchain – eine Einführung"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain.jpg 1000w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/ethereum-blockchain-einfuehrung-59930">Die Ethereum Blockchain – eine Einführung</a></li></ul></div><div id="text-16" class="widget widget_text">			<div class="textwidget"><iframe src="https://jax.de/session-qualification/wp-sidebar-feed-featured-box-jax/?layout=sidebarfeed" width="350" height="760" style="margin:0px; padding:0px; overflow:hidden; border:none;" scrolling="no"></iframe></div>
		</div><div id="polls-widget-3" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-23" class="wp-polls">
	<form id="polls_form_23" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_23_nonce" name="wp-polls-nonce" value="35da4b19ad" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="23" /></p>
		<p style="display: none;"><input type="hidden" id="poll_multiple_ans_23" name="poll_multiple_ans_23" value="1" /></p>
		<p><strong>Welche Java-Version setzen Sie ein?</strong></p><div id="polls-23-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="checkbox" id="poll-answer-166" name="poll_23" value="166" /> <label for="poll-answer-166">Java 8</label></li>
		<li><input type="checkbox" id="poll-answer-167" name="poll_23" value="167" /> <label for="poll-answer-167">Java 7</label></li>
		<li><input type="checkbox" id="poll-answer-168" name="poll_23" value="168" /> <label for="poll-answer-168">Java 6</label></li>
		<li><input type="checkbox" id="poll-answer-169" name="poll_23" value="169" /> <label for="poll-answer-169">Java 5</label></li>
		<li><input type="checkbox" id="poll-answer-170" name="poll_23" value="170" /> <label for="poll-answer-170">Java 1.4</label></li>
		<li><input type="checkbox" id="poll-answer-171" name="poll_23" value="171" /> <label for="poll-answer-171">Java 1.3</label></li>
		<li><input type="checkbox" id="poll-answer-172" name="poll_23" value="172" /> <label for="poll-answer-172">Java 1.2</label></li>
		<li><input type="checkbox" id="poll-answer-173" name="poll_23" value="173" /> <label for="poll-answer-173">Java 1.1</label></li>
		<li><input type="checkbox" id="poll-answer-174" name="poll_23" value="174" /> <label for="poll-answer-174">Java 1.0</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(23);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-23-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="aktuelle_magazine-4" class="widget widget_aktuelle_magazine"><p class="widget-title">Aktuelle Magazine</p><div class="aktuelle-ausgaben-wrapper"><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/java-magazin"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/06/Java-Magazin-8-17_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/java-magazin">Java Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/java-magazin" class="button">Alle Infos</a></a></div></div></div><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/business-technology"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/05/BT-Magazin-2-17_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/business-technology">Business Technology Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/business-technology" class="button">Alle Infos</a></a></div></div></div><div class="aktuelle-ausgabe clearfix"><div class="image"><a href="https://jaxenter.de/magazine/eclipse-magazin"><img width="150" height="212" src="https://jaxenter.de/wp-content/uploads/2016/03/ECM-Magazin-3-16_Cover_595x842-e1471272115384.jpg" class="attachment-150x300 size-150x300 wp-post-image" alt="" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></div><div class="button"><a href="https://jaxenter.de/magazine/eclipse-magazin" class="button">Alle Infos</a></a></div></div></div></div></div><div id="tag-widget-2" class="widget TagWidget"><a href="https://jaxenter.de/tag/kolumne"><p class="widget-title">Kolumnen</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Java Kolumne" id="posts-by-tag-item-60048"><a class="thumb" href="https://jaxenter.de/java-8-streams-lazy-60048" title="Sind Java 8 Streams wirklich Lazy? Nicht ganz!"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/Java-8-streams-lazy.jpg 1000w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/java-8-streams-lazy-60048">Sind Java 8 Streams wirklich Lazy? Nicht ganz!</a></li><li class="posts-by-tag-item Diversität Kolumne Women in Tech" id="posts-by-tag-item-59954"><a class="thumb" href="https://jaxenter.de/women-in-tech-donna-dillenberger-59954" title="Women in Tech: &#8222;Im richtigen Unternehmen ist es großartig&#8220;"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Donna_Dillenberger.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/women-in-tech-donna-dillenberger-59954">Women in Tech: "Im richtigen Unternehmen ist es großartig"</a></li><li class="posts-by-tag-item Backend meets Frontend Kolumne Testen &amp; Qualität Vaadin" id="posts-by-tag-item-59524"><a class="thumb" href="https://jaxenter.de/vaadin-selenium-screenshots-59524" title="Backend meets Frontend: Selenium goes Functional"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/vaadin-selenium-screenshots-59524">Backend meets Frontend: Selenium goes Functional</a></li><li class="posts-by-tag-item Backend meets Frontend Kolumne Testen &amp; Qualität Vaadin" id="posts-by-tag-item-59517"><a class="thumb" href="https://jaxenter.de/vaadin-selenium-testgetriebene-entwicklung-59517" title="Testgetriebene Entwicklung mit Vaadin und Selenium"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/vaadin-selenium-testgetriebene-entwicklung-59517">Testgetriebene Entwicklung mit Vaadin und Selenium</a></li><li class="posts-by-tag-item Diversität Kolumne Women in Tech" id="posts-by-tag-item-59580"><a class="thumb" href="https://jaxenter.de/woman-in-tech-heather-vancura-59580" title="Women in Tech: &#8222;Technik spiegelt diejenigen wider, die sie erschaffen&#8220;"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/Women_in_Tech_Aufmacher_900x450_39593_Heather_VanCura.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/woman-in-tech-heather-vancura-59580">Women in Tech: "Technik spiegelt diejenigen wider, die sie erschaffen"</a></li></ul></div><div id="bwp_recent_comments-2" class="widget bwp-rc-widget"><p class="widget-title">Letzte Kommentare</p>
		<ul class="bwp-rc-ulist">
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Rüdiger Möller</span><span class="recent-comment-text"> Runtime Polymorphie ist natürlich langsam. Hotspot ist allerdings so clever, daß er rausfindet wenn es z.B. nur eine Implementierung eines interfaces gibt. http://insightfullogic.com/2014/May/12/fast-and-megamorphic-what-influences-method-invoca/ </span> <a href="https://jaxenter.de/aus-der-java-trickkiste-performancemythen-103#comment-173073" title="Comment on Aus der Java-Trickkiste: Performancemythen"><strong>Aus der Java-Trickkiste: Performancemythen</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Rüdiger Möller</span><span class="recent-comment-text"> leider braucht nashorn ewig, ist einfacher und schneller den kram mit nem externen nodejs prozess/demon zu übersetzen .. </span> <a href="https://jaxenter.de/isomorphe-javascript-webanwendungen-mit-java-ee-und-react-js-38266#comment-173072" title="Comment on Isomorphe JavaScript-Webanwendungen mit Java (EE) und React.JS"><strong>Isomorphe JavaScript-Webanwendungen mit Java (EE) und React.JS</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://secure.gravatar.com/avatar/28305a1ed4eaad62d709724a78b847bd?s=40&#038;d=https%3A%2F%2Fjaxenter.de%2Fwp-content%2Fplugins%2Fwp-user-avatar%2Fimages%2Fwpua-96x96.png&#038;r=g" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">skipperTux</span><span class="recent-comment-text"> Im Code richtig, im Text falsch. "Dazu wird * hinter den Typ geschrieben, der Parameter ist also p Person* [...] Wird ein Struct mit p... </span> <a href="https://jaxenter.de/google-go-golang-java-55356#comment-173062" title="Comment on Google Go für Java-Entwickler: Alles was Sie wissen müssen"><strong>Google Go für Java-Entwickler: Alles was Sie wissen müssen</strong></a></span></li>
		</ul>
</div><div id="featured_posts-2" class="widget widget_featured_posts"><p class="widget-title">Featured Posts</p><ul class="featured-posts-list"><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/blockchain-bitcoin-disruptiv-60039"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/07/blockchain-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/blockchain-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/blockchain.jpg 1000w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/blockchain-bitcoin-disruptiv-60039">Blockchain – die Büchse der Pandora: Wie disruptiv ist die Technologie hinter Bitcoin?</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/expertencheck-java-9-59975"><img width="80" height="80" src="https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-80x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-300x300.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-768x768.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/java-9-Jigsaw-expertencheck.jpg 1000w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="title"><a href="https://jaxenter.de/expertencheck-java-9-59975">Expertencheck Java 9: Wie relevant ist Projekt Jigsaw wirklich?</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/ethereum-blockchain-einfuehrung-59930"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/ethereum-blockchain.jpg 1000w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/ethereum-blockchain-einfuehrung-59930">Die Ethereum Blockchain – eine Einführung</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/google-go-golang-java-55356"><img width="107" height="80" src="https://jaxenter.de/wp-content/uploads/2017/03/shutterstock_248662924-107x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/03/shutterstock_248662924-107x80.jpg 107w, https://jaxenter.de/wp-content/uploads/2017/03/shutterstock_248662924-150x113.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/03/shutterstock_248662924.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/03/shutterstock_248662924-200x150.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/03/shutterstock_248662924-170x128.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/03/shutterstock_248662924-173x130.jpg 173w, https://jaxenter.de/wp-content/uploads/2017/03/shutterstock_248662924-180x135.jpg 180w" sizes="(max-width: 107px) 100vw, 107px" /></a></div><div class="title"><a href="https://jaxenter.de/google-go-golang-java-55356">Google Go für Java-Entwickler: Alles was Sie wissen müssen</a></div></li></ul></div><div id="newsletter-2" class="widget widget_newsletter"><p class="widget-title">Newsletter</p><div class="newsletter"><p class="newsletter-icon pull-left"><a href="https://jaxenter.de/newsletter"><img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter.jpg" alt="Newsletter" /></a></p><p class="newsletter-info"><a href="https://jaxenter.de/newsletter">Alle Neuigkeiten die wichtig sind, mit dem JAXenter Newsletter!</a></p><p><a href="https://jaxenter.de/newsletter">Jetzt bestellen!</a></p></div></div><div id="text-4" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD1_Wordpress -->
<div id='div-gpt-ad-1423038811881-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-0'); });
</script>
</div></div>
		</div><div id="text-5" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD2_Wordpress -->
<div id='div-gpt-ad-1423038811881-1' style='width:300px; height:250px; clear:both;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-1'); });
</script>
</div></div>
		</div><div id="text-6" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD3_Wordpress -->
<div id='div-gpt-ad-1423038811881-2' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-2'); });
</script>
</div></div>
		</div><div id="text-15" class="widget widget_text">			<div class="textwidget"></div>
		</div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-4'); });
        </script>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-5'); });
        </script>
        </div>
    </div>
</div>				</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="/magazine/business-technology">Business Technology Magazin</a></li>
<li id="menu-item-38592" class="menu-item menu-item-type-post_type menu-item-object-magazin menu-item-38592"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="http://sharepoint-kompendium.de">SharePoint Kompendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13255"><a href="https://finance.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX Finance (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://btdays.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Business Technology Days</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="http://bigdatacon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BigData Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://webtechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">WebTech Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="http://entwickler-akademie.de">Entwickler Akademie</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-563H99" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-563H99');</script>
<!-- End Google Tag Manager -->

		
		<!-- Facebook Ads Pixel Code -->
		<script>
			(function() {
				var _fbq = window._fbq || (window._fbq = []);
				if (!_fbq.loaded) {
					var fbds = document.createElement('script');
					fbds.async = true;
					fbds.src = '//connect.facebook.net/en_US/fbds.js';
					var s = document.getElementsByTagName('script')[0];
					s.parentNode.insertBefore(fbds, s);
					_fbq.loaded = true;
				}
				_fbq.push(['addPixelId', '407071789447604']);
			})();
			window._fbq = window._fbq || [];
			window._fbq.push(['track', 'PixelInitialized', {}]);
		</script>
		<noscript>
			<img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=407071789447604&ev=PixelInitialized" />
		</noscript>

		<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.7.5' type='text/css' media='all' />
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.5'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
	</body>
</html>
