<!DOCTYPE html>
<html lang="de-DE" prefix="og: http://ogp.me/ns#"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>Java EE 8: Hält es, was die lange Wartezeit versprochen hat?</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>	
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
		
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Das gerade veröffentlichte Java EE 8 ist deutlich mehr als nur Technologie. Es ist ein Bekenntnis zum Java Community Process Seitens Oracles."/>
<meta name="robots" content="noodp"/>
<meta name="keywords" content="Java,Java EE"/>
<link rel="canonical" href="https://jaxenter.de/java-ee-8-62568" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Java EE 8: Hält es, was die lange Wartezeit versprochen hat?" />
<meta property="og:description" content="Das gerade veröffentlichte Java EE 8 ist deutlich mehr als nur Technologie. Es ist ein Bekenntnis zum Java Community Process Seitens Oracles." />
<meta property="og:url" content="https://jaxenter.de/java-ee-8-62568" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="Java" />
<meta property="article:tag" content="Java EE" />
<meta property="article:section" content="Artikel" />
<meta property="article:published_time" content="2017-09-28T14:53:21+00:00" />
<meta property="article:modified_time" content="2017-09-28T15:13:56+00:00" />
<meta property="og:updated_time" content="2017-09-28T15:13:56+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="200" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; Java EE 8: Hält es, was die lange Wartezeit versprochen hat? Kommentar-Feed" href="https://jaxenter.de/java-ee-8-62568/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.13 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-18197167-38', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.5" />
<link rel='shortlink' href='https://jaxenter.de/?p=62568' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fjava-ee-8-62568" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fjava-ee-8-62568&#038;format=xml" />
	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>

		        
        <script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + 
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		
		<script type='text/javascript'>
		googletag.cmd.push(function() {
		googletag.defineSlot('/21339274/jaxenter.de_contentAD1_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD2_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-1').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_contentAD3_Wordpress', [300, 250], 'div-gpt-ad-1423038811881-2').addService(googletag.pubads());		
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper1_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-4').addService(googletag.pubads());
		googletag.defineSlot('/21339274/jaxenter.de_skyscraper2_Wordpress', [160, 600], 'div-gpt-ad-1423038811881-5').addService(googletag.pubads());
		googletag.pubads().collapseEmptyDivs(true);
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();				
		});
		</script>
        
        <script>
  		googletag.cmd.push(function() {
  		googletag.defineSlot('/21339274/jaxenter.de_leaderboard_Wordpress', [728, 90], 'div-gpt-ad-1423038811881-3')
		.addService(googletag.pubads())    
		.setCollapseEmptyDiv();
		  });
		</script>

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>	
		
		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->
		
	</head>
	<body class="post-template-default single single-post postid-62568 single-format-standard">
		
        <header>    
        <div class="topbanner hidden-xs hidden-sm">
        	<div class="container">
					<!-- jaxenter.de_leaderboard_Wordpress -->
                    <div id='div-gpt-ad-1423038811881-3' style='width:100%; min-height:90px; margin:10px 0;'>
                    <script type='text/javascript'>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-3'); });
                    </script>
                    </div>
            </div>
         </div> 
        	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://jaxenter.de/events">Events</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://jaxenter.de/magazine">Java Magazin</a></li>
<li id="menu-item-39337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39337"><a href="https://jax.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=menu">W-JAX 2017</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/docker">Docker</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16647" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16647"><a href="https://jaxenter.de/tag/internet-of-things">Internet of Things</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/maschinelles-lernen">Machine Learning</a></li>
</ul>		</div>
	</div>
 
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">Frühling für Enterprise Java:</span>
                                        
                                    <u><a href="https://jaxenter.de/spring-5-released-62586">Spring 5 ist da!</a></u>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>
		
		                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/W-JAX-Logo-blau-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=StartseiteFeature&amp;utm_campaign=Headerleiste">W-JAX 2017: Die Konferenz für Java, Architektur- und Software-Innovation</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/03/Angular-4-Features-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/angular-4-update-55042">Angular 4: Diese Features müssen Sie kennen</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2015/03/Spring-Boot-Tutorial-1-300x300-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://jaxenter.de/spring-boot-tutorial-54020">Spring Boot Tutorial: So entwickelt man REST-Services mit Spring Boot</a></p>
<p>&nbsp;</p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			

          </div>
		</header>
	<script type="text/javascript">
	$( document ).ready(function() {
		$('.single .next-article-popup-post .popup-close').click(function(){
			$('.single .next-article-popup-post').hide();
		});
		$(window).scroll(function() {
		   var hT = $('#content > .text').offset().top,
		       hH = $('#content > .text').outerHeight(),
		       wH = $(window).height(),
		       wS = $(this).scrollTop();
		   if (wS > (hT+hH-wH)){
			   //console.log(wS);
			   if(!$('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').addClass('active');
			   }
		   }else{
			   if($('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').removeClass('active');
			   }
		   }
		});
	}); 
	</script>
	<div class="hidden-xs next-article-popup-post ">
	    <strong class="popup-heading">Nächster Beitrag:</strong>
	    <div class="popup-content">
	    	        <figure class="thumb">
	            <a href="https://jaxenter.de/api-interview-frotscher-62574"><img width="150" height="105" src="https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350-150x105.jpg" class="alignleft wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/Thilo-Frotscher_500x350.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a>
	           <!--  <img src="https://entwickler.de/wp-content/uploads/2017/07/ff-brotli-dotnet-mozilla-stt-engine-90x45.jpg" alt="" data-pin-no-hover="true"> -->
	        </figure>
	   	        <h3 class="popup-post-title"><a href="https://jaxenter.de/api-interview-frotscher-62574">"&#8222;Gibt man Entwicklern für das Erstellen eines APIs nicht genügend Zeit, wird man es bald bereuen&#8220;"</a></h3>
	    </div>
	    <span class="popup-close">X</span>
	</div>
	


	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Die Macht der 8</div>
														<h1 class="title">Java EE 8: Hält es, was die lange Wartezeit versprochen hat?</h1>
							
									<div class="button-tags-block">
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/java" target="_blank" >
	                  #Java 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/java-ee" target="_blank" >
	                  #Java EE 	         </a>   
	      		</div>
								
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2017-09-28T14:53">28. September 2017</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Lars Röwekamp										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="200" src="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-180x120.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"><p>©Shutterstock/Macrovector</p>
</div>
								</div>
														
															<div class="excerpt">
									<p>Nach Jahren des Stillstands war es vor wenigen Tagen endlich so weit: Die neue Java-EE-Spezifikation, Java EE 8, wurde veröffentlicht. Die ursprünglich für den Sommer dieses Jahres geplante Version 8 des Java-Enterprise-Standards ist dabei deutlich mehr als nur Technologie. Sie ist ein Bekenntnis von Oracle zum Java Community Process. Lars Röwekamp </p>
								</div>
													</div>
					
					
					
					<div class="text">
						<p class="SuSMengentext">Was lange währt, wird endlich gut. Dieses Sprichwort als Maßstab genommen, müsste die neue Version der Java-EE-Spezifikation nicht nur gut, sondern sehr gut werden. Mehr als vier Jahre sind seit dem Erscheinen des Vorgängers und damit der immer noch aktuellen Version 7 ins Land gezogen. Wer nun aber glaubt, dass Java EE 8 mit unzähligen Neuerungen und Verbesserungen aufwartet, der sei eines Besseren belehrt. Die kommende Version ist eher eine Evolution denn eine Revolution. Einige sprechen sogar von einem Maintenance-Release auf dem Weg zu Java EE 9. Trotzdem ist genau diese Version ein wichtiger Meilenstein für die Zukunft von Java EE. Aber immer der Reihe nach &#8230;</p>
<h2 class="SuSAbsatzheadline">Politik, wohin man schaut</h2>
<p class="SuSMengentext">Eigentlich fing alles so schön an. Nachdem es bei der Spezifikation von Java EE 7 zu etlichen Unstimmigkeiten gekommen war und Oracle sich den Vorwurf gefallen lassen musste, ein wenig den Fokus verloren zu haben, schien man mit Java EE 8 alles besser machen zu wollen. Bereits kurz nach der finalen Veröffentlichung von Java EE 7 wurde im Rahmen der JavaOne Conference 2013 ein Panel mit dem bezeichnenden Titel „Java EE – Meet the Spec Leads“ abgehalten, in dem ausgiebig über die zukünftige Ausrichtung von Java EE diskutiert wurde.</p>
<p class="SuSMengentext">Alle waren sich einig, dass die Community bei der Bestimmung der zukünftigen Ausrichtung eine größere Rolle spielen sollte, um späte Richtungswechsel, wie bei Java EE 7 geschehen, zu verhindern. Um das zu gewährleisten, wurde eine <a href="https://javaee.github.io/javaee-spec/download/JavaEE8_Community_Survey_Results.pdf">zweiteilige öffentliche Umfrage</a> gestartet, an der sich ca. 5 000 Interessierte beteiligten. In Teil 1 der Umfrage, durchgeführt im Dezember 2013, ging es um sinnvolle neue APIs und eine generelle Einschätzung zu Hype-Themen wie NoSQL oder HTML5. Im Januar 2014 wurden im zweiten Teil zusätzlich die Themen Cloud und Microservices sowie Security, Logging und Deployment aufgegriffen. Das damalige Ergebnis war eindeutig. Die Community legte den Fokus auf „leichtgewichtig“ und „einfach zu verwenden“. Cloud und Co. sowie neue UI-Technologien dagegen schienen eher von geringerem Interesse zu sein. API-Kandidaten wie JSON Binding, Java EE Configuration oder JCache bekamen einen Zuspruch von 60 % bis 80 %. Gleiches galt für die Fokussierung auf ein Alignment der Verwendung von CDI innerhalb der vielen existierenden Java-EE-APIs. Vorschläge zu Cloud-nahen Themen dagegen lagen nur selten über 50 %. Die zukünftige Roadmap von Java EE schien somit klar zu sein.</p>
<p style="text-align: center;"><strong>Lesen Sie auch: <a href="https://jaxenter.de/java-ee-eclipse-foundation-61846?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=seealso">Java EE geht an die Eclipse Foundation</a></strong></p>
<p class="SuSMengentext">Interessant ist, dass im Anschluss an diese anfängliche Euphorie die weiteren Bemühungen erst einmal ins Stocken gerieten. So wurde zum Beispiel zunächst keine neue Java EE 8 Expert Group ins Leben gerufen, sondern Diskussionen über die bestehenden Kanäle der Java EE 7 Expert Group geführt. Das Ganze artete am Ende so weit aus, dass die Weiterentwicklung von Java EE nahezu zum Erliegen kam und Oracle ein gewisses Desinteresse an Java EE vorgeworfen wurde. Nicht wenige gingen sogar so weit, Java EE – mal wieder – für tot zu erklären, da Oracle sich scheinbar voll und ganz auf die eigene Cloud-Strategie konzentrierte und die Zukunft von Java EE keine Rolle mehr zu spielen schien. Das war in etwa auch der Zeitpunkt der Gründung der <a href="https://javaee-guardians.io">Java EE Guardians</a>, einer Initiative zur Rettung von Java EE. Eine interessante Übersicht über die damals vorhandenen bzw. nicht vorhandenen Aktivitäten findet sich in dem Artikel „<a href="https://dzone.com/articles/java-ee-8-current-status-case-study-for-completed">Java EE 8, Current Status: Case study for completed work since late 2015</a>“.</p>
<p class="SuSMengentext">Erst nach arger Kritik aus der Community und dem Weggang etlicher Java-EE-Experten von Oracle (einige gingen freiwillig, andere wurden gegangen), fand eine Kehrtwende statt. Oracle betonte mehrfach die strategische Bedeutung von Java EE und veröffentlichte auf der JavaOne 2016 eine korrigierte und minimierte Version der Roadmap. Java EE 8 würde keine revolutionären Neuerungen beinhalten, sondern das konsequent fortführen, was mit Java EE 5, 6 und 7 begonnen wurde: „Ease of Development“ und „API Alignment“. Themenbereiche wie Cloud und Microservices sollten bis auf wenige vorbereitende Maßnahmen außen vor bleiben und stattdessen Kernthema von Java EE 9 werden. Gleichzeitig wurde auch die Verschiebung des Release auf Sommer 2017 bekannt gegeben. Die Community wurde wenige Wochen später ein zweites Mal gebeten, über die potenziellen Kandidaten – oder sollte man besser sagen: Streichkandidaten – der zukünftigen Java-EE-Version abzustimmen. Diese Mal nahmen nur noch knapp über 1 500 Personen an der Umfrage teil, die meisten aus Europa. Die für die Weltwirtschaft durchaus relevanten BRIC-Staaten Brasilien, Russland, Indien und China haben die Umfrage indes weitestgehend ignoriert.</p>
<p class="SuSMengentext">Das <a href="https://javaee.github.io/javaee-spec/">Ergebnis der Umfrage</a> floss direkt in die finale Roadmap ein. Bereits geplante APIs, wie das Security-API oder JAX-RS, wurden in ihrem Umfang erweitert. Neue API-Kandidaten kamen hinzu: Configuration API, HealthCheck API – beide wurden aber später wieder fallen gelassen und auf Java EE 9 verschoben. Im Gegenzug fielen einige prominente APIs wie JMS 2.1, Management 2.0 oder MVC 1.0 dem Rotstift zum Opfer, da nur so der geplante Releasetermin gehalten werden konnte. Das wiederum ist wichtig, da man zukünftig deutlich kürzere Zyklen für die Java-Enterprise-Plattformen angekündigt hat und Java EE 9 – mit den Schwerpunktthemen modulare Runtime und Cloud – bereits 2018 veröffentlicht werden soll.</p>
<h2>Technologie</h2>
<p>So viel zur nicht ganz unkomplizierten Entstehungsgeschichte von Java EE 8 und der damit verbundenen politischen Komponente. Aber natürlich gibt es auch den einen oder anderen technologischen Aspekt, der es wert ist, genauer beleuchtet zu werden.</p>
<p>Java EE 8 hat sich zum Ziel gesetzt, den in Java EE 7 gesetzten Fokus auf moderne Webanwendungen konsequent weiterzuverfolgen. HTTP/2-Support inkl. Push statt Pull, eine deutlich verbesserte Unterstützung von JSON sowie ein reaktives Programmiermodell stehen hier ganz oben auf der Liste. Auch das bereits in Java EE 5 eingeführte Motto Ease of Development wird weiter vorangetrieben. Die Einführung neuer Annotationen in nahezu jedem API sowie ein verbesserter CDI-Support zur vereinfachten Programmierung sind hierfür ein klares Indiz. Zusätzlich findet bei etlichen Java-EE-APIs eine Adaption hin zu den neuen Features von Java 8, zum Beispiel Nutzung von Lambdas oder Stream-API, statt.</p>
<div class='widgets_on_page'> <div id="wysiwyg_widgets_widget-12" class="widget widget_wysiwyg_widgets_widget"><!-- Widget by WYSIWYG Widgets v2.3.6 - https://wordpress.org/plugins/wysiwyg-widgets/ --><div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://jax.de/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"><img style="width: 100%; height: auto;" src="/wp-content/uploads/2017/09/WJAX_2017_Contentbox_2126x162_42564_v1.jpg" alt="W-JAX" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="/wp-content/uploads/2017/09/WJAX_2017_Speakerbox_550x214_42564_v1.jpg" alt="W-JAX" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;"></div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jax.de/wp-content/uploads/2017/05/Mike-Wiesner.jpg" alt="Mike Wiesner" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://jax.de/big-data-machine-learning/data-event-driven-microservices-mit-apache-kafka/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://jax.de/big-data-machine-learning/data-event-driven-microservices-mit-apache-kafka/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Data- und Event-driven Microservices mit Apache Kafka');" style="color: #264186; font-size: 19px; font-weight: 600;">Data- und Event-driven Microservices mit Apache Kafka</a></h3>
<p style="margin: 0px 0 5px; color: #000;">mit Mike Wiesner (MHP &#8211; A Porsche Company)</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="border: 1px solid #fff; max-width: 100%; height: auto;" src="https://jax.de/wp-content/uploads/2017/05/Uwe-Friedrichsen.jpg" alt="Niko Köbler" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://jax.de/software-architecture/digitization-solutions-a-new-breed-of-software/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://jax.de/software-architecture/digitization-solutions-a-new-breed-of-software/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox', 'Digitization Solutions – a new Breed of Software');" style="color: #264186; font-size: 19px; font-weight: 600;">Digitization Solutions – a new Breed of Software</a></h3>
<p style="margin: 0px 0 5px; color: #000;">with Uwe Friedrichsen (codecentric AG)</p>
</div>
</div>
</div>
</div>
</div>
</div>
<div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://microservices-summit.de/"><img style="width: 100%; height: auto;" src="/wp-content/uploads/2017/09/MSS_2017_Contentbox_2126x162_41330_v1.jpg" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><a href="https://microservices-summit.de/"><img class="" style="width: 100%; height: auto;" src="/wp-content/uploads/2017/09/MSS_2017_Contentbox_550x214_41330_v1.jpg" alt="Microservices Summit 2017" /></a></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<h3 style="margin: 12px 0; font-size: 19px !important; font-weight: 700 !important; padding: 5px 0 12px 0 !important;"><span style="color: #a71580;"><a href="https://microservices-summit.de/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://microservices-summit.de/', 'Das große Trainingsevent für Microservices, DevOps, Continuous Delivery, Docker &amp; Clouds!');" style="color: #ea007f;">Das große Trainingsevent für Microservices, DevOps, Continuous Delivery, Docker &amp; Clouds!</a></span></h3>
</div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jaxenter.de/wp-content/uploads/2017/03/1488201344472_yanar_erkan_wp350x500.jpg" alt="Erkan Yanar" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #a71580;"><a href="https://microservices-summit.de/microservices/docker-basics-kurz-und-knapp/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://microservices-summit.de/microservices/docker-basics-kurz-und-knapp/', 'Docker Basics: kurz und knapp');" style="color: #ea007f; font-size: 19px; font-weight: 600;">Docker Basics: kurz und knapp</a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Erkan Yanar (Freiberufler)</p>
</div>
</div>
<div class="sb-content-item-sands col-xs-12" style="padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="border: 1px solid #fff; max-width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2017/08/lars-roewekamp.jpg" alt="Lars Röwekamp" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #a71580;"><a href="https://microservices-summit.de/microservices/wider-dem-chaos-microservices-architektur-patterns/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://microservices-summit.de/microservices/wider-dem-chaos-microservices-architektur-patterns/', 'Wider dem Chaos: Microservices Architektur &#038; Patterns');" style="color: #ea007f; font-size: 19px; font-weight: 600;">Wider dem Chaos: Microservices Architektur &#038; Patterns</a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Lars Röwekamp (OPEN KNOWLEDGE)</p>
</div>
</div>
</div>
</div>
</div>
</div>
<!-- / WYSIWYG Widgets --></div>
  </div><!-- widgets_on_page -->
<h2>Brave new Web</h2>
<p>Viele der Änderungen und Neuerungen finden sich im direkten oder indirekten Webumfeld wieder. Geht man einmal von klassischen Java-EE-Webanwendungen aus, sind hier vor allem die beiden Spezifikationen Java Servlet 4.0 (<a href="https://jcp.org/en/jsr/detail?id=369">JSR 369</a>) und JSF 2.3 (<a href="https://www.jcp.org/en/jsr/detail?id=372">JSR 372</a>) zu nennen.</p>
<p>Ein Großteil der neuen Servlet-4.0-Features betrifft den Support von HTTP/2 und dient somit vor allem der Performanceoptimierung beim Browsen von Webapplikationen. Mittels Server Push kann der Servlet-Container zukünftig proaktiv Daten bzw. Ressourcen an den Client senden. Sind zum Beispiel innerhalb einer <em>index.html</em> weitere Webressourcen wie Stylesheets, Images oder JavaScript-Dateien referenziert, können diese vom Servlet-Container parallel zur eigentlich angeforderten Ressource – in diesem Fall also der <em>index.html</em> – ausgeliefert werden. Ein weiterer Performance-Boost kann durch die Unterstützung des HTTP/2 Request-/Response Multiplexing erreicht werden. Hierbei können mehrere Requests und Responses asynchron – also non-blocking – über eine einzige TCP-Verbindung verarbeitet werden. Die meisten Entwickler von Java-basierten Webanwendungen werden allerdings kaum Berührungspunkte zu den neuen Features des Servlet-API haben, da diese sich eher transparent im Hintergrund abspielen.</p>
<p>Etwas handfester wird es, zumindest aus Sicht des Anwendungsentwicklers, bei der neuen JSF-Spezifikation. Nachdem man jahrelang an dem veralteten Modell der JSF Managed Bean Facility festgehalten hat, ist dieses nun endlich (endlich!) deprecated. Konkret heißt es dazu in der Spezifikation:</p>
<p>„As of version 2.3 of this specification, use of the managed bean facility as specified in this section is strongly discouraged. A better and more cohesively integrated solution for solving the same problem is to use Contexts and Dependency Injection (CDI), as specified in JSR-365.“</p>
<p>Entsprechend verbessert wurde die Integration von CDI. Zum einen können die bisher noch nicht unterstützen JSF-Komponenten Converter, Validator und Client Behaviour als Injection Target fungieren. Zum anderen stellt JSF eine ganze Reihe neuer CDI Producer zur Verfügung, um so innerhalb der eigenen Sourcen auf einfache Weise Zugriff auf wesentliche JSF-Artefakte wie zum Beispiel <em>@SessionMap, @RequestMap</em> oder <em>@HeaderMap</em> zu bekommen.</p>
<p>Ebenfalls neu in JSF ist der direkte WebSocket-Support. Mittels <em>f:websocket</em>-Tag kann innerhalb einer JSF View eine WebSocket Push Connection aufgebaut und so auf eingehende Messages reagiert werden. Das Pendant auf Seiten des Servers nennt sich <em>PushContext</em> und kann via CDI injectet werden. Listings 1 und 2 zeigen ein minimalistisches Beispiel.</p>
<pre class="brush: java" title="Listing 1: JSF View mit „f:websocket“-Tag">&lt;!DOCTYPE html&gt;
&lt;html xmlns="http://www.w3.org/1999/xhtml"
  xmlns:f="http://xmlns.jcp.org/jsf/core"
  xmlns:h="http://xmlns.jcp.org/jsf/html"&gt;
  &lt;h:head&gt;
    Websocket Example
  &lt;/h:head&gt;
  &lt;h:body&gt;
    &lt;f:websocket channel="helloWorldChannel" 
      onmessage="function(message){alert(message)}" /&gt;
  &lt;/h:body&gt;
&lt;/html&gt;</pre>
<pre class="brush: java" title="Listing 2: CDI Bean mit PushContext">@Named
@RequestScoped
public class SomeBean {

  // WebSocket push channel with name "helloWorldChannel"
  @Inject @Push(channel = "helloWorldChannel""
  private PushContext channel;

  public void send(){
    channel.send("Hello, push world!");
  }
)</pre>
<p>Auch im Bereich Ajax gibt es einige Verbesserungen. So können künftig beliebige Methoden auf Seiten des Servers via <em>&lt;h:commandScript/&gt;</em>-Tag asynchron angestoßen werden. Wer schon einmal mit OmniFaces gearbeitet hat, dem dürfte dieses Tag vertraut vorkommen. Zusätzlich erlaubt das <em>&lt;f:ajax&gt;</em>-Tag die Rückgabe von JavaScript-Fragmenten, die innerhalb des Partial Response als Eval-Skripte mitgegeben und nach der Abarbeitung des Requests auf Seiten des Clients ausgeführt werden können.</p>
<p>Interessant und seit Langem überfällig ist auch die neu eingeführte Class Level Validation. Mithilfe des <em>&lt;f:validateWholeBean&gt;</em>-Tags werden Prüfungen auf Klassenebene der Backing Bean einer JSF View möglich, was u. a. eine Multi-Field-Validierung von Eingabeformularen erlaubt.</p>
<p>JSF 2.3 setzt Java 8 voraus, was die Nutzung sämtlicher Java-8-Features in JSF ermöglicht. Unter anderem spiegelt sich dies in Form eines neuen Java Date and Time API (JSR 310) und verbesserter UIData- und UIRepeat-Komponenten wider.</p>
<h2>RESTful API Design</h2>
<p>Die mit Abstand meisten Änderungen und Neuerungen in Java EE gibt es im Umfeld derjenigen APIs, die zum Design von Anwendungsschnittstellen genutzt werden können, allen voran das API zur Implementierung von REST-konformen Schnittstellen: <a href="https://jcp.org/en/jsr/detail?id=370">JAX-RS 2.1</a>.</p>
<p>Für ein Minor-Release beinhaltet das JAX-RS-2.1-API eine ganze Menge neuer Features, wobei scheinbar im Endspurt zum finalen Release das eine oder andere geplante Feature auf der Strecke geblieben zu sein scheint. Wie schon zuvor beim Servlet API, stehen auch bei JAX-RS Non-Blocking I/O und Asynchronität im Fokus. So wird zum Beispiel Asynchronität in Form eines Reactive Clients auf Basis des CompletionStage-Features aus Java 8 unterstützt. Die Idee der Reactive Clients ist nicht neu. Bereits seit JAX-RS 2.0 können Clients asynchrone Anfragen an einen Server senden und auf deren Antwort via <em>InvocationCallback</em> oder <em>Future&lt;T&gt;</em> reagieren. Kompliziert wird es bei diesem Szenario allerdings immer dann, wenn mehrere Events ins Spiel kommen, was zu einer Verschachtelung der Callback Handler führt (auch bekannt als Pyramid of Doom). Genau an diesem Punkt setzt die auf dem Interface <em>CompletionStage</em> basierende Lösung an. Listing 3 zeigt ein Beispiel aus der Spezifikation, in dem ein Client zwei asynchrone Calls absetzt, deren Ergebnisse im Anschluss nach ihrem Eintreffen wieder zusammengeführt werden.</p>
<pre class="brush: java" title="Listing 3: Reactive Client via RxInvoker ">// async REST call no 1 (via RxInvoker using CompletionStage)
CompletionStage cs1 = client.target("http://one.de/api")
  .request()
  .rx()
  .get(String.class);

// async REST call no 2 (via RxInvoker using CompletionStage)
CompletionStage cs2 = client.target("http://two.de/api")
  .request()
  .rx()
  .get(String.class);

// combining result of async REST call no 1 and no 2
CompletionStageString&gt;&gt; list = cs1.thenCombine(cs2, list::of);</pre>
<p>Ebenfalls neu unterstützt wird in JAX-RS 2.1 der W3C- bzw. WHATWG-Standard <a href="https://www.w3.org/TR/eventsource/">Server-sent Events</a>, bei dem über eine langlebende HTTP-Verbindung Push Notifications in Form spezieller DOM Events vom Server zum Browser gesendet werden. Die Events können dabei sowohl an einen speziellen Client als auch – via Broadcasting – an eine Gruppe von Clients geschickt werden. Listing 4 zeigt den Aufbau einer SSE-Verbindung durch einen JAX-RS Client, Listing 5 den zugehörigen JAX-RS Server, der via Broadcasting Events an alle registrierten Clients verschickt.</p>
<pre class="brush: java" title="Listing 4: JAX-RS-SSE-Client">WebTarget target = client.target("http://...");
try (SseEventSource source = SseEventSource.target(target).build()) {
  source.register(System.out::println);
  source.open();
  Thread.sleep(5000); // Consume events for just 5000 ms
} catch (InterruptedException e) {
  // do some intelligent exception handling
    ...
}</pre>
<pre class="brush: java" title="Listing 5: JAX-RS-SSE-Broadcast-Server">@Singleton
public class SseResource {

  @Context
  private Sse sse;

  private SseBroadcaster sseBroadcaster;

  @PostConstruct
  public init() {
    this.sseBroadcaster = sse.newBroadcaster();
  }

  @GET
  @Path("register")
  @Produces(MediaType.SERVER_SENT_EVENTS)
  public void register(@Context SseEventSink eventSink) {
    eventSink.send(sse.newEvent("welcome!"));
    sseBroadcaster.register(eventSink);
  }

  @POST
  @Path("broadcast")
  @Consumes(MediaType.MULTIPART_FORM_DATA)
  public void broadcast(@FormParam("event") String event) {
    sseBroadcaster.broadcast(sse.newEvent(event));
  }
}</pre>
<p>Neben den bisher aufgeführten Features können natürlich in einer Java-EE-8-Umgebung auch die Möglichkeiten des neuen JSON-B-API innerhalb von JAX-RS genutzt werden.</p>
<p class="SuSMengentext">Das längst überfällige JSON-B-1.0-API (<a href="https://jcp.org/en/jsr/detail?id=367">JSR 367</a>) bietet out of the Box Support für die Transformation von Java-Objekten hin zu JSON-Objekten und vice versa. Mittels Annotationen lässt sich das gewünschte Mapping-Verhalten beliebig anpassen. So können Felder via <em><span class="SuSKursiv">@JsonbTransient</span></em> ausgeblendet oder die Attributnamen via <em><span class="SuSKursiv">@JsonProperty</span></em> individuell bestimmt werden. Mithilfe von <em><span class="SuSKursiv">@PropertyNamingStrategy</span></em> lässt sich festlegen, welche generelle Namensstrategie gewählt werden soll (mit Unterstrich, ohne Unterstrich, CamelCase usw.). Die Reihenfolge der Attribute innerhalb des generierten JSON kann via <em><span class="SuSKursiv">@PropertyOrderStrategy</span></em> bestimmt werden. Auch für die gezielte Behandlung von Null-Values gibt es mit <em><span class="SuSKursiv">@JsonbNillable</span></em> eine eigene Annotation. Reichen die genannten Annotationen nicht aus, können Adapter oder Serializer bzw. Deserializer programmiert und für die individuell zu transformierende Klasse verwendet werden.</p>
<p style="text-align: center;"><strong>Lesen Sie auch: <a href="https://jaxenter.de/java-ee-8-features-61567?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=seealso">Java EE 8 ist da! Das sind die wichtigsten Änderungen und Features</a></strong></p>
<p class="SuSMengentext">Die Tatsache, dass es für die JSON-Transformation in Java EE 8 nun endlich ein eigenes API gibt und nicht mehr auf die Krücke JAX-B oder proprietäre APIs zurückgegriffen werden muss, unterstreicht die zunehmende Bedeutung von JSON im Umfeld moderner, verteilter (Web-)Anwendungen. Das wird zusätzlich durch die Erweiterungen innerhalb des API zum Parsen von JSON-Objekten deutlich (JSON-P-1.1.-API – <a href="https://www.jcp.org/en/jsr/detail?id=374">JSR 374</a>). Neben einigen kleineren Änderungen, zum Beispiel der Unterstützung des Java-8-Stream-API und der damit einhergehenden Einführung der Helper-Klasse <em><span class="SuSKursiv">JsonCollectors</span></em>, stehen vor allem Anpassungen zur Unterstützung aufstrebender JSON-Standards im Fokus. Dank neu eingeführter JSON-Pointer-Klasse kann innerhalb einer JSON-Struktur gezielt ein Teilobjekt referenziert und bei Bedarf manipuliert werden (Listing 6).</p>
<pre class="brush: java" title="Listing 6: JSON-Manipulation via JSON-Pointer">// original json object 
JsonObject jsonObject = (JsonObject) JsonUtil.toJson(
  " {                               " +
  "   'name': 'lars',                " +
  "   'hobbies': [                  " +
  "        'swimming', 'running'    " +
  "   ]                             " +
  " }                               " +
// extract name from JSON structure
JsonPointer getPointer = new JsonPointer("/name");
JsonValue value = pointer.getValue(jsonObject)

// add nickname to JSON structure
String pointerStr = ("{'pointer': '/nickname', 'value': 'mobileLarson'}"
JsonObject operation = (JsonObject) JsonUtil.toJson(pointerStr);
JsonPointer pointer = new JsonPointer(operation.getString("pointer"));
JsonObject modifiedJson = (JsonObject) pointer.add(targetJson, operation.get("value"));</pre>
<p>Alternativ zum JSON Pointer kann auch JSON Patch zur Manipulation von JSON-Objekten verwendet werden. JSON Patch bietet sich immer dann an, wenn mehrere Operationen – add, remove, replace, move, copy und test – parallel erfolgen sollen. Die gewünschten Operationen werden als eigene JSON-Array-Struktur deklariert (Listing 7) oder alternativ über einen <em>JsonPatchBuilder</em> angegeben.</p>
<pre class="brush: java" title="Listing 7: JSON Manipulation via JSON-Patch">// original json object
JsonObject targetObject = (JsonObject) JsonUtil.toJson(
  " {                               " +
  "   'name': 'lars',                " +
  "   'nickname': 'mobileLarson',  " +
  "   'hobbies': [                  " +
  "        'swimming', 'running'    " +
  "   ]                             " +
  " }                               " ); 

// patch operations to apply
JsonArray patch = (JsonAray) JsonUtil.toJson(
  " [                                                            " +
  "    { 'op': 'copy', 'path': '/nickname', 'from': '/name' },   " +
  "    { 'op': 'remove', 'path': '/hobbies/1},                   " +
  "    { 'op': 'add', 'path': '/hobbies/-', 'value': 'cycling' } " +
  "]                                                             " );
JsonPatch patch = new JsonPatch(patch)

// apply patch will result in:
// {
//    'name' : 'lars'
//    'nickname' : 'lars'
//    'hobiies' : [
//       'swimming', 'cycling'
//    ]
// }
JsonStructure result = patch.apply(target)</pre>
<p>In eine ähnliche Richtung wie JSON Patch geht auch das neu eingeführte JSON <em>MergePatch</em>. Allerdings werden bei einem Merge Patch – anders als beim eben vorgestellten Patch – nicht die Patch-Operationen direkt angegeben, sondern stattdessen ein zu verschmelzendes Objekt, aus dem dann die notwendigen Operationen automatisch errechnet werden.</p>
<h2>Alte Bekannte aufpoliert</h2>
<p>Neben den bisher beschriebenen Neuerungen im Java-EE-Umfeld gibt es zwei weitere APIs, die grundlegend erweitert wurden und daher einen Major-Release-Sprung hingelegt haben: CDI 2.0 (<a href="http://cdi-spec.org">JSR 365</a>) und Bean Validation 2.0 (<a href="http://beanvalidation.org/specification/">JSR 380</a>).</p>
<p>Die neue Version der CDI-Spezifikation setzt gleich mehrere Akzente. Wie die meisten anderen Java-EE-APIs, erlaubt CDI künftig die Verwendung der wichtigsten Java-8-Features (Streams, Lambdas, Repeating Qualifiers). Für mehr Transparenz zur Laufzeit sorgt die Möglichkeit, die Abarbeitungsreihenfolge von Observern durch die Angabe von Prioritäten – via <em>@Priority</em> aus Commons Annotation – zu bestimmen. Mithilfe der neuen <em>InterceptionFactory</em> lassen sich künftig Interceptors programmatisch an Producers binden und so zum Beispiel on the fly Qualifier-Annotationen beim Produzieren eines Objekts hinzufügen. Möchte man zur Laufzeit kontextsensitiv Annotationen, wie zum Beispiel fallbezogene Qualifier, erzeugen, stehen einem dafür künftig eine ganze Reihe vordefinierter Annotation Literals zur Verfügung. Das garantiert zusätzliche Typsicherheit und verhindert somit unnötige Laufzeitfehler.</p>
<p>Eine wesentliche Neuerung der CDI-2.0-Spezifikation ist die Unterstützung von Java SE als Laufzeitumgebung inklusive standardisiertem Bootstraping. Um CDI zukünftig auch außerhalb von Java EE sinnvoll und standardisiert nutzen zu können, wurde die Spezifikation in drei Teile untergliedert:</p>
<ul>
<li>Core CDI</li>
<li>CDI in Java SE</li>
<li>CDI in Java EE</li>
</ul>
<p>Der Bereich „CDI in Java SE“ definiert, wie ein CDI-Container (<em>SeContainer</em>) innerhalb von Java SE initialisiert, gestartet, verwaltet und am Ende sauber heruntergefahren werden kann. Listing 8 zeigt ein minimalistisches Beispiel, in dem genau diese Schritte nachvollzogen werden. Mithilfe eines Container Initializers (<em>SeContainerInitializer</em>) kann das Bootstrapping des Containers gesteuert werden. So kann zum Beispiel zwischen automatischer Bean Discovery via Annotationen (Default) und manueller Discovery umgeschaltet werden.</p>
<pre class="brush: java" title="Listing 8: CDI Bootstrapping in Java SE">public static void main(String... args) {
  SeContainerInitializer containerInit = SeContainerInitializer.newInstance();
  SeContainer container = containerInit.initialize();
  // retrieve a bean and do work with it
  MyWorkerBean myBean = container.select(MyWorkerBean.class).get();
  myBean.doSomeWork();
  // when done
  container.close();
}</pre>
<p>Neben der eben vorgestellten Unterstützung von Java SE ist die zweite wichtige Neuerung in CDI 2.0 die Einführung von asynchronen Events – ein Feature, für das man bisher auf EJBs zurückgreifen musste. Hierzu wurde das Event-Interface um zwei <em>fireAsync</em>-Methoden erweitert, die beide ein Objekt vom Typ <em>CompletionStage&lt;T&gt;</em> (aus Java 8) zurückgeben. Die Verwendung ist denkbar einfach, wie die Listings 9 und 10 zeigen. In Listing 9 wird ein asynchrones Event gemäß „Fire and Forget“-Pattern erzeugt, dessen Verarbeitung im Anschluss in Listing 10 durch einen entsprechenden asynchronen Observer erfolgt.</p>
<pre class="brush: java" title="Listing 9: Asynchrones CDI-Event „Fire and Forget“">@ApplicationScoped
public class AsyncEventFireBean {

  @Inject 
  Event event; 

  public void someAsyncBusinessTriggerMethod() {
    // fire (and forget) asynchronous event
    event.fireAsync(new SomePayload());
    // do some additional work in main thread
    ...
  }
}</pre>
<pre class="brush: java" title="Listing 10: Asynchroner CDI Observer">@ApplicationScoped
public class MyAsyncObserverBean {

  public void callMe(@ObservesAsync SomePayload payload) { 
    // BTW: this is another thread
  } 
}</pre>
<p>Wie bereits erwähnt, hat auch das Bean-Validation-API eine neue Major-Version (2.0) erhalten. Wesentlicher Grund für den Versionssprung ist die Adaption hin zu Java 8. So unterstützt Bean Validation künftig sowohl die beiden Java-8-Typen <em>LocalTime</em> und <em>Optional</em> als auch etliche der neuen Sprachfeatures (Lambdas, Repeating Qualifiers, Type Annotations). Zusätzlich werden neue Constraints (z. B. <em>@NotBlank, @NotEmpty, @Email, @Past, @Future, @negative, @Positive</em> &#8230;) zur Verfügung gestellt.</p>
<h2>Sicher ist sicher</h2>
<p>Nach gefühlten hundert Jahren nimmt sich Java EE 8 mit dem Security API 1.0 (<a href="https://www.jcp.org/en/jsr/detail?id=375">JSR 375</a>) endlich auch eines Themas an, das bisher im Standard vernachlässigt wurde. Ziel des neu geschaffenen API ist es, die über die letzten Jahre gewachsenen Lücken, die bisher durch herstellerspezifische Lösungen überbrückt wurden, auf einfache und moderne Art und Weise zu schließen. Eine Portabilität der verschiedenen Securityaspekte ist besonders in Hinblick auf die Zielplattform Cloud ein essenzielles Feature.</p>
<p>Die Security Expert Group hat sich bei dem Design des API zu einer wesentlichen Aufgabe gemacht, bestehende Security-Mechanismen zu zentralisieren und sinnvoll zu ergänzen, ohne sie aber zwingend auch zu ersetzen. So sollen z. B. innerhalb der <em>web.xml</em> angegebene Securitydeklarationen weiterhin Bestand haben. Gleiches gilt für bereits existierende Securityannotationen (z. B. <em>@RolesAllowed</em>). Auch sollte ein Wechsel zwischen herstellerspezifischer und herstellerneutraler Lösung einfach möglich sein. Zu diesem Zweck bildet die aktuelle Spezifikation drei grundlegende Komponenten ab:</p>
<ul>
<li>Authentication Mechanism</li>
<li>Identity Storage</li>
<li>Security Context</li>
</ul>
<p>Die erste Komponente, der Authentication-Mechanismus, stellt den Einstiegspunkt für die Authentifizierung dar. Mithilfe der durch den Aufrufer an den Mechanismus übergebenen Credentials (z. B. Username und Passwort) erfolgt eine Authentifizierung gegen einen der angebundenen Identity Stores. Im Erfolgsfall wird der zugehörigen User inklusive seiner Attribute (Principals) als Authenticated Subject bereitgestellt. Im Fehlerfall dagegen signalisiert der Mechanismus einen Anmeldefehler, und der Aufrufer ist nicht angemeldet. Java-EE-Container müssen mindestens LDAP und Database als Identity-Store-Typ zur Verfügung stellen.</p>
<p>Die dritte und letzte Komponente, der Security Context, ist die programmatische Schnittstelle des Security-API und stellt somit das Bindeglied zum Container dar. Listing 11 zeigt eine Backing Bean einer typischen Log-in-Seite (JSF View), mit deren Hilfe sich ein User innerhalb einer Webanwendung unter Verwendung des <em>HttpAuthenticationMechanism</em> anmelden kann. Der <em>SecurityContext</em> wird in diesem Beispiel zur Authentifizierung und somit für den Zugriff auf den angebundenen Identity Store genutzt. Alternativ dazu hätte man auch einen aktiven Identity Store injecten und im Anschluss dessen <em>validate</em>-Methode mit den Credentials aufrufen können.</p>
<pre class="brush: java" title="Listing 11: Java-Security-API in Aktion">@Named
@RequestScoped
public class LoginBean {

  @NotNull
  private String username;

  @NotNull
  private String password;

  @Inject
  private SecurityContext securityContext;

  @Inject
  private FacesContext facesContext;

  public void login() {

    Credential credential =
      new UsernamePasswordCredential(username, new Password(password));

    AuthenticationStatus status = securityContext.authenticate(
      getRequest(facesContext),
      getResponse(facesContext),
      withParams()
        .credential(credential));   

    if (status.equals(IN_PROGRESS)) {
      facesContext.responseComplete();
    } else if (status.equals(FAILURE)) {
      addError(facesContext, "Authentication failed");
    }
  }
}</pre>
<h2 class="SuSAbsatzheadline">Fazit</h2>
<p class="SuSMengentext">Auch wenn Java EE 8 am Ende aus technologischer Sicht vielleicht weniger bietet, als von dem einen oder anderen erhofft, ist es doch ein wichtiger Meilenstein auf dem Weg in die Zukunft des Java-Enterprise-Standards. Zum einen stellt Java EE 8 ein klares Bekenntnis von Oracle bezüglich des Fortbestehens des Umbrella JSR dar – eine Tatsache, an der viele Entwickler aus der Community vor wenigen Monaten noch arg gezweifelt haben. Zum anderen bietet Java EE 8, dank der Fokussierung auf API Alignement und Ease of Development, eine solide Grundlage für den zukünftigen Ausbau der Plattform in Richtung Cloud, Microservices und Reactive Programing.</p>
<p class="SuSMengentext">Positiv anzumerken ist auf jeden Fall, dass mehr und mehr zentrale Themen wie Transaction Handling (Java EE 7) oder Security (Java EE 8) in eigene APIs ausgelagert werden und somit nicht mehr impliziter, proprietärer Bestandteil anderer APIs (z. B. EJB) sind. Das erlaubt dem Java-EE-Entwickler eine deutlich höhere Flexibilität bei der Wahl der Mittel und stellt einen ersten, wichtigen Schritt hin zu einer modularen Java EE Runtime dar, wie wir sie aktuell nur außerhalb des Standards kennen.</p>
<p class="SuSMengentext">Abzuwarten bleibt allerdings, ob es nach Java EE 8 tatsächlich so weitergeht wie geplant und die für Java EE 9 angekündigte Roadmap gehalten werden kann. Das wäre ein extrem wichtiges Signal für alle und würde endlich für ein wenig mehr Ruhe in der Community sorgen.</p>
<div class='widgets_on_page'> <div id="wp_editor_widget-17" class="widget WP_Editor_Widget"><p class="widget-title">Enterprise Tales</p><p><img style="float: left; margin-left: 15px; margin-right: 15px;" title=" " src="https://jaxenter.de/wp-content/uploads/2015/10/Enterprise-Tales-300x200-300x200.jpg" alt="" width="100" height="66" /></p>
<p>In der Kolumne <a href="https://jaxenter.de/tag/Enterprise-Tales">Enterprise Tales</a> erzählen <strong>Lars Röwekamp und Arne Limburg</strong> (<a href="https://www.openknowledge.de/" target="_blank">open knowledge</a>) interessante Geschichten und gibt informative Einsichten  rund um Java EE und die bunte Welt von Enterprise Java.</p>
<p>Bisher erschienen:</p>
<ul>
<li><a title="Enterprise Tales: Die Reihen im Maschinenraum lichten sich" href="https://jaxenter.de/enterprise-tales-die-reihen-im-maschinenraum-lichten-sich-41784" target="_blank">Die Reihen im Maschinenraum lichten sich</a></li>
<li><a title="EnterpriseTales: Des Microservice großer Bruder" href="https://jaxenter.de/enterprisetales-des-microservice-grosser-bruder-39180" target="_blank">Des Microservice großer Bruder</a></li>
<li><a title="Enterprise Tales: Pragmatic REST" href="https://jaxenter.de/enterprise-tales-pragmatic-rest-36008" target="_blank">Pragmatic REST: &#8222;To REST or not to REST&#8220;</a></li>
<li><a href="https://jaxenter.de/app-server-auf-diaet-haben-klassische-application-server-noch-eine-zukunft-35551">App-Server auf Diät: Haben klassische Application Server noch eine Zukunft?</a></li>
<li><a href="https://jaxenter.de/enterprise-tales-mvc-1-0-das-aus-fuer-jsf-30682">MVC 1.0, das Aus für JSF?</a></li>
<li><a href="https://jaxenter.de/enterprise-tales-wie-gross-sollte-ein-optimaler-microservice-sein-28067">Wie groß sollte ein optimaler Microservice sein?</a></li>
<li><a href="https://jaxenter.de/es-tut-sich-was-im-web-servlet-4-0-mit-http2-24161">Es tut sich was im Web: Servlet 4.0 mit HTTP/2</a></li>
<li><a href="https://jaxenter.de/version-2-0-der-cdi-specification-auch-in-java-se-nutzbar-23149">Version 2.0 der CDI Specification auch in Java SE nutzbar</a></li>
<li><a href="https://jaxenter.de/asynchrone-events-in-cdi-2-0-20570">Asynchrone Events in CDI 2.0</a></li>
<li><a href="https://jaxenter.de/alles-valide-bean-validation-in-pojos-mittels-aspektorientierter-programmierung-19882">Alles valide? Bean Validation in POJOs mittels aspektorientierter Programmierung</a></li>
<li><a href="https://jaxenter.de/testen-im-kontext-integration-testing-in-java-ee-19303">Testen im Kontext: Integration Testing in Java EE</a></li>
<li><a href="https://jaxenter.de/reduce-to-the-max-microservices-20205">Reduce to the Max: Microservices</a></li>
<li><a href="https://jaxenter.de/wenn-scopes-fremdgehen-mehr-spass-mit-cdi-scopes-18851">Wenn Scopes fremdgehen: Mehr Spaß mit CDI-Scopes</a></li>
<li><a href="https://jaxenter.de/vorschau-java-ee-8-17106">Was erwartet uns in Java EE 8?</a></li>
<li><a href="https://jaxenter.de/wofuer-braucht-man-java-ee-7-eigentlich-noch-ejbs-13386">Wofür braucht man in Java EE 7 eigentlich noch EJBs?</a></li>
<li><a href="https://jaxenter.de/java-ee-8-meets-mvc-ein-blick-in-die-kristallkugel-13009">Java EE 8 meets MVC: ein Blick in die Kristallkugel</a></li>
</ul>
<p><strong> </strong><a href="https://jaxenter.de/tag/enterprise-tales"><strong>Weitere Teile der Serie Enterprise Tales »»»</strong></a></p>
</div>
  </div><!-- widgets_on_page -->
					</div>
					
										
					
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/java-ee-8-62568" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/java-ee-8-62568" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=Java EE 8: Hält es, was die lange Wartezeit versprochen hat? - https://jaxenter.de/java-ee-8-62568" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/java-ee-8-62568" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/java-ee-8-62568" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/java-ee-8-62568" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/java-ee-8-62568" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/java-ee-8-62568" data-url-old=""></span></div>
						</a>
					</div>
					
					<div class="row"><div class="more-topics"><div class="col-xs-12 col-md-3"><h3 class="box-headline">Verwandte Themen:</h3></div><div class="col-xs-12 col-md-9">		<div class="button-tags-block">
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/java" target="_blank" >
	                   Java 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/java-ee" target="_blank" >
	                   Java EE 	         </a>   
	      		</div>
	</div></div></div>
					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2015/01/rowekamp_lars_sw-119x150.png" width="76" height="96" alt="Lars Röwekamp" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Lars Röwekamp</div>

																							<div class="author-description">
													Lars Röwekamp ist Gründer des IT-Beratungs- und Entwicklungsunternehmens open knowledge GmbH, beschäftigt sich im Rahmen seiner Tätigkeit als „CIO New Technologies“ mit der eingehenden Analyse und Bewertung neuer Software- und Technologietrends. Ein besonderer Schwerpunkt seiner Arbeit liegt derzeit in den Bereichen Enterprise und Mobile Computing, wobei neben Design- und Architekturfragen insbesondere die Real-Life-Aspekte im Fokus seiner Betrachtung stehen. Lars Röwekamp, Autor mehrerer Fachartikel und -bücher, beschäftigt sich seit der Geburtsstunde von Java mit dieser Programmiersprache, wobei er einen Großteil seiner praktischen Erfahrungen im Rahmen großer internationaler Projekte sammeln konnte.												</div>
																				
																							<div class="author-more"><a href="https://jaxenter.de/author/larsrwekamp">Alle Beiträge von Lars Röwekamp</a></div>
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/java-ee-8-javascript-60394" rel="bookmark">
						<div class="image">
															<img width="186" height="130" src="https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin-186x130.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin-186x130.jpg 186w, https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin-150x105.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin-300x210.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin-200x140.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin-170x119.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin-114x80.jpg 114w, https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin-180x126.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/sven-kölpin.jpg 500w" sizes="(max-width: 186px) 100vw, 186px" />													</div>
						<div class="title">
							Zeitgemäße Webentwicklung: Java EE oder JavaScript?						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/die-java-ee-guardians-reden-klartext-java-ee-kann-nicht-von-der-community-allein-getragen-werden-41689" rel="bookmark">
						<div class="image">
															<img width="130" height="130" src="https://jaxenter.de/wp-content/uploads/2016/06/peter-pilgrim-130x130.png" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2016/06/peter-pilgrim-130x130.png 130w, https://jaxenter.de/wp-content/uploads/2016/06/peter-pilgrim-150x150.png 150w, https://jaxenter.de/wp-content/uploads/2016/06/peter-pilgrim-200x199.png 200w, https://jaxenter.de/wp-content/uploads/2016/06/peter-pilgrim-170x169.png 170w, https://jaxenter.de/wp-content/uploads/2016/06/peter-pilgrim-80x80.png 80w, https://jaxenter.de/wp-content/uploads/2016/06/peter-pilgrim-180x179.png 180w, https://jaxenter.de/wp-content/uploads/2016/06/peter-pilgrim.png 293w" sizes="(max-width: 130px) 100vw, 130px" />													</div>
						<div class="title">
							Die Java EE Guardians reden Klartext: &#8222;Java EE kann nicht von der Community allein getragen werden&#8220;						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/frameworks-und-tools-nicht-nur-fuer-grosse-java-ee-projekte-richtig-auswaehlen-30670" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2015/11/shutterstock_291420743.jpg 900w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							Frameworks und Tools (nicht nur) für große Java-EE-Projekte richtig auswählen						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

															<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
														<div class="comments">
		<ol class="comments-list">
			<li id="comment-179712" class="clearfix level-1"><div class="comment-info"><span class="comment-author">Java EE 8: Hält es, was die lange Wartezeit versprochen hat? &#8211; Bizzcheck.de</span><span class="comment-date">2017-09-28 17:03:22</span></div><div class="comment-body"><p>[&#8230;] Die für die Weltwirtschaft durchaus relevanten BRIC-Staaten Brasilien &#8230; innerhalb einer index.html weitere Webressourcen &#8230; (Orginal &#8211; Story lesen&#8230;) [&#8230;]</p>
</div></li></li><!-- #comment-## -->
		</ol>
	</div>

<div class="comment-form-wrapper">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Schreibe einen Kommentar <small><a rel="nofollow" id="cancel-comment-reply-link" href="/java-ee-8-62568#respond" style="display:none;">Antworten abbrechen</a></small></h3>			<form action="https://jaxenter.de/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Deine E-Mail-Adresse wird nicht veröffentlicht.</span></p><p class="comment-form-comment"><label for="comment">Kommentar</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">E-Mail</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Kommentar abschicken" /> <input type='hidden' name='comment_post_ID' value='62568' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d272e11de4" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="130"/></p>			</form>
			</div><!-- #respond -->
	</div>

											</div>
									</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
					<div id="text-16" class="widget widget_text">			<div class="textwidget"><iframe src="https://jax.de/session-qualification/wp-sidebar-feed-featured-box-jax/?layout=sidebarfeed"" width="350" height="800" style="margin:0px; padding:0px; overflow:hidden; border:none;" scrolling="no"> </iframe></div>
		</div><div id="polls-widget-3" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-27" class="wp-polls">
	<form id="polls_form_27" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_27_nonce" name="wp-polls-nonce" value="67f798e124" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="27" /></p>
		<p><strong>Welche Berufsbezeichnung bevorzugt ihr?</strong></p><div id="polls-27-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-212" name="poll_27" value="212" /> <label for="poll-answer-212">Entwickler</label></li>
		<li><input type="radio" id="poll-answer-213" name="poll_27" value="213" /> <label for="poll-answer-213">Softwarearchitekt</label></li>
		<li><input type="radio" id="poll-answer-214" name="poll_27" value="214" /> <label for="poll-answer-214">Software Engineer</label></li>
		<li><input type="radio" id="poll-answer-215" name="poll_27" value="215" /> <label for="poll-answer-215">Programmierer</label></li>
		<li><input type="radio" id="poll-answer-216" name="poll_27" value="216" /> <label for="poll-answer-216">Coder</label></li>
		<li><input type="radio" id="poll-answer-217" name="poll_27" value="217" /> <label for="poll-answer-217">Code Ninja</label></li>
		<li><input type="radio" id="poll-answer-218" name="poll_27" value="218" /> <label for="poll-answer-218">Bastard Operator From Hell (BOFH)</label></li>
		<li><input type="radio" id="poll-answer-219" name="poll_27" value="219" /> <label for="poll-answer-219">Tech-Prophet</label></li>
		<li><input type="radio" id="poll-answer-220" name="poll_27" value="220" /> <label for="poll-answer-220">Source Code Wizard</label></li>
		<li><input type="radio" id="poll-answer-221" name="poll_27" value="221" /> <label for="poll-answer-221">Quelltextgärtner</label></li>
		<li><input type="radio" id="poll-answer-222" name="poll_27" value="222" /> <label for="poll-answer-222">Fachinformatiker</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(27);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-27-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="aktuelle_magazine-4" class="widget widget_aktuelle_magazine"><div class="ausgabe-wrapper"><p class="widget-title">Artikel erschienen in</p><div class="image"><a href="https://jaxenter.de/ausgaben/java-magazin"><img width="212" height="300" src="https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842.jpg 595w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-106x150.jpg 106w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-212x300.jpg 212w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-200x283.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-170x241.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-92x130.jpg 92w, https://jaxenter.de/wp-content/uploads/2017/07/Java-Magazin-9-17_Cover_595x842-180x255.jpg 180w" sizes="(max-width: 212px) 100vw, 212px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/ausgaben/java-magazin">Java Magazin 9.17</a></div><div class="button"><a href="https://jaxenter.de/ausgaben/java-magazin" class="button">Infos zum Heft</a></div></div></div></div><div id="tag-widget-2" class="widget TagWidget"><a href="https://jaxenter.de/tag/kolumne"><p class="widget-title">Kolumnen</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Eclipse Kolumne Lagebericht Eclipse" id="posts-by-tag-item-62447"><a class="thumb" href="https://jaxenter.de/kolumne-eclipse-git-mit-eclipse-62447" title="Getting Git done mit Eclipse"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2017/09/kolumne_lagebericht_eclipse-ide-300x150-300x150-1-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/kolumne_lagebericht_eclipse-ide-300x150-300x150-1-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/kolumne_lagebericht_eclipse-ide-300x150-300x150-1.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/kolumne_lagebericht_eclipse-ide-300x150-300x150-1-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/kolumne_lagebericht_eclipse-ide-300x150-300x150-1-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/kolumne_lagebericht_eclipse-ide-300x150-300x150-1-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/kolumne_lagebericht_eclipse-ide-300x150-300x150-1-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/kolumne_lagebericht_eclipse-ide-300x150-300x150-1-180x90.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/kolumne-eclipse-git-mit-eclipse-62447">Getting Git done mit Eclipse</a></li><li class="posts-by-tag-item Agile DevOps DevOps Stories Kolumne" id="posts-by-tag-item-61602"><a class="thumb" href="https://jaxenter.de/devops-stories-crossfunktionale-teams-61602" title="DevOps Stories: Das kann doch nicht jeder anders machen!"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/DevOps_Stories-300x200-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops-stories-crossfunktionale-teams-61602">DevOps Stories: Das kann doch nicht jeder anders machen!</a></li><li class="posts-by-tag-item Diversität Karriere Kolumne Women in Tech" id="posts-by-tag-item-62471"><a class="thumb" href="https://jaxenter.de/women-in-tech-daniela-sfregola-62471" title="Kulturelle Einflüsse werden nicht durch Geschlecht, sondern durch Vielfalt getrieben"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/09/Women_in_Tech_Aufmacher_900x450_39593_Daniela_Stregola.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/women-in-tech-daniela-sfregola-62471">Kulturelle Einflüsse werden nicht durch Geschlecht, sondern durch Vielfalt getrieben</a></li><li class="posts-by-tag-item Backend meets Frontend Kolumne Security Vaadin" id="posts-by-tag-item-61670"><a class="thumb" href="https://jaxenter.de/vaadin-webanwendungen-apache-shiro-61670" title="Webanwendungen absichern mit Apache Shiro"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/07/backend-frontend-vaadin.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/vaadin-webanwendungen-apache-shiro-61670">Webanwendungen absichern mit Apache Shiro</a></li><li class="posts-by-tag-item Android Kolumne Planet Android Security" id="posts-by-tag-item-62314"><a class="thumb" href="https://jaxenter.de/planet-android-security-play-billing-library-62314" title="Planet Android: Safety first, PHAs und Google Play Billing Library"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Planet-Android-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/planet-android-security-play-billing-library-62314">Planet Android: Safety first, PHAs und Google Play Billing Library</a></li></ul></div><div id="bwp_recent_comments-2" class="widget bwp-rc-widget"><p class="widget-title">Letzte Kommentare</p>
		<ul class="bwp-rc-ulist">
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Jonas</span><span class="recent-comment-text"> Hi, vielen Dank für die Einführung! Gibt es Teil 3 + 4 auch schon? MfG Jonas </span> <a href="https://jaxenter.de/java-tutorial-einsteiger-ii-47387#comment-179713" title="Comment on Java-Tutorial für Einsteiger - Teil 2: die wichtigsten Sprachmerkmale"><strong>Java-Tutorial für Einsteiger - Teil 2: die wichtigsten Sprachmerkmale</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Der Baron</span><span class="recent-comment-text"> Es ist doch so, die meisten PM's haben doch gar nicht die Eier in der Hose um dem Kunden von vornherein zu sagen "Du bekommst... </span> <a href="https://jaxenter.de/die-10-todsunden-der-aufwandsschatzung-fur-entwickler-351#comment-179690" title="Comment on Die 10 Todsünden der Aufwandsschätzung für Entwickler"><strong>Die 10 Todsünden der Aufwandsschätzung für Entwickler</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author">Steven</span><span class="recent-comment-text"> Interessantes Thema. Danke dafür. 🙂 </span> <a href="https://jaxenter.de/microservices-docker-angular-spring-boot-61340#comment-179530" title="Comment on Microservices mit Docker, Angular und Spring Boot"><strong>Microservices mit Docker, Angular und Spring Boot</strong></a></span></li>
		</ul>
</div><div id="featured_posts-2" class="widget widget_featured_posts"><p class="widget-title">Featured Posts</p><ul class="featured-posts-list"><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/java-ee-8-62568"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-9-17_Aufmacher_Roewekamp_shutterstock_Macrovector_300x200-180x120.jpg 180w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/java-ee-8-62568">Java EE 8: Hält es, was die lange Wartezeit versprochen hat?</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/spring-5-released-62586"><img width="120" height="80" src="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-120x80.jpg" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Java-Magazin-5-17_Aufmacher_Gierke_shutterstock_Depiano_300x200-180x120.jpg 180w" sizes="(max-width: 120px) 100vw, 120px" /></a></div><div class="title"><a href="https://jaxenter.de/spring-5-released-62586">Spring 5 ist da! Frühling für Enterprise Java</a></div></li><li class="clearfix"><div class="thumb"><a href="https://jaxenter.de/java-9-infografik-project-jigsaw-62290"><img width="114" height="80" src="https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-114x80.png" class="attachment-widget-featured size-widget-featured wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-114x80.png 114w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-150x105.png 150w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-300x211.png 300w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-200x140.png 200w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-170x119.png 170w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-185x130.png 185w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic-180x126.png 180w, https://jaxenter.de/wp-content/uploads/2017/09/jigsawinfographic.png 500w" sizes="(max-width: 114px) 100vw, 114px" /></a></div><div class="title"><a href="https://jaxenter.de/java-9-infografik-project-jigsaw-62290">Java 9 Infografik: Project Jigsaw auf einen Blick</a></div></li></ul></div><div id="newsletter-2" class="widget widget_newsletter"><p class="widget-title">Newsletter</p><div class="newsletter"><p class="newsletter-icon pull-left"><a href="https://jaxenter.de/newsletter"><img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter.jpg" alt="Newsletter" /></a></p><p class="newsletter-info"><a href="https://jaxenter.de/newsletter">Alle Neuigkeiten die wichtig sind, mit dem JAXenter Newsletter!</a></p><p><a href="https://jaxenter.de/newsletter">Jetzt bestellen!</a></p></div></div><div id="text-4" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD1_Wordpress -->
<div id='div-gpt-ad-1423038811881-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-0'); });
</script>
</div></div>
		</div><div id="tag-widget-7" class="widget TagWidget"><a href="https://jaxenter.de/tag/Docker"><p class="widget-title">Dossier Docker</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Docker Linux Tutorial" id="posts-by-tag-item-62049"><a class="thumb" href="https://jaxenter.de/docker-einfuehrung-linux-basics-62049" title="Einführung: Was Sie über Docker wissen müssen"  ><img width="150" height="92" src="https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-150x92.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-150x92.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-300x185.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-200x123.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-170x105.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-120x74.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-190x117.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung-180x111.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/09/Docker-Einführung.jpg 650w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/docker-einfuehrung-linux-basics-62049">Einführung: Was Sie über Docker wissen müssen</a></li><li class="posts-by-tag-item Container Docker" id="posts-by-tag-item-61779"><a class="thumb" href="https://jaxenter.de/docker-virtuelle-maschine-61779" title="Docker vs. Virtuelle Maschine: Wo liegen die Unterschiede?"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="© Shutterstock / Julia Waller" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-150x150.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-300x300.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-768x768.jpg 768w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-200x200.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-170x170.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-80x80.jpg 80w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-130x130.jpg 130w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps-180x180.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/08/Docker-Tipps.jpg 800w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/docker-virtuelle-maschine-61779">Docker vs. Virtuelle Maschine: Wo liegen die Unterschiede?</a></li><li class="posts-by-tag-item Docker Java Programmieren" id="posts-by-tag-item-61732"><a class="thumb" href="https://jaxenter.de/verwirrender-code-und-namensgebung-topthemen-der-woche-61732" title="Von verwirrendem Code und sinnbefreiten Programmiersprachen &#8211; unsere Topthemen der Woche"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-200x134.jpg 200w, https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2016/02/shutterstock_311465798.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/verwirrender-code-und-namensgebung-topthemen-der-woche-61732">Von verwirrendem Code und sinnbefreiten Programmiersprachen - unsere Topthemen der Woche</a></li><li class="posts-by-tag-item Container Docker" id="posts-by-tag-item-61716"><a class="thumb" href="https://jaxenter.de/top-10-docker-logging-probleme-61716" title="Top 10 Docker-Logging-Probleme, die jeder kennen sollte"  ><img width="150" height="85" src="https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494-150x85.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494-150x85.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494-300x169.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494-200x113.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494-170x96.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494-120x68.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494-190x107.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494-180x102.jpg 180w, https://jaxenter.de/wp-content/uploads/2017/09/shutterstock_315885494.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/top-10-docker-logging-probleme-61716">Top 10 Docker-Logging-Probleme, die jeder kennen sollte</a></li></ul></div><div id="text-5" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD2_Wordpress -->
<div id='div-gpt-ad-1423038811881-1' style='width:300px; height:250px; clear:both;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-1'); });
</script>
</div></div>
		</div><div id="text-6" class="widget widget_text">			<div class="textwidget"><!-- jaxenter.de_contentAD3_Wordpress -->
<div id='div-gpt-ad-1423038811881-2' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-2'); });
</script>
</div></div>
		</div><div id="text-15" class="widget widget_text">			<div class="textwidget"></div>
		</div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-4'); });
        </script>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423038811881-5'); });
        </script>
        </div>
    </div>
</div>				</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="/magazine/business-technology">Business Technology Magazin</a></li>
<li id="menu-item-38592" class="menu-item menu-item-type-post_type menu-item-object-magazin menu-item-38592"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="http://sharepoint-kompendium.de">SharePoint Kompendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13255"><a href="https://finance.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX Finance (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://btdays.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Business Technology Days</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="http://bigdatacon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BigData Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://webtechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">WebTech Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="http://entwickler-akademie.de">Entwickler Akademie</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-563H99" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-563H99');</script>
<!-- End Google Tag Manager -->

		
		<!-- Facebook Ads Pixel Code -->
		<script>
			(function() {
				var _fbq = window._fbq || (window._fbq = []);
				if (!_fbq.loaded) {
					var fbds = document.createElement('script');
					fbds.async = true;
					fbds.src = '//connect.facebook.net/en_US/fbds.js';
					var s = document.getElementsByTagName('script')[0];
					s.parentNode.insertBefore(fbds, s);
					_fbq.loaded = true;
				}
				_fbq.push(['addPixelId', '407071789447604']);
			})();
			window._fbq = window._fbq || [];
			window._fbq.push(['track', 'PixelInitialized', {}]);
		</script>
		<noscript>
			<img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=407071789447604&ev=PixelInitialized" />
		</noscript>

		<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		//document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		
		document.getElementById("syntaxhighlighteranchor").parentNode.insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		//document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
		
		document.getElementById("syntaxhighlighteranchor").parentNode.insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.7.5' type='text/css' media='all' />
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
	</body>
</html>
