Design by Contract: GContracts 1.2.5 unterstützt Groovy 1.8.4

Hartmut Schlosser

Ein Update steht für die Groovy-basierte Bibliothek GContracts zur Verfügung. Die Version 1.2.5 ist vornehmlich ein Bugfix-Release, in dem u.a. ein Kompilierungsfehler in den Spock-Spezifikationen behoben wurde. Kompatibel ist GContracts nun mit Groovy 1.8.4.

GContracts ist eine quelloffene Bibliothek für die Erweiterung von Groovy um Design-by-Contract-Funktionen. Eine Einführung in die Bibliothek bietet der JAXenter-Artikel „Design by Contract mit Groovy„.

Geschrieben von
Hartmut Schlosser
Kommentare

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.