<!DOCTYPE html>
<html lang="de-DE"><head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">

		<title>EnterpriseTales: Cloud-Computing is someone else’s computer</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://jaxenter.de/xmlrpc.php">
		<link rel="shortcut icon" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/favicon.ico" type="image/vnd.microsoft.icon" />
		<link href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700|Lato:400,700|Source+Code+Pro:400,600' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/bootstrap.min.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/font-awesome.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/stylesheets/screen.css">
		<link rel="stylesheet" type="text/css" href="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/css/bootstrap-select.min.css">
		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
                <script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/jquery.min.js"></script>
		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
		<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
		<![endif]-->
	<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-563H99');</script>
	
<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Die Nachfrage für Cloud Computing steigt. Doch was genau steckt dahiner und was muss man bei diesem Geschäftsmodell beachten?"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" />
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="EnterpriseTales: Cloud-Computing is someone else’s computer" />
<meta property="og:description" content="Die Nachfrage für Cloud Computing steigt. Doch was genau steckt dahiner und was muss man bei diesem Geschäftsmodell beachten?" />
<meta property="og:url" content="https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" />
<meta property="og:site_name" content="JAXenter" />
<meta property="article:tag" content="Cloud" />
<meta property="article:tag" content="Enterprise Tales" />
<meta property="article:tag" content="Microservices" />
<meta property="article:section" content="Kolumnen" />
<meta property="article:published_time" content="2020-04-30T05:17:00+00:00" />
<meta property="article:modified_time" content="2020-04-28T06:22:40+00:00" />
<meta property="og:updated_time" content="2020-04-28T06:22:40+00:00" />
<meta property="og:image" content="https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1.jpg" />
<meta property="og:image:secure_url" content="https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="200" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://jaxenter.de/#website","url":"https://jaxenter.de/","name":"JAXenter","inLanguage":"de-DE","description":"Infos &amp; News f\u00fcr Java, Architektur, Web &amp; DevOps","potentialAction":{"@type":"SearchAction","target":"https://jaxenter.de/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806#primaryimage","inLanguage":"de-DE","url":"https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1.jpg","width":300,"height":200},{"@type":"WebPage","@id":"https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806#webpage","url":"https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806","name":"EnterpriseTales: Cloud-Computing is someone else\u2019s computer","isPartOf":{"@id":"https://jaxenter.de/#website"},"inLanguage":"de-DE","primaryImageOfPage":{"@id":"https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806#primaryimage"},"datePublished":"2020-04-30T05:17:00+00:00","dateModified":"2020-04-28T06:22:40+00:00","author":{"@id":"https://jaxenter.de/#/schema/person/414da884dfe0af9af5371341b0aac7ef"},"description":"Die Nachfrage f\u00fcr Cloud Computing steigt. Doch was genau steckt dahiner und was muss man bei diesem Gesch\u00e4ftsmodell beachten?"},{"@type":["Person"],"@id":"https://jaxenter.de/#/schema/person/414da884dfe0af9af5371341b0aac7ef","name":"Redaktion JAXenter","image":{"@type":"ImageObject","@id":"https://jaxenter.de/#authorlogo","inLanguage":"de-DE","url":"https://secure.gravatar.com/avatar/6a4ad402b592f41c2e8be2961bff851f?s=96&d=wp_user_avatar&r=g","caption":"Redaktion JAXenter"},"sameAs":["https://twitter.com/jaxenter"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="JAXenter &raquo; EnterpriseTales: Cloud-Computing is someone else’s computer Kommentar-Feed" href="https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jaxenter.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='https://jaxenter.de/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://jaxenter.de/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='sands-breaking-news-css'  href='https://jaxenter.de/wp-content/plugins/sands-breaking-news/includes/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://jaxenter.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://jaxenter.de/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpdiscuz-font-awesome-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.0.6/css/fontawesome-all.min.css?ver=5.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz.css?ver=5.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-user-content-css-css'  href='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-user-content.css?ver=5.3.5' type='text/css' media='all' />

<!-- This site uses the Google Analytics by MonsterInsights plugin v 6.0.13 - https://www.monsterinsights.com/ -->
<!-- Normally you will find the Google Analytics tracking code here, but the webmaster disabled your user group. -->
<!-- / Google Analytics by MonsterInsights -->

<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/wpdccjs/wpdcc.js?ver=5.3.5'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=5.3.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/jaxenter.de\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Antworten verbergen","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Bitte f\u00fclle alle ben\u00f6tigten Felder aus","wc_invalid_field":"Nicht alle von dir ausgef\u00fcllten Felder sind richtig.","wc_error_empty_text":"Bitte f\u00fclle dieses Feld aus.","wc_error_url_text":"Bitte \u00fcberpr\u00fcfe deine angegebene URL.","wc_error_email_text":"Bitte \u00fcberpr\u00fcfe deine angegebene Email-Adresse.","wc_invalid_captcha":"Leider wurde der CAPTCHA -Code falsch eingetragen","wc_login_to_vote":"Um deine Stimme abgeben zu k\u00f6nnen musst du angemeldet sein.","wc_deny_voting_from_same_ip":"Es ist nur eine Stimm-Vergabe m\u00f6glich.","wc_self_vote":"Eigene Kommentare k\u00f6nnen nicht bewertet werden.","wc_vote_only_one_time":"Es ist immer nur eine Bewertung erlaubt.","wc_voting_error":"Bewertungs-Fehler bei deiner Wahl: Bitte versuche es erneut","wc_held_for_moderate":"Dein Kommentar wurde zur Freischaltung vorgelegt.","wc_comment_edit_not_possible":"Tut uns leid aber dieser Kommentar kann leider nicht mehr aktualisiert werden.","wc_comment_not_updated":"Tut uns leid aber dieser Kommentar konnte leider nicht aktualisiert werden.","wc_comment_not_edited":"Es wurden keine \u00c4nderungen von dir vorgenommen.","wc_new_comment_button_text":"neuer Kommentar","wc_new_comments_button_text":"neue Kommentare","wc_new_reply_button_text":"Neue Antwort auf deinen Kommentar","wc_new_replies_button_text":"Bei einen von dir abonnierten Video wurde eine neue Antwort ver\u00f6ffentlicht.","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":false,"commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wpdiscuzCommentsOrder":"asc","wpdiscuzCommentOrderBy":"comment_date_gmt","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":4000,"storeCommenterData":100000,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"socialLoginAgreementCheckbox":0,"enableFbLogin":0,"enableFbShare":0,"facebookAppID":"","facebookUseOAuth2":0,"enableGoogleLogin":0,"googleAppID":"","cookiehash":"b68f42a0021b63881a010e7410207d2c","isLoadOnlyParentComments":0,"ahk":"","enableDropAnimation":0,"isNativeAjaxEnabled":1,"cookieCommentsSorting":"wpdiscuz_comments_sorting","enableLastVisitCookie":0,"version":"5.3.5","wc_post_id":94806,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","isCookiesEnabled":true,"wc_captcha_show_for_guest":"1","wc_captcha_show_for_members":"0","is_email_field_required":"1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js?ver=5.3.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Sind Sie sicher, dass Sie diesen Kommentar l\u00f6schen wollen?","msgConfirmCancelSubscription":"Sind Sie sicher, dass Sie Ihr Abo k\u00fcndigen wollen?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-user-content.js?ver=5.3.5'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/third-party/lity/lity.js?ver=5.3.5'></script>
<link rel='https://api.w.org/' href='https://jaxenter.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jaxenter.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jaxenter.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://jaxenter.de/?p=94806' />
<link rel="alternate" type="application/json+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fcloud%2Fcloud-computing-microservices-monolith-94806" />
<link rel="alternate" type="text/xml+oembed" href="https://jaxenter.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjaxenter.de%2Fcloud%2Fcloud-computing-microservices-monolith-94806&#038;format=xml" />
            <style>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</style>
            	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<style type="text/css" id="syntaxhighlighteranchor"></style>
		<style type="text/css" id="wp-custom-css">
			/*
Füge deinen eigenen CSS-Code nach diesem Kommentar hinter dem abschließenden Schrägstrich ein. 



Klicke auf das Hilfe-Symbol oben, um mehr zu erfahren.
*/
@media print{
article.post.single .social-icons, .footer-menu, #sidebar, .related-posts, .comments-wrapper{
display:none;
}
}		</style>
		
		

			<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>

		<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
		<script type="text/javascript">
			window.cookieconsent_options = {"message":"Wir haben unsere Cookie-Policy geändert. Wir verwenden Cookies, um Ihnen die bestmögliche Surferfahrung auf unseren Webseiten zu bieten. Darunter fallen auch Cookies von Social-Media-Diensten, insofern Inhalte von diesen Diensten auf unseren Webseiten eingebettet sind. Diese Cookies können Ihre Nutzung unserer Webseiten tracken. Wir und unsere Partner verwenden ebenfalls Cookies, um sicherzustellen, dass Ihnen für Sie relevante Werbeinhalte gezeigt werden.","dismiss":"Verstanden","learnMore":"Mehr Infos","link":"https://jaxenter.de/datenschutz","theme":"dark-bottom"};
		</script>

		<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
		<!-- End Cookie Consent plugin -->


	</head>
	<body class="post-template-default single single-post postid-94806 single-format-standard">
		<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-563H99"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
		        <header>
                	<div class="topnav">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper pull-left">
							<a href="https://jaxenter.de/" class="logo"></a>
						</div>

						<div class="menu-wrapper pull-left">
							<div class="visible-xs visible-sm">
								<button type="button" class="navbar-toggle">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>
							</div>
							<div class="hidden-xs hidden-sm">
								
<div class="hidden-xs hidden-sm">
	<ul id="menu-menu" class="menu"><li id="menu-item-13610" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-13610"><a href="/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://jaxenter.de/news">News</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33"><a href="https://jaxenter.de/artikel">Artikel</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://jaxenter.de/videos">Videos</a></li>
<li id="menu-item-86812" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86812"><a href="https://kiosk.entwickler.de/java-magazin/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">Java Magazin</a></li>
<li id="menu-item-77506" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77506"><a href="https://e-academy.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">e.academy</a></li>
<li id="menu-item-77814" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77814"><a href="https://jax.de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_campaign=hauptnavi">JAX 2020</a></li>
</ul></div>

							</div>
						</div>
						<div class="search-wrapper pull-right">
							<div class="clearfix">
								<div class="search-label pull-left">Suche</div>
								<div class="search-form pull-left">
									<form method="get" action="https://jaxenter.de/">
										<button class="search-button" id="searchbutton">
											<i class="icon icon-search"></i>
										</button>
										<input type="text" class="search-input" name="s" placeholder="Geben Sie bitte Ihren Suchbegriff ein" onblur="$('.search-wrapper').toggleClass('active');" />
									</form>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>
           			<div class="container subnavigation hidden-xs hidden-sm">
		<div class="container">
				<ul id="menu-subnavi-general" class="menu"><li id="menu-item-16648" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16648"><a href="https://jaxenter.de/tag/java">Java</a></li>
<li id="menu-item-16645" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16645"><a href="https://jaxenter.de/tag/devops">DevOps</a></li>
<li id="menu-item-33513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33513"><a href="https://jaxenter.de/tag/microservices">Microservices</a></li>
<li id="menu-item-79302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79302"><a href="https://jaxenter.de/tag/serverless">Serverless</a></li>
<li id="menu-item-59870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59870"><a href="https://jaxenter.de/tag/kubernetes">Kubernetes</a></li>
<li id="menu-item-59869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59869"><a href="https://jaxenter.de/tag/blockchain">Blockchain</a></li>
<li id="menu-item-16646" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16646"><a href="https://jaxenter.de/tag/eclipse">Eclipse</a></li>
<li id="menu-item-16642" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16642"><a href="https://jaxenter.de/tag/android">Android</a></li>
<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-16641"><a href="https://jaxenter.de/tag/agile">Agile</a></li>
<li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://jaxenter.de/tag/machine-learning">Machine Learning</a></li>
</ul>		</div>
	</div>
             </div>

			<div class="subnav hidden-xs hidden-sm">
                  <div class="announcement">
                    <div class="container">
                        <div class="row">
                            <div class="col-lg-8 col-md-8 mood-message-top">
                                                                                                            <span class="prefix">DevOps im Jahr 2020:</span>
                                    
                                    <u><a href="https://jaxenter.de/devops/devops-2020-survey-94449">Unsere große DevOps-Umfrage</a></u>                                                            </div>
                            <div class="col-lg-4 col-md-4 text-right hidden-sm hidden-xs">
                                <a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


                            </div>
                        </div>
                    </div>
                </div>

			                <div class="highlights hidden-sm hidden-xs">
                    <div class="container">
                        <div class="row">
                                                                                                                            <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/10/DevOpsCon-Logo-schwarz2-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p><a href="https://devopscon.io/berlin-de/" target="_blank" rel="noopener">DevOpsCon &#8211; Berlin | 12. bis 15. Oktober 2020</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2020/04/Gopher-74x50.jpg" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p class="title"><a href="https://kiosk.entwickler.de/kiosk-specials/kiosk-specials-volume-3/" target="_blank" rel="noopener">Kiosk Special Vol. 3: Alles zur Programmiersprache Go</a></p>
</div>
                                        </div>
                                    </div>
                                                                    <div class="col-lg-4 col-md-4 col-sm-4">
                                        <div class="highlight clearfix">
                                                                                                                                        <div class="image">
                                                                                                    <img src="https://jaxenter.de/wp-content/uploads/2017/12/Konferenzlogos_300x200_44484_v1_JAX-74x50.png" width="74" height="50" />
                                                </div>
                                                                                        <div class="text"><p><a href="https://jax.de">JAX 2020 | 7. bis 11. September, Mainz</a></p>
</div>
                                        </div>
                                    </div>
                                                                                    </div>
                    </div>
                </div>
			
          </div>
          <div class="custom_header_wa">
                    </div>
		</header>
	<script type="text/javascript">
	$( document ).ready(function() {
		$('.single .next-article-popup-post .popup-close').click(function(){
			$('.single .next-article-popup-post').hide();
		});
		$(window).scroll(function() {
		   var hT = $('#content > .text').offset().top,
		       hH = $('#content > .text').outerHeight(),
		       wH = $(window).height(),
		       wS = $(this).scrollTop();
		   if (wS > (hT+hH-wH)){
			   //console.log(wS);
			   if(!$('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').addClass('active');
			   }
		   }else{
			   if($('.single .next-article-popup-post').hasClass('active')){
			   		$('.single .next-article-popup-post').removeClass('active');
			   }
		   }
		});
	}); 
	</script>
	<div class="hidden-xs next-article-popup-post ">
	    <strong class="popup-heading">Nächster Beitrag:</strong>
	    <div class="popup-content">
	    	        <figure class="thumb">
	            <a href="https://jaxenter.de/cloud-native-serverless-java-mit-quarkus-und-graalvm-auf-aws-lambda-94817"><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-150x75.jpg" class="alignleft wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/04/Köbler_900x450.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a>
	           <!--  <img src="https://entwickler.de/wp-content/uploads/2017/07/ff-brotli-dotnet-mozilla-stt-engine-90x45.jpg" alt="" data-pin-no-hover="true"> -->
	        </figure>
	   	        <h3 class="popup-post-title"><a href="https://jaxenter.de/cloud-native-serverless-java-mit-quarkus-und-graalvm-auf-aws-lambda-94817">"Cloud Native Serverless Java mit Quarkus und GraalVM auf AWS Lambda"</a></h3>
	    </div>
	    <span class="popup-close">X</span>
	</div>
	


	<article class="post single">
							
		
		<div id="main" class="container">
			<div class="row">
				<div id="content" class="col-md-8 col-sm-12">
					
											<div class="old">
															<div class="tagline">Kolumne</div>
														<h1 class="title">EnterpriseTales: Cloud-Computing is someone else’s computer</h1>
							
									<div class="button-tags-block">
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/cloud" target="_blank" >
	                  #Cloud 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/enterprise-tales" target="_blank" >
	                  #Enterprise Tales 	         </a>   
	      	        <a class="boxed-tag-button tags" href="https://jaxenter.de/tag/microservices" target="_blank" >
	                  #Microservices 	         </a>   
	      		</div>
								
															<div class="meta">
									<span class="date">
										<i class="icon icon-calendar-o"></i>
																				<time datetime="2020-04-30T07:17">30. April 2020</time>
									</span>

																			<span class="author">
											<i class="icon icon-user"></i>
											Lars Kölpin										</span>
																	</div>
							
															<div class="image">
									<img width="300" height="200" src="https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/01/Enterprise-Tales-300x200-1-180x120.jpg 180w" sizes="(max-width: 300px) 100vw, 300px" />									
									<div class="credits"><p style="text-align: right;"><span style="color: #999999;">© S&amp;S Media</span></p>
</div>
								</div>
														
															<div class="excerpt">
									<p>Schon lange hören wir von Kunden immer wieder von der Absicht, in die Cloud zu wollen. So viele Befürworter hinter dem Geschäftsmodell stehen, so viele Kritiker stehen ihm gegenüber. Bei Vorfällen hört man dann immer öfter in scherzhaftem Ton, dass Cloud-Computing nur „someone else’s“ Computer sei. Doch ist das tatsächlich noch so? Steckt hinter Cloud-Computing wirklich nur der Computer von jemand anderem, oder hat sich das Geschäftsmodell in den letzten Jahren gewandelt?</p>
								</div>
													</div>
					
					
					
					<div class="text">
						<h2>Vom zentralen Team zum dezentralen Team</h2>
<p>Früher war das Entwicklerdasein doch so einfach. Der Kunde bzw. die Fachabteilung hatte einen Wunsch, gab uns ein bisschen Zeit, den Wunsch umzusetzen, und ein paar Monate später sahen wir uns mit der fertigen Software wieder. Diese wurde an die Testabteilung übergeben. Nachdem sie nach einer mehrwöchigen Testphase abgenommen wurde, wurde die Software in Produktion genommen. Doch es hat sich etwas verändert. Unternehmen setzen in ihrer IT-Abteilung heutzutage vermehrt auf agile Methoden, Extreme Programming und praktizieren den „Continuous Process“ – um genau zu sein, also das permanente Integrieren von Veränderungen im Code sowie kleine Releasezyklen.</p>
<p>Als der Streaminggigant Netflix das Konzept der Microservices etablierte, gab es eine regelrechte Revolution. Unternehmen wollten keine große Software – genannt Monolith – mehr, sondern kleine, unabhängige Dienste, die gemeinsam eine Softwarelandschaft ergeben. Jeder dieser Dienste wird dabei von einem separaten Team betrieben, das einen reibungslosen Ablauf des jeweiligen Dienstes gewährleistet. Frei nach dem Motto: „You build it, you run it.“ Der Entwickler wandelt sich damit einhergehend in vielen Unternehmen immer mehr vom reinen Developer zu einem vollständigen Produktbetreiber eines Dienstes. Damit verbunden migrieren immer mehr Unternehmen ihre Infrastruktur in die Cloud. Doch warum ist das so?</p>
<p>Damit Software Werte für das Unternehmen generieren kann, müssen diese in irgendeiner Weise auf einem physikalischen Computer laufen. Das führt dazu, dass Unternehmen vor dem eigentlichen Release der Software in eine Infrastruktur investieren müssen, indem sie physikalische Rechner anschaffen und dafür sorgen, dass sie störungsfrei laufen. Software, die in Produktion betrieben wird, sollte der Erfahrung nach isoliert, also auf für die Software eigener oder virtualisierter Hardware, betrieben werden, damit ein System bei falscher Konfiguration andere Systeme nicht beeinflusst. Wird die Software von Endkonsumenten besser angenommen als erwartet und wird zu wenig in eine Infrastruktur investiert, muss trotzdem eine Verfügbarkeit sichergestellt werden. Wird im Gegensatz dazu das Produkt weniger gut angenommen, wurde für die bereitgestellte Infrastruktur unnötiges Geld ausgegeben. Die perfekte Investition für das Betreiben der Rechner ist deshalb kaum vorherzusagen. Wird die Software international verwendet, muss darüber hinaus eine gute Antwortzeit in den verschiedenen Regionen der Welt garantiert werden. Läuft der Speicher des Servers voll, muss er erweitert werden. Damit sichergestellt werden kann, dass keine Daten verloren gehen, darf das regelmäßige Erstellen eines Backups natürlich nicht fehlen. Die Kosten der Software bestehen also nicht nur aus der reinen Entwicklung, sondern beinhalten auch versteckte Kosten von Hardware, Monitoring und Wartung der Hardware. Das sind Kostenpunkte, die vor allem durch die vielen kleinen Teams und Dienste, die der Microservices-Ansatz mit sich bringt, multipliziert werden.</p>
<div class='widgets_on_page'> <div id="wysiwyg_widgets_widget-12" class="widget widget_wysiwyg_widgets_widget"><!-- Widget by WYSIWYG Widgets v2.3.6 - https://wordpress.org/plugins/wysiwyg-widgets/ --><div style="width: 100%; padding: 0 0px 0 0px; background-color: #f5f5f5; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://apiconference.net/program/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"><img style="width: 100%; height: auto;" src="/wp-content/uploads/2020/03/APIC_SE20_Smartblocks_57045_v1_2.jpg" alt="API Confernce 2020" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="/wp-content/uploads/2020/03/APIC_SE20_Smartblocks_57045_v1_1.jpg" alt="API Confernce 2020" /></div>
</div>
<div class="col-xs-12" style="background-color: #f5f5f5; padding: 15px; display: grid;">
<div class="col-xs-12" style="border-bottom: 1px solid #9d9d9c;">
<div class="col-xs-1" style="padding: 5px 0;"><img class="alignnone" style="max-width: 100%; height: auto; border: 1px solid #fff;" src="/wp-content/uploads/2020/02/Rahul-Dighe-15.jpg" alt="Rahul Dighe" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #8bb315;"><a style="color: #002782; font-size: 19px; font-weight: 600;" href="https://apiconference.net/api-platforms-software-as-a-service/mistakes-to-avoid-while-building-api-products/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"><span style="color: #6322e6;"><span style="color: #cc3333;">Mistakes to avoid while building API Products</span></span></a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Rahul Dighe (PayPal)</p>
</div>
</div>
<div class="col-xs-12" style="border-bottom: 1px solid #9d9d9c;">
<div class="col-xs-1" style="padding: 5px 0;"><img class="alignnone" style="max-width: 100%; height: auto; border: 1px solid #fff;" src="/wp-content/uploads/2019/12/Petteri-Kivimäki.jpg" alt="Petteri Kivimäki" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #8bb315;"><a style="color: #002782; font-size: 19px; font-weight: 600;" href="https://apiconference.net/api-platforms-software-as-a-service/apis-and-cross-border-data-exchange-in-e-government-context/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"><span style="color: #6322e6;"><span style="color: #cc3333;">APIs and Cross-Border Data Exchange in E-Government Context</span></span></a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Petteri Kivimäki (NIIS)</p>
</div>
</div>
<div class="col-xs-12" style="border-bottom: 1px solid #9d9d9c;">
<div class="col-xs-1" style="padding: 5px 0;"><img class="alignnone" style="max-width: 100%; height: auto; border: 1px solid #fff;" src="/wp-content/uploads/2019/12/Dr.-Matthew-O-Riordan.jpg" alt="Petteri Kivimäki" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><span style="color: #8bb315;"><a style="color: #002782; font-size: 19px; font-weight: 600;" href="https://apiconference.net/api-design/taming-the-rising-complexity-of-event-driven-apis/?utm_source=jaxenter.de&amp;utm_medium=referral&amp;utm_content=ArtikelFeature&amp;utm_campaign=Contentbox"><span style="color: #6322e6;"><span style="color: #cc3333;">Taming the rising complexity of Event-Driven APIs</span></span></a></span></h3>
<p style="margin: 0px 0 5px; color: #000;">Ably Realtime (Ably Realtime)</p>
</div>
</div>
</div>
<p>&nbsp;</p>
</div>
<div style="width: 100%; padding: 0 0px 0 0px; background-color: #fff; border: 0px solid #DDDDDD;">
<div class="sands-smart-block-box col-xs-12" style="margin: 0 !important; padding: 0;">
<div class="sands-sb-header col-xs-12 hidden-xs sands-sb-header-big" style="padding: 0;"><a href="https://domaindrivendesign-training.de/"><img style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2020/04/DDD_Camp_20_sblock_jaxenter_2126x162_57460_v2_remote-3.jpg" alt="DDD Camp" /></a></div>
<div class="sands-sb-header col-xs-12 visible-xs sands-sb-header-small" style="padding: 0;"><img class="" style="width: 100%; height: auto;" src="https://jaxenter.de/wp-content/uploads/2020/04/DDD_Camp_20_sblock_jaxenter_700x350_57460_v2_remote-3.jpg" alt="DDD Camp" /></div>
<div class="sands-sb-content col-xs-12">
<div style="padding: 0px 15px;">
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;"></div>
<div class="sb-content-item-sands col-xs-12" style="border-bottom: 1px solid #9d9d9c; padding: 0;">
<div class="col-xs-1" style="padding: 5px 0;"><img style="max-width: 100%; height: auto; border: 1px solid #fff;" src="https://jaxenter.de/wp-content/uploads/2020/04/Matthias_Bohlen_500x350-300x210-1.jpg" alt="Matthias Bohlen" width="500" height="350" /></div>
<div class="col-xs-11">
<h3 style="margin: 5px 0 0 0 !important; padding: 0px !important;"><a href="https://domaindrivendesign-training.de/remote/"><span style="color: #e0007a;"><span style="color: #554697;">Jetzt auch als Online-Seminar</span></span></a></h3>
<p style="margin: 0px 0 5px; color: #000;">Das Intensivtraining für Domain-driven Design mit Matthias Bolen</p>
</div>
</div>
</div>
</div>
</div>
</div>
<!-- / WYSIWYG Widgets --></div>
  </div><!-- widgets_on_page -->
<h2>Cloud-Computing damals</h2>
<p>Amazon erfuhr die Probleme im Rahmen des Weihnachtsgeschäfts am eigenen Leib und extrahierte 2006 die Amazon Web Services (AWS) und damit das Geschäftsmodell des Cloud-Computings. Mit dem Dienst war es erstmals möglich, Rechenpower im Minutentakt dynamisch zu mieten – und vor allem wieder zu kündigen. Die Hardware, auf der die Software läuft, die zu Stoßzeiten, wie beispielsweise zur Weihnachtszeit, mehr Rechenpower benötigte, konnte auf Knopfdruck oder sogar vollautomatisch skaliert werden. Infrastructure as a Service war geboren. Aber das Modell bringt Probleme mit sich. Zwar wird die Infrastruktur bereitgestellt, jegliche Software, die auf der Infrastruktur betrieben wird, wie beispielsweise das Betriebssystem und die auf dem System laufende Laufzeitumgebung, müssen jedoch selbst gepflegt werden. Das Administrieren und Konfigurieren der Systeme bleiben deshalb nicht aus. Neue Entwickler im Team müssen deshalb häufig zusätzlich zu dem gewählten Tech-Stack auch noch Fähigkeiten in der Administration von Linux-Systemen oder Ähnlichem lernen.</p>
<p>Es folgten deshalb kurze Zeit später die ersten Services, die statt reiner Hardware nun Hardware inklusive Laufzeitumgebung anboten. Dazu zählen z. B. Heroku oder der Dienst der Google Cloud Platform AppEngine, bei denen das reine Artefakt einer Software weltweit betrieben werden kann. Die Dienste bieten die Laufzeitumgebung in einer bestimmten Version für das Artefakt (im Fall von Java: JAR-Dateien) an. Das konkrete Betriebssystem, inklusive Sicherheitsupdates und Ähnlichem, wird komplett vom Anbieter verwaltet. Dabei wird ein tieferes Verständnis des Betriebssystems, wie beispielsweise Linux, nicht weiter benötigt. Die darunterliegende Hardware und deren Skalierung werden abstrahiert.</p>
<p>Auf die Spitze treibt Amazon das Konzept der verwalteten Hardware und Software mit dem Dienst Lambda und dem damit verbundenen Konzept von Function as a Service, bei dem einzelne Funktionen auf der Infrastruktur von Amazon hochgefahren, ausgeführt und dann direkt wieder runtergefahren werden. In Rechnung gestellt werden die reine Ausführungszeit sowie die Anzahl der Ausführungen. Als Auslöser dieser Funktionen dienen AWS interne Ereignisse oder externe Auslöser wie HTTP-Anfragen.</p>
<p>Die Herangehensweise, dass Server nicht mehr im eigenen Rechenzentrum betrieben, sondern (ggf. virtuell) angemietet werden, hat sich mittlerweile etabliert. Bei dem Blick darauf, was die internen Rechenzentren so tun, fiel allerdings schnell auf, dass es nicht nur das Betreiben von Servern war, sondern auch das Betreiben von Datenbanken. Daher war es eine gravierende Veränderung, dass bei den gängigen Anbietern Datenbanken wie PostgreSQL, MySQL oder Oracle mit wenigen Klicks erstellt und betrieben werden konnten – automatische Backups inklusive. Was gut für die nutzenden Unternehmen ist, stellt ein Problem für die Cloud-Anbieter dar. Sich vom Konkurrenten in diesem Bereich abzuheben, ist nur begrenzt möglich, weshalb die Anbieter das Angebot häufig um Eigenentwicklungen für ihre spezifischen Anwendungsfälle erweiterten. Ein solcher Dienst ist zum Beispiel DynamoDB, eine verwaltete NoSQL-Datenbank, die das Problem einer weltweit skalierbaren Datenhaltung löst, dafür aber mit Eigenheiten daherkommt.</p>
<h2>Cloud-Computing heute</h2>
<p>Durch die positive Annahme der spezifischen Dienste ist ein weiterer Trend zu beobachten: Neben dem Angebot von Infrastruktur und klassischen Anwendungen wie Datenbanken und Datenhaltung gibt es immer mehr Dienste, die ein Wissen für bestimmte Nischen abdecken.</p>
<p>Nimmt man als Beispiel dazu den Dienst Recognition von Amazon, so bietet dieser den Kunden Zugriff auf ein riesiges Machine-Learning-Netz, um Bilder und Videos zu analysieren, ohne sich tiefer mit dem Thema auskennen zu müssen. Mit Textract kann der Traum vom „paperless Office“ realisiert werden. Der Dienst kann gescannte Dokumente analysieren und auswerten, ohne dass ein Mensch dazu die Daten mühselig in ein Computersystem übertragen muss. Das Spannende: Theoretisch muss dabei nicht eine Zeile Code geschrieben werden.</p>
<p>Die wenigsten Applikationen kommen ohne Querschnittsfunktionen, wie z. B. eine Authentifizierung, aus. Ohne tieferes kryptografisches und mathematisches Verständnis ist es meist schwer möglich, eine wirklich sichere Benutzerverwaltung zu implementieren. Nicht selten werden deshalb mehrere Wochen zum Feinjustieren investiert, ohne einen wirklichen Mehrwert der Software für Unternehmen zu bieten. Durch das Einbinden der entsprechenden Dienste, wie beispielsweise Amazons Cognito, steht dem System im Gegensatz dazu mit wenig Code ein kompletter Authentifizierungsserver – inklusive granularer Rechteverwaltung für die eigenen Dienste des Cloud-Anbieters – zur Verfügung. Es ist also ein klarer Trend zu erkennen: Cloud-Computing wandelt sich immer mehr vom Anbieter reiner Infrastruktur zum Anbieter von Lösungen.</p>
<p>Das Kaufen von fertiger Software zur Integration in die eigene Systemlandschaft und damit verbundenem Wissen, das nicht der eigenen Kernkompetenz entspricht, ist keine neue Idee. In der Vergangenheit bedeutete das aber immer, dass solche Software im eigenen Rechenzentrum betrieben werden musste und sehr viel Aufwand in die Integration der heterogenen Teilsysteme geflossen ist. Die Kosten für diesen Integrationsaufwand sind häufig nicht abzuschätzen, obwohl sie eigentlich bei der Kalkulation auf die Anschaffungs- und Lizenzkosten der Drittanbieter aufgeschlagen werden müssten. Vor diesem Hintergrund ist es besonders interessant, dass der Fokus der Cloud-Anbieter in den vergangenen Jahren neben dem Anbieten der Dienste zunehmend auf deren wechselseitiger Integration liegt. Wer sich für einen Cloud-Anbieter entscheidet, kauft damit nicht nur spezifisches Wissen und Lösungen, sondern ein ganzes Ökosystem von integrierten Diensten ein.</p>
<p>Wo es vor einigen Jahren noch undenkbar war, Dienste, wie beispielsweise einen Dokumentenscanner oder Bilderkennung, außerhalb des eigenen Rechenzentrums zu betreiben, stehen diese heute mit einem einzigen Klick und ohne eine vorherige große monetäre Investition direkt zur Verfügung. Unternehmen erhalten Zugriff auf eine riesige Sammlung von Infrastruktur und Wissen der Giganten von Google und Amazon. Sie zahlen nur das, was sie wirklich brauchen, und müssen nicht einmal die darunterliegende Rechenpower betreiben.</p>
<p>Aber wie heißt es doch so schön: Es ist nicht alles Gold, was glänzt. Nicht zuletzt zeigen Vorfälle wie der bei <a href="https://www.golem.de/news/microsoft-azure-loescht-aus-versehen-datenbanken-von-kunden-1901-139101.html" rel="noopener noreferrer" target="_blank">Microsofts Azure</a>, dass die Nutzung vollständig verwalteter Dienste nicht ganz ohne Risiken daherkommt. Dort wurden Anfang 2019 automatisiert Datensätze aus Datenbanken gelöscht und waren unwiederbringlich verloren. Durch das Einkaufen und Nutzen der Dienste und das damit verbundene Wissen verliert das eigene Unternehmen einerseits diese Kompetenzen, und erhöht andererseits zugleich die Abhängigkeit vom Anbieter. Weil ein Dienst selten allein daherkommt, und diese Dienste oft miteinander verzahnt bzw. sehr einfach mit anderen Diensten zu integrieren sind, kaufen sich Unternehmen häufig unbewusst in das Ökosystem der Cloud-Anbieter ein. Damit macht sich das eigene Unternehmen abhängig von dessen Preispolitik und Service Level Agreements. Auch deshalb entschied sich z. B. der <a href="https://t3n.de/news/weggang-aws-dropbox-spart-75-962140/" rel="noopener noreferrer" target="_blank">Speicherdienst Dropbox</a> in den letzten Jahren, die Daten aus dem Simple Storage Service von Amazon in ein eigenes Datenzentrum mit eigener Software zu migrieren.</p>
<h2>Fazit</h2>
<p>Also ist Cloud-Computing tatsächlich nur „someone else’s“ Computer? Meiner Meinung nach ist diese Aussage nicht ganz einfach zu beantworten. Im Allgemeinen muss zunächst zwischen Infrastruktur und angebotenen Diensten unterschieden werden. Betrachtet man den infrastrukturellen Aspekt, so ist Cloud-Computing nicht nur „someone else’s“ Computer, sondern eher „someone else’s globally distributed datacenter with engineers working 24/7 to ensure its availability“. Dennoch darf nicht vergessen werden: Es herrscht die Einschränkung, dass Kompetenzen abgegeben werden. Gibt es einen Vorfall im Datenzentrum, ist man selbst zunächst machtlos. Betrachtet man im Gegenzug den Wandel und setzt ein Unternehmen vermehrt auf die Dienste eines Anbieters, so kauft sich dieser eher „someone else’s knowledge“ und „someone else’s ecosystem“ ein. Und das ist als eine Chance und ein Risiko zugleich zu verstehen.</p>
					</div>
					
										
					
					
					<div class="social-icons">
						
						<a href="https://www.facebook.com/sharer/sharer.php?u=https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" target="_blank" class="social-icon facebook">
							<div class="icon"><i class="icon icon-facebook"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="facebook" data-platform-name="0" data-url="https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" data-url-old=""></span></div>
						</a>
						<a href="https://twitter.com/home?status=EnterpriseTales: Cloud-Computing is someone else’s computer - https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" target="_blank" class="social-icon twitter">
							<div class="icon"><i class="icon icon-twitter"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="twitter" data-platform-name="0" data-url="https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" data-url-old=""></span></div>
						</a>
						<a href="https://plus.google.com/share?url=https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" target="_blank" class="social-icon googleplus">
							<div class="icon"><i class="icon icon-google-plus"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="googleplus" data-platform-name="0" data-url="https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" data-url-old=""></span></div>
						</a>
					
						<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" target="_blank" class="social-icon linkedin">
							<div class="icon"><i class="icon icon-linkedin"></i></div>
							<div class="count"><span class="num-shares" data-platform-key="linkedin" data-platform-name="0" data-url="https://jaxenter.de/cloud/cloud-computing-microservices-monolith-94806" data-url-old=""></span></div>
						</a>
					</div>
					
					<div class="row"><div class="more-topics"><div class="col-xs-12 col-md-3"><h3 class="box-headline">Verwandte Themen:</h3></div><div class="col-xs-12 col-md-9">		<div class="button-tags-block">
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/cloud" target="_blank" >
	                   Cloud 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/enterprise-tales" target="_blank" >
	                   Enterprise Tales 	         </a>   
	      	        <a class="boxed-tag-button btn btn-default tags" href="https://jaxenter.de/tag/microservices" target="_blank" >
	                   Microservices 	         </a>   
	      		</div>
	</div></div></div>
					 
						<div class="post-article-box author-box">
							<div class="box-headline">Geschrieben von</div>
							<div class="container-fluid no-padding">
																	<div class="author-row row">
										<div class="author-image col-lg-2 col-sm-2 col-xs-4">
											<img src="https://jaxenter.de/wp-content/uploads/2020/04/koelpin_lars_sw.tif_fmt1.jpg" class="img-responsive" />										</div>
										<div class="author-info col-lg-10 col-sm-10 col-xs-8">
											<div class="author-name">Lars Kölpin</div>

																							<div class="author-description">
													<p><span class="bold">Lars Kölpin </span>ist Enterprise-Entwickler bei der OPEN KNOWLEDGE GmbH in Oldenburg. Zu seinen Leidenschaften gehören moderne Frontend-Technologien, vor allem im Zusammenspiel mit modernen Cloud-Architekturen.</p>
												</div>
																				
																					</div>
									</div>
															</div>
						</div>
					
					
							<div class="related-posts">
								<div class='yarpp-related'>
  <div class="post-article-box related-posts-wrapper test">
	<div class="box-headline">Das könnte Sie auch interessieren!</div>
	<div class="container-fluid no-padding">
		<div class="row">
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/enterprise-tales-businesstransaktionen-microservices-80886" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2017/08/Enterprise-Tales-300x200-180x120.jpg 180w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							Enterprise Tales: Lost in Transaction – Businesstransaktionen mit Microservices umsetzen						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/enterprisetales-des-microservice-grosser-bruder-39180" rel="bookmark">
						<div class="image">
															<img width="190" height="127" src="https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-190x127.jpg" class="attachment-related size-related wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2015/05/Enterprise-Tales.jpg 600w" sizes="(max-width: 190px) 100vw, 190px" />													</div>
						<div class="title">
							EnterpriseTales: Des Microservice großer Bruder						</div>
					</a>
				</div>
							<div class="col-md-4">
					<a class="related-post" href="https://jaxenter.de/reduce-to-the-max-microservices-20205" rel="bookmark">
						<div class="image">
															<img width="163" height="130" src="https://jaxenter.de/wp-content/uploads/2015/05/enterprise_tales1-163x130.jpg" class="attachment-related size-related wp-post-image" alt="Enterprise Tales" srcset="https://jaxenter.de/wp-content/uploads/2015/05/enterprise_tales1-163x130.jpg 163w, https://jaxenter.de/wp-content/uploads/2015/05/enterprise_tales1-150x120.jpg 150w, https://jaxenter.de/wp-content/uploads/2015/05/enterprise_tales1.jpg 300w, https://jaxenter.de/wp-content/uploads/2015/05/enterprise_tales1-200x160.jpg 200w, https://jaxenter.de/wp-content/uploads/2015/05/enterprise_tales1-170x136.jpg 170w, https://jaxenter.de/wp-content/uploads/2015/05/enterprise_tales1-100x80.jpg 100w, https://jaxenter.de/wp-content/uploads/2015/05/enterprise_tales1-180x144.jpg 180w" sizes="(max-width: 163px) 100vw, 163px" />													</div>
						<div class="title">
							Reduce to the Max: Microservices						</div>
					</a>
				</div>
					</div>
	</div>
  </div>
</div>
							</div>

																				<div class="post-article-box comments-wrapper">
						<div class="box-headline">Kommentare</div>
							    <div class="wpdiscuz_top_clearing"></div>
    <div id="comments" class="comments-area"><div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>            <h3 id="wc-comment-header">
                                Hinterlasse einen Kommentar            </h3>
                    <div id="wpcomm" class="wpdiscuz_unauth wpd-default">
            <div class="wpdiscuz-form-top-bar">
                <div class="wpdiscuz-ftb-left">
                                                            <div id="wc_show_hide_loggedin_username">
                                            </div>
                </div>
                                <div class="wpd-clear"></div>
            </div>


                        <div class="wc_social_plugin_wrapper">
                            </div>
                    <div class="wc-form-wrapper wc-main-form-wrapper"  id='wc-main-form-wrapper-0_0' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                                        <form class="wc_comm_form wc_main_comm_form" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">

                                                                                                        <div class="wc-field-avatararea">
                                        <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="40" height="40" alt="avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" />                                    </div>
                                
                                <textarea id="wc-textarea-0_0" pattern=".{1,4000}" maxlength=4000 placeholder="Beginne eine Diskussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">4000</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                                <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                                <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*">
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website">
                                            </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Geben Sie den CAPTCHA-Code ein">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5eaa5f5397e85"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5eaa5f5397e85" class="wpdiscuz-cnonce" name="cnonce" value="c5eaa5f5397e85" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" title="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" />
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                        </div>
                <div id = "wpdiscuz_hidden_secondary_form" style = "display: none;">
                    <div class="wc-form-wrapper wc-secondary-form-wrapper"  id='wc-secondary-form-wrapper-wpdiscuzuniqueid'  style='display: none;' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                            <div class="wc-secondary-forms-social-content"></div><div class="clearfix"></div>
                                        <form class="wc_comm_form wc-secondary-form-wrapper" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">

                                                                                                        <div class="wc-field-avatararea">
                                        <img src="https://jaxenter.de/wp-content/plugins/wp-user-avatar/images/wpua-96x96.png" width="48" height="48" alt="avatar" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 photo avatar-default" />                                    </div>
                                
                                <textarea id="wc-textarea-wpdiscuzuniqueid" pattern=".{1,4000}" maxlength=4000 placeholder="Beteilige dich an der Dikussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                    <div class="commentTextMaxLength">4000</div>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                                <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                                <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*">
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website">
                                            </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Geben Sie den CAPTCHA-Code ein">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5eaa5f5398082"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://jaxenter.de/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5eaa5f5398082" class="wpdiscuz-cnonce" name="cnonce" value="c5eaa5f5398082" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" title="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" />
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Kommentar veröffentlichen">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                        </div>
                </div>
                                           

                                    <div class="wpdiscuz-front-actions">
                                                    <div class="wpdiscuz-sbs-wrap">
                                <span><i class="far fa-envelope" aria-hidden="true"></i>&nbsp; Subscribe &nbsp;<i class="fas fa-caret-down" aria-hidden="true"></i></span>
                            </div>
                                                                        <div class="clearfix"></div>
                    </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://jaxenter.de/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Benachrichtige mich zu: </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">Alle neuen Kommentare</option>
                                                                                                                            <option value="all_comment" >Nur Antworten zu meinen Kommentar/en</option>
                                                                            </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" type="submit" value="›" name="wpdiscuz_subscription_button" />
                                </div> 
                                                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="023a3a361a" /><input type="hidden" name="_wp_http_referer" value="/cloud/cloud-computing-microservices-monolith-94806" />                                                                <input type="hidden" value="94806" name="wpdiscuzSubscriptionPostId" />
                            </form>
                                                <div class="wpdiscuz_clear"></div>
                                            </div>
                    
                                <div id="wcThreadWrapper" class="wc-thread-wrapper">
                                    
                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
                <div class="wpdiscuz_clear"></div>
                                            </div>
        </div>
        <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div>
        					</div>
														</div>
				<div id="sidebar" class="col-md-4 col-sm-12">
				<div class="widget sidebarSpecificTagContent"><p><iframe style="margin: 0px; padding: 0px; overflow: hidden; border: none;" src="https://serverless-architecture.io/session-qualification/speaker-box-sla-3/?layout=sidebarfeed&amp;utmtrackerversion=1" width="350" height="665" scrolling="no"></iframe></p>
</div><div id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://kiosk.entwickler.de/devs-at-home-einzel/" target="blank" rel="noopener noreferrer"><img src="https://jaxenter.de/wp-content/uploads/2020/04/EKiosk_20_Special_Responsive_300x250_57359_v3.jpg" style="width:350px; height:auto;"></a></div></div><div id="polls-widget-5" class="widget widget_polls-widget"><p class="widget-title">Polls</p><div id="polls-51" class="wp-polls">
	<form id="polls_form_51" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_51_nonce" name="wp-polls-nonce" value="b59c0b5fc9" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="51" /></p>
		<p><strong>Arbeiten in Zeiten der Pandemie – Sind Sie schon im Home Office?</strong></p><div id="polls-51-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-404" name="poll_51" value="404" /> <label for="poll-answer-404">Ja, ich arbeite Vollzeit im Home Office</label></li>
		<li><input type="radio" id="poll-answer-405" name="poll_51" value="405" /> <label for="poll-answer-405">Ja, allerdings nur teilweise – Ich habe auch einige Office-Termine</label></li>
		<li><input type="radio" id="poll-answer-406" name="poll_51" value="406" /> <label for="poll-answer-406">Nein, ich arbeite im Büro</label></li>
		</ul>
<div class="text-center"><a href="#" class="btn btn-info btn-sm button" onclick="poll_vote(51);"  ><span class="glyphicon glyphicon-ok" aria-hidden="true"></span> VOTE</a></div></div>
	</form>
</div>
<div id="polls-51-loading" class="wp-polls-loading"><img src="https://jaxenter.de/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div><div id="aktuelle_magazine-6" class="widget widget_aktuelle_magazine"><div class="ausgabe-wrapper"><p class="widget-title">Artikel erschienen in</p><div class="image"><a href="https://jaxenter.de/ausgaben/java-magazin-5-20"><img width="214" height="300" src="https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504.jpg" class="attachment-300x300 size-300x300 wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504.jpg 1200w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-214x300.jpg 214w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-730x1024.jpg 730w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-107x150.jpg 107w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-768x1077.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-1095x1536.jpg 1095w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-200x281.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-170x238.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-57x80.jpg 57w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-93x130.jpg 93w, https://jaxenter.de/wp-content/uploads/2020/04/cover_xxx_JM5_20_cover@2x_1584957435504-180x252.jpg 180w" sizes="(max-width: 214px) 100vw, 214px" /></a></div><div class="body"><div class="title"><a href="https://jaxenter.de/ausgaben/java-magazin-5-20">Java Magazin 5.20</a></div><div class="button"><a href="https://jaxenter.de/ausgaben/java-magazin-5-20" class="button">Infos zum Heft</a></div></div></div></div><div id="tag-widget-5" class="widget TagWidget"><a href="https://jaxenter.de/tag/devops"><p class="widget-title">DevOpsCon 2020</p></a><ul class = "posts-by-tag-list"><li class="posts-by-tag-item Continuous Delivery Continuous Integration DevOps" id="posts-by-tag-item-95027"><a class="thumb" href="https://jaxenter.de/devops/fruehjahrsputz-struktur-deployment-prozess-95027" title="Frühjahrsputz: Tipps und Tricks für mehr Struktur im Deployment-Prozess"  ><img width="150" height="93" src="https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137-150x93.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137-150x93.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137-300x186.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137-200x124.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137-170x105.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137-120x74.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137-190x118.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137-180x112.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1287149137.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops/fruehjahrsputz-struktur-deployment-prozess-95027">Frühjahrsputz: Tipps und Tricks für mehr Struktur im Deployment-Prozess</a></li><li class="posts-by-tag-item DevOps Entwicklung SPA TDD Testing" id="posts-by-tag-item-94759"><a class="thumb" href="https://jaxenter.de/devops/testing-methoden-technologien-94759" title="Testing-Methoden und -Technologien im Überblick"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-e1587720603982.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/04/shutterstock_1038876388-180x120.jpg 180w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops/testing-methoden-technologien-94759">Testing-Methoden und -Technologien im Überblick</a></li><li class="posts-by-tag-item API Cloud Container DevOps" id="posts-by-tag-item-94828"><a class="thumb" href="https://jaxenter.de/cloud/kernelemente-cloud-native-entwicklung-94828" title="Die 4 Kernelemente Cloud-nativer Entwicklung"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-200x134.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-170x114.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/04/cloud-native-cloud-enabled.jpg 500w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/cloud/kernelemente-cloud-native-entwicklung-94828">Die 4 Kernelemente Cloud-nativer Entwicklung</a></li><li class="posts-by-tag-item DevOps DevSecOps Security" id="posts-by-tag-item-94793"><a class="thumb" href="https://jaxenter.de/security/security-kommentar-dawson-94793" title="DevSecOps: &#8222;Fehlende Daten können anfällige Daten sein&#8220;"  ><img width="150" height="150" src="https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-150x150.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-150x150.png 150w, https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-300x300.png 300w, https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-1024x1024.png 1024w, https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-200x200.png 200w, https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-170x170.png 170w, https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-80x80.png 80w, https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-130x130.png 130w, https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200-180x180.png 180w, https://jaxenter.de/wp-content/uploads/2016/05/BrianDawson-headshot-1200x1200.png 1200w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/security/security-kommentar-dawson-94793">DevSecOps: "Fehlende Daten können anfällige Daten sein"</a></li><li class="posts-by-tag-item Cloud Continuous Delivery DevOps DevOpsCon 2020 Microservices" id="posts-by-tag-item-94449"><a class="thumb" href="https://jaxenter.de/devops/devops-2020-survey-94449" title="DevOps im Jahr 2020: Unsere große DevOps-Umfrage"  ><img width="150" height="100" src="https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-150x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-150x100.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-300x200.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-1024x683.jpg 1024w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-768x512.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-200x133.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-170x113.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-120x80.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-74x50.jpg 74w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-190x127.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800-180x120.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/04/DOC_LDN20_Beitragsbild_Survey_v1_1200x800.jpg 1200w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops/devops-2020-survey-94449">DevOps im Jahr 2020: Unsere große DevOps-Umfrage</a></li><li class="posts-by-tag-item DevOps DevOpsCon iJS JavaScript" id="posts-by-tag-item-94347"><a class="thumb" href="https://jaxenter.de/devops/ijs-devopscon-online-94347" title="Virtuelle Konferenzen: iJS und DevOpsCon ONLINE finden vom 20. bis 21. April statt"  ><img width="150" height="75" src="https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-150x75.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-150x75.jpg 150w, https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-300x150.jpg 300w, https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-768x384.jpg 768w, https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-200x100.jpg 200w, https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-170x85.jpg 170w, https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-120x60.jpg 120w, https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-190x95.jpg 190w, https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu-180x90.jpg 180w, https://jaxenter.de/wp-content/uploads/2020/04/IJS-DEVOPSCON-Online-neu.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class = "posts-by-tag-item-title" href="https://jaxenter.de/devops/ijs-devopscon-online-94347">Virtuelle Konferenzen: iJS und DevOpsCon ONLINE finden vom 20. bis 21. April statt</a></li></ul></div><div class="skyscraper-ad hidden-xs hidden-sm">
	<div class="skyscraper-top">
        <!-- jaxenter.de_skyscraper1_Wordpress -->
        <div id='div-gpt-ad-1423038811881-4' style='width:160px; height:600px;'>
        </div>
    </div>
    <div class="skyscraper-bottom">
        <!-- jaxenter.de_skyscraper2_Wordpress -->
        <div id='div-gpt-ad-1423038811881-5' style='width:160px; height:600px;'>
        </div>
    </div>
</div>
									</div>
			</div>
		</div>
	</article>




		<footer>
			<div class="footer-menu">
				<div class="container">
					<div class="row menu-wrapper">
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-2" class="widget widget_nav_menu"><p class="widget-title">Online</p><div class="menu-footer-menu-online-container"><ul id="menu-footer-menu-online" class="menu"><li id="menu-item-79978" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-79978"><a href="https://jaxenter.de/">JAXenter.de</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40"><a href="http://jaxenter.com">JAXenter.com (engl.)</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41"><a href="http://entwickler.de">entwickler.de</a></li>
<li id="menu-item-13241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13241"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13242"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13243"><a href="http://webmagazin.de">WebMagazin</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="wp_editor_widget-28" class="widget WP_Editor_Widget"></div><div id="nav_menu-3" class="widget widget_nav_menu"><p class="widget-title">Magazine</p><div class="menu-footer-menu-magazine-container"><ul id="menu-footer-menu-magazine" class="menu"><li id="menu-item-13244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13244"><a href="/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-13252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13252"><a href="http://jaxenter.com/jax-magazine">JAX Magazine (engl.)</a></li>
<li id="menu-item-13246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13246"><a href="https://entwickler.de/javascript-kompendium">JavaScript Kompendium</a></li>
<li id="menu-item-13247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13247"><a href="http://entwickler-magazin.de">Entwickler Magazin</a></li>
<li id="menu-item-13248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13248"><a href="http://mobiletechnology.de">Mobile Technology Magazin</a></li>
<li id="menu-item-13249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13249"><a href="http://phpmagazin.de">PHP Magazin</a></li>
<li id="menu-item-13250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13250"><a href="http://windowsdeveloper.de">Windows Developer</a></li>
<li id="menu-item-13251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13251"><a href="https://entwickler.de/cloud-compendium">Cloud Compendium</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-4" class="widget widget_nav_menu"><p class="widget-title">Konferenzen</p><div class="menu-footer-menu-konferenzen-container"><ul id="menu-footer-menu-konferenzen" class="menu"><li id="menu-item-13253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13253"><a href="https://jax.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX, W-JAX</a></li>
<li id="menu-item-13254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13254"><a href="https://jaxlondon.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX London</a></li>
<li id="menu-item-54582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54582"><a href="https://devops.jaxlondon.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">JAX DevOps (London)</a></li>
<li id="menu-item-13256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13256"><a href="https://serverless-architecture.io/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Serverless Architecture Conference</a></li>
<li id="menu-item-13257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13257"><a href="https://mlconference.ai/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Machine Learning Conference</a></li>
<li id="menu-item-13263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13263"><a href="https://devopsconference.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">DevOps Conference</a></li>
<li id="menu-item-13258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13258"><a href="https://iotcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">IoT Conference</a></li>
<li id="menu-item-13259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13259"><a href="https://blockchainconf.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Blockchain Technology Conference</a></li>
<li id="menu-item-13260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13260"><a href="https://mobiletechcon.de?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">MobileTech Conference</a></li>
<li id="menu-item-13261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13261"><a href="https://basta.net?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">BASTA!</a></li>
<li id="menu-item-13262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13262"><a href="https://phpconference.com?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International PHP Conference</a></li>
<li id="menu-item-54428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54428"><a href="https://javascript-conference.com/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">International JavaScript Conference</a></li>
<li id="menu-item-54429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54429"><a href="https://apiconference.net/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">API Conference</a></li>
<li id="menu-item-54427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54427"><a href="https://webinale.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">Webinale</a></li>
<li id="menu-item-54430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54430"><a href="https://entwickler-konferenz.de/de/?utm_source=jaxenter.de&#038;utm_medium=referral&#038;utm_term=general&#038;utm_campaign=footer">EKON</a></li>
</ul></div></div>						</div>
						<div class="col-lg-2 col-sm-3 col-xs-6">
							<div id="nav_menu-5" class="widget widget_nav_menu"><p class="widget-title">S&#038;S Media</p><div class="menu-footer-menu-ss-media-container"><ul id="menu-footer-menu-ss-media" class="menu"><li id="menu-item-13269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13269"><a href="https://e-academy.net/">e.academy</a></li>
<li id="menu-item-13267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13267"><a href="http://entwickler-kiosk.de">entwickler.kiosk</a></li>
<li id="menu-item-79980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79980"><a href="https://tutorials.entwickler.de/">entwickler.tutorials</a></li>
<li id="menu-item-13268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13268"><a href="http://entwickler-press.de">entwickler.press</a></li>
<li id="menu-item-79979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79979"><a href="https://entwickler.de/jobs">entwickler.jobs</a></li>
<li id="menu-item-13264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13264"><a href="http://sandsmedia.com/de/unternehmen">Über Software &#038; Support Media</a></li>
<li id="menu-item-13265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13265"><a href="http://sandsmedia.com/de/sponsoring-advertising">Sponsoring &#038; Advertising</a></li>
<li id="menu-item-13266" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13266"><a href="http://sandsmedia.com/de/karriere">Karriere &#038; Stellenangebote</a></li>
<li id="menu-item-13270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13270"><a href="http://sandsmedia.com/de/kontakt">Kontakt &#038; Anschrift</a></li>
</ul></div></div>						</div>
						<div class="col-lg-4 col-sm-12">
							<div class="widget">
								<p class="widget-title">Follow us</p>
								
								<div class="socialmedia-wrapper">
									<a href="https://www.facebook.com/JAXenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-facebook icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://twitter.com/jaxenter" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-twitter icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="http://vimeo.com/jaxtv" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-vimeo-square icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://jaxenter.de/feed" class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-rss icon-stack-1x icon-inverse"></i>
	</span>
</a>

<a href="https://www.youtube.com/user/VideosJAXenter " class="social-link" target="_blank">
	<span class="icon-stack">
		<i class="icon icon-circle icon-stack-2x"></i>
		<i class="icon icon-youtube icon-stack-1x icon-inverse"></i>
	</span>
</a>


								</div>
							</div>

							<div class="widget widget_newsletter">
								<p class="widget-title">Newsletter</p>
                                
                                <p class="newsletter-icon pull-left">
                                <a href="https://jaxenter.de/newsletter"> <img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/icon-newsletter-footer.png" alt="Newsletter" /></a>
                                </p>
                                <p class="newsletter-info-footer"><a href="https://jaxenter.de/newsletter">Jetzt den JAXenter <br />Newsletter bestellen!</a></p>
								
							</div>
						</div>
					</div>
					
					<div class="row search-wrapper">
						<div class="col-lg-12">
							<form method="get" action="https://jaxenter.de/">
								<input type="text" name="s" />
								<button><i class="icon icon-search"></i></button>
							</form>
						</div>
					</div>
				</div>
			</div>

			<div class="footer-bottom">
				<div class="container">
					<div class="row">
						<div class="logo-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<img src="https://jaxenter.de/wp-content/themes/jaxenter.de/images/logo-footer.png" alt="jaxenter.de" />
						</div>
						<div class="menu-wrapper col-lg-6 col-md-6 col-sm-6 col-xs-6">
							<ul id="menu-footer" class="menu"><li id="menu-item-16359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16359"><a href="http://sandsmedia.com/">Software &#038; Support Media Group</a></li>
<li id="menu-item-13783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13783"><a href="https://jaxenter.de/datenschutz">Datenschutz</a></li>
<li id="menu-item-13233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13233"><a href="https://jaxenter.de/impressum">Impressum</a></li>
</ul>						</div>
					</div>
				</div>
			</div>
		</footer>

		<script type="text/javascript">var templateDirUrl = 'https://jaxenter.de/wp-content/themes/jaxenter.de';</script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/bootstrap-select/dist/js/bootstrap-select.min.js"></script>
		<script src="https://jaxenter.de/wp-content/themes/jaxenter.de/assets/js/functions.js"></script>
		
		<a id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://jaxenter.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeMidnight.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['auto-links'] = false;
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.defaults['wrap-lines'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://jaxenter.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/jaxenter.de\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?ver=1.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/jaxenter.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jaxenter.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='https://jaxenter.de/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
	</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 

Served from: jaxenter.de @ 2020-04-30 07:17:07 by W3 Total Cache
-->